<!DOCTYPE html>
<!--[if IE 8]> <html lang="en" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://hoopshype.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="It was two rookies who captured the imaginations of basketball aficionados everywhere over the final months of the 2017-18 season, one in the Eastern Conference and the other in the West." />
<meta name="keywords" content="longform, ranking, evergreen, featured, longform, ranking, top" />
<title>We have ranked the Top 15 NBA rookies of the 21st century | HoopsHype</title>
<meta name="google-site-verification" content="ES19h9gPLaQcyadjeYaOsIx4sOJD7JsZ301C9TFyX9A" />
<meta name="msvalidate.01" content="6C7AFE373C691E833D6444FFA7F6E8A2" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=hoopshype.com&amp;id=85827622&amp;t=1524776157&amp;back=https%3A%2F%2Fhoopshype.com%2F2018%2F04%2F26%2Fwe-have-ranked-the-top-15-nba-rookies-of-the-21st-century%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//usatodaysports-d.openx.net' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//tags.tiqcdn.com' />
<link rel='dns-prefetch' href='//usathoopshype.wordpress.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="HoopsHype &raquo; Feed" href="https://hoopshype.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="HoopsHype &raquo; Comments Feed" href="https://hoopshype.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="HoopsHype &raquo; We have ranked the Top 15 NBA rookies of the 21st century Comments Feed" href="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1516999477h&ver=4.9.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s1.wp.com/_static/??-eJyFj90OwjAIhV9IrBqd8cL4LLUjDlfaRphzb29no4k/mTcNUD7OOaZP4GJQDGq4g+S7EwUxfXKRQZg8Dh/d3InMzG/MU4tizqjJuhYe3dS6ixfMc05Wxw3Gmix65Lw2hfVUn1AzLs8aFG+TCKfqKTSWTbY36awkPh7TBUUgv0wdgzbZ259EPLov0R8G3yYFJROiUqblVXzdLFLmSsl0YjXWdniJSGbaASh4CghXqjEWrV8f4+UD75eb1Xpb7RarzfkO/eS72w==?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='galleria-theme-css'  href='//cdnjs.cloudflare.com/ajax/libs/galleria/1.4.2/themes/classic/galleria.classic.css?ver=1.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s2.wp.com/_static/??-eJylUEtOAzEMvRDBLbQLFohtb8DaTdyMKyeO4gyjuT0ZpFYdIRVV7Pzk97NhKs5rbpQbtIESGXxxgdGwacDZFRkjZ4NBtdgwF4KkYZQfWiB1EUWozs4Grc1rIEAzaus1kz17syf4I0xwqpQ9XZafaHjkf0jhsNQ+9Nq/TNJ4vW3iEJfKpp5RHHfKGjwgThQYLxZtlrvBsX9I1GNjzSvgToJc70krHUVjHyN01g1cRB/pfbt/2W02u7ft6/kbCt22gA==?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-ubuntu-css'  href='https://fonts.googleapis.com/css?family=Ubuntu:300,400,500,700' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-4-1' href='https://s0.wp.com/wp-content/themes/h4/global.css?m=1420737423h&cssminify=yes' type='text/css' media='all' />
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script src="https://run.adrizer.com/track.js" id="ADRIZER_JS" data-domain="hoopshype.com"></script><script type='text/javascript'>
/* <![CDATA[ */
var amznAcctId = ["3090"];
/* ]]> */
</script>
<script type='text/javascript'>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");window.bidSlots=window.bidSlots||[];window._mweb=0;apstag.init({pubID: amznAcctId, adServer: "googletag"});
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFjt0KwjAMRl/IrptMmBfis2RtnKnrj027MZ/eDvRCHAqBQHJy8sk5CHJqzBpZmlL3jHF5tcrwTv4ChKUhQsLKknvDyruELq2s9T2NKDJjhKHMiujiN7jgOVlkLtDG9jMSuYlw/osZTAHUTURkenxZ0xXLPzlRkJkheQ2LGGGO6BSurp60xigsuBIpluuzPTWHfVt3x7przBPGh3M8'></script>
<script type='text/javascript' src='https://mtrx.go.sonobi.com/morpheus.usatoday.1587.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://usatodaysports-d.openx.net/w/1.0/jstag?nc=7103-USA_RON&#038;ver=4.9.5'></script>
<script type='text/javascript' src='https://js-sec.indexww.com/ht/p/184031-126856402220676.js?ver=4.9.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var utag_data = {"ssts":"sports:hoopshype","priority_asset":"","blogname":"hoopshype","videoincluded":"no","platform":"desktop","contenttype":"story pages","assetid":"1177698","headline":"We have ranked the Top 15 NBA rookies of the 21st century","byline":"Frank Urbina","taxonomykeywords":"Evergreen, Featured, Longform, Ranking, Top"};
/* ]]> */
</script>
<script type='text/javascript'>
					utag_data.clickPage = sessionStorage.getItem( "clickPage" );
					sessionStorage.setItem( "clickPage", window.location.href );
					
</script>
<script type='text/javascript' src='https://tags.tiqcdn.com/utag/gci/hoopshype/prod/utag.js?ver=4.9.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var usatoday_gallery_ajax_object = {"publisherGA":"UA-5226424-1","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-5226424-1","dfpid":"","pid":"SMG_HoopsHype","ads":[],"tlmurl":"https:\/\/tags.tiqcdn.com\/utag\/gci\/hoopshype\/prod\/utag.js"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJytkEsOwjAMRC9EsAKqWCHOEhK3OM2POGnh9gQhfitAYmfNeJ48hjkJHUPBUKAc0CPDRAkqqxKNOgun5oxBI/hoqmvuPtNwKDpOCJahoHJUvXiqS8sL+ABNrg4UGFQiMSjnMFNbUcxY+JV6887/QFY2qelzs8Qkl6tvmI/uLc8jJeEojKKPurLo6fQrwh7rtYxXFH6NOtrf41xIj1+95O18MvlBaHPL7/xWdnKz7lZSru0FCSzEIA=='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1522184747h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://usathoopshype.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://usat.ly/2HUu6QV' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fhoopshype.com%2F2018%2F04%2F26%2Fwe-have-ranked-the-top-15-nba-rookies-of-the-21st-century%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fhoopshype.com%2F2018%2F04%2F26%2Fwe-have-ranked-the-top-15-nba-rookies-of-the-21st-century%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="We have ranked the Top 15 NBA rookies of the 21st century" />
<meta property="og:url" content="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/" />
<meta property="og:description" content="It was two rookies who captured the imaginations of basketball aficionados everywhere over the final months of the 2017-18 season, one in the Eastern Conference and the other in the West. The forme…" />
<meta property="article:published_time" content="2018-04-26T19:55:49+00:00" />
<meta property="article:modified_time" content="2018-04-26T19:55:51+00:00" />
<meta property="og:site_name" content="HoopsHype" />
<meta property="og:image" content="https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=1024&amp;h=576&amp;crop=1" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@hoopshype" />
<meta name="twitter:text:title" content="We have ranked the Top 15 NBA rookies of the 21st century" />
<meta name="twitter:image:src" content="https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="http://facebook.com/hoopshype" />
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/8195f692d09575689011557b84764b61?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/8195f692d09575689011557b84764b61?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="https://secure.gravatar.com/blavatar/8195f692d09575689011557b84764b61?s=114" />
<link rel='openid.server' href='https://usathoopshype.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://usathoopshype.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://hoopshype.com/osd.xml" title="HoopsHype" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script><style type="text/css">
.articleBody a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.widget--box .text-block > h2,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover,
.hero__secondary .hero__link:hover .hero__title {
	color: #eb1e00;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #eb1e00;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #eb1e00;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #eb1e00;
}

.nav__item:hover,
.nav__item--current,
#footer-info {
	border-top-color: #eb1e00;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #eb1e00;
}

.article__back,
.newsletter__input,
.daily-newsletter__input {
	border-color: #eb1e00;
}

.vertical-gallery--icon,
.vertical-gallery__overlay,
.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.newsletter__button,
.daily-newsletter__button {
	background-color: #eb1e00;
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #eb1e00;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #eb1e00;
	}
}
</style>
<link rel="canonical" href="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/" />
		<style>
			.wpcom-related-posts ul li {
				list-style-type: none;
				display: inline-block;
			}
		</style>
				<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="HoopsHype" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://hoopshype.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/8195f692d09575689011557b84764b61?s=16" />
<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
	bidManager.timeout = 2500;
	bidManager.addBidder('a9');
		bidManager.addBidSlot({ slotID: "videoSlot", mediaType : 'video' } );

	</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>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</script>
<link rel="amphtml" href="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/amp/"><style type="text/css" id="syntaxhighlighteranchor"></style>
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s1.wp.com/?custom-css=1&#038;csblog=5O7Gu&#038;cscache=6&#038;csrev=53" />
		
	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-1177698 single-format-standard mp6 customizer-styles-applied highlander-enabled highlander-light">

	
	<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_interstitial' style='width:2px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_interstitial'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_outstream' style='width:4px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_outstream'); });</script></div>
	
<div id="wrapper">

	<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>

	<div class="wrapper-holder">

		<div
	class="branding "
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="https://hoopshype.com"
				title="HoopsHype"
				class="branding__logo-link "
			>
				<img
					src="https://usathoopshype.files.wordpress.com/2017/01/logo-hoopshype-header.png"
					alt="HoopsHype"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

	
	<span class="branding__search">
		<form method="get" class="branding__search-form" action="https://hoopshype.com" role="search">
			<input type="text" name="s" value="" placeholder="search HoopsHype" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="http://usatodaysports.com" target="_blank" title="USA TODAY Sports">
			<img src="https://usathoopshype.files.wordpress.com/2017/01/usat-logo-header.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-423204" class="nav__item nav__item--rumors nav__item--parent sub-menu-3columns sub-menu-columns-offset200"><a title="NBA Rumors" href="/rumors/">Rumors</a>
<ul class="sub-menu">
	<li id="menu-item-1023487" class="nav__item nav__item--atlanta-hawks"><a title="Atlanta Rumors" href="https://hoopshype.com/team/atlanta-hawks/">Atlanta Hawks</a></li>
	<li id="menu-item-1023488" class="nav__item nav__item--boston-celtics"><a title="Boston Rumors" href="https://hoopshype.com/team/boston-celtics/">Boston Celtics</a></li>
	<li id="menu-item-1023489" class="nav__item nav__item--brooklyn-nets"><a title="Brooklyn Rumors" href="https://hoopshype.com/team/brooklyn-nets/">Brooklyn Nets</a></li>
	<li id="menu-item-1023490" class="nav__item nav__item--charlotte-hornets"><a title="Charlotte Rumors" href="https://hoopshype.com/team/charlotte-hornets/">Charlotte Hornets</a></li>
	<li id="menu-item-1023491" class="nav__item nav__item--chicago-bulls"><a title="Chicago Rumors" href="https://hoopshype.com/team/chicago-bulls/">Chicago Bulls</a></li>
	<li id="menu-item-1023492" class="nav__item nav__item--cleveland-cavaliers"><a title="Cleveland Rumors" href="https://hoopshype.com/team/cleveland-cavaliers/">Cleveland Cavaliers</a></li>
	<li id="menu-item-1023493" class="nav__item nav__item--dallas-mavericks"><a title="Dallas Rumors" href="https://hoopshype.com/team/dallas-mavericks/">Dallas Mavericks</a></li>
	<li id="menu-item-1023494" class="nav__item nav__item--denver-nuggets"><a title="Denver Rumors" href="https://hoopshype.com/team/denver-nuggets/">Denver Nuggets</a></li>
	<li id="menu-item-1023495" class="nav__item nav__item--detroit-pistons"><a title="Detroit Rumors" href="https://hoopshype.com/team/detroit-pistons/">Detroit Pistons</a></li>
	<li id="menu-item-1023496" class="nav__item nav__item--golden-state-warriors"><a title="Golden State Rumors" href="https://hoopshype.com/team/golden-state-warriors/">Golden State Warriors</a></li>
	<li id="menu-item-1023497" class="nav__item nav__item--houston-rockets"><a title="Houston Rumors" href="https://hoopshype.com/team/houston-rockets/">Houston Rockets</a></li>
	<li id="menu-item-1023498" class="nav__item nav__item--indiana-pacers"><a title="Indiana Rumors" href="https://hoopshype.com/team/indiana-pacers/">Indiana Pacers</a></li>
	<li id="menu-item-1023499" class="nav__item nav__item--los-angeles-clippers"><a title="LA Clippers Rumors" href="https://hoopshype.com/team/los-angeles-clippers/">Los Angeles Clippers</a></li>
	<li id="menu-item-1023500" class="nav__item nav__item--los-angeles-lakers"><a title="LA Lakers Rumors" href="https://hoopshype.com/team/los-angeles-lakers/">Los Angeles Lakers</a></li>
	<li id="menu-item-1023501" class="nav__item nav__item--memphis-grizzlies"><a title="Memphis Rumors" href="https://hoopshype.com/team/memphis-grizzlies/">Memphis Grizzlies</a></li>
	<li id="menu-item-1023502" class="nav__item nav__item--miami-heat"><a title="Miami Rumors" href="https://hoopshype.com/team/miami-heat/">Miami Heat</a></li>
	<li id="menu-item-1023503" class="nav__item nav__item--milwaukee-bucks"><a title="Milwaukee Rumors" href="https://hoopshype.com/team/milwaukee-bucks/">Milwaukee Bucks</a></li>
	<li id="menu-item-1023504" class="nav__item nav__item--minnesota-timberwolves"><a title="Minnesota Rumors" href="https://hoopshype.com/team/minnesota-timberwolves/">Minnesota Timberwolves</a></li>
	<li id="menu-item-1023505" class="nav__item nav__item--new-orleans-pelicans"><a title="New Orleans Rumors" href="https://hoopshype.com/team/new-orleans-pelicans/">New Orleans Pelicans</a></li>
	<li id="menu-item-1023506" class="nav__item nav__item--new-york-knicks"><a title="New York Rumors" href="https://hoopshype.com/team/new-york-knicks/">New York Knicks</a></li>
	<li id="menu-item-1023507" class="nav__item nav__item--oklahoma-city-thunder"><a title="Oklahoma City Rumors" href="https://hoopshype.com/team/oklahoma-city-thunder/">Oklahoma City Thunder</a></li>
	<li id="menu-item-1023508" class="nav__item nav__item--orlando-magic"><a title="Orlando Rumors" href="https://hoopshype.com/team/orlando-magic/">Orlando Magic</a></li>
	<li id="menu-item-1023509" class="nav__item nav__item--philadelphia-76ers"><a title="Philadelphia Rumors" href="https://hoopshype.com/team/philadelphia-76ers/">Philadelphia 76ers</a></li>
	<li id="menu-item-1023510" class="nav__item nav__item--phoenix-suns"><a title="Phoenix Rumors" href="https://hoopshype.com/team/phoenix-suns/">Phoenix Suns</a></li>
	<li id="menu-item-1023511" class="nav__item nav__item--portland-trail-blazers"><a title="Portland Rumors" href="https://hoopshype.com/team/portland-trail-blazers/">Portland Trail Blazers</a></li>
	<li id="menu-item-1023512" class="nav__item nav__item--sacramento-kings"><a title="Sacramento Rumors" href="https://hoopshype.com/team/sacramento-kings/">Sacramento Kings</a></li>
	<li id="menu-item-1023513" class="nav__item nav__item--san-antonio-spurs"><a title="San Antonio Rumors" href="https://hoopshype.com/team/san-antonio-spurs/">San Antonio Spurs</a></li>
	<li id="menu-item-1023514" class="nav__item nav__item--toronto-raptors"><a title="Toronto Rumors" href="https://hoopshype.com/team/toronto-raptors/">Toronto Raptors</a></li>
	<li id="menu-item-1023515" class="nav__item nav__item--utah-jazz"><a title="Utah Rumors" href="https://hoopshype.com/team/utah-jazz/">Utah Jazz</a></li>
	<li id="menu-item-1023516" class="nav__item nav__item--washington-wizards"><a title="Washington Rumors" href="https://hoopshype.com/team/washington-wizards/">Washington Wizards</a></li>
</ul>
</li>
<li id="menu-item-458969" class="nav__item nav__item--salaries nav__item--parent sub-menu-minwidth140"><a title="NBA Salaries" href="/salaries/">Salaries</a>
<ul class="sub-menu">
	<li id="menu-item-16" class="nav__item nav__item--players"><a title="NBA Player Salaries" href="https://hoopshype.com/salaries/players/">Players</a></li>
	<li id="menu-item-12" class="nav__item nav__item--teams"><a title="NBA Salaries" href="https://hoopshype.com/salaries/">Teams</a></li>
</ul>
</li>
<li id="menu-item-1022515" class="nav__item nav__item--twitter nav__item--parent sub-menu-minwidth140"><a title="NBA Media Twitters" href="/social/">Twitter</a>
<ul class="sub-menu">
	<li id="menu-item-18" class="nav__item nav__item--media"><a title="NBA Media Twitters" href="/social/">Media</a></li>
	<li id="menu-item-999057" class="nav__item nav__item--players"><a title="NBA Players on Twitter" href="/social/tweets/">Players</a></li>
</ul>
</li>
<li id="menu-item-423198" class="nav__item nav__item--features nav__item--parent sub-menu-columns"><a href="#">Features</a>
<ul class="sub-menu">
	<li id="menu-item-1000630" class="nav__item nav__item--agents"><a title="NBA Agents" href="/reps/">Agents</a></li>
	<li id="menu-item-1006555" class="nav__item nav__item--analytics"><a title="NBA Analytics" href="/category/analytics/">Analytics</a></li>
	<li id="menu-item-11" class="nav__item nav__item--draft"><a title="NBA Draft" href="/2018/01/09/nba-mock-draft-2018/">Draft</a></li>
	<li id="menu-item-17" class="nav__item nav__item--free-agency-2018"><a title="NBA Free Agency 2018" href="/2018/01/11/nba-free-agency-2018-the-top-players/">Free Agency 2018</a></li>
	<li id="menu-item-1000631" class="nav__item nav__item--hoopshype-podcasts"><a href="/category/podcast/">HoopsHype Podcasts</a></li>
	<li id="menu-item-1006554" class="nav__item nav__item--instagram"><a title="NBA Players on Instagram" href="/social/gallery/">Instagram</a></li>
	<li id="menu-item-1000632" class="nav__item nav__item--longform"><a title="Longform" href="https://hoopshype.com/category/longform/">Longform</a></li>
	<li id="menu-item-423200" class="nav__item nav__item--players"><a title="NBA Players" href="/players/">Players</a></li>
	<li id="menu-item-1119544" class="nav__item nav__item--re-drafts"><a href="https://hoopshype.com/tag/re-drafts/">Re-Drafts</a></li>
	<li id="menu-item-1118240" class="nav__item nav__item--store"><a href="https://sportngoods.threadless.com/collections/hoops-hype/">Store</a></li>
	<li id="menu-item-1160065" class="nav__item nav__item--top-rumors"><a href="https://hoopshype.com/category/top-rumors/">Top Rumors</a></li>
	<li id="menu-item-1119543" class="nav__item nav__item--trade-candidate-watch"><a href="https://hoopshype.com/tag/trade-candidate-watch/">Trade Candidate Watch</a></li>
	<li id="menu-item-10" class="nav__item nav__item--transactions"><a title="NBA Transactions" href="/transactions.htm">Transactions</a></li>
	<li id="menu-item-1068878" class="nav__item nav__item--trending-stories"><a href="https://hoopshype.com/tag/trending/">Trending Stories</a></li>
	<li id="menu-item-1006556" class="nav__item nav__item--trivia"><a title="NBA Trivia" href="/category/trivia/">Trivia</a></li>
</ul>
</li>
		</ul>
		<ul class="nav__social ">
			<li class="nav__item nav__item--social nav__item--facebook">
			<a href="http://facebook.com/hoopshype" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--twitter">
			<a href="https://twitter.com/hoopshype" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--podcast">
			<a href="https://hoopshype.com/category/podcast/" class="nav__item-link"></a>
		</li>
	</ul>
	</nav>
</header>

		
		
		<div id="main" class="site-main ">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-1177698" class="post-1177698 post type-post status-publish format-standard has-post-thumbnail hentry category-longform category-ranking tag-evergreen tag-featured tag-longform tag-ranking tag-top player-ben-simmons player-blake-griffin player-carmelo-anthony player-chris-paul player-damian-lillard player-derrick-rose player-donovan-mitchell player-karl-anthony-towns-3 player-kevin-durant player-lebron-james player-pau-gasol player-yao-ming team-cleveland-cavaliers team-detroit-pistons team-golden-state-warriors team-houston-rockets team-minnesota-timberwolves team-oklahoma-city-thunder team-philadelphia-76ers team-portland-trail-blazers team-san-antonio-spurs team-utah-jazz" itemscope itemtype="http://schema.org/NewsArticle">

				<div class="article__title ">
	<h1 class="article__headline">We have ranked the Top 15 NBA rookies of the 21st century</h1>

			<img width="1000" height="600" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" class="article__image wp-post-image" alt data-attachment-id="1178070" data-permalink="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/cavaliers-v-nuggets-2/" data-orig-file="https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg" data-orig-size="3000,2035" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;DENVER - DECEMBER 2:  Carmelo Anthony #15 of the Denver Nuggets and LeBron James #23 of the Clevelenad Cavaliers cover each other during the fourth quarter December 2, 2003 at the Pepsi Center in Denver, Colorado.  Anthony had 26 points; James 19, in the Nuggets&#039; 115-103 win.  NOTE TO USER:  User expressly acknowledges and agrees that, by downloading and\/or using this Photograph, User is consenting to the terms and conditions of the Getty Images License Agreement.  (Photo by Brian Bahr\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;2003 Getty Images&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;Cavaliers v Nuggets&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Cavaliers v Nuggets" data-image-description data-medium-file="https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=1000" data-lazy-src="https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=1000&amp;h=600&amp;crop=1" data-lazy-srcset="https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=1000&amp;h=600&amp;crop=1 1000w, https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=2000&amp;h=1200&amp;crop=1 2000w, https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=190&amp;h=114&amp;crop=1 190w, https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=300&amp;h=180&amp;crop=1 300w, https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=768&amp;h=461&amp;crop=1 768w, https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=1024&amp;h=614&amp;crop=1 1024w" data-lazy-sizes="(max-width: 1000px) 100vw, 1000px"><noscript><img width="1000" height="600" src="https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=1000&amp;h=600&amp;crop=1" class="article__image wp-post-image" alt="" srcset="https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=1000&amp;h=600&amp;crop=1 1000w, https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=2000&amp;h=1200&amp;crop=1 2000w, https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=190&amp;h=114&amp;crop=1 190w, https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=300&amp;h=180&amp;crop=1 300w, https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=768&amp;h=461&amp;crop=1 768w, https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=1024&amp;h=614&amp;crop=1 1024w" sizes="(max-width: 1000px) 100vw, 1000px" data-attachment-id="1178070" data-permalink="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/cavaliers-v-nuggets-2/" data-orig-file="https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg" data-orig-size="3000,2035" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;DENVER - DECEMBER 2:  Carmelo Anthony #15 of the Denver Nuggets and LeBron James #23 of the Clevelenad Cavaliers cover each other during the fourth quarter December 2, 2003 at the Pepsi Center in Denver, Colorado.  Anthony had 26 points; James 19, in the Nuggets&#039; 115-103 win.  NOTE TO USER:  User expressly acknowledges and agrees that, by downloading and\/or using this Photograph, User is consenting to the terms and conditions of the Getty Images License Agreement.  (Photo by Brian Bahr\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;2003 Getty Images&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;Cavaliers v Nuggets&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Cavaliers v Nuggets" data-image-description="" data-medium-file="https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=1000" /></noscript>		<cite class="article__source"></cite>
		<div class="article__gradient"></div>
	</div>
<h1 class="article__headline article__headline--mobile">We have ranked the Top 15 NBA rookies of the 21st century</h1>

				<header class="entry-header  ">

					
<h2 class="cat-show">
	<a href="https://hoopshype.com/category/ranking/" class="" itemprop="articleSection">Ranking</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">We have ranked the Top 15 NBA rookies of the 21st century</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p itemprop="author" itemscope itemtype="http://schema.org/Person">

	
	    <span class="post-date updated">April 26, 2018</span>-
		by <a href="https://hoopshype.com/author/fau09fsu/" title="Posts by Frank Urbina" class="author url fn" rel="author">Frank Urbina</a> 
	
	</p>
					</div>

					<div id='acm-ad-tag-lawrence_dfp_mobile_sponsor_by_logo' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_mobile_sponsor_by_logo'); });</script></div>
				</header>

				
				
				
				<div id="content-container">
					<div class="entry-content normal-format">

						<div class="article-container">
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/"
		data-short-url="https://usat.ly/2HUu6QV"
		data-track="hoopshypestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/"
		data-short-url="https://usat.ly/2HUu6QV"
		data-track="hoopshypestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="hoopshype"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/"
		data-short-url="https://usat.ly/2HUu6QV"
		data-track="hoopshypestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/"
		data-short-url="https://usat.ly/2HUu6QV"
		data-track="hoopshypestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/"
		data-short-url="https://usat.ly/2HUu6QV"
		data-track="hoopshypestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/"
			data-short-url="https://usat.ly/2HUu6QV"
			data-track="hoopshypestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p itemprop="author" itemscope itemtype="http://schema.org/Person">
		By: <a href="https://hoopshype.com/author/fau09fsu/" title="Posts by Frank Urbina" class="author url fn" rel="author">Frank Urbina</a>		| April 26, 2018		<span class="article__author__widgets">
								</span>
	</p>

	</div>


						
						<div class="articleBody" itemprop="articleBody"><p>It was two rookies who captured the imaginations of basketball aficionados everywhere over the final months of the 2017-18 season, one in the Eastern Conference and the other in the West.</p>
<p>The former, a point guard in the body of a freakish power forward, did so by dishing out dazzling dimes and bullying opponents on the block. While the latter, a normal-sized combo guard with not-so-normal athletic prowess, did so by leading an elite team in nightly scoring thanks to a assortment of tough shots in his repertoire along with a keen ability to get in the paint.</p>
<p>The historic seasons put on by the two young guys were among the best first-year campaigns in recent memory, and got us thinking about other impressive debuts.</p>
<p>So we decided to rank the top 15 rookie campaigns dating back to 2000-01.</p>
<p>Without further ado, let&#8217;s get into it.</p>
<h3>15. Brandon Roy (Portland), 2006-07</h3>
<p>The 2006-07 Rookie of the Year, <strong>Brandon Roy</strong> hit the ground running in his first season with the Portland Trail Blazers.</p>
<p>Roy&#8217;s first-year marks – 16.8 points, 4.4 rebounds and 4.0 assists nightly on impressive 45.6/37.7/83.8 shooting splits – made the Washington product appear to be next in line among the league&#8217;s great guards.</p>
<p>And for what it&#8217;s worth, Roy did manage to have an impressive career, earning three All-Star bids and two All-NBA nods (one 2nd and one 3rd Team appearance) over his six years of service.</p>
<p>Unfortunately, constant knee troubles forced the Portland guard to retire after his Age-28 season, right when he should have been hitting his professional peak.</p>
<p>Nevertheless, Roy&#8217;s career, albeit short, wound up being memorable, and his rookie season was one of the most efficient – and impressive – since the turn of the century.</p>
<p><img data-attachment-id="1178066" data-permalink="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/yao-ming-blocks-out-chris-webber/" data-orig-file="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-1891696.jpg?w=1000&#038;h=669" data-orig-size="3146,2104" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;SACRAMENTO, CA - MARCH 23:  Yao Ming #11 of the Houston Rockets blocks out Chris Webber #4 of the Sacramento Kings during the game at Arco Arena on March 23, 2003 in Sacramento, California.  The Kings won 109-108.   NOTE TO USER: User expressly acknowledges and agrees that, by downloading and\/or using this Photograph, User is consenting to the terms and conditions of the Getty Images License Agreement.  (Photo by Jed Jacobsohn\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;2003 Getty Images&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;Yao Ming blocks out Chris Webber&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Yao Ming" data-image-description data-medium-file="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-1891696.jpg?w=1000&#038;h=669?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-1891696.jpg?w=1000&#038;h=669?w=1000" class="size-full wp-image-1178066 aligncenter" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt width="1000" height="669" data-lazy-src="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-1891696.jpg?w=1000&#038;h=669"><noscript><img data-attachment-id="1178066" data-permalink="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/yao-ming-blocks-out-chris-webber/" data-orig-file="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-1891696.jpg?w=1000&#038;h=669" data-orig-size="3146,2104" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;SACRAMENTO, CA - MARCH 23:  Yao Ming #11 of the Houston Rockets blocks out Chris Webber #4 of the Sacramento Kings during the game at Arco Arena on March 23, 2003 in Sacramento, California.  The Kings won 109-108.   NOTE TO USER: User expressly acknowledges and agrees that, by downloading and\/or using this Photograph, User is consenting to the terms and conditions of the Getty Images License Agreement.  (Photo by Jed Jacobsohn\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;2003 Getty Images&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;Yao Ming blocks out Chris Webber&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Yao Ming" data-image-description="" data-medium-file="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-1891696.jpg?w=1000&#038;h=669?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-1891696.jpg?w=1000&#038;h=669?w=1000" class="size-full wp-image-1178066 aligncenter" src="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-1891696.jpg?w=1000&#038;h=669" alt="" width="1000" height="669" srcset="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-1891696.jpg?w=1000&amp;h=669 1000w, https://usathoopshype.files.wordpress.com/2018/04/gettyimages-1891696.jpg?w=2000&amp;h=1338 2000w, https://usathoopshype.files.wordpress.com/2018/04/gettyimages-1891696.jpg?w=190&amp;h=127 190w, https://usathoopshype.files.wordpress.com/2018/04/gettyimages-1891696.jpg?w=300&amp;h=201 300w, https://usathoopshype.files.wordpress.com/2018/04/gettyimages-1891696.jpg?w=768&amp;h=514 768w, https://usathoopshype.files.wordpress.com/2018/04/gettyimages-1891696.jpg?w=1024&amp;h=685 1024w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript></p>
<h3>14. Yao Ming (Houston), 2002-03</h3>
<p>One of the most mysterious-yet-exciting international prospects in recent NBA history, the behemoth out of China known as <strong>Yao Ming</strong> did not disappoint once he arrived to the States and joined the Houston Rockets.</p>
<p>The 7-foot-6 Hall of Famer joined the NBA for the 2002-03 season, and put up moderately promising numbers in his first year. He averaged 13.5 points, 8.2 rebounds and 1.8 blocks per contest as a rookie, earning 1st Team All-Rookie honors for his contributions.</p>
<p>Of course, Yao&#8217;s play really took off after the opening salvos of his career, as he would end up making three All-NBA 3rd Teams and two All-NBA 2nd Teams throughout his time in the Association.</p>
<p>Nevertheless, it should be noted: He was far from a slouch as a rookie.</p>
<p>Yao scored at least 20 points 16 times in his first year, including a ridiculous 30-point performance against the Dallas Mavericks, in which the Chinese big man successfully converted on 10 of his 12 field-goal attempts.</p>
<h3>13. Damian Lillard (Portland), 2012-13</h3>
<p>Though <strong>Damian Lillard</strong> didn&#8217;t arrive to the NBA with close to the fanfare Yao did, he was even more impressive than the Hall-of-Fame center in his first season with the Blazers.</p>
<p>The four-year Weber State product averaged 19.0 points, 6.5 assists and 2.3 three-pointers per game in his first campaign, flashing brilliance from beyond the arc and decent vision as a distributor.</p>
<p>More than anything, however, it was clear right away Lillard was going to be a special scorer. And it was never more apparent than on March 8, 2013, when Lillard went for 35 points and nine assists against the San Antonio Spurs&#8217; third-ranked defense.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='1000' height='593' src='https://www.youtube.com/embed/gzDQKKbkAfQ?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>Lillard wound up winning Rookie of the Year in 2012-13, a fitting reward for his outstanding first season as a pro.</p>
<h3>12. Amare Stoudemire (Phoenix), 2002-03</h3>
<p>After being selected ninth overall by the Phoenix Suns in the 2002 draft, it didn&#8217;t take long for <strong>Amare Stoudemire</strong> to break his way into the team&#8217;s starting lineup.</p>
<p>Ten games into the season and staring at a 5-5 record, head coach <strong>Frank Johnson</strong> opted to move his prized rookie into the opening unit.</p>
<p>Safe to say, it was the right decision.</p>
<p>From that point on, Stoudemire averaged 14.4 points and 9.9 rebounds nightly, and became a pivotal piece on a team that won 44 games and took a nasty Spurs squad to six games in the first round of the playoffs.</p>
<p>The 2002-03 Rookie of the Year, Stoudemire&#8217;s career – with five All-NBA appearances and six All-Star bids – would end up being special.</p>
<p>And it all started with a strong rookie campaign.</p>
<h3>11. Kevin Durant (Seattle), 2007-08</h3>
<p>As a member of the then-Seattle SuperSonics, <strong>Kevin Durant</strong> had the luxury of taking his rookie-year lumps on a very bad team with zero expectations.</p>
<p>Even so, the Texas product had himself an impressive first campaign. Durant averaged 20.3 points and 4.4 rebounds per contest as a rookie, despite the fact his head coach, <strong>PJ Carlesimo</strong>, slotted him into a 2-guard role unfit for his skill set.</p>
<p>Durant&#8217;s efficiency suffered as a result, as he shot 43.0 percent from the floor and a paltry 28.8 percent from beyond the arc in 2007-08.</p>
<p>The Sonics would go on to win 20 games that season, but Durant&#8217;s counting stats were so good he took home Rookie of the Year honors anyway.</p>
<h3>10. Derrick Rose (Chicago), 2008-09</h3>
<p>As a member of the Chicago Bulls, <strong>Derrick Rose</strong> had quite the exciting first regular season. Averaging 16.8 points, 3.9 rebounds and 6.3 assists per contest, Rose took the league by storm with his explosive, clutch style of play.</p>
<p>Even more importantly, however, he took it to another level once the games started to matter more, in the postseason, against one of the best teams in the NBA.</p>
<p>Facing the 2008-09 title-favorite Boston Celtics in the first round of the playoffs, Rose put up 19.7 points, 6.3 rebounds and 6.4 assists nightly in the seven-game series, with his most impressive showing coming in his postseason debut.</p>
<p>In Game 1, Rose scored 36 points on 12-of-19 shooting, while chipping in 11 assists in what was two-point Chicago win.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='1000' height='593' src='https://www.youtube.com/embed/YqSSn2OuzXs?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>To this day, Rose <a href="https://www.basketball-reference.com/play-index/pgl_finder.cgi?request=1&amp;match=game&amp;is_playoffs=Y&amp;age_min=0&amp;age_max=99&amp;game_num_type=team&amp;game_num_min=1&amp;game_num_max=1&amp;season_start=1&amp;season_end=1&amp;pos_is_g=Y&amp;pos_is_gf=Y&amp;pos_is_f=Y&amp;pos_is_fg=Y&amp;pos_is_fc=Y&amp;pos_is_c=Y&amp;pos_is_cf=Y&amp;order_by=pts" target="_blank" rel="noopener">remains tied</a> with the legendary <strong>Kareem-Abdul Jabbar</strong> for most points scored in a rookie&#8217;s first playoff outing – a ridiculous accomplishment for the former No. 1 pick.</p>
<p>At that point, the Memphis product looked like he was about to embark on a Hall-of-Fame career. And though he did go on to win the 2011 MVP trophy, since then, injuries have unfortunately put a damper on what had the makings of a special player.</p>
<h3>9. Donovan Mitchell (Utah), 2017-18</h3>
<p>The fact <strong>Donovan Mitchell</strong> fell to the 13th pick of the 2018 draft looks ludicrous in hindsight.</p>
<p>The guard out of Louisville followed up the slight by averaging 20.5 points, 3.7 rebounds and 3.7 assists per contest as a member of the Utah Jazz, helping lead the team to 48 wins and a playoff spot in the stacked Western Conference.</p>
<p>Utah desperately lacked scoring following the departure of <strong>Gordon Hayward</strong> last summer. The fact Mitchell, as a rookie, was able to take charge and aptly fill the hole left behind the All-Star wing is beyond impressive.</p>
<div class="embed-twitter">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Donovan Mitchell (28-9-8 in W over Lakers to clinch) is the first rookie to lead a playoff team in scoring since Carmelo Anthony.</p>
<p>&mdash; Tim MacMahon (@espn_macmahon) <a href="https://twitter.com/espn_macmahon/status/983138582801068032?ref_src=twsrc%5Etfw">April 9, 2018</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div>
<p>Mitchell&#8217;s efficiency wasn&#8217;t great (43.7 percent from the field, 34.0 percent from deep), but that&#8217;s quite understandable considering the circumstances.</p>
<p><em>What&#8217;s more, the 6-foot-3 guard took his play to another level in the postseason. Through four playoff games, Mitchell averaged an absurd 27.5 points and 8.5 rebounds nightly against a tough Oklahoma City Thunder </em>squad,<em> and has his team on the brink of eliminating an opponent with a lot more star power on it.</em></p>
<p>Impressive stuff from Mitchell, whose career will be exhilarating to watch unfold going forward.</p>
<h3>8. Carmelo Anthony (Denver), 2003-04</h3>
<p>Speaking of Oklahoma City star power, <strong>Carmelo Anthony</strong> enjoyed an excellent rookie campaign in his own right back when his career was just getting started.</p>
<p>The Syracuse legend averaged 21.0 points, 6.1 rebounds and 2.8 assists per contest as a first-year member of the Denver Nuggets, helping lead the team to 43 wins and a sixth seed in the Western Conference. Anthony had 10 30-plus-point performances in his first season, including an absurd 41-point against the then-Sonics, in which he made 19 of his 29 field-goal attempts.</p>
<p>The Nuggets didn&#8217;t make much of a run once they reached the postseason (Denver was ousted 3-1 by the Minnesota Timberwolves), but the fact Anthony was able to make such an impact right away made his rookie campaign memorable.</p>
<h3>7. Tyreke Evans (Sacramento), 2009-10</h3>
<p>Much like Rose, <strong>Tyreke Evans</strong> appeared destined for stardom in his first year of professional basketball.</p>
<p>As a member of the Sacramento Kings, the 6-foot-6 ball-handler averaged 20.1 points, 5.3 rebounds and 5.8 assists per contest, becoming <a href="https://www.basketball-reference.com/play-index/psl_finder.cgi?request=1&amp;match=single&amp;type=totals&amp;per_minute_base=36&amp;per_poss_base=100&amp;season_start=1&amp;season_end=1&amp;lg_id=NBA&amp;age_min=0&amp;age_max=99&amp;is_playoffs=N&amp;height_min=0&amp;height_max=99&amp;birth_country_is=Y&amp;as_comp=gt&amp;as_val=0&amp;pos_is_g=Y&amp;pos_is_gf=Y&amp;pos_is_f=Y&amp;pos_is_fg=Y&amp;pos_is_fc=Y&amp;pos_is_c=Y&amp;pos_is_cf=Y&amp;c1stat=pts_per_g&amp;c1comp=gt&amp;c1val=20&amp;c2stat=ast_per_g&amp;c2comp=gt&amp;c2val=5&amp;c3stat=trb_per_g&amp;c3comp=gt&amp;c3val=5&amp;order_by=ws" target="_blank" rel="noopener">one of just four rookies</a> to ever put up at least 20/5/5 for an entire season. The other three were <strong>Michael Jordan</strong>, <strong>Oscar Robertson</strong> and a player who&#8217;s coming up later in our countdown.</p>
<p>Not bad company to be in for Evans.</p>
<p>The Memphis product would go on to win Rookie of the Year in 2009-10, beating out future two-time league MVP <strong>Stephen Curry</strong> in the process.</p>
<p>Unfortunately, injuries and poor shooting have hampered much of Evans&#8217; career since then, and he was never really able to build on the success of his first campaign.</p>
<p><img data-attachment-id="1178069" data-permalink="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/pau-gasol-reaches-for-the-ball/" data-orig-file="https://usathoopshype.files.wordpress.com/2018/04/pau2.jpg?w=1000&#038;h=669" data-orig-size="3063,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;WASHINGTON - DECEMBER 18:  Forward Pau Gasol #16 of the Memphis Grizzlies reaches for the ball against forward Kwame Brown #5 of the Washington Wizards during the game at MCI Center on December 18, 2002 in Washington, DC.  The Wizards won 118-100.  NOTE TO USER: User expressly acknowledges and agrees that, by downloading and or using this photograph, User is consenting to the terms and conditions of the Getty Images License Agreement.  (Photo by Doug Pensinger\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;2002 Getty Images&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;Pau Gasol reaches for the ball&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Pau Gasol" data-image-description data-medium-file="https://usathoopshype.files.wordpress.com/2018/04/pau2.jpg?w=1000&#038;h=669?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2018/04/pau2.jpg?w=1000&#038;h=669?w=1000" class="size-full wp-image-1178069 aligncenter" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt width="1000" height="669" data-lazy-src="https://usathoopshype.files.wordpress.com/2018/04/pau2.jpg?w=1000&#038;h=669"><noscript><img data-attachment-id="1178069" data-permalink="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/pau-gasol-reaches-for-the-ball/" data-orig-file="https://usathoopshype.files.wordpress.com/2018/04/pau2.jpg?w=1000&#038;h=669" data-orig-size="3063,2048" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;WASHINGTON - DECEMBER 18:  Forward Pau Gasol #16 of the Memphis Grizzlies reaches for the ball against forward Kwame Brown #5 of the Washington Wizards during the game at MCI Center on December 18, 2002 in Washington, DC.  The Wizards won 118-100.  NOTE TO USER: User expressly acknowledges and agrees that, by downloading and or using this photograph, User is consenting to the terms and conditions of the Getty Images License Agreement.  (Photo by Doug Pensinger\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;2002 Getty Images&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;Pau Gasol reaches for the ball&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Pau Gasol" data-image-description="" data-medium-file="https://usathoopshype.files.wordpress.com/2018/04/pau2.jpg?w=1000&#038;h=669?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2018/04/pau2.jpg?w=1000&#038;h=669?w=1000" class="size-full wp-image-1178069 aligncenter" src="https://usathoopshype.files.wordpress.com/2018/04/pau2.jpg?w=1000&#038;h=669" alt="" width="1000" height="669" srcset="https://usathoopshype.files.wordpress.com/2018/04/pau2.jpg?w=1000&amp;h=669 1000w, https://usathoopshype.files.wordpress.com/2018/04/pau2.jpg?w=2000&amp;h=1338 2000w, https://usathoopshype.files.wordpress.com/2018/04/pau2.jpg?w=190&amp;h=127 190w, https://usathoopshype.files.wordpress.com/2018/04/pau2.jpg?w=300&amp;h=201 300w, https://usathoopshype.files.wordpress.com/2018/04/pau2.jpg?w=768&amp;h=514 768w, https://usathoopshype.files.wordpress.com/2018/04/pau2.jpg?w=1024&amp;h=685 1024w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript></p>
<h3>6. Pau Gasol (Memphis), 2001-02</h3>
<p>Fortunate enough to arrive to the NBA after years of professional experience in the Spanish Liga ACB, <strong>Pau Gasol</strong> was able to produce like an elite big man right away in his first season.</p>
<p>As a member of the Memphis Grizzlies, the big Spaniard averaged 17.6 points, 8.9 rebounds, 2.7 assists and 2.1 blocks as a rookie, earning Rookie of the Year honors in 2001-02 for his troubles.</p>
<p>Gasol is <a href="https://www.basketball-reference.com/play-index/psl_finder.cgi?request=1&amp;match=single&amp;type=totals&amp;per_minute_base=36&amp;per_poss_base=100&amp;season_start=1&amp;season_end=1&amp;lg_id=NBA&amp;age_min=0&amp;age_max=99&amp;is_playoffs=N&amp;height_min=0&amp;height_max=99&amp;birth_country_is=Y&amp;as_comp=gt&amp;as_val=0&amp;pos_is_g=Y&amp;pos_is_gf=Y&amp;pos_is_f=Y&amp;pos_is_fg=Y&amp;pos_is_fc=Y&amp;pos_is_c=Y&amp;pos_is_cf=Y&amp;c1stat=pts_per_g&amp;c1comp=gt&amp;c1val=17&amp;c2stat=blk_per_g&amp;c2comp=gt&amp;c2val=2&amp;c3stat=trb_per_g&amp;c3comp=gt&amp;c3val=8&amp;c4stat=ast_per_g&amp;c4comp=gt&amp;c4val=2.5&amp;order_by=ws" target="_blank" rel="noopener">one of just three rookies</a> to average at least 17.0 points, 8.0 rebounds, 2.5 assists and 2.0 blocks since 1973-74, the other two being <strong>Tim Duncan</strong> and <strong>Chris Webber</strong>. That&#8217;s not a shabby group of big men right there.</p>
<p>Though Memphis wasn&#8217;t able to enjoy much team success that season, Gasol&#8217;s rookie campaign was still a spectacular show of first-year prosperity.</p>
<h3>5. Karl-Anthony Towns (Minnesota), 2015-16</h3>
<p>If forced to choose the most apt replica of Gasol&#8217;s first season, it would undoubtedly be <strong>Karl-Anthony Towns</strong>.</p>
<p>Efficient scoring? Check.</p>
<ul>
<li>Towns averaged 18.3 points on 54.2 shooting in his first season.</li>
</ul>
<p>Rebounding and distribution skills? Yep.</p>
<ul>
<li>The Minnesota Timberwolves big man secured 10.5 rebounds nightly as a rookie, while flashing creative passing chops on his way to putting up 2.0 assists per contest.</li>
</ul>
<p>Rare skill outside the paint for a 7-footer? No doubt.</p>
<ul>
<li>Towns attempted 88 triples in his first year, successfully converting 34.1 percent of them.</li>
</ul>
<p>Rookie of the Year? But of course.</p>
<ul>
<li>The Kentucky product was the <a href="http://pr.nba.com/karl-anthony-towns-2015-16-kia-nba-rookie-year-award/" target="_blank" rel="noopener">fifth unanimous winner</a> of the award since 1984.</li>
</ul>
<p>Also similarly to Gasol, Towns&#8217; team struggled mightily during his rookie season. But that doesn&#8217;t take away from how special the opening salvos of his career were.</p>
<h3>4. LeBron James (Cleveland), 2003-04</h3>
<p>Easily the greatest player since the turn of the century, <strong>LeBron</strong><strong> James</strong> also had one of the most memorable rookie seasons since 2000-01.</p>
<p>James&#8217; numbers – 20.9 points, 5.5 rebounds and 5.9 assists per contest – were jaw-dropping even despite his lack of efficiency, and the Cleveland Cavaliers saw an immediate 18-win improvement from the year prior to drafting the future four-time MVP.</p>
<p>James went on to reach huge heights as a member of the Cavaliers, including winning the 2016 NBA championship, and it all started on the road in Sleep Train Arena against the Sacramento Kings.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='1000' height='593' src='https://www.youtube.com/embed/MJ9NiKO5Bnk?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<h3>3. Chris Paul (New Orleans), 2005-06</h3>
<p>From the jump, <strong>Chris Paul</strong> was a pivotal piece for the then-New Orleans Hornets. Drafted fourth overall out of Wake Forest, Paul was a starter in all 78 games he was available for as a rookie, and the numbers he put up made it clear why.</p>
<p>In 2005-06, the 6-foot point guard averaged 16.1 points, 5.1 rebounds, 7.8 assists and 2.2 steals per contest – marks so impressive that they put Paul&#8217;s rookie year in statistically elite company.</p>
<p>Only <a href="https://www.basketball-reference.com/play-index/psl_finder.cgi?request=1&amp;match=single&amp;type=totals&amp;per_minute_base=36&amp;per_poss_base=100&amp;season_start=1&amp;season_end=1&amp;lg_id=NBA&amp;age_min=0&amp;age_max=99&amp;is_playoffs=N&amp;height_min=0&amp;height_max=99&amp;birth_country_is=Y&amp;as_comp=gt&amp;as_val=0&amp;pos_is_g=Y&amp;pos_is_gf=Y&amp;pos_is_f=Y&amp;pos_is_fg=Y&amp;pos_is_fc=Y&amp;pos_is_c=Y&amp;pos_is_cf=Y&amp;c1stat=pts_per_g&amp;c1comp=gt&amp;c1val=16&amp;c2stat=stl_per_g&amp;c2comp=gt&amp;c2val=2&amp;c4stat=ast_per_g&amp;c4comp=gt&amp;c4val=7&amp;order_by=ws" target="_blank" rel="noopener">three other rookie lead guards</a> dating back to 1973-74 have averaged at least 16 points, 7 assists and 2 steals over a full season: <strong>Isiah Thomas</strong>, <strong>Magic Johnson</strong> and <strong>Allen Iverson</strong>.</p>
<p>Paul won Rookie of the Year in 2005-06. And though the Hornets struggled that season and the one following, failing to reach a .500 record in either campaign, by Year-3 of Paul&#8217;s tenure with the club, New Orleans became a 56-win titan, mostly thanks to the elite production out of their starting point guard.</p>
<p><img data-attachment-id="1174314" data-permalink="https://hoopshype.com/2018/04/08/philadelphia-sixers-ben-simmons-best-cutter-nba-rookie-of-the-year-candidate/cleveland-cavaliers-v-philadelphia-76ers-4/" data-orig-file="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-942816686.jpg?w=1000&#038;h=667" data-orig-size="4585,3057" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X Mark II&quot;,&quot;caption&quot;:&quot;PHILADELPHIA, PA - APRIL 6: Ben Simmons #25 of the Philadelphia 76ers dunks the ball past LeBron James #23 of the Cleveland Cavaliers in the second quarter at the Wells Fargo Center on April 6, 2018 in Philadelphia, Pennsylvania. The 76ers defeated the Cavaliers 132-130. NOTE TO USER: User expressly acknowledges and agrees that, by downloading and or using this photograph, User is consenting to the terms and conditions of the Getty Images License Agreement. (Photo by Mitchell Leff\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;1523058840&quot;,&quot;copyright&quot;:&quot;2018 Getty Images&quot;,&quot;focal_length&quot;:&quot;16&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.00125&quot;,&quot;title&quot;:&quot;Cleveland Cavaliers v Philadelphia 76ers&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ben simmons" data-image-description data-medium-file="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-942816686.jpg?w=1000&#038;h=667?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-942816686.jpg?w=1000&#038;h=667?w=1000" class="size-full wp-image-1174314 aligncenter" src="https://s0.wp.com/wp-content/themes/vip/plugins/lazy-load-0.7/images/1x1.trans.gif" alt width="1000" height="667" data-lazy-src="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-942816686.jpg?w=1000&#038;h=667"><noscript><img data-attachment-id="1174314" data-permalink="https://hoopshype.com/2018/04/08/philadelphia-sixers-ben-simmons-best-cutter-nba-rookie-of-the-year-candidate/cleveland-cavaliers-v-philadelphia-76ers-4/" data-orig-file="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-942816686.jpg?w=1000&#038;h=667" data-orig-size="4585,3057" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X Mark II&quot;,&quot;caption&quot;:&quot;PHILADELPHIA, PA - APRIL 6: Ben Simmons #25 of the Philadelphia 76ers dunks the ball past LeBron James #23 of the Cleveland Cavaliers in the second quarter at the Wells Fargo Center on April 6, 2018 in Philadelphia, Pennsylvania. The 76ers defeated the Cavaliers 132-130. NOTE TO USER: User expressly acknowledges and agrees that, by downloading and or using this photograph, User is consenting to the terms and conditions of the Getty Images License Agreement. (Photo by Mitchell Leff\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;1523058840&quot;,&quot;copyright&quot;:&quot;2018 Getty Images&quot;,&quot;focal_length&quot;:&quot;16&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.00125&quot;,&quot;title&quot;:&quot;Cleveland Cavaliers v Philadelphia 76ers&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ben simmons" data-image-description="" data-medium-file="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-942816686.jpg?w=1000&#038;h=667?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-942816686.jpg?w=1000&#038;h=667?w=1000" class="size-full wp-image-1174314 aligncenter" src="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-942816686.jpg?w=1000&#038;h=667" alt="" width="1000" height="667" srcset="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-942816686.jpg?w=1000&amp;h=667 1000w, https://usathoopshype.files.wordpress.com/2018/04/gettyimages-942816686.jpg?w=2000&amp;h=1334 2000w, https://usathoopshype.files.wordpress.com/2018/04/gettyimages-942816686.jpg?w=190&amp;h=127 190w, https://usathoopshype.files.wordpress.com/2018/04/gettyimages-942816686.jpg?w=300&amp;h=200 300w, https://usathoopshype.files.wordpress.com/2018/04/gettyimages-942816686.jpg?w=768&amp;h=512 768w, https://usathoopshype.files.wordpress.com/2018/04/gettyimages-942816686.jpg?w=1024&amp;h=683 1024w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript></p>
<h3>2. Ben Simmons (Philadelphia), 2017-18</h3>
<p>Full disclosure: The next two players on our list did have the benefit being redshirt rookies, meaning they were drafted, sat out for a season (due to injury) and suited up for the first time the year <em>after</em> being drafted.</p>
<p>And though there is value in that (both guys were able to learn about the ins and outs of life in the Association without the pressure of having to produce right away), that doesn&#8217;t make what they did as rookies any less impressive.</p>
<p>At all.</p>
<p>First up is <strong>Ben Simmons</strong>, whose play resembles a taller reincarnation of No. 4 on our list, and put up numbers not just unheard of for a rookie – but unheard of for a 10-year vet.</p>
<p>In 2017-18, Simmons averaged 15.8 points, 8.1 rebounds, 8.2 assists and 1.7 steals nightly while shooting a pristine 54.5 percent from the floor. The only other players <em>ever</em> to put up at a 15/8/8 stat line for an entire season are James, <strong>Oscar Robertson</strong>, <strong>Wilt Chamberlain</strong>, <strong>Magic Johnson</strong> and <strong>Russell Westbrook</strong>.</p>
<p>Basically, right off the bat, Simmons produced like a future Hall-of-Famer. And he did so as a 21-year-old rookie.</p>
<p>For the concerns about his lack of a jumper and how that would affect him when teams could pack the paint and force him to shoot, that didn&#8217;t really matter in his first playoff appearance. Simmons actually upped his counting stats to 19.3 points, 10.8 rebounds and 9.8 assists per contest in his first taste of postseason action, and led the Philadelphia 76ers out of the first round even despite missing <strong>Joel Embiid</strong> for two games.</p>
<p>To call Simmons&#8217; first season impressive would be underselling it. The Australian ball-handler flat-out looked like a future MVP winner in his rookie campaign.</p>
<p>And like Mitchell, tracking the heights Simmons will reach is going to be enthralling for basketball fans everywhere.</p>
<h3>1. Blake Griffin (LA Clippers), 2010-11</h3>
<p>Before Simmons, there was Griffin – the original redshirt rookie.</p>
<p>Drafted out of Oklahoma No. 1 overall by the Los Angeles Clippers, Griffin suffered a stress fracture in his knee during the preseason, which forced him to miss what was supposed to be first season.</p>
<p>The athletic big man returned a year later and more than made up for lost time.</p>
<p>Griffin averaged 22.2 points, 12.1 rebounds and 3.8 assists per contest in his rookie season, becoming the first first-year player to earn All-Star honors since Yao in 2003 and <strong>Tim Duncan</strong> in 1998.</p>
<p>Griffin&#8217;s most memorable outing that season came against another big man featured in this countdown, Stoudemire, on Nov. 20, 2010.</p>
<p>The two explosive power forwards put on an absolute show, dazzling with high-flying dunk after high-flying dunk.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='1000' height='593' src='https://www.youtube.com/embed/5oWP3-ogAEY?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>That was that game that truly put Griffin on the map in the NBA, and gave everyone a glimpse of his ceiling as a player.</p>
<p>Injuries somewhat robbed Griffin of his peak, but he&#8217;s adapted nicely by improving his overall skill level which has allowed him to enjoy five All-Star and four All-NBA appearances.</p>
<p><em>You can find Frank Urbina on Twitter <a href="http://twitter.com/frankurbina_" target="_blank" rel="noopener">@frankurbina_</a>.</em></p>
<div id=inline-newsletter-widget class=hidden data-position=10><div class="widget widget--newsletter widget--box">
<div class="newsletter__wrapper ">

	<div class="newsletter__signup-wrapper">
		<form novalidate="novalidate" action="https://hoopshype.com/wp-json/usat/v1/gems/subscribe/">

			
			<input
				type="email"
				class="newsletter__input"
				placeholder="Enter your email address"
				name="email"
				required
			>
			<button
					type="submit"
					class="newsletter__button"
			>Sign up			</button>

			
			
		</form>

					<div class="newsletter__sidetext">
				<h3>Like this article?</h3>
				<p>Sign up for the HoopsHype email newsletter to get our top stories in your inbox every morning</p>
			</div>
			</div>

	<div class="newsletter__state newsletter__state--success">

		<h3 class="newsletter__header">Success</h3>

		<p class="newsletter__text">
			Thanks for signing up.<br>
			You&#039;ll be waking up a little more awesome tomorrow.		</p>

	</div>

	<div class="newsletter__state newsletter__state--error">

		<h3 class="newsletter__header">Whoa!</h3>

		<p class="newsletter__text newsletter__text--error">
			Something went wrong.		</p>

		<button class="newsletter__button newsletter__button--reset">
			Try again?		</button>

	</div>

	</div>

</div></div></div>

						
						
						<p class="post-tags post-tags--hide"><a href="https://hoopshype.com/tag/evergreen/" rel="tag">Evergreen</a>, <a href="https://hoopshype.com/tag/featured/" rel="tag">Featured</a>, <a href="https://hoopshype.com/tag/longform/" rel="tag">Longform</a>, <a href="https://hoopshype.com/tag/ranking/" rel="tag">Ranking</a>, <a href="https://hoopshype.com/tag/top/" rel="tag">Top</a>, <a href="https://hoopshype.com/category/longform/" rel="category tag">Longform</a>, <a href="https://hoopshype.com/category/ranking/" rel="category tag">Ranking</a></p><p>
			<span class="icomoon icon-tag"></span>
			<span class="post-terms"><a href="https://hoopshype.com/category/longform/" rel="tag">Longform</a>, <a href="https://hoopshype.com/category/ranking/" rel="tag">Ranking</a>, <a href="https://hoopshype.com/tag/evergreen/" rel="tag">Evergreen</a>, <a href="https://hoopshype.com/tag/featured/" rel="tag">Featured</a>, <a href="https://hoopshype.com/tag/longform/" rel="tag">Longform</a>, <a href="https://hoopshype.com/tag/ranking/" rel="tag">Ranking</a>, <a href="https://hoopshype.com/tag/top/" rel="tag">Top</a>, <a href="https://hoopshype.com/player/ben-simmons/" rel="tag">Ben Simmons</a>, <a href="https://hoopshype.com/player/blake-griffin/" rel="tag">Blake Griffin</a>, <a href="https://hoopshype.com/player/carmelo-anthony/" rel="tag">Carmelo Anthony</a>, <a href="https://hoopshype.com/player/chris-paul/" rel="tag">Chris Paul</a>, <a href="https://hoopshype.com/player/damian-lillard/" rel="tag">Damian Lillard</a>, <a href="https://hoopshype.com/player/derrick-rose/" rel="tag">Derrick Rose</a>, <a href="https://hoopshype.com/player/donovan-mitchell/" rel="tag">Donovan Mitchell</a>, <a href="https://hoopshype.com/player/karl-anthony-towns-3/" rel="tag">Karl-Anthony Towns</a>, <a href="https://hoopshype.com/player/kevin-durant/" rel="tag">Kevin Durant</a>, <a href="https://hoopshype.com/player/lebron-james/" rel="tag">LeBron James</a>, <a href="https://hoopshype.com/player/pau-gasol/" rel="tag">Pau Gasol</a>, <a href="https://hoopshype.com/player/yao-ming/" rel="tag">Yao Ming</a>, <a href="https://hoopshype.com/team/cleveland-cavaliers/" rel="tag">Cleveland Cavaliers</a>, <a href="https://hoopshype.com/team/detroit-pistons/" rel="tag">Detroit Pistons</a>, <a href="https://hoopshype.com/team/golden-state-warriors/" rel="tag">Golden State Warriors</a>, <a href="https://hoopshype.com/team/houston-rockets/" rel="tag">Houston Rockets</a>, <a href="https://hoopshype.com/team/minnesota-timberwolves/" rel="tag">Minnesota Timberwolves</a>, <a href="https://hoopshype.com/team/oklahoma-city-thunder/" rel="tag">Oklahoma City Thunder</a>, <a href="https://hoopshype.com/team/philadelphia-76ers/" rel="tag">Philadelphia 76ers</a>, <a href="https://hoopshype.com/team/portland-trail-blazers/" rel="tag">Portland Trail Blazers</a>, <a href="https://hoopshype.com/team/san-antonio-spurs/" rel="tag">San Antonio Spurs</a>, <a href="https://hoopshype.com/team/utah-jazz/" rel="tag">Utah Jazz</a></span>
			</p>
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/"
		data-short-url="https://usat.ly/2HUu6QV"
		data-track="hoopshypestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/"
		data-short-url="https://usat.ly/2HUu6QV"
		data-track="hoopshypestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="hoopshype"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/"
		data-short-url="https://usat.ly/2HUu6QV"
		data-track="hoopshypestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/"
		data-short-url="https://usat.ly/2HUu6QV"
		data-track="hoopshypestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/"
		data-short-url="https://usat.ly/2HUu6QV"
		data-track="hoopshypestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/"
			data-short-url="https://usat.ly/2HUu6QV"
			data-track="hoopshypestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
</div><div class="after-article widget_text">			<div class="textwidget"><div class="veeseoRA2VW"></div></div>
		</div>					</div><!-- .entry-content -->
				</div><!-- #content-container -->

				
			</article><!-- #post-## -->

		
		<div class="container divider"></div><aside class="width widget--author author main-column">
	<img width="90" height="90" src="https://usathoopshype.files.wordpress.com/2018/03/frank-avi.jpg?w=90&#038;h=90&#038;crop=1" class="author__profile" alt="Frank Urbina"/>
	<h3 class="author__name">
		Frank Urbina	</h3>

	
	<p class="author__description">
		Frank Urbina writes about the NBA for HoopsHype, usually with an eye towards the analytical or business side of things. His work is often littered with video evidence so as to give statistical data meaning. Attended Florida State University, currently based in Miami, FL. Contact: furbina@hoopshype.com	</p>

	<a href="https://hoopshype.com/author/fau09fsu/" class="author__archive">More &hellip;</a>
</aside>

<div class="container single-related">

		<div class="heading-small">
		<h2>RELATED <span>ARTICLES</span></h2>
	</div>
	
	<div class="holder-column">
		<div class="column">
			<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="https://hoopshype.com/2018/04/22/nba-free-agency-2018-the-top-players-2/"
	   data-track="hoopshypefeaturedstories hoopshypemore-chartbeat-1"
	   title="NBA Free Agency 2018: The top players"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usathoopshype.files.wordpress.com/2017/11/lebron-durant-finals.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usathoopshype.files.wordpress.com/2017/11/lebron-durant-finals.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="NBA Free Agency 2018: The top players" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
			</a>

	<div class="text-block">

		<span class="block__shares">547 shares</span><span class="block__time block__time--mobile">4d ago</span>
		<h2><a href="https://hoopshype.com/category/free-agency/" class="category" itemprop="articleSection">Free Agency</a></h2>

		<p>
			<a data-track="hoopshypefeaturedstories hoopshypemore-chartbeat-1" href="https://hoopshype.com/2018/04/22/nba-free-agency-2018-the-top-players-2/"
			   title="NBA Free Agency 2018: The top players" itemprop="url">
				NBA Free Agency 2018: The top players			</a>
		</p>

	</div>
</article>
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="https://hoopshype.com/2018/04/17/four-potential-tyreke-evans-landing-spots-in-free-agency/"
	   data-track="hoopshypefeaturedstories hoopshypemore-related-2"
	   title="Four potential Tyreke Evans landing spots in free agency"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usathoopshype.files.wordpress.com/2018/04/tyreke-evans-cover.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usathoopshype.files.wordpress.com/2018/04/tyreke-evans-cover.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Four potential Tyreke Evans landing spots in free agency" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
			</a>

	<div class="text-block">

		<span class="block__shares">911 shares</span><span class="block__time block__time--mobile">2w ago</span>
		<h2><a href="https://hoopshype.com/category/business/" class="category" itemprop="articleSection">Business</a></h2>

		<p>
			<a data-track="hoopshypefeaturedstories hoopshypemore-related-2" href="https://hoopshype.com/2018/04/17/four-potential-tyreke-evans-landing-spots-in-free-agency/"
			   title="Four potential Tyreke Evans landing spots in free agency" itemprop="url">
				Four potential Tyreke Evans landing spots in free agency			</a>
		</p>

	</div>
</article>
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="https://hoopshype.com/2018/03/25/the-highest-paid-players-in-the-history-of-each-nba-franchise/"
	   data-track="hoopshypefeaturedstories hoopshypemore-related-3"
	   title="The highest-paid player in the history of each NBA franchise"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usathoopshype.files.wordpress.com/2018/03/curry-russ.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usathoopshype.files.wordpress.com/2018/03/curry-russ.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="The highest-paid player in the history of each NBA franchise" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
			</a>

	<div class="text-block">

		<span class="block__shares">2685 shares</span><span class="block__time block__time--mobile">25 Mar</span>
		<h2><a href="https://hoopshype.com/category/longform/" class="category" itemprop="articleSection">Longform</a></h2>

		<p>
			<a data-track="hoopshypefeaturedstories hoopshypemore-related-3" href="https://hoopshype.com/2018/03/25/the-highest-paid-players-in-the-history-of-each-nba-franchise/"
			   title="The highest-paid player in the history of each NBA franchise" itemprop="url">
				The highest-paid player in the history of each NBA franchise			</a>
		</p>

	</div>
</article>

		</div>
	</div>
</div>
<div class="container single-related container--comments">
	<div class="heading-small">
		<h2>Comments</h2>
	</div>

	<div id="comments" class="comments-area">
	<div data-spotim-module="recirculation" data-spot-id="sp_RTMRhhxs"></div>
		<script async src="https://recirculation.spot.im/spot/sp_RTMRhhxs"></script>
	<script async src="https://launcher.spot.im/spot/sp_RTMRhhxs"
		data-spotim-module="spotim-launcher"
		data-post-url="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/"
		data-post-id="1177698"
	></script>
	</div>
</div>
<div class="container column container--stories">
	<div class="heading-small">
		<h2>LATEST</h2>
	</div>
	<div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_native'); });</script></div>
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/26/lebron-james-top-10-playoff-moments/"
						title="10 times LeBron James did something amazing in the playoffs"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2018/04/gettyimages-541546966.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-541546966.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="10 times LeBron James did something amazing in the playoffs" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2018/04/26/lebron-james-top-10-playoff-moments/"
								title="10 times LeBron James did something amazing in the playoffs"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/04/26/lebron-james-top-10-playoff-moments/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/04/26/lebron-james-top-10-playoff-moments/"
			title="10 times LeBron James did something amazing in the playoffs"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/04/26/lebron-james-top-10-playoff-moments/" class="share-text">
	0</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				11m			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a>						<span class="block__time block__time--mobile">11m ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/26/lebron-james-top-10-playoff-moments/"
						title="10 times LeBron James did something amazing in the playoffs"
						itemprop="url" 						>
							10 times LeBron James did something amazing in the playoffs					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a><span class="dot">&middot;</span>						<span class="time">April 26, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/nesbittandy1/" title="Posts by Andy Nesbitt" class="author url fn" rel="author">Andy Nesbitt</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/26/after-high-school-success-mike-bibby-wants-to-coach-at-the-ncaa-or-nba-level/"
						title="After high-school success, Mike Bibby wants to coach at the NCAA or NBA level"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2018/03/mikebibbyoffcourt.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2018/03/mikebibbyoffcourt.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="After high-school success, Mike Bibby wants to coach at the NCAA or NBA level" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2018/04/26/after-high-school-success-mike-bibby-wants-to-coach-at-the-ncaa-or-nba-level/"
								title="After high-school success, Mike Bibby wants to coach at the NCAA or NBA level"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/04/26/after-high-school-success-mike-bibby-wants-to-coach-at-the-ncaa-or-nba-level/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/04/26/after-high-school-success-mike-bibby-wants-to-coach-at-the-ncaa-or-nba-level/"
			title="After high-school success, Mike Bibby wants to coach at the NCAA or NBA level"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/04/26/after-high-school-success-mike-bibby-wants-to-coach-at-the-ncaa-or-nba-level/" class="share-text">
	34</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/interview/" class="category" itemprop="articleSection">Interview</a>						<span class="block__time block__time--mobile">4hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/26/after-high-school-success-mike-bibby-wants-to-coach-at-the-ncaa-or-nba-level/"
						title="After high-school success, Mike Bibby wants to coach at the NCAA or NBA level"
						itemprop="url" 						>
							After high-school success, Mike Bibby wants to coach at the NCAA or NBA level					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/interview/" class="category" itemprop="articleSection">Interview</a><span class="dot">&middot;</span>						<span class="time">April 26, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/alexkennedynba/" title="Posts by Alex Kennedy" class="author url fn" rel="author">Alex Kennedy</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/26/oklahoma-city-carmelo-anthony-jerami-grant-alex-abrines-lineup/"
						title="Thunder excel with Alex Abrines and Jerami Grant, not Carmelo Anthony"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2018/04/usatsi_10361410.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2018/04/usatsi_10361410.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Thunder excel with Alex Abrines and Jerami Grant, not Carmelo Anthony" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2018/04/26/oklahoma-city-carmelo-anthony-jerami-grant-alex-abrines-lineup/"
								title="Thunder excel with Alex Abrines and Jerami Grant, not Carmelo Anthony"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/04/26/oklahoma-city-carmelo-anthony-jerami-grant-alex-abrines-lineup/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/04/26/oklahoma-city-carmelo-anthony-jerami-grant-alex-abrines-lineup/"
			title="Thunder excel with Alex Abrines and Jerami Grant, not Carmelo Anthony"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/04/26/oklahoma-city-carmelo-anthony-jerami-grant-alex-abrines-lineup/" class="share-text">
	124</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a>						<span class="block__time block__time--mobile">4hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/26/oklahoma-city-carmelo-anthony-jerami-grant-alex-abrines-lineup/"
						title="Thunder excel with Alex Abrines and Jerami Grant, not Carmelo Anthony"
						itemprop="url" 						>
							Thunder excel with Alex Abrines and Jerami Grant, not Carmelo Anthony					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a><span class="dot">&middot;</span>						<span class="time">April 26, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/bryankalbrosky/" title="Posts by Bryan Kalbrosky" class="author url fn" rel="author">Bryan Kalbrosky</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/26/ron-artest-brawl-early-retirement-2004/"
						title="Metta World Peace says he almost retired before &#039;Malice in the Palace&#039;"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2018/04/gettyimages-51830632.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-51830632.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Metta World Peace says he almost retired before &#039;Malice in the Palace&#039;" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2018/04/26/ron-artest-brawl-early-retirement-2004/"
								title="Metta World Peace says he almost retired before &#039;Malice in the Palace&#039;"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/04/26/ron-artest-brawl-early-retirement-2004/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/04/26/ron-artest-brawl-early-retirement-2004/"
			title="Metta World Peace says he almost retired before &#039;Malice in the Palace&#039;"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/04/26/ron-artest-brawl-early-retirement-2004/" class="share-text">
	34</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				5hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a>						<span class="block__time block__time--mobile">5hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/26/ron-artest-brawl-early-retirement-2004/"
						title="Metta World Peace says he almost retired before &#039;Malice in the Palace&#039;"
						itemprop="url" 						>
							Metta World Peace says he almost retired before &#039;Malice in the Palace&#039;					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a><span class="dot">&middot;</span>						<span class="time">April 26, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/bryankalbrosky/" title="Posts by Bryan Kalbrosky" class="author url fn" rel="author">Bryan Kalbrosky</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/26/charles-barkley-visits-richard-jefferson-and-other-podcasts-you-need-to-listen-today/"
						title="Charles Barkley visits Richard Jefferson and other podcasts you need to listen today"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2017/01/barkley_durant.png?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2017/01/barkley_durant.png?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Charles Barkley visits Richard Jefferson and other podcasts you need to listen today" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2018/04/26/charles-barkley-visits-richard-jefferson-and-other-podcasts-you-need-to-listen-today/"
								title="Charles Barkley visits Richard Jefferson and other podcasts you need to listen today"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/04/26/charles-barkley-visits-richard-jefferson-and-other-podcasts-you-need-to-listen-today/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/04/26/charles-barkley-visits-richard-jefferson-and-other-podcasts-you-need-to-listen-today/"
			title="Charles Barkley visits Richard Jefferson and other podcasts you need to listen today"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/04/26/charles-barkley-visits-richard-jefferson-and-other-podcasts-you-need-to-listen-today/" class="share-text">
	15</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				5hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/podcasts/" class="category" itemprop="articleSection">Podcasts</a>						<span class="block__time block__time--mobile">5hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/26/charles-barkley-visits-richard-jefferson-and-other-podcasts-you-need-to-listen-today/"
						title="Charles Barkley visits Richard Jefferson and other podcasts you need to listen today"
						itemprop="url" 						>
							Charles Barkley visits Richard Jefferson and other podcasts you need to listen today					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/podcasts/" class="category" itemprop="articleSection">Podcasts</a><span class="dot">&middot;</span>						<span class="time">April 26, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/hoopshype/" title="Posts by HoopsHype" class="author url fn" rel="author">HoopsHype</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/26/trending-stories-the-nba-articles-you-should-read-this-morning-599/"
						title="The Sixers are not waiting their turn and other trending stories"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2018/04/ben-simmons-wade.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2018/04/ben-simmons-wade.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="The Sixers are not waiting their turn and other trending stories" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2018/04/26/trending-stories-the-nba-articles-you-should-read-this-morning-599/"
								title="The Sixers are not waiting their turn and other trending stories"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/04/26/trending-stories-the-nba-articles-you-should-read-this-morning-599/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/04/26/trending-stories-the-nba-articles-you-should-read-this-morning-599/"
			title="The Sixers are not waiting their turn and other trending stories"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/04/26/trending-stories-the-nba-articles-you-should-read-this-morning-599/" class="share-text">
	41</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				8hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/social-media/" class="category" itemprop="articleSection">Social Media</a>						<span class="block__time block__time--mobile">8hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/26/trending-stories-the-nba-articles-you-should-read-this-morning-599/"
						title="The Sixers are not waiting their turn and other trending stories"
						itemprop="url" 						>
							The Sixers are not waiting their turn and other trending stories					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/social-media/" class="category" itemprop="articleSection">Social Media</a><span class="dot">&middot;</span>						<span class="time">April 26, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/hoopshype-staff/" title="Posts by HoopsHype staff" class="author url fn" rel="author">HoopsHype staff</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/25/atlanta-hawks-mike-budenholzer-david-fizdale-stephen-silas-potential-replacements/"
						title="Top candidates who could replace Mike Budenholzer as coach of Hawks"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2018/04/gettyimages-618000166.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-618000166.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Top candidates who could replace Mike Budenholzer as coach of Hawks" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2018/04/25/atlanta-hawks-mike-budenholzer-david-fizdale-stephen-silas-potential-replacements/"
								title="Top candidates who could replace Mike Budenholzer as coach of Hawks"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/04/25/atlanta-hawks-mike-budenholzer-david-fizdale-stephen-silas-potential-replacements/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/04/25/atlanta-hawks-mike-budenholzer-david-fizdale-stephen-silas-potential-replacements/"
			title="Top candidates who could replace Mike Budenholzer as coach of Hawks"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/04/25/atlanta-hawks-mike-budenholzer-david-fizdale-stephen-silas-potential-replacements/" class="share-text">
	285</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				17hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a>						<span class="block__time block__time--mobile">17hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/25/atlanta-hawks-mike-budenholzer-david-fizdale-stephen-silas-potential-replacements/"
						title="Top candidates who could replace Mike Budenholzer as coach of Hawks"
						itemprop="url" 						>
							Top candidates who could replace Mike Budenholzer as coach of Hawks					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a><span class="dot">&middot;</span>						<span class="time">April 25, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/bryankalbrosky/" title="Posts by Bryan Kalbrosky" class="author url fn" rel="author">Bryan Kalbrosky</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/25/philadelphia-76ers-miami-heat-marco-belinelli-jj-redick-off-screen/"
						title="Sixers found perfect play type for Marco Belinelli, JJ Redick vs. Heat"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2018/04/gettyimages-950901792.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-950901792.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Sixers found perfect play type for Marco Belinelli, JJ Redick vs. Heat" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2018/04/25/philadelphia-76ers-miami-heat-marco-belinelli-jj-redick-off-screen/"
								title="Sixers found perfect play type for Marco Belinelli, JJ Redick vs. Heat"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/04/25/philadelphia-76ers-miami-heat-marco-belinelli-jj-redick-off-screen/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/04/25/philadelphia-76ers-miami-heat-marco-belinelli-jj-redick-off-screen/"
			title="Sixers found perfect play type for Marco Belinelli, JJ Redick vs. Heat"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/04/25/philadelphia-76ers-miami-heat-marco-belinelli-jj-redick-off-screen/" class="share-text">
	46</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				22hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a>						<span class="block__time block__time--mobile">22hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/25/philadelphia-76ers-miami-heat-marco-belinelli-jj-redick-off-screen/"
						title="Sixers found perfect play type for Marco Belinelli, JJ Redick vs. Heat"
						itemprop="url" 						>
							Sixers found perfect play type for Marco Belinelli, JJ Redick vs. Heat					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a><span class="dot">&middot;</span>						<span class="time">April 25, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/bryankalbrosky/" title="Posts by Bryan Kalbrosky" class="author url fn" rel="author">Bryan Kalbrosky</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/25/michael-jordan-lebron-james-best-ever-debate/"
						title="10 key stats that LeBron still trails Jordan in race for best ever"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2018/04/gettyimages-944720240.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-944720240.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="10 key stats that LeBron still trails Jordan in race for best ever" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2018/04/25/michael-jordan-lebron-james-best-ever-debate/"
								title="10 key stats that LeBron still trails Jordan in race for best ever"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/04/25/michael-jordan-lebron-james-best-ever-debate/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/04/25/michael-jordan-lebron-james-best-ever-debate/"
			title="10 key stats that LeBron still trails Jordan in race for best ever"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/04/25/michael-jordan-lebron-james-best-ever-debate/" class="share-text">
	363</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				23hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a>						<span class="block__time block__time--mobile">23hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/25/michael-jordan-lebron-james-best-ever-debate/"
						title="10 key stats that LeBron still trails Jordan in race for best ever"
						itemprop="url" 						>
							10 key stats that LeBron still trails Jordan in race for best ever					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a><span class="dot">&middot;</span>						<span class="time">April 25, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/nesbittandy1/" title="Posts by Andy Nesbitt" class="author url fn" rel="author">Andy Nesbitt</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/25/nba-podcasts-du-jour-lakers-to-benefit-from-cavs-thunder-spurs-struggles/"
						title="NBA podcasts du jour: Lakers to benefit from Cavs/Thunder/Spurs struggles?"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2017/02/452862628.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2017/02/452862628.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="NBA podcasts du jour: Lakers to benefit from Cavs/Thunder/Spurs struggles?" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2018/04/25/nba-podcasts-du-jour-lakers-to-benefit-from-cavs-thunder-spurs-struggles/"
								title="NBA podcasts du jour: Lakers to benefit from Cavs/Thunder/Spurs struggles?"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/04/25/nba-podcasts-du-jour-lakers-to-benefit-from-cavs-thunder-spurs-struggles/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/04/25/nba-podcasts-du-jour-lakers-to-benefit-from-cavs-thunder-spurs-struggles/"
			title="NBA podcasts du jour: Lakers to benefit from Cavs/Thunder/Spurs struggles?"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/04/25/nba-podcasts-du-jour-lakers-to-benefit-from-cavs-thunder-spurs-struggles/" class="share-text">
	373</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/podcasts/" class="category" itemprop="articleSection">Podcasts</a>						<span class="block__time block__time--mobile">1d ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/04/25/nba-podcasts-du-jour-lakers-to-benefit-from-cavs-thunder-spurs-struggles/"
						title="NBA podcasts du jour: Lakers to benefit from Cavs/Thunder/Spurs struggles?"
						itemprop="url" 						>
							NBA podcasts du jour: Lakers to benefit from Cavs/Thunder/Spurs struggles?					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/podcasts/" class="category" itemprop="articleSection">Podcasts</a><span class="dot">&middot;</span>						<span class="time">April 25, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/hoopshype/" title="Posts by HoopsHype" class="author url fn" rel="author">HoopsHype</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	</div>
<div class="social-cta container column">

	<h2 class="social-cta__header">
		Follow HH!	</h2>

			<div class="social-cta__column social-cta__column--social">

			<h3 class="social-cta__type social-cta__type--social">Social</h3>
			<span class="social-cta__desc social-cta__desc--social">
				See HH stories in your feed			</span>

							<a
					href="http://facebook.com/hoopshype"
					class="social-cta__button social-cta__button--facebook"
					target="_blank"
				>Like HoopsHype</a>
			
							<a
					href="https://twitter.com/hoopshype"
					class="social-cta__button social-cta__button--twitter"
					target="_blank"
				>Follow HoopsHype</a>
			
		</div>
	
			<div class="social-cta__column social-cta__column--email">

			<h3 class="social-cta__type social-cta__type--email">Newsletter</h3>
			<span class="social-cta__desc social-cta__desc--email">
				Get the day&#039;s top stories			</span>

			<form action="https://hoopshype.com/wp-json/usat/v1/gems/subscribe/">

				<span class="social-cta__input-wrapper">
					<input
						type="email"
						class="social-cta__input"
						placeholder="name@domain.com"
						name="email"
						required
					>
				</span>
				<button
					type="submit"
					class="social-cta__button"
				>Sign me up!</button>

			</form>

			<div class="social-cta__state social-cta__state--success">

				<span class="social-cta__notice social-cta__notice--success">Success</span>

				<p>
					Thanks for signing up.<br>
					You'll be waking up a little more awesome tomorrow.
				</p>

			</div>

			<div class="social-cta__state social-cta__state--error">

				<span class="social-cta__notice social-cta__notice--error">Whoa!</span>

				<p class="social-cta__text--error">
					Something went wrong.
				</p>

				<button class="social-cta__button social-cta__button--dark social-cta__button--reset">
					Try again?
				</button>

			</div>

		</div>
	
			<div class="social-cta__column social-cta__column--podcast">

			<h3 class="social-cta__type social-cta__type--podcast">Podcast</h3>
			<span class="social-cta__desc social-cta__desc--podcast">
				Hear HH writers out loud			</span>

			<a
				href="https://hoopshype.com/category/podcast/"
				class="social-cta__button social-cta__button--podcast"
			>Latest podcast</a>

		</div>
	
</div>
<a href="https://hoopshype.com" class="article__back">More HoopsHype</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		<div class="widget sidebar-ad top">
			<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>		</div>

		
		<div class="widget HotStorylines_Widget" id="hotstorylines_widget-2"><div class="hype-wrapper hot-storylines-wrapper hot-storylines-simple" id="chartContainer-hot-storylines" style="width:100%;" data-url="https://hoopshype.com/post_stats/hot-storylines-stats">
	<div class="hype-title">
		<h2 class="hype-title-title">Hot Storylines</h2>
					</div>
		<ul class="hot-storylines-list">
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/luc-mbah-a-moute-injury/">
					Luc Mbah a Moute Injury				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/enes-kanter-free-agency/">
					Enes Kanter Free Agency				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/marcus-smart-injury/">
					Marcus Smart Injury				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/otto-porter-injury/">
					Otto Porter Injury				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/knicks-coaching-job/">
					Knicks Coaching Job				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/jay-larranaga-to-knicks/">
					Jay Larranaga to Knicks?				</a>
			</li>
			</ul>

			<a class="all-rumors-link" href="https://hoopshype.com/rumors/">View all rumors</a>
	
</div>
</div><div class="widget salaries_widget tabbed_widget" id="salaries_widget-2"><div class="heading-small"><h2>Top salaries</h2></div><div class="tabs">
	<ul class="tab-controls hh-team-details">
					<li><a href="#hh-tab-team-payroll">Team Payrolls</a></li>
							<li><a href="#hh-tab-team-salaries">Player Salaries</a></li>
			</ul>
			<div id="hh-tab-team-payroll" class="hh-team-payroll">
			<table class="">
								<tbody>
											<tr>
							<td>
								1.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/cleveland_cavaliers/">
									Cleveland								</a>
							</td>
															<td>
									$137,718,426								</td>
													</tr>
											<tr>
							<td>
								2.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/golden_state_warriors/">
									Golden State								</a>
							</td>
															<td>
									$137,607,884								</td>
													</tr>
											<tr>
							<td>
								3.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/oklahoma_city_thunder/">
									Oklahoma City								</a>
							</td>
															<td>
									$134,530,140								</td>
													</tr>
											<tr>
							<td>
								4.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/miami_heat/">
									Miami								</a>
							</td>
															<td>
									$133,617,624								</td>
													</tr>
											<tr>
							<td>
								5.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/washington_wizards/">
									Washington								</a>
							</td>
															<td>
									$123,301,896								</td>
													</tr>
											<tr>
							<td>
								6.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/new_orleans_pelicans/">
									New Orleans								</a>
							</td>
															<td>
									$120,809,952								</td>
													</tr>
											<tr>
							<td>
								7.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/milwaukee_bucks/">
									Milwaukee								</a>
							</td>
															<td>
									$120,514,499								</td>
													</tr>
											<tr>
							<td>
								8.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/houston_rockets/">
									Houston								</a>
							</td>
															<td>
									$119,898,782								</td>
													</tr>
											<tr>
							<td>
								9.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/detroit_pistons/">
									Detroit								</a>
							</td>
															<td>
									$119,766,441								</td>
													</tr>
											<tr>
							<td>
								10.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/los_angeles_clippers/">
									LA Clippers								</a>
							</td>
															<td>
									$119,086,260								</td>
													</tr>
									</tbody>
			</table>
							<div class="hh-salaries-cta">
					<a href="https://hoopshype.com/salaries/#hh-tab-team-payroll">
						View more team payrolls
					</a>
				</div>
					</div>
				<div id="hh-tab-team-salaries" class="hh-team-salaries">
			<table>
				<tbody>
											<tr>
							<td class="player-rank">
								1.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/stephen-curry/">
										Stephen Curry									</a>
															</td>
							<td class="player-salary">
								$34,682,550							</td>
						</tr>
											<tr>
							<td class="player-rank">
								2.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/lebron-james/">
										LeBron James									</a>
															</td>
							<td class="player-salary">
								$33,285,709							</td>
						</tr>
											<tr>
							<td class="player-rank">
								3.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/paul-millsap/">
										Paul Millsap									</a>
															</td>
							<td class="player-salary">
								$30,769,231							</td>
						</tr>
											<tr>
							<td class="player-rank">
								4.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/gordon-hayward/">
										Gordon Hayward									</a>
															</td>
							<td class="player-salary">
								$29,727,900							</td>
						</tr>
											<tr>
							<td class="player-rank">
								5.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/blake-griffin/">
										Blake Griffin									</a>
															</td>
							<td class="player-salary">
								$29,512,900							</td>
						</tr>
											<tr>
							<td class="player-rank">
								6.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/kyle-lowry/">
										Kyle Lowry									</a>
															</td>
							<td class="player-salary">
								$28,903,704							</td>
						</tr>
											<tr>
							<td class="player-rank">
								7.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/mike-conley/">
										Mike Conley									</a>
															</td>
							<td class="player-salary">
								$28,530,608							</td>
						</tr>
											<tr>
							<td class="player-rank">
								8.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/james-harden/">
										James Harden									</a>
															</td>
							<td class="player-salary">
								$28,299,399							</td>
						</tr>
											<tr>
							<td class="player-rank">
								8.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/russell-westbrook/">
										Russell Westbrook									</a>
															</td>
							<td class="player-salary">
								$28,299,399							</td>
						</tr>
											<tr>
							<td class="player-rank">
								10.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/demar-derozan/">
										DeMar DeRozan									</a>
															</td>
							<td class="player-salary">
								$27,739,975							</td>
						</tr>
									</tbody>
			</table>
							<div class="hh-salaries-cta">
					<a href="https://hoopshype.com/salaries/#hh-tab-team-salaries">
						View more player salaries
					</a>
				</div>
					</div>
	</div><!-- /.tabs -->
</div><div class="widget widget--newsletter widget--box" id="newsletter_widget-2">
<div class="newsletter__wrapper ">

	<div class="newsletter__signup-wrapper">
		<form novalidate="novalidate" action="https://hoopshype.com/wp-json/usat/v1/gems/subscribe/">

							<h3 class="newsletter__header">NEWSLETTER</h3>
			
			<input
				type="email"
				class="newsletter__input"
				placeholder="Enter your email address"
				name="email"
				required
			>
			<button
					type="submit"
					class="newsletter__button"
			>Sign up			</button>

							<p class="newsletter__text">Always fresh, no spam, guaranteed!</p>
			
			
		</form>

			</div>

	<div class="newsletter__state newsletter__state--success">

		<h3 class="newsletter__header">Success</h3>

		<p class="newsletter__text">
			Thanks for signing up.<br>
			You&#039;ll be waking up a little more awesome tomorrow.		</p>

	</div>

	<div class="newsletter__state newsletter__state--error">

		<h3 class="newsletter__header">Whoa!</h3>

		<p class="newsletter__text newsletter__text--error">
			Something went wrong.		</p>

		<button class="newsletter__button newsletter__button--reset">
			Try again?		</button>

	</div>

	</div>

</div><div class="widget widget_wpcom_social_media_icons_widget" id="wpcom_social_media_icons_widget-2"><div class="heading-small"><h2>Social</h2></div><ul><li><a href="https://www.facebook.com/hoopshype/" class="genericon genericon-facebook" target="_blank"><span class="screen-reader-text">View hoopshype&#8217;s profile on Facebook</span></a></li><li><a href="https://twitter.com/hoopshype/" class="genericon genericon-twitter" target="_blank"><span class="screen-reader-text">View hoopshype&#8217;s profile on Twitter</span></a></li></ul></div><div class="widget tabs hoopshype-social-widget" id="usat_hoopshype_social-2">		<ul class="tab-controls social-widget">
							<li><a href="#usat_hoopshype_social-2-media" >Media</a></li>
							<li><a href="#usat_hoopshype_social-2-players" >Players</a></li>
							<li><a href="#usat_hoopshype_social-2-spanish" >Spanish</a></li>
					</ul>
					<ul id="usat_hoopshype_social-2-media" class="tab-pane social-widget-wrap">
																					<li>
							<header>
								<a class="username" href="https://twitter.com/AaronMcMann" target="_blank"><img src="https://pbs.twimg.com/profile_images/712662350776508416/J_H1yDiS_normal.jpg" class="user-avatar" /></a>
								<div class="social-meta">
									<a class="fullname" href="https://twitter.com/AaronMcMann" target="_blank">Aaron McMann</a>
									<a class="username" href="https://twitter.com/AaronMcMann" target="_blank">@AaronMcMann</a>
								</div>
																	<p>Before I board this plane for France, any other <a href="https://twitter.com/search?q=%23Michigan" target="_blank" rel="nofollow">#Michigan</a> football Qs? Next mailbag drops tomorrow.</p>
															</header>
							<footer class="user-actions">
								<a class="time-posted" href="https://twitter.com/AaronMcMann/status/989608253922439168">16:52 - 26 April 18</a>
								<a href="https://twitter.com/intent/tweet?in_reply_to=989608253922439168">Reply</a>
								<a href="https://twitter.com/intent/retweet?tweet_id=989608253922439168">Retweet</a>
								<a href="https://twitter.com/intent/favorite?tweet_id=989608253922439168">Favorite</a>
							</footer>
						</li>
																	<li>
							<header>
								<a class="username" href="https://twitter.com/MikeVorkunov" target="_blank"><img src="https://pbs.twimg.com/profile_images/777647889690554368/lBsopZnS_normal.jpg" class="user-avatar" /></a>
								<div class="social-meta">
									<a class="fullname" href="https://twitter.com/MikeVorkunov" target="_blank">Mike Vorkunov</a>
									<a class="username" href="https://twitter.com/MikeVorkunov" target="_blank">@MikeVorkunov</a>
								</div>
																	<p>David Blatt interviewed with the Knicks today in Europe, a source confirmed. <a href="https://twitter.com/NYPost_Berman" target="_blank" rel="nofollow">@Marc Berman</a> first with that. Blatt previously coached the Cavs and was fired. He has a stellar resume coaching in Europe. Here's the <a href="https://twitter.com/TheAthleticNYC" target="_blank" rel="nofollow">@TheAthleticNYC</a> coaching profile on Blatt. <a href="https://t.co/9sY1zak3B0" target="_blank" rel="nofollow">theathletic.com/322010/2018/04…</a></p>
															</header>
							<footer class="user-actions">
								<a class="time-posted" href="https://twitter.com/MikeVorkunov/status/989608119180374022">16:52 - 26 April 18</a>
								<a href="https://twitter.com/intent/tweet?in_reply_to=989608119180374022">Reply</a>
								<a href="https://twitter.com/intent/retweet?tweet_id=989608119180374022">Retweet</a>
								<a href="https://twitter.com/intent/favorite?tweet_id=989608119180374022">Favorite</a>
							</footer>
						</li>
																	<li>
							<header>
								<a class="username" href="https://twitter.com/celtics" target="_blank"><img src="https://pbs.twimg.com/profile_images/2815110476/033393c13e6dec0fd6cc5006453fbeb5_normal.png" class="user-avatar" /></a>
								<div class="social-meta">
									<a class="fullname" href="https://twitter.com/celtics" target="_blank">Marc D&#039;Amico</a>
									<a class="username" href="https://twitter.com/celtics" target="_blank">@celtics</a>
								</div>
																	<p>Just over 3 hours until game time. Shop <a href="https://twitter.com/search?q=%23CUsRise" target="_blank" rel="nofollow">#CUsRise</a> gear ➡️ <a href="https://t.co/mPpfjis4PP" target="_blank" rel="nofollow">bit.ly/2r1fWWX</a> <a href="https://t.co/Kj7u3GJbML" target="_blank" rel="nofollow">pic.twitter.com/Kj7u3GJbML</a></p>
															</header>
							<footer class="user-actions">
								<a class="time-posted" href="https://twitter.com/celtics/status/989608061416427520">16:52 - 26 April 18</a>
								<a href="https://twitter.com/intent/tweet?in_reply_to=989608061416427520">Reply</a>
								<a href="https://twitter.com/intent/retweet?tweet_id=989608061416427520">Retweet</a>
								<a href="https://twitter.com/intent/favorite?tweet_id=989608061416427520">Favorite</a>
							</footer>
						</li>
																<li class="social-view-more">
							<a href="https://hoopshype.com/social/">View more NBA Media Twitter</a>
						</li>
												</ul>
					<ul id="usat_hoopshype_social-2-players" class="tab-pane social-widget-wrap">
																					<li>
							<header>
								<a class="username" href="https://twitter.com/LeaderOfHorde" target="_blank"><img src="https://pbs.twimg.com/profile_images/978924818018926592/UyTgIFb2_normal.jpg" class="user-avatar" /></a>
								<div class="social-meta">
									<a class="fullname" href="https://twitter.com/LeaderOfHorde" target="_blank">Bogdan Bogdanovic</a>
									<a class="username" href="https://twitter.com/LeaderOfHorde" target="_blank">@LeaderOfHorde</a>
								</div>
																	<p>Congrats to <a href="https://twitter.com/FBBasketbol" target="_blank" rel="nofollow">@FBBasketbol</a> on making another Final 4! See you in Belgrade! &#129303;&#128170;</p>
															</header>
							<footer class="user-actions">
								<a class="time-posted" href="https://twitter.com/LeaderOfHorde/status/989607897100423168">16:51 - 26 April 18</a>
								<a href="https://twitter.com/intent/tweet?in_reply_to=989607897100423168">Reply</a>
								<a href="https://twitter.com/intent/retweet?tweet_id=989607897100423168">Retweet</a>
								<a href="https://twitter.com/intent/favorite?tweet_id=989607897100423168">Favorite</a>
							</footer>
						</li>
																	<li>
							<header>
								<a class="username" href="https://twitter.com/ThisIsUD" target="_blank"><img src="https://pbs.twimg.com/profile_images/378800000098645027/158cd453eac2f932a09460cfd23de096_normal.jpeg" class="user-avatar" /></a>
								<div class="social-meta">
									<a class="fullname" href="https://twitter.com/ThisIsUD" target="_blank">Udonis Haslem</a>
									<a class="username" href="https://twitter.com/ThisIsUD" target="_blank">@ThisIsUD</a>
								</div>
																	<p>Anybody know when the next Olympic trials? I think I got a shot with my signature Blackflip!!&#128514;&#128557;&#129315; <a href="https://twitter.com/search?q=%23og" target="_blank" rel="nofollow">#og</a> <a href="https://t.co/QOXC1mBc99" target="_blank" rel="nofollow">pic.twitter.com/QOXC1mBc99</a></p>
															</header>
							<footer class="user-actions">
								<a class="time-posted" href="https://twitter.com/ThisIsUD/status/989607659409215489">16:50 - 26 April 18</a>
								<a href="https://twitter.com/intent/tweet?in_reply_to=989607659409215489">Reply</a>
								<a href="https://twitter.com/intent/retweet?tweet_id=989607659409215489">Retweet</a>
								<a href="https://twitter.com/intent/favorite?tweet_id=989607659409215489">Favorite</a>
							</footer>
						</li>
																	<li>
							<header>
								<a class="username" href="https://twitter.com/TheRealJRSmith" target="_blank"><img src="https://pbs.twimg.com/profile_images/797111946243936256/qbW1-iIU_normal.jpg" class="user-avatar" /></a>
								<div class="social-meta">
									<a class="fullname" href="https://twitter.com/TheRealJRSmith" target="_blank">JR Smith</a>
									<a class="username" href="https://twitter.com/TheRealJRSmith" target="_blank">@TheRealJRSmith</a>
								</div>
																	<p>One of my favorite photos. So many things I could say but why? Just SMILE! &#128513; (I was golfing by… <a href="https://t.co/QCBdnJmAM2" target="_blank" rel="nofollow">instagram.com/p/BiDC38QHABk/</a></p>
															</header>
							<footer class="user-actions">
								<a class="time-posted" href="https://twitter.com/TheRealJRSmith/status/989607054154362881">16:48 - 26 April 18</a>
								<a href="https://twitter.com/intent/tweet?in_reply_to=989607054154362881">Reply</a>
								<a href="https://twitter.com/intent/retweet?tweet_id=989607054154362881">Retweet</a>
								<a href="https://twitter.com/intent/favorite?tweet_id=989607054154362881">Favorite</a>
							</footer>
						</li>
																<li class="social-view-more">
							<a href="https://hoopshype.com/social/tweets/">View more NBA Players on Twitter</a>
						</li>
												</ul>
					<ul id="usat_hoopshype_social-2-spanish" class="tab-pane social-widget-wrap">
																					<li>
							<header>
								<a class="username" href="https://twitter.com/nbamarcelogodoy" target="_blank"><img src="https://pbs.twimg.com/profile_images/953440615643140096/-pEDO3Jv_normal.jpg" class="user-avatar" /></a>
								<div class="social-meta">
									<a class="fullname" href="https://twitter.com/nbamarcelogodoy" target="_blank">Marcelo Godoy</a>
									<a class="username" href="https://twitter.com/nbamarcelogodoy" target="_blank">@nbamarcelogodoy</a>
								</div>
																	<p><a href="https://t.co/WrYUfTr3Hk" target="_blank" rel="nofollow">pic.twitter.com/WrYUfTr3Hk</a></p>
															</header>
							<footer class="user-actions">
								<a class="time-posted" href="https://twitter.com/nbamarcelogodoy/status/989607621903769600">16:50 - 26 April 18</a>
								<a href="https://twitter.com/intent/tweet?in_reply_to=989607621903769600">Reply</a>
								<a href="https://twitter.com/intent/retweet?tweet_id=989607621903769600">Retweet</a>
								<a href="https://twitter.com/intent/favorite?tweet_id=989607621903769600">Favorite</a>
							</footer>
						</li>
																	<li>
							<header>
								<a class="username" href="https://twitter.com/mnogueira14" target="_blank"><img src="https://pbs.twimg.com/profile_images/979124318381727750/0QIJkpB-_normal.jpg" class="user-avatar" /></a>
								<div class="social-meta">
									<a class="fullname" href="https://twitter.com/mnogueira14" target="_blank">Marcelo Nogueira</a>
									<a class="username" href="https://twitter.com/mnogueira14" target="_blank">@mnogueira14</a>
								</div>
																	<p>Hay que esperar hasta julio, dijo <a href="https://twitter.com/manuginobili" target="_blank" rel="nofollow">@Manu Ginobili</a> Así será el recorrido de la decisión <a href="https://t.co/UoXI2ser7B" target="_blank" rel="nofollow">ole.com.ar/opinion/nba-op…</a> <a href="https://t.co/cPsttsQQGb" target="_blank" rel="nofollow">pic.twitter.com/cPsttsQQGb</a></p>
															</header>
							<footer class="user-actions">
								<a class="time-posted" href="https://twitter.com/mnogueira14/status/989606819847987206">16:47 - 26 April 18</a>
								<a href="https://twitter.com/intent/tweet?in_reply_to=989606819847987206">Reply</a>
								<a href="https://twitter.com/intent/retweet?tweet_id=989606819847987206">Retweet</a>
								<a href="https://twitter.com/intent/favorite?tweet_id=989606819847987206">Favorite</a>
							</footer>
						</li>
																	<li>
							<header>
								<a class="username" href="https://twitter.com/ganchetto" target="_blank"><img src="https://pbs.twimg.com/profile_images/935613475954548737/YTCY0xGi_normal.jpg" class="user-avatar" /></a>
								<div class="social-meta">
									<a class="fullname" href="https://twitter.com/ganchetto" target="_blank">Javier Gancedo</a>
									<a class="username" href="https://twitter.com/ganchetto" target="_blank">@ganchetto</a>
								</div>
																	<p>Entre Sloukas, Wanamaker, Vesely y Datome anotan por encima de 44 puntos de promedio entre los cuatro. </p>
<p>Hoy llevan 19 entre los cuatro. Pero da igual. Fenerbahce es un equipazo y Obradovic tiene recursos para todo.</p>
															</header>
							<footer class="user-actions">
								<a class="time-posted" href="https://twitter.com/ganchetto/status/989605887592554496">16:43 - 26 April 18</a>
								<a href="https://twitter.com/intent/tweet?in_reply_to=989605887592554496">Reply</a>
								<a href="https://twitter.com/intent/retweet?tweet_id=989605887592554496">Retweet</a>
								<a href="https://twitter.com/intent/favorite?tweet_id=989605887592554496">Favorite</a>
							</footer>
						</li>
																	</ul>
				</div><div class="widget latestnews_widget tabbed_widget" id="latestnews_widget-2"><div class="tabs">
	<ul class="tab-controls hh-team-details">
		<li><a href="#hh-tab-news">Latest News</a></li>
					<li><a href="#hh-tab-custom-tag">Trending</a></li>
			</ul>
	<div id="hh-tab-news" class="col1 right hh-latest-news">
		<ul>
			
<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2018/04/gettyimages-541546966.jpg?w=480 ');" href="https://hoopshype.com/2018/04/26/lebron-james-top-10-playoff-moments/" title="10 times LeBron James did something amazing in the playoffs" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-541546966.jpg?w=100&#038;h=100&#038;crop=1" alt="10 times LeBron James did something amazing in the playoffs" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
												<h2>
						<span class="share-count">0</span>
					</h2>
									</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/dunkwire/" class="category">DunkWire</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/04/26/lebron-james-top-10-playoff-moments/" title="10 times LeBron James did something amazing in the playoffs">
			10 times LeBron James did something amazing in the playoffs		</a>
		<p class="widget-date">April 26, 2018</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=480 ');" href="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/" title="We have ranked the Top 15 NBA rookies of the 21st century" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2018/04/bron-and-melo.jpg?w=100&#038;h=100&#038;crop=1" alt="We have ranked the Top 15 NBA rookies of the 21st century" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
												<h2>
						<span class="share-count">0</span>
					</h2>
									</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/ranking/" class="category">Ranking</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/" title="We have ranked the Top 15 NBA rookies of the 21st century">
			We have ranked the Top 15 NBA rookies of the 21st century		</a>
		<p class="widget-date"></p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2018/03/mikebibbyoffcourt.jpg?w=480 ');" href="https://hoopshype.com/2018/04/26/after-high-school-success-mike-bibby-wants-to-coach-at-the-ncaa-or-nba-level/" title="After high-school success, Mike Bibby wants to coach at the NCAA or NBA level" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2018/03/mikebibbyoffcourt.jpg?w=100&#038;h=100&#038;crop=1" alt="After high-school success, Mike Bibby wants to coach at the NCAA or NBA level" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
												<h2>
						<span class="share-count">34</span>
					</h2>
									</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/interview/" class="category">Interview</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/04/26/after-high-school-success-mike-bibby-wants-to-coach-at-the-ncaa-or-nba-level/" title="After high-school success, Mike Bibby wants to coach at the NCAA or NBA level">
			After high-school success, Mike Bibby wants to coach at the NCAA or NBA level		</a>
		<p class="widget-date"></p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2018/04/usatsi_10361410.jpg?w=453 ');" href="https://hoopshype.com/2018/04/26/oklahoma-city-carmelo-anthony-jerami-grant-alex-abrines-lineup/" title="Thunder excel with Alex Abrines and Jerami Grant, not Carmelo Anthony" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2018/04/usatsi_10361410.jpg?w=100&#038;h=100&#038;crop=1" alt="Thunder excel with Alex Abrines and Jerami Grant, not Carmelo Anthony" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
												<h2>
						<span class="share-count">124</span>
					</h2>
									</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/dunkwire/" class="category">DunkWire</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/04/26/oklahoma-city-carmelo-anthony-jerami-grant-alex-abrines-lineup/" title="Thunder excel with Alex Abrines and Jerami Grant, not Carmelo Anthony">
			Thunder excel with Alex Abrines and Jerami Grant, not Carmelo Anthony		</a>
		<p class="widget-date"></p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2018/04/gettyimages-51830632.jpg?w=480 ');" href="https://hoopshype.com/2018/04/26/ron-artest-brawl-early-retirement-2004/" title="Metta World Peace says he almost retired before &#039;Malice in the Palace&#039;" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2018/04/gettyimages-51830632.jpg?w=100&#038;h=100&#038;crop=1" alt="Metta World Peace says he almost retired before &#039;Malice in the Palace&#039;" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
												<h2>
						<span class="share-count">34</span>
					</h2>
									</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/dunkwire/" class="category">DunkWire</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/04/26/ron-artest-brawl-early-retirement-2004/" title="Metta World Peace says he almost retired before &#039;Malice in the Palace&#039;">
			Metta World Peace says he almost retired before 'Malice in the Palace'		</a>
		<p class="widget-date"></p>
	</div>
</li>
		</ul>
	</div>
			<div id="hh-tab-custom-tag" class="col1 right hh-latest-news">
			<ul>
				
<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2018/04/ben-simmons-wade.jpg?w=480 ');" href="https://hoopshype.com/2018/04/26/trending-stories-the-nba-articles-you-should-read-this-morning-599/" title="The Sixers are not waiting their turn and other trending stories" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2018/04/ben-simmons-wade.jpg?w=100&#038;h=100&#038;crop=1" alt="The Sixers are not waiting their turn and other trending stories" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
												<h2>
						<span class="share-count">41</span>
					</h2>
									</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/social-media/" class="category">Social Media</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/04/26/trending-stories-the-nba-articles-you-should-read-this-morning-599/" title="The Sixers are not waiting their turn and other trending stories">
			The Sixers are not waiting their turn and other trending stories		</a>
		<p class="widget-date"></p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2018/02/wade.jpg?w=480 ');" href="https://hoopshype.com/2018/04/25/trending-stories-the-nba-articles-you-should-read-this-morning-598/" title="Dwyane Wade has a decision to make and other trending stories" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2018/02/wade.jpg?w=100&#038;h=100&#038;crop=1" alt="Dwyane Wade has a decision to make and other trending stories" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
												<h2>
						<span class="share-count">61</span>
					</h2>
									</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/social-media/" class="category">Social Media</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/04/25/trending-stories-the-nba-articles-you-should-read-this-morning-598/" title="Dwyane Wade has a decision to make and other trending stories">
			Dwyane Wade has a decision to make and other trending stories		</a>
		<p class="widget-date">April 25, 2018</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2016/10/usatsi_9638485.jpg?w=480 ');" href="https://hoopshype.com/2018/04/24/trending-stories-the-nba-articles-you-should-read-this-morning-597/" title="Trending stories: Fortnite, playoffs and more" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2016/10/usatsi_9638485.jpg?w=100&#038;h=100&#038;crop=1" alt="Trending stories: Fortnite, playoffs and more" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
												<h2>
						<span class="share-count">19</span>
					</h2>
									</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/social-media/" class="category">Social Media</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/04/24/trending-stories-the-nba-articles-you-should-read-this-morning-597/" title="Trending stories: Fortnite, playoffs and more">
			Trending stories: Fortnite, playoffs and more		</a>
		<p class="widget-date">April 24, 2018</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2017/11/damian-lillard-referee.jpg?w=480 ');" href="https://hoopshype.com/2018/04/23/trending-stories-the-nba-articles-you-should-read-this-morning-596/" title="Trending stories: Trail Blazers exit interviews, Stephen Curry and more" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2017/11/damian-lillard-referee.jpg?w=100&#038;h=100&#038;crop=1" alt="Trending stories: Trail Blazers exit interviews, Stephen Curry and more" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
												<h2>
						<span class="share-count">86</span>
					</h2>
									</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/social-media/" class="category">Social Media</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/04/23/trending-stories-the-nba-articles-you-should-read-this-morning-596/" title="Trending stories: Trail Blazers exit interviews, Stephen Curry and more">
			Trending stories: Trail Blazers exit interviews, Stephen Curry and more		</a>
		<p class="widget-date">April 23, 2018</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2015/12/usatsi_8455088.jpg?w=480 ');" href="https://hoopshype.com/2018/04/20/trending-stories-the-nba-articles-you-should-read-this-morning-595/" title="Trending stories: How the Sixers got good" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2015/12/usatsi_8455088.jpg?w=100&#038;h=100&#038;crop=1" alt="Trending stories: How the Sixers got good" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
												<h2>
						<span class="share-count">194</span>
					</h2>
									</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/social-media/" class="category">Social Media</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/04/20/trending-stories-the-nba-articles-you-should-read-this-morning-595/" title="Trending stories: How the Sixers got good">
			Trending stories: How the Sixers got good		</a>
		<p class="widget-date">April 20, 2018</p>
	</div>
</li>
			</ul>
		</div>
	</div>
</div>
		<div class="widget sidebar-ad bottom">
			<div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_bottom_300x250'); });</script></div>		</div>

		
<div id="footer-info">
	<p class="footer__logo">
		<a href="http://usatodaysports.com" rel="nofollow" target="_blank">
			<img src="https://usathoopshype.files.wordpress.com/2017/01/usatlogo.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-navigation-container"><ul id="menu-footer-navigation" class="menu"><li id="menu-item-992433" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-992433"><a href="https://hoopshype.com/terms-of-service/">Terms of Service</a>
<ul class="sub-menu">
	<li id="menu-item-992432" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-992432"><a href="https://hoopshype.com/privacy/">Privacy Notice/Your California Privacy Rights</a>
	<ul class="sub-menu">
		<li id="menu-item-992434" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-992434"><a href="/privacy/#adchoices">Ad Choices</a></li>
	</ul>
</li>
</ul>
</li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=hoopshype.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "More Information";
		var footer_collapse_text = "Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	
	<!-- wpcom_wp_footer -->
<script type="text/javascript">
	var _sf_async_config = {"uid":"89374","useCanonical":true,"domain":"hoopshype.com","authors":"Frank Urbina","sections":"Longform,Ranking"};

	(function(){
		function loadChartbeat() {
			window._sf_endpt = (new Date()).getTime();
			var e = document.createElement('script');
			e.setAttribute('language', 'javascript');
			e.setAttribute('type', 'text/javascript');
			e.setAttribute('src',
			(('https:' == document.location.protocol) ? 'https://s3.amazonaws.com/' : 'http://') +
			'static.chartbeat.com/js/chartbeat.js');
			document.body.appendChild(e);
		}
		var oldonload = window.onload;
		window.onload = ( 'function' !== typeof window.onload ) ?
		loadChartbeat : function() { oldonload(); loadChartbeat(); };
	})();
</script>
<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://usathoopshype.files.wordpress.com/2017/01/logo-hoopshype-header.png" alt="HoopsHype">
				<a class="mobile-nav__breadcrumb" href="https://hoopshype.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
		<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="http://facebook.com/hoopshype" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/hoopshype" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--podcast">
				<a href="https://hoopshype.com/category/podcast/" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--rumors mobile-nav__item--parent sub-menu-3columns sub-menu-columns-offset200"><a title="NBA Rumors" href="/rumors/">Rumors</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--atlanta-hawks"><a title="Atlanta Rumors" href="https://hoopshype.com/team/atlanta-hawks/">Atlanta Hawks</a></li>
	<li class="mobile-nav__item mobile-nav__item--boston-celtics"><a title="Boston Rumors" href="https://hoopshype.com/team/boston-celtics/">Boston Celtics</a></li>
	<li class="mobile-nav__item mobile-nav__item--brooklyn-nets"><a title="Brooklyn Rumors" href="https://hoopshype.com/team/brooklyn-nets/">Brooklyn Nets</a></li>
	<li class="mobile-nav__item mobile-nav__item--charlotte-hornets"><a title="Charlotte Rumors" href="https://hoopshype.com/team/charlotte-hornets/">Charlotte Hornets</a></li>
	<li class="mobile-nav__item mobile-nav__item--chicago-bulls"><a title="Chicago Rumors" href="https://hoopshype.com/team/chicago-bulls/">Chicago Bulls</a></li>
	<li class="mobile-nav__item mobile-nav__item--cleveland-cavaliers"><a title="Cleveland Rumors" href="https://hoopshype.com/team/cleveland-cavaliers/">Cleveland Cavaliers</a></li>
	<li class="mobile-nav__item mobile-nav__item--dallas-mavericks"><a title="Dallas Rumors" href="https://hoopshype.com/team/dallas-mavericks/">Dallas Mavericks</a></li>
	<li class="mobile-nav__item mobile-nav__item--denver-nuggets"><a title="Denver Rumors" href="https://hoopshype.com/team/denver-nuggets/">Denver Nuggets</a></li>
	<li class="mobile-nav__item mobile-nav__item--detroit-pistons"><a title="Detroit Rumors" href="https://hoopshype.com/team/detroit-pistons/">Detroit Pistons</a></li>
	<li class="mobile-nav__item mobile-nav__item--golden-state-warriors"><a title="Golden State Rumors" href="https://hoopshype.com/team/golden-state-warriors/">Golden State Warriors</a></li>
	<li class="mobile-nav__item mobile-nav__item--houston-rockets"><a title="Houston Rumors" href="https://hoopshype.com/team/houston-rockets/">Houston Rockets</a></li>
	<li class="mobile-nav__item mobile-nav__item--indiana-pacers"><a title="Indiana Rumors" href="https://hoopshype.com/team/indiana-pacers/">Indiana Pacers</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-clippers"><a title="LA Clippers Rumors" href="https://hoopshype.com/team/los-angeles-clippers/">Los Angeles Clippers</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-lakers"><a title="LA Lakers Rumors" href="https://hoopshype.com/team/los-angeles-lakers/">Los Angeles Lakers</a></li>
	<li class="mobile-nav__item mobile-nav__item--memphis-grizzlies"><a title="Memphis Rumors" href="https://hoopshype.com/team/memphis-grizzlies/">Memphis Grizzlies</a></li>
	<li class="mobile-nav__item mobile-nav__item--miami-heat"><a title="Miami Rumors" href="https://hoopshype.com/team/miami-heat/">Miami Heat</a></li>
	<li class="mobile-nav__item mobile-nav__item--milwaukee-bucks"><a title="Milwaukee Rumors" href="https://hoopshype.com/team/milwaukee-bucks/">Milwaukee Bucks</a></li>
	<li class="mobile-nav__item mobile-nav__item--minnesota-timberwolves"><a title="Minnesota Rumors" href="https://hoopshype.com/team/minnesota-timberwolves/">Minnesota Timberwolves</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-orleans-pelicans"><a title="New Orleans Rumors" href="https://hoopshype.com/team/new-orleans-pelicans/">New Orleans Pelicans</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-york-knicks"><a title="New York Rumors" href="https://hoopshype.com/team/new-york-knicks/">New York Knicks</a></li>
	<li class="mobile-nav__item mobile-nav__item--oklahoma-city-thunder"><a title="Oklahoma City Rumors" href="https://hoopshype.com/team/oklahoma-city-thunder/">Oklahoma City Thunder</a></li>
	<li class="mobile-nav__item mobile-nav__item--orlando-magic"><a title="Orlando Rumors" href="https://hoopshype.com/team/orlando-magic/">Orlando Magic</a></li>
	<li class="mobile-nav__item mobile-nav__item--philadelphia-76ers"><a title="Philadelphia Rumors" href="https://hoopshype.com/team/philadelphia-76ers/">Philadelphia 76ers</a></li>
	<li class="mobile-nav__item mobile-nav__item--phoenix-suns"><a title="Phoenix Rumors" href="https://hoopshype.com/team/phoenix-suns/">Phoenix Suns</a></li>
	<li class="mobile-nav__item mobile-nav__item--portland-trail-blazers"><a title="Portland Rumors" href="https://hoopshype.com/team/portland-trail-blazers/">Portland Trail Blazers</a></li>
	<li class="mobile-nav__item mobile-nav__item--sacramento-kings"><a title="Sacramento Rumors" href="https://hoopshype.com/team/sacramento-kings/">Sacramento Kings</a></li>
	<li class="mobile-nav__item mobile-nav__item--san-antonio-spurs"><a title="San Antonio Rumors" href="https://hoopshype.com/team/san-antonio-spurs/">San Antonio Spurs</a></li>
	<li class="mobile-nav__item mobile-nav__item--toronto-raptors"><a title="Toronto Rumors" href="https://hoopshype.com/team/toronto-raptors/">Toronto Raptors</a></li>
	<li class="mobile-nav__item mobile-nav__item--utah-jazz"><a title="Utah Rumors" href="https://hoopshype.com/team/utah-jazz/">Utah Jazz</a></li>
	<li class="mobile-nav__item mobile-nav__item--washington-wizards"><a title="Washington Rumors" href="https://hoopshype.com/team/washington-wizards/">Washington Wizards</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--salaries mobile-nav__item--parent sub-menu-minwidth140"><a title="NBA Salaries" href="/salaries/">Salaries</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--players"><a title="NBA Player Salaries" href="https://hoopshype.com/salaries/players/">Players</a></li>
	<li class="mobile-nav__item mobile-nav__item--teams"><a title="NBA Salaries" href="https://hoopshype.com/salaries/">Teams</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--twitter mobile-nav__item--parent sub-menu-minwidth140"><a title="NBA Media Twitters" href="/social/">Twitter</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--media"><a title="NBA Media Twitters" href="/social/">Media</a></li>
	<li class="mobile-nav__item mobile-nav__item--players"><a title="NBA Players on Twitter" href="/social/tweets/">Players</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--features mobile-nav__item--parent sub-menu-columns"><a href="#">Features</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--agents"><a title="NBA Agents" href="/reps/">Agents</a></li>
	<li class="mobile-nav__item mobile-nav__item--analytics"><a title="NBA Analytics" href="/category/analytics/">Analytics</a></li>
	<li class="mobile-nav__item mobile-nav__item--draft"><a title="NBA Draft" href="/2018/01/09/nba-mock-draft-2018/">Draft</a></li>
	<li class="mobile-nav__item mobile-nav__item--free-agency-2018"><a title="NBA Free Agency 2018" href="/2018/01/11/nba-free-agency-2018-the-top-players/">Free Agency 2018</a></li>
	<li class="mobile-nav__item mobile-nav__item--hoopshype-podcasts"><a href="/category/podcast/">HoopsHype Podcasts</a></li>
	<li class="mobile-nav__item mobile-nav__item--instagram"><a title="NBA Players on Instagram" href="/social/gallery/">Instagram</a></li>
	<li class="mobile-nav__item mobile-nav__item--longform"><a title="Longform" href="https://hoopshype.com/category/longform/">Longform</a></li>
	<li class="mobile-nav__item mobile-nav__item--players"><a title="NBA Players" href="/players/">Players</a></li>
	<li class="mobile-nav__item mobile-nav__item--re-drafts"><a href="https://hoopshype.com/tag/re-drafts/">Re-Drafts</a></li>
	<li class="mobile-nav__item mobile-nav__item--store"><a href="https://sportngoods.threadless.com/collections/hoops-hype/">Store</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-rumors"><a href="https://hoopshype.com/category/top-rumors/">Top Rumors</a></li>
	<li class="mobile-nav__item mobile-nav__item--trade-candidate-watch"><a href="https://hoopshype.com/tag/trade-candidate-watch/">Trade Candidate Watch</a></li>
	<li class="mobile-nav__item mobile-nav__item--transactions"><a title="NBA Transactions" href="/transactions.htm">Transactions</a></li>
	<li class="mobile-nav__item mobile-nav__item--trending-stories"><a href="https://hoopshype.com/tag/trending/">Trending Stories</a></li>
	<li class="mobile-nav__item mobile-nav__item--trivia"><a title="NBA Trivia" href="/category/trivia/">Trivia</a></li>
</ul>
</li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-992433" class="mobile-nav__item mobile-nav__item--terms-of-service mobile-nav__item--parent"><a href="https://hoopshype.com/terms-of-service/">Terms of Service</a>
<ul class="sub-menu">
	<li id="menu-item-992432" class="mobile-nav__item mobile-nav__item--privacy-notice-your-california-privacy-rights mobile-nav__item--parent"><a href="https://hoopshype.com/privacy/">Privacy Notice/Your California Privacy Rights</a>
	<ul class="sub-menu">
		<li id="menu-item-992434" class="mobile-nav__item mobile-nav__item--ad-choices"><a href="/privacy/#adchoices">Ad Choices</a></li>
	</ul>
</li>
</ul>
</li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=hoopshype.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</li>
			</ul>

	</div>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><script src="https://run.adrizer.com/track.js" id="ADRIZER_JS" data-domain="hoopshype.com"></script><script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201817y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script src="https://run.adrizer.com/track.js" id="ADRIZER_JS" data-domain="hoopshype.com"></script><script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/usathoopshype.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/usathoopshype.wordpress.com\/wp-login.php?action=logout&_wpnonce=6f19ba6201","homeURL":"https:\/\/hoopshype.com\/","postID":"1177698","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1521806916j'></script>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="85827622" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://hoopshype.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="HoopsHype" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="9dcbffdf17" /><input type="hidden" name="_wp_http_referer" value="/2018/04/26/we-have-ranked-the-top-15-nba-rookies-of-the-21st-century/" />		</form>

		<div class="arrow"></div>
	</div>
<link rel='stylesheet' id='all-css-0-3' href='https://s0.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1524699534h&cssminify=yes' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='all-css-2-3' href='https://s0.wp.com/wp-content/mu-plugins/genericons/genericons/genericons.css?m=1443615899h&cssminify=yes' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var comment_like_text = {"loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyVy0EOQDAQheELqVGCWIizUBNabZVRHB+xYSOx/d/7YHNMjHZBu4AiaHGVAt0eKgrgMRnPnPadtARaDkgwefTY17bVOH+cxWjMmdiN1KUboE06/INe4YSVKXnKC57HSRapAyLtR9U='></script>
<script type='text/javascript' src='https://native.sharethrough.com/assets/sfp.js?ver=1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var kruxTrackingId = "r5tams7gw";
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var stickyInlineVideosOptions = {"side":"right"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/s2.wp.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var newsletter = {"force_modal":"","force_abovenav":"","is_mobile":"","modal_enabled":"","abovenav_enabled":"","cookie_expiry":"30","inline_position":"10"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var _LAWRENCE_MAIN_EXPORTS = {"right_rail_ad_delay":{"distance":"2000","seconds":"10","active":"1"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiFacebookReferral = "0";
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"1","maxDistance":"1300","medAdHeight":"239","maxDistanceMed":"600","largeAdHeight":"400","maxDistanceLarge":"0","isDesktop":"1","headerHeight":"60"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/hoopshype.com\/wp-admin\/admin-ajax.php","nonce":"de5a1e2082","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/usathoopshype.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fhoopshype.com%2F2018%2F04%2F26%2Fwe-have-ranked-the-top-15-nba-rookies-of-the-21st-century%2F","blog_id":"85827622","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=85827622&v=wpcom&tz=-4&user_id=0&subd=usathoopshype","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyllO120zAMhm8I1zA2OPvB4VoUW7RK/YVlJ82ufmqgbs8WWtL9cxTp0Xuk19ZjUiaGgqHoskOPrAdKujKUaGFSDsaMwaD20VYnfyGAmwoZVmwypcK6Z73P9aBKBrOnsN30/EnfwCZXtxRYs5D2k6LgKKAayGKcgUvxNdwWyNXHPCP73xXztPnlKH2Q9Cb0P7Q2Ril31J3EmBj3hCcABeOqxblH2ckAunhohzWaR2Do6IgJOLLDUjCrkewWy1qxHiisrSkIjqpXeJB0phjejcjXpvVBHTn9jFPNXFdangodvEjbCFZ93ny/WDDHAHnjr8r+J6MFlnZSg8XMJma8gX+3kF2MiXdTmsfTPu4m+NiRQ8VO7oUKMNznjVrIrbpUF7aCgbZQZLX31bMI72RLdxVDFoe4VdM7Fy/5+cKNYGWzSqRJIsutkZOKA+ZMRw+02ErC/DLykqU4neVcxv94uVk6XRVtIMfK6HSPJUkndQpcIVfSb428nPX32biZV6DjD10LAXRoz8/UT//jy9PD47fn56evj/0rR4KFIQ=='></script>
<script type='text/javascript' src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<script>
			(function( $ ) {
				$( "#usat_hoopshype_social-2" ).tabs();
			}( jQuery ));
		</script>
		<script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'85827622','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'85827622','v':'wpcom','tz':'-4','user_id':'0','post':'1177698','subd':'usathoopshype'}]);
function st_vt() {var x=document.createElement("img");x.src="https://pixel.wp.com/g.gif?blog=85827622&v=wpcomvt&tz=-4&user_id=0&post=1177698&subd=usathoopshype&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcvN1dHVE8tU1Y5Tk5xJUNPdGUvNWlURCVDWHdySjhHMEF6azhRa2xxSC5tLj1TNUl6JUJILXl0Wm1BWTZzaltZVVpMN2ozLzdYRzRpYWlKJVtKRDNHYTV6MnxOJjMlMldwMnMyQ3ZIZjBoZ0lnPVEwPStWRz8xKy5yZDdBWHpYQUtkLUhbZF9rZVt2RUlMcWFkYnI3ZWwsayxVWEhXY0N5LGpdTnYld1Blb0oua2QxVWp4Q1dpNC5LTUJGTl0xSlhjZFtbZUJrfEdsT2olQmlOM3JbclkmMDQtdSxEY1djfFlpLm0lWCs='}]);
_stq.push([ 'clickTrackerInit', '85827622', '1177698' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
<!--
	generated 206 seconds ago
	generated in 0.318 seconds
	served from batcache in 0.003 seconds
	expires in 94 seconds
-->
