<!DOCTYPE html>
<!--[if IE 8]> <html lang="en" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://hoopshype.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="POINT GUARDS / SHOOTING GUARDS / SMALL FORWARDS / POWER FORWARDS / CENTERS &amp;nbsp; 1. Sacramento: Marvin Bagley Power Forward / 6-11 / Duke / Freshman 21.0 ppg, 11.1 rpg Bagley makes the most sense from both a positional and talent standpoint." />
<meta name="keywords" content="draft, draft" />
<title>NBA Mock Draft 2018: Power Forwards | HoopsHype</title>
<meta name="google-site-verification" content="ES19h9gPLaQcyadjeYaOsIx4sOJD7JsZ301C9TFyX9A" />
<meta name="msvalidate.01" content="6C7AFE373C691E833D6444FFA7F6E8A2" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=hoopshype.com&amp;id=85827622&amp;t=1529431746&amp;back=https%3A%2F%2Fhoopshype.com%2F2018%2F06%2F19%2Fnba-mock-draft-2018-power-forwards%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//usatodaysports-d.openx.net' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//tags.tiqcdn.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//run.adrizer.com' />
<link rel='dns-prefetch' href='//usathoopshype.wordpress.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="HoopsHype &raquo; Feed" href="https://hoopshype.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="HoopsHype &raquo; Comments Feed" href="https://hoopshype.com/comments/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s2.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1516999477h&ver=4.9.7-alpha-43298"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s1.wp.com/_static/??-eJyFj90OwjAIhV9IrBqd8cL4LLUjDlfaRphzb29no4k/mTcNUD7OOaZP4GJQDGq4g+S7EwUxfXKRQZg8Dh/d3InMzG/MU4tizqjJuhYe3dS6ixfMc05Wxw3Gmix65Lw2hfVUn1AzLs8aFG+TCKfqKTSWTbY36awkPh7TBUUgv0wdgzbZ259EPLov0R8G3yYFJROiUqblVXzdLFLmSsl0YjXWdniJSGbaASh4CghXqjEWrV8f4+UD75eb1Xpb7RarzfkO/eS72w==?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='galleria-theme-css'  href='//cdnjs.cloudflare.com/ajax/libs/galleria/1.4.2/themes/classic/galleria.classic.css?ver=1.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s0.wp.com/_static/??-eJylUEtqAzEMvVBdkZSUZFG6zQ26VmzVoyBbxvJ0mNvXU0jJEEgJ3emh95NgKs5rbpQbtIESGXxxgdGwacDZFRkjZ4NBtdgwF4KkYZQfWiB1EUWozs4Grc1rIEAzaus1kz17syf4I0xwqpQ9XZYfaHjif0jhuNQ+9to3Jmn8vW3iEJfKpp5RHHfKGjwgThQYLxZtlrvBsX9I1GNjzSvgPgW53pNWOonGPkborCu4iN7T22a33W8Pu83L6/kbCzK2jQ==?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-ubuntu-css'  href='https://fonts.googleapis.com/css?family=Ubuntu:300,400,500,700' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-4-1' href='https://s0.wp.com/wp-content/themes/h4/global.css?m=1420737423h&cssminify=yes' type='text/css' media='all' />
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script type='text/javascript'>
/* <![CDATA[ */
var amznAcctId = ["3090"];
/* ]]> */
</script>
<script type='text/javascript'>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");window.bidSlots=window.bidSlots||[];window._mweb=0;apstag.init({pubID: amznAcctId, adServer: "googletag"});
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFjt0KwjAMRl/Irk4UdyM+S9fGmbr+mLQr8+ntQC/EoRAIJCcnnyxRoNdjNsDS1rpnoPnVGssb+QsQDgdSCRqH/g3r4BP4tLAu9DiCyAykhjqroktY4WLg5IC5Qivbz0joJ4TyF7OQotI3QcD4+LKmK9R/csIoM6sUjJrFqAqB17C4ejQGSDjlaySq12d3ag+747bt2m5vn8Z6czs='></script>
<script type='text/javascript' src='https://mtrx.go.sonobi.com/morpheus.usatoday.1587.js?ver=4.9.7-alpha-43298'></script>
<script type='text/javascript' src='https://usatodaysports-d.openx.net/w/1.0/jstag?nc=7103-USA_RON&#038;ver=4.9.7-alpha-43298'></script>
<script type='text/javascript' src='https://js-sec.indexww.com/ht/p/184031-126856402220676.js?ver=4.9.7-alpha-43298'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var utag_data = {"ssts":"sports:hoopshype","priority_asset":"","blogname":"hoopshype","videoincluded":"no","platform":"desktop","contenttype":"story pages","assetid":"1138657","headline":"NBA Mock Draft 2018: Power Forwards","byline":"Aran Smith","taxonomykeywords":"Draft"};
/* ]]> */
</script>
<script type='text/javascript'>
			utag_data.clickPage = sessionStorage.getItem( "clickPage" );
			sessionStorage.setItem( "clickPage", window.location.href );
			
</script>
<script type='text/javascript' src='https://tags.tiqcdn.com/utag/gci/hoopshype/prod/utag.js?ver=4.9.7-alpha-43298'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var usatoday_gallery_ajax_object = {"publisherGA":"UA-5226424-1","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-5226424-1","dfpid":"","pid":"SMG_HoopsHype","ads":[],"tlmurl":"https:\/\/tags.tiqcdn.com\/utag\/gci\/hoopshype\/prod\/utag.js"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJytkEsOwjAMRC9EsAKqWCHOEhK3OM2POGnh9gQhfitAYmfNeJ48hjkJHUPBUKAc0CPDRAkqqxKNOgun5oxBI/hoqmvuPtNwKDpOCJahoHJUvXiqS8sL+ABNrg4UGFQiMSjnMFNbUcxY+JV6887/QFY2qelzs8Qkl6tvmI/uLc8jJeEojKKPurLo6fQrwh7rtYxXFH6NOtrf41xIj1+95O18MvlBaHPL7/xWdnKz7lZSru0FCSzEIA=='></script>
<script type="text/javascript" src="//run.adrizer.com/track.js?ver=4.9.7-alpha-43298" id="ADRIZER_JS" data-domain="hoopshype.com"></script><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://usathoopshype.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://usat.ly/2xYjOfy' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fhoopshype.com%2F2018%2F06%2F19%2Fnba-mock-draft-2018-power-forwards%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fhoopshype.com%2F2018%2F06%2F19%2Fnba-mock-draft-2018-power-forwards%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="NBA Mock Draft 2018: Power Forwards" />
<meta property="og:url" content="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-power-forwards/" />
<meta property="og:description" content="POINT GUARDS / SHOOTING GUARDS / SMALL FORWARDS / POWER FORWARDS / CENTERS &nbsp; 1. Sacramento: Marvin Bagley Power Forward / 6-11 / Duke / Freshman 21.0 ppg, 11.1 rpg Bagley makes the most sense …" />
<meta property="article:published_time" content="2018-06-19T17:30:39+00:00" />
<meta property="article:modified_time" content="2018-06-19T17:34:13+00:00" />
<meta property="og:site_name" content="HoopsHype" />
<meta property="og:image" content="https://usathoopshype.files.wordpress.com/2017/10/marvin-bagley.jpg?w=1024&amp;h=576&amp;crop=1" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@hoopshype" />
<meta name="twitter:text:title" content="NBA Mock Draft 2018: Power Forwards" />
<meta name="twitter:image" content="https://usathoopshype.files.wordpress.com/2017/10/marvin-bagley.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="http://facebook.com/hoopshype" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/8195f692d09575689011557b84764b61?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/8195f692d09575689011557b84764b61?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="https://secure.gravatar.com/blavatar/8195f692d09575689011557b84764b61?s=114" />
<link rel='openid.server' href='https://usathoopshype.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://usathoopshype.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://hoopshype.com/osd.xml" title="HoopsHype" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />

<meta name="gdpr" content="false" />
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script><style type="text/css">
.articleBody a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.widget--box .text-block > h2,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover,
.hero__secondary .hero__link:hover .hero__title {
	color: #eb1e00;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #eb1e00;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #eb1e00;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #eb1e00;
}

.nav__item:hover,
.nav__item--current,
#footer-info {
	border-top-color: #eb1e00;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #eb1e00;
}

.article__back,
.newsletter__input,
.daily-newsletter__input {
	border-color: #eb1e00;
}

.vertical-gallery--icon,
.vertical-gallery__overlay,
.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.newsletter__button,
.daily-newsletter__button {
	background-color: #eb1e00;
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #eb1e00;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #eb1e00;
	}
}

.smg-event__ctabutton {
	background-color: #eb1e00;
	box-shadow: 0 2px 0 0 #eb1e00;
}
</style>
<link rel="canonical" href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-power-forwards/" />
		<style>
			.wpcom-related-posts ul li {
				list-style-type: none;
				display: inline-block;
			}
		</style>
				<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="HoopsHype" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://hoopshype.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/8195f692d09575689011557b84764b61?s=16" />
<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
	bidManager.timeout = 2500;
	bidManager.addBidder('a9');
		bidManager.addBidSlot({ slotID: "videoSlot", mediaType : 'video' } );

	</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>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</script>
<link rel="amphtml" href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-power-forwards/amp/"><style type="text/css" id="syntaxhighlighteranchor"></style>
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s1.wp.com/?custom-css=1&#038;csblog=5O7Gu&#038;cscache=6&#038;csrev=53" />
		
	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-1138657 single-format-standard mp6 customizer-styles-applied highlander-enabled highlander-light">

	
	<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_interstitial' style='width:2px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_interstitial'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_outstream' style='width:4px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_outstream'); });</script></div>
	
<div id="wrapper">

	
	<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>

	<div class="wrapper-holder">

		<div
	class="branding "
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="https://hoopshype.com"
				title="HoopsHype"
				class="branding__logo-link "
			>
				<img
					src="https://usathoopshype.files.wordpress.com/2017/01/logo-hoopshype-header.png"
					alt="HoopsHype"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

	
	<span class="branding__search">
		<form method="get" class="branding__search-form" action="https://hoopshype.com" role="search">
			<input type="text" name="s" value="" placeholder="search HoopsHype" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="http://usatodaysports.com" target="_blank" title="USA TODAY Sports">
			<img src="https://usathoopshype.files.wordpress.com/2017/01/usat-logo-header.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-423204" class="nav__item nav__item--rumors nav__item--parent sub-menu-3columns sub-menu-columns-offset200"><a title="NBA Rumors" href="/rumors/">Rumors</a>
<ul class="sub-menu">
	<li id="menu-item-1023487" class="nav__item nav__item--atlanta-hawks"><a title="Atlanta Rumors" href="https://hoopshype.com/team/atlanta-hawks/">Atlanta Hawks</a></li>
	<li id="menu-item-1023488" class="nav__item nav__item--boston-celtics"><a title="Boston Rumors" href="https://hoopshype.com/team/boston-celtics/">Boston Celtics</a></li>
	<li id="menu-item-1023489" class="nav__item nav__item--brooklyn-nets"><a title="Brooklyn Rumors" href="https://hoopshype.com/team/brooklyn-nets/">Brooklyn Nets</a></li>
	<li id="menu-item-1023490" class="nav__item nav__item--charlotte-hornets"><a title="Charlotte Rumors" href="https://hoopshype.com/team/charlotte-hornets/">Charlotte Hornets</a></li>
	<li id="menu-item-1023491" class="nav__item nav__item--chicago-bulls"><a title="Chicago Rumors" href="https://hoopshype.com/team/chicago-bulls/">Chicago Bulls</a></li>
	<li id="menu-item-1023492" class="nav__item nav__item--cleveland-cavaliers"><a title="Cleveland Rumors" href="https://hoopshype.com/team/cleveland-cavaliers/">Cleveland Cavaliers</a></li>
	<li id="menu-item-1023493" class="nav__item nav__item--dallas-mavericks"><a title="Dallas Rumors" href="https://hoopshype.com/team/dallas-mavericks/">Dallas Mavericks</a></li>
	<li id="menu-item-1023494" class="nav__item nav__item--denver-nuggets"><a title="Denver Rumors" href="https://hoopshype.com/team/denver-nuggets/">Denver Nuggets</a></li>
	<li id="menu-item-1023495" class="nav__item nav__item--detroit-pistons"><a title="Detroit Rumors" href="https://hoopshype.com/team/detroit-pistons/">Detroit Pistons</a></li>
	<li id="menu-item-1023496" class="nav__item nav__item--golden-state-warriors"><a title="Golden State Rumors" href="https://hoopshype.com/team/golden-state-warriors/">Golden State Warriors</a></li>
	<li id="menu-item-1023497" class="nav__item nav__item--houston-rockets"><a title="Houston Rumors" href="https://hoopshype.com/team/houston-rockets/">Houston Rockets</a></li>
	<li id="menu-item-1023498" class="nav__item nav__item--indiana-pacers"><a title="Indiana Rumors" href="https://hoopshype.com/team/indiana-pacers/">Indiana Pacers</a></li>
	<li id="menu-item-1023499" class="nav__item nav__item--los-angeles-clippers"><a title="LA Clippers Rumors" href="https://hoopshype.com/team/los-angeles-clippers/">Los Angeles Clippers</a></li>
	<li id="menu-item-1023500" class="nav__item nav__item--los-angeles-lakers"><a title="LA Lakers Rumors" href="https://hoopshype.com/team/los-angeles-lakers/">Los Angeles Lakers</a></li>
	<li id="menu-item-1023501" class="nav__item nav__item--memphis-grizzlies"><a title="Memphis Rumors" href="https://hoopshype.com/team/memphis-grizzlies/">Memphis Grizzlies</a></li>
	<li id="menu-item-1023502" class="nav__item nav__item--miami-heat"><a title="Miami Rumors" href="https://hoopshype.com/team/miami-heat/">Miami Heat</a></li>
	<li id="menu-item-1023503" class="nav__item nav__item--milwaukee-bucks"><a title="Milwaukee Rumors" href="https://hoopshype.com/team/milwaukee-bucks/">Milwaukee Bucks</a></li>
	<li id="menu-item-1023504" class="nav__item nav__item--minnesota-timberwolves"><a title="Minnesota Rumors" href="https://hoopshype.com/team/minnesota-timberwolves/">Minnesota Timberwolves</a></li>
	<li id="menu-item-1023505" class="nav__item nav__item--new-orleans-pelicans"><a title="New Orleans Rumors" href="https://hoopshype.com/team/new-orleans-pelicans/">New Orleans Pelicans</a></li>
	<li id="menu-item-1023506" class="nav__item nav__item--new-york-knicks"><a title="New York Rumors" href="https://hoopshype.com/team/new-york-knicks/">New York Knicks</a></li>
	<li id="menu-item-1023507" class="nav__item nav__item--oklahoma-city-thunder"><a title="Oklahoma City Rumors" href="https://hoopshype.com/team/oklahoma-city-thunder/">Oklahoma City Thunder</a></li>
	<li id="menu-item-1023508" class="nav__item nav__item--orlando-magic"><a title="Orlando Rumors" href="https://hoopshype.com/team/orlando-magic/">Orlando Magic</a></li>
	<li id="menu-item-1023509" class="nav__item nav__item--philadelphia-76ers"><a title="Philadelphia Rumors" href="https://hoopshype.com/team/philadelphia-76ers/">Philadelphia 76ers</a></li>
	<li id="menu-item-1023510" class="nav__item nav__item--phoenix-suns"><a title="Phoenix Rumors" href="https://hoopshype.com/team/phoenix-suns/">Phoenix Suns</a></li>
	<li id="menu-item-1023511" class="nav__item nav__item--portland-trail-blazers"><a title="Portland Rumors" href="https://hoopshype.com/team/portland-trail-blazers/">Portland Trail Blazers</a></li>
	<li id="menu-item-1023512" class="nav__item nav__item--sacramento-kings"><a title="Sacramento Rumors" href="https://hoopshype.com/team/sacramento-kings/">Sacramento Kings</a></li>
	<li id="menu-item-1023513" class="nav__item nav__item--san-antonio-spurs"><a title="San Antonio Rumors" href="https://hoopshype.com/team/san-antonio-spurs/">San Antonio Spurs</a></li>
	<li id="menu-item-1023514" class="nav__item nav__item--toronto-raptors"><a title="Toronto Rumors" href="https://hoopshype.com/team/toronto-raptors/">Toronto Raptors</a></li>
	<li id="menu-item-1023515" class="nav__item nav__item--utah-jazz"><a title="Utah Rumors" href="https://hoopshype.com/team/utah-jazz/">Utah Jazz</a></li>
	<li id="menu-item-1023516" class="nav__item nav__item--washington-wizards"><a title="Washington Rumors" href="https://hoopshype.com/team/washington-wizards/">Washington Wizards</a></li>
</ul>
</li>
<li id="menu-item-458969" class="nav__item nav__item--salaries nav__item--parent sub-menu-minwidth140"><a title="NBA Salaries" href="/salaries/">Salaries</a>
<ul class="sub-menu">
	<li id="menu-item-16" class="nav__item nav__item--players"><a title="NBA Player Salaries" href="https://hoopshype.com/salaries/players/">Players</a></li>
	<li id="menu-item-12" class="nav__item nav__item--teams"><a title="NBA Salaries" href="https://hoopshype.com/salaries/">Teams</a></li>
</ul>
</li>
<li id="menu-item-1022515" class="nav__item nav__item--twitter nav__item--parent sub-menu-minwidth140"><a title="NBA Media Twitters" href="/social/">Twitter</a>
<ul class="sub-menu">
	<li id="menu-item-18" class="nav__item nav__item--media"><a title="NBA Media Twitters" href="/social/">Media</a></li>
	<li id="menu-item-999057" class="nav__item nav__item--players"><a title="NBA Players on Twitter" href="/social/tweets/">Players</a></li>
</ul>
</li>
<li id="menu-item-423198" class="nav__item nav__item--features nav__item--parent sub-menu-columns"><a href="#">Features</a>
<ul class="sub-menu">
	<li id="menu-item-1000630" class="nav__item nav__item--agents"><a title="NBA Agents" href="/reps/">Agents</a></li>
	<li id="menu-item-1006555" class="nav__item nav__item--analytics"><a title="NBA Analytics" href="/category/analytics/">Analytics</a></li>
	<li id="menu-item-11" class="nav__item nav__item--draft"><a title="NBA Draft" href="/2018/01/09/nba-mock-draft-2018/">Draft</a></li>
	<li id="menu-item-17" class="nav__item nav__item--free-agency-2018"><a title="NBA Free Agency 2018" href="/2018/01/11/nba-free-agency-2018-the-top-players/">Free Agency 2018</a></li>
	<li id="menu-item-1000631" class="nav__item nav__item--hoopshype-podcasts"><a href="/category/podcast/">HoopsHype Podcasts</a></li>
	<li id="menu-item-1006554" class="nav__item nav__item--instagram"><a title="NBA Players on Instagram" href="/social/gallery/">Instagram</a></li>
	<li id="menu-item-1000632" class="nav__item nav__item--longform"><a title="Longform" href="https://hoopshype.com/category/longform/">Longform</a></li>
	<li id="menu-item-423200" class="nav__item nav__item--players"><a title="NBA Players" href="/players/">Players</a></li>
	<li id="menu-item-1119544" class="nav__item nav__item--re-drafts"><a href="https://hoopshype.com/tag/re-drafts/">Re-Drafts</a></li>
	<li id="menu-item-1118240" class="nav__item nav__item--store"><a href="https://sportngoods.threadless.com/collections/hoops-hype/">Store</a></li>
	<li id="menu-item-1160065" class="nav__item nav__item--top-rumors"><a href="https://hoopshype.com/category/top-rumors/">Top Rumors</a></li>
	<li id="menu-item-1119543" class="nav__item nav__item--trade-candidate-watch"><a href="https://hoopshype.com/tag/trade-candidate-watch/">Trade Candidate Watch</a></li>
	<li id="menu-item-10" class="nav__item nav__item--transactions"><a title="NBA Transactions" href="/transactions.htm">Transactions</a></li>
	<li id="menu-item-1068878" class="nav__item nav__item--trending-stories"><a href="https://hoopshype.com/tag/trending/">Trending Stories</a></li>
	<li id="menu-item-1006556" class="nav__item nav__item--trivia"><a title="NBA Trivia" href="/category/trivia/">Trivia</a></li>
</ul>
</li>
		</ul>
		<ul class="nav__social ">
			<li class="nav__item nav__item--social nav__item--facebook">
			<a href="http://facebook.com/hoopshype" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--twitter">
			<a href="https://twitter.com/hoopshype" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--podcast">
			<a href="https://hoopshype.com/category/podcast/" class="nav__item-link"></a>
		</li>
	</ul>
	</nav>
</header>

		
		
		<div id="main" class="site-main ">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-1138657" class="post-1138657 post type-post status-publish format-standard has-post-thumbnail hentry category-draft tag-draft player-jaren-jackson player-marvin-bagley team-brooklyn-nets team-los-angeles-clippers team-los-angeles-lakers team-philadelphia-76ers team-utah-jazz" itemscope
				itemtype="http://schema.org/NewsArticle">

				<div class="article__title ">
	<h1 class="article__headline">NBA Mock Draft 2018: Power Forwards</h1>

			<img width="1000" height="600" src="https://usathoopshype.files.wordpress.com/2017/10/marvin-bagley.jpg?w=1000&amp;h=600&amp;crop=1" class="article__image wp-post-image" alt="" srcset="https://usathoopshype.files.wordpress.com/2017/10/marvin-bagley.jpg?w=1000&amp;h=600&amp;crop=1 1000w, https://usathoopshype.files.wordpress.com/2017/10/marvin-bagley.jpg?w=190&amp;h=114&amp;crop=1 190w, https://usathoopshype.files.wordpress.com/2017/10/marvin-bagley.jpg?w=300&amp;h=180&amp;crop=1 300w, https://usathoopshype.files.wordpress.com/2017/10/marvin-bagley.jpg?w=768&amp;h=461&amp;crop=1 768w, https://usathoopshype.files.wordpress.com/2017/10/marvin-bagley.jpg?w=1024&amp;h=614&amp;crop=1 1024w" sizes="(max-width: 1000px) 100vw, 1000px" data-attachment-id="1138654" data-permalink="https://hoopshype.com/marvin-bagley/" data-orig-file="https://usathoopshype.files.wordpress.com/2017/10/marvin-bagley.jpg" data-orig-size="1280,900" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Marvin Bagley" data-image-description="" data-medium-file="https://usathoopshype.files.wordpress.com/2017/10/marvin-bagley.jpg?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2017/10/marvin-bagley.jpg?w=1000" />		<cite class="article__source"></cite>
		<div class="article__gradient"></div>
	</div>
<h1 class="article__headline article__headline--mobile">NBA Mock Draft 2018: Power Forwards</h1>

				<header class="entry-header  ">

					
<h2 class="cat-show">
	<a href="https://hoopshype.com/category/draft/" class="" itemprop="articleSection">Draft</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">NBA Mock Draft 2018: Power Forwards</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p itemprop="author" itemscope itemtype="http://schema.org/Person">

	
		<span class="post-date updated">June 19, 2018</span>-
		by <a href="https://hoopshype.com/author/aran-smith/" title="Posts by Aran Smith" class="author url fn" rel="author">Aran Smith</a> 
	
	</p>
					</div>

					<div id='acm-ad-tag-lawrence_dfp_mobile_sponsor_by_logo' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_mobile_sponsor_by_logo'); });</script></div>
				</header>

				
				
				
				
				<div id="content-container">
					<div class="entry-content normal-format">

						<div class="article-container">
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-power-forwards/"
		data-short-url="https://usat.ly/2xYjOfy"
		data-track="hoopshypestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-power-forwards/"
		data-short-url="https://usat.ly/2xYjOfy"
		data-track="hoopshypestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="hoopshype"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-power-forwards/"
		data-short-url="https://usat.ly/2xYjOfy"
		data-track="hoopshypestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-power-forwards/"
		data-short-url="https://usat.ly/2xYjOfy"
		data-track="hoopshypestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-power-forwards/"
		data-short-url="https://usat.ly/2xYjOfy"
		data-track="hoopshypestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-power-forwards/"
			data-short-url="https://usat.ly/2xYjOfy"
			data-track="hoopshypestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p itemprop="author" itemscope itemtype="http://schema.org/Person">
		By: <a href="https://hoopshype.com/author/aran-smith/" title="Posts by Aran Smith" class="author url fn" rel="author">Aran Smith</a>		| June 19, 2018		<span class="article__author__widgets">
								</span>
	</p>

	</div>


						
						<div class="articleBody" itemprop="articleBody"><p><a href="/2017/10/04/nba-mock-draft-2018-point-guards" target="_self">POINT GUARDS</a> / <a href="/2017/10/04/nba-mock-draft-2018-shooting-guards" target="_self">SHOOTING GUARDS</a> / <a href="/2017/10/04/nba-mock-draft-2018-small-forwards" target="_self">SMALL FORWARDS</a> / <a href="/2017/10/04/nba-mock-draft-2018-power-forwards" target="_self">POWER FORWARDS</a> / <a href="/2017/10/04/nba-mock-draft-2018-centers" target="_self">CENTERS</a></p>
<p>&nbsp;</p>
<div style="border-top:1px #d0d2c5 solid;">
<div style="border-bottom:1px solid #ea362e;margin-bottom:10px;padding-bottom:10px;">
<table style="margin:0;">
<tbody>
<tr>
<td style="width:90px;text-align:center;vertical-align:top;padding-right:10px;"><img style="max-width:90px;max-height:90px;" src="https://i2.wp.com/cdn.hoopshype.com/i/7d/62/f9/marvin-bagley.jpg" align="top" hspace="1" vspace="1" /></td>
<td>
<div style="display:block;">1. <a style="color:#000000;" href="/team/sacramento_kings/">Sacramento</a>: <a href="http://www.nbadraft.net/players/marvin-bagley">Marvin Bagley</a></div>
<div><b>Power Forward</b><b> / 6-11</b><b> / </b><b>Duke</b><b> / </b><b>Freshman</b></div>
<div style="display:block;color:#353535;">21.0 ppg, 11.1 rpg</div>
</td>
</tr>
<tr>
<td colspan="2">
<div>
<p>Bagley makes the most sense from both a positional and talent standpoint. There are whispers that the team may still be interested in Luka Doncic. But after trading away DeMarcus Cousins, the chance to land a potentially dominant big to anchor their frontcourt is likely too big of an opportunity to pass up. Bagley could team with De&#8217;Aaron Fox to give the Kings a very nice inside/outside nucleus to build around.</p>
</div>
</td>
</tr>
</tbody>
</table>
<div>
<div style="display:inline-block;width:32%;"><b>Twitter:</b> <a href="http://twitter.com/MB3FIVE" target="_blank" rel="nofollow noopener">@MB3FIVE</a></div>
<div style="display:inline-block;width:32%;"><b>Comparison:</b> <a href="http://www.nbadraft.net/players/chris-bosh">Chris Bosh</a></div>
<div style="display:inline-block;width:32%;"><b>Salary:</b> $6,036,200*</div>
</div>
</div>
<div style="border-bottom:1px solid #ea362e;margin-bottom:10px;padding-bottom:10px;">
<table style="margin:0;">
<tbody>
<tr>
<td style="width:90px;text-align:center;vertical-align:top;padding-right:10px;"><img style="max-width:90px;max-height:90px;" src="https://i2.wp.com/cdn.hoopshype.com/i/12/31/19/jaren-jackson.jpg" align="top" hspace="1" vspace="1" /></td>
<td>
<div style="display:block;">2. <a style="color:#000000;" href="/team/memphis_grizzlies/">Memphis</a>: <a href="http://www.nbadraft.net/players/jaren-jackson">Jaren Jackson</a></div>
<div><b>Power Forward</b><b> / 6-11</b><b> / </b><b>Michigan State</b><b> / </b><b>Freshman</b></div>
<div style="display:block;color:#353535;">10.9 ppg, 5.8 rpg</div>
</td>
</tr>
<tr>
<td colspan="2">
<div>
<p>The Grizzlies are all of a sudden one of the oldest and least talented teams in the league and, with a Top 8 protection on their 2019 pick which is headed to Boston, they seem to have a lot of incentive to let their aging talent (Gasol and Conley) move on and start fresh. Jackson is a swing-for-the-fences type of pick that a team in Memphis&#8217; position should be looking at. Some other prospects such as Luka Doncic have a higher floor, but lack the upside of JJJ. Mo Bamba and Michael Porter Jr both make sense as well for their upside and ability to be players a team can attempt to build around.</p>
</div>
</td>
</tr>
</tbody>
</table>
<div>
<div style="display:inline-block;width:32%;"><b>Twitter:</b></div>
<div style="display:inline-block;width:32%;"><b>Comparison:</b> <a href="http://www.nbadraft.net/players/jermaine-oneal">Jermaine O&#8217;Neal</a></div>
<div style="display:inline-block;width:32%;"><b>Salary:</b> $4,887,200*</div>
</div>
</div>
<div style="border-bottom:1px solid #ea362e;margin-bottom:10px;padding-bottom:10px;">
<table style="margin:0;">
<tbody>
<tr>
<td style="width:90px;text-align:center;vertical-align:top;padding-right:10px;"><img style="max-width:90px;max-height:90px;" src="https://i0.wp.com/cdn.hoopshype.com/i/d0/1f/24/wendell-carter.jpg" align="top" hspace="1" vspace="1" /></td>
<td>
<div style="display:block;">3. <a style="color:#000000;" href="/team/cleveland_cavaliers/">Cleveland</a>: <a href="http://www.nbadraft.net/players/wendell-carter">Wendell Carter</a></div>
<div><b>Power Forward</b><b> / 6-10</b><b> / </b><b>Duke</b><b> / </b><b>Freshman</b></div>
<div style="display:block;color:#353535;">13.5 ppg, 9.1 rpg</div>
</td>
</tr>
<tr>
<td colspan="2">
<div>
<p>Carter figures to go in the second half of the Top 10 with 6-through-9 his most likely landing spots. He is one of the safest picks in the draft and would offer a solid replacement for Kevin Love in the event that the team loses LeBron and subsequently moves Love this offseason.</p>
</div>
</td>
</tr>
</tbody>
</table>
<div>
<div style="display:inline-block;width:32%;"><b>Twitter:</b></div>
<div style="display:inline-block;width:32%;"><b>Comparison:</b> <a href="http://www.nbadraft.net/players/al-horford">Al Horford</a></div>
<div style="display:inline-block;width:32%;"><b>Salary:</b> $3,361,500*</div>
</div>
</div>
<div style="border-bottom:1px solid #ea362e;margin-bottom:10px;padding-bottom:10px;">
<table style="margin:0;">
<tbody>
<tr>
<td style="width:90px;text-align:center;vertical-align:top;padding-right:10px;"><img style="max-width:90px;max-height:90px;" src="https://cdn.hoopshype.com/i/9f/23/a5/robert-williams.jpg" align="top" hspace="1" vspace="1" /></td>
<td>
<div style="display:block;">4. <a style="color:#000000;" href="/team/denver_nuggets/">Denver</a>: <a href="http://www.nbadraft.net/players/robert-williams">Robert Williams</a></div>
<div><b>Power Forward</b><b> / 6-9</b><b> / </b><b>Texas A&amp;M</b><b> / </b><b>Sophomore</b></div>
<div style="display:block;color:#353535;">10.4 ppg, 9.2 rpg</div>
</td>
</tr>
<tr>
<td colspan="2">
<div>
<p>Paul Millsap is now 33 years of age so there&#8217;s definitely a need for the team to find his eventual replacement. Williams is an extremely explosive and athletic post player who would figure to pair well with the less athletic but extremely skilled Nikola Jokic.</p>
</div>
</td>
</tr>
</tbody>
</table>
<div>
<div style="display:inline-block;width:32%;"><b>Twitter:</b></div>
<div style="display:inline-block;width:32%;"><b>Comparison:</b> <a href="http://www.nbadraft.net/players/stromile-swift">Stromile Swift</a></div>
<div style="display:inline-block;width:32%;"><b>Salary:</b> $2,391,100*</div>
</div>
</div>
<div style="border-bottom:1px solid #ea362e;margin-bottom:10px;padding-bottom:10px;">
<table style="margin:0;">
<tbody>
<tr>
<td style="width:90px;text-align:center;vertical-align:top;padding-right:10px;"><img style="max-width:90px;max-height:90px;" src="https://i0.wp.com/cdn.hoopshype.com/i/91/8f/07/miles-bridges.jpg" align="top" hspace="1" vspace="1" /></td>
<td>
<div style="display:block;">5. <a style="color:#000000;" href="/team/washington_wizards/">Washington</a>: <a href="http://www.nbadraft.net/players/miles-bridges">Miles Bridges</a></div>
<div><b>Power Forward</b><b> / 6-7</b><b> / </b><b>Michigan State</b><b> / </b><b>Sophomore</b></div>
<div style="display:block;color:#353535;">17.1 ppg, 7.0 rpg</div>
</td>
</tr>
<tr>
<td colspan="2">
<div>
<p>Bridges has everyone using the term &#8220;positionless basketball&#8221;, and while today&#8217;s league has a number of &#8220;tweeners&#8221; thriving, his inability to fit a position could limit his ability to stay on the floor, or actually play into his hands as a possible mismatch. He could fill the role that Markieff Morris currently plays for the Wizards, only for a cheaper price and in a younger, more energetic body.</p>
</div>
</td>
</tr>
</tbody>
</table>
<div>
<div style="display:inline-block;width:32%;"><b>Twitter:</b> <a href="http://twitter.com/MilesBridges" target="_blank" rel="nofollow noopener">@MilesBridges</a></div>
<div style="display:inline-block;width:32%;"><b>Comparison:</b> <a href="http://www.nbadraft.net/players/jerome-kersey">Jerome Kersey</a></div>
<div style="display:inline-block;width:32%;"><b>Salary:</b> $2,271,400*</div>
</div>
</div>
<div style="border-bottom:1px solid #ea362e;margin-bottom:10px;padding-bottom:10px;">
<table style="margin:0;">
<tbody>
<tr>
<td style="width:90px;text-align:center;vertical-align:top;padding-right:10px;"><img style="max-width:90px;max-height:90px;" src="https://cdn.hoopshype.com/i/3c/85/74/omari_spellman.jpg" align="top" hspace="1" vspace="1" /></td>
<td>
<div style="display:block;">6. <a style="color:#000000;" href="/team/utah_jazz/">Utah</a>: <a href="http://www.nbadraft.net/players/omari-spellman">Omari Spellman</a></div>
<div><b>Power Forward</b><b> / 6-9</b><b> / </b><b>Villanova</b><b> / </b><b>Freshman</b></div>
<div style="display:block;color:#353535;">10.9 ppg, 8.0 rpg</div>
</td>
</tr>
<tr>
<td colspan="2">
<div>
<p>Spellman gives the Jazz a skilled big that can do some of the things that Gobert cannot, namely hit outside shots. He&#8217;s probably a few years away from being a starter, if he ever becomes one, but his ability to knock down three-pointers at his size fits into today&#8217;s game superbly.</p>
</div>
</td>
</tr>
</tbody>
</table>
<div>
<div style="display:inline-block;width:32%;"><b>Twitter:</b> <a href="http://twitter.com/Omarispellman" target="_blank" rel="nofollow noopener">@Omarispellman</a></div>
<div style="display:inline-block;width:32%;"><b>Comparison:</b> <a href="http://www.nbadraft.net/players/adreian-payne">Adreian Payne</a></div>
<div style="display:inline-block;width:32%;"><b>Salary:</b> $1,713,900*</div>
</div>
</div>
<div style="border-bottom:1px solid #ea362e;margin-bottom:10px;padding-bottom:10px;">
<table style="margin:0;">
<tbody>
<tr>
<td style="width:90px;text-align:center;vertical-align:top;padding-right:10px;"><img style="max-width:90px;max-height:90px;" src="https://cdn.hoopshype.com/i/ae/a4/47/moritz-wagner.jpg" align="top" hspace="1" vspace="1" /></td>
<td>
<div style="display:block;">7. <a style="color:#000000;" href="/team/atlanta_hawks/">Atlanta</a>: <a href="http://www.nbadraft.net/players/moritz-wagner">Moritz Wagner</a></div>
<div><b>Power Forward</b><b> / 6-11</b><b> / </b><b>Michigan</b><b> / </b><b>Junior</b></div>
<div style="display:block;color:#353535;">14.6 ppg, 7.1 rpg</div>
</td>
</tr>
<tr>
<td colspan="2">
<div>
<p>With a team essentially being built from scratch, developing the right culture is vital. Wagner checks a lot of the boxes as far as being a strong influence and leader, aside from his basketball skills. Is he a team&#8217;s long-term answer as a starting center? Probably not, but he could potentially be a valuable addition for a young team like the Hawks.</p>
</div>
</td>
</tr>
</tbody>
</table>
<div>
<div style="display:inline-block;width:32%;"><b>Twitter:</b></div>
<div style="display:inline-block;width:32%;"><b>Comparison:</b> <a href="http://www.nbadraft.net/players/kelly-olynyk">Kelly Olynyk</a></div>
<div style="display:inline-block;width:32%;"><b>Salary:</b> $1,338,900*</div>
</div>
</div>
<p><b>Key</b>: (*) Standard salary for players selected with that pick in 2018-19.</p>
</div>
<div id=inline-newsletter-widget class=hidden data-position=10><div class="widget widget--newsletter widget--box">
<div class="newsletter__wrapper " style="display: none;">

	<div class="newsletter__signup-wrapper">
		<form novalidate="novalidate" action="https://hoopshype.com/wp-json/usat/v1/gems/subscribe/">

			
			<input
				type="email"
				class="newsletter__input"
				placeholder="Enter your email address"
				name="email"
				required
			>
			<button
					type="submit"
					class="newsletter__button"
			>Sign up			</button>

			
			
		</form>

					<div class="newsletter__sidetext">
				<h3>Like this article?</h3>
				<p>Sign up for the HoopsHype email newsletter to get our top stories in your inbox every morning</p>
			</div>
			</div>

	<div class="newsletter__state newsletter__state--success">

		<h3 class="newsletter__header">Success</h3>

		<p class="newsletter__text">
			Thanks for signing up.<br>
			You&#039;ll be waking up a little more awesome tomorrow.		</p>

	</div>

	<div class="newsletter__state newsletter__state--error">

		<h3 class="newsletter__header">Whoa!</h3>

		<p class="newsletter__text newsletter__text--error">
			Something went wrong.		</p>

		<button class="newsletter__button newsletter__button--reset">
			Try again?		</button>

	</div>

	</div>

</div></div></div>

						
						
						<p class="post-tags post-tags--hide"><a href="https://hoopshype.com/tag/draft/" rel="tag">Draft</a>, <a href="https://hoopshype.com/category/draft/" rel="category tag">Draft</a></p><p>
			<span class="icomoon icon-tag"></span>
			<span class="post-terms"><a href="https://hoopshype.com/category/draft/" rel="tag">Draft</a>, <a href="https://hoopshype.com/tag/draft/" rel="tag">Draft</a>, <a href="https://hoopshype.com/player/jaren-jackson/" rel="tag">Jaren Jackson</a>, <a href="https://hoopshype.com/player/marvin-bagley/" rel="tag">Marvin Bagley</a>, <a href="https://hoopshype.com/team/brooklyn-nets/" rel="tag">Brooklyn Nets</a>, <a href="https://hoopshype.com/team/los-angeles-clippers/" rel="tag">Los Angeles Clippers</a>, <a href="https://hoopshype.com/team/los-angeles-lakers/" rel="tag">Los Angeles Lakers</a>, <a href="https://hoopshype.com/team/philadelphia-76ers/" rel="tag">Philadelphia 76ers</a>, <a href="https://hoopshype.com/team/utah-jazz/" rel="tag">Utah Jazz</a></span>
			</p>
						<div class="story-share-buttons sms no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">0</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-power-forwards/"
		data-short-url="https://usat.ly/2xYjOfy"
		data-track="hoopshypestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-power-forwards/"
		data-short-url="https://usat.ly/2xYjOfy"
		data-track="hoopshypestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="hoopshype"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-power-forwards/"
		data-short-url="https://usat.ly/2xYjOfy"
		data-track="hoopshypestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-power-forwards/"
		data-short-url="https://usat.ly/2xYjOfy"
		data-track="hoopshypestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-power-forwards/"
		data-short-url="https://usat.ly/2xYjOfy"
		data-track="hoopshypestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-power-forwards/"
			data-short-url="https://usat.ly/2xYjOfy"
			data-track="hoopshypestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
</div><div class="after-article widget_text">			<div class="textwidget"><div class="veeseoRA2VW"></div></div>
		</div>					</div><!-- .entry-content -->
				</div><!-- #content-container -->

				
			</article><!-- #post-## -->

		
		<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>RELATED <span>ARTICLES</span></h2>
	</div>
	
	<div class="holder-column">
		<div class="column">
			<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="https://hoopshype.com/2018/04/22/nba-free-agency-2018-the-top-players-2/"
	   data-track="hoopshypefeaturedstories hoopshypemore-chartbeat-1"
	   title="NBA Free Agency 2018: The top players"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usathoopshype.files.wordpress.com/2017/11/lebron-durant-finals.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usathoopshype.files.wordpress.com/2017/11/lebron-durant-finals.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="NBA Free Agency 2018: The top players" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
			</a>

	<div class="text-block">

		<span class="block__shares">3.4k shares</span><span class="block__time block__time--mobile">22 Apr</span>
		<h2><a href="https://hoopshype.com/category/free-agency/" class="category" itemprop="articleSection">Free Agency</a></h2>

		<p>
			<a data-track="hoopshypefeaturedstories hoopshypemore-chartbeat-1" href="https://hoopshype.com/2018/04/22/nba-free-agency-2018-the-top-players-2/"
			   title="NBA Free Agency 2018: The top players" itemprop="url">
				NBA Free Agency 2018: The top players			</a>
		</p>

	</div>
</article>
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018/"
	   data-track="hoopshypefeaturedstories hoopshypemore-related-2"
	   title="NBA Mock Draft 2018"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usathoopshype.files.wordpress.com/2018/04/deandre-ayton.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usathoopshype.files.wordpress.com/2018/04/deandre-ayton.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="NBA Mock Draft 2018" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
			</a>

	<div class="text-block">

		<span class="block__time block__time--mobile">40m ago</span>
		<h2><a href="https://hoopshype.com/category/draft/" class="category" itemprop="articleSection">Draft</a></h2>

		<p>
			<a data-track="hoopshypefeaturedstories hoopshypemore-related-2" href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018/"
			   title="NBA Mock Draft 2018" itemprop="url">
				NBA Mock Draft 2018			</a>
		</p>

	</div>
</article>
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-centers/"
	   data-track="hoopshypefeaturedstories hoopshypemore-related-3"
	   title="NBA Mock Draft 2018: Centers"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usathoopshype.files.wordpress.com/2017/10/deandre-ayton.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usathoopshype.files.wordpress.com/2017/10/deandre-ayton.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="NBA Mock Draft 2018: Centers" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
			</a>

	<div class="text-block">

		<span class="block__time block__time--mobile">37m ago</span>
		<h2><a href="https://hoopshype.com/category/draft/" class="category" itemprop="articleSection">Draft</a></h2>

		<p>
			<a data-track="hoopshypefeaturedstories hoopshypemore-related-3" href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-centers/"
			   title="NBA Mock Draft 2018: Centers" itemprop="url">
				NBA Mock Draft 2018: Centers			</a>
		</p>

	</div>
</article>

		</div>
	</div>
</div>
<div class="container column container--stories">
	<div class="heading-small">
		<h2>LATEST</h2>
	</div>
	<div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_native'); });</script></div>
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-small-forwards/"
						title="NBA Mock Draft 2018: Small Forwards"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2017/10/doncic-madrid.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2017/10/doncic-madrid.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="NBA Mock Draft 2018: Small Forwards" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-small-forwards/"
								title="NBA Mock Draft 2018: Small Forwards"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/06/19/nba-mock-draft-2018-small-forwards/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-small-forwards/"
			title="NBA Mock Draft 2018: Small Forwards"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-small-forwards/" class="share-text">
	0</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				36m			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/draft/" class="category" itemprop="articleSection">Draft</a>						<span class="block__time block__time--mobile">36m ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-small-forwards/"
						title="NBA Mock Draft 2018: Small Forwards"
						itemprop="url" 						>
							NBA Mock Draft 2018: Small Forwards					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/draft/" class="category" itemprop="articleSection">Draft</a><span class="dot">&middot;</span>						<span class="time">June 19, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/aran-smith/" title="Posts by Aran Smith" class="author url fn" rel="author">Aran Smith</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-centers/"
						title="NBA Mock Draft 2018: Centers"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2017/10/deandre-ayton.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2017/10/deandre-ayton.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="NBA Mock Draft 2018: Centers" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-centers/"
								title="NBA Mock Draft 2018: Centers"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/06/19/nba-mock-draft-2018-centers/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-centers/"
			title="NBA Mock Draft 2018: Centers"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-centers/" class="share-text">
	0</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				37m			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/draft/" class="category" itemprop="articleSection">Draft</a>						<span class="block__time block__time--mobile">37m ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-centers/"
						title="NBA Mock Draft 2018: Centers"
						itemprop="url" 						>
							NBA Mock Draft 2018: Centers					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/draft/" class="category" itemprop="articleSection">Draft</a><span class="dot">&middot;</span>						<span class="time">June 19, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/aran-smith/" title="Posts by Aran Smith" class="author url fn" rel="author">Aran Smith</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-shooting-guards/"
						title="NBA Mock Draft 2018: Shooting Guards"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2018/05/mikal-bridges.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2018/05/mikal-bridges.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="NBA Mock Draft 2018: Shooting Guards" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-shooting-guards/"
								title="NBA Mock Draft 2018: Shooting Guards"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/06/19/nba-mock-draft-2018-shooting-guards/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-shooting-guards/"
			title="NBA Mock Draft 2018: Shooting Guards"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-shooting-guards/" class="share-text">
	0</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				39m			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/draft/" class="category" itemprop="articleSection">Draft</a>						<span class="block__time block__time--mobile">39m ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-shooting-guards/"
						title="NBA Mock Draft 2018: Shooting Guards"
						itemprop="url" 						>
							NBA Mock Draft 2018: Shooting Guards					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/draft/" class="category" itemprop="articleSection">Draft</a><span class="dot">&middot;</span>						<span class="time">June 19, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/aran-smith/" title="Posts by Aran Smith" class="author url fn" rel="author">Aran Smith</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-point-guards/"
						title="NBA Mock Draft 2018: Point Guards"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2017/10/collin-sexton.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2017/10/collin-sexton.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="NBA Mock Draft 2018: Point Guards" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-point-guards/"
								title="NBA Mock Draft 2018: Point Guards"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/06/19/nba-mock-draft-2018-point-guards/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-point-guards/"
			title="NBA Mock Draft 2018: Point Guards"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-point-guards/" class="share-text">
	0</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				39m			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/draft/" class="category" itemprop="articleSection">Draft</a>						<span class="block__time block__time--mobile">39m ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-point-guards/"
						title="NBA Mock Draft 2018: Point Guards"
						itemprop="url" 						>
							NBA Mock Draft 2018: Point Guards					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/draft/" class="category" itemprop="articleSection">Draft</a><span class="dot">&middot;</span>						<span class="time">June 19, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/aran-smith/" title="Posts by Aran Smith" class="author url fn" rel="author">Aran Smith</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018/"
						title="NBA Mock Draft 2018"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2018/04/deandre-ayton.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2018/04/deandre-ayton.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="NBA Mock Draft 2018" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018/"
								title="NBA Mock Draft 2018"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/06/19/nba-mock-draft-2018/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018/"
			title="NBA Mock Draft 2018"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018/" class="share-text">
	0</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				40m			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/draft/" class="category" itemprop="articleSection">Draft</a>						<span class="block__time block__time--mobile">40m ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018/"
						title="NBA Mock Draft 2018"
						itemprop="url" 						>
							NBA Mock Draft 2018					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/draft/" class="category" itemprop="articleSection">Draft</a><span class="dot">&middot;</span>						<span class="time">June 19, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/aran-smith/" title="Posts by Aran Smith" class="author url fn" rel="author">Aran Smith</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light no-image">
											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/06/19/kawhi-leonard-rumors-draft-prep-and-other-nba-podcasts-you-need-to-listen-today/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/06/19/kawhi-leonard-rumors-draft-prep-and-other-nba-podcasts-you-need-to-listen-today/"
			title="Kawhi Leonard rumors, draft prep and other NBA podcasts you need to listen today"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/06/19/kawhi-leonard-rumors-draft-prep-and-other-nba-podcasts-you-need-to-listen-today/" class="share-text">
	2</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3hr			</div>

			<div class="content  content--no-image">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/podcasts/" class="category" itemprop="articleSection">Podcasts</a>						<span class="block__time block__time--mobile">3hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/06/19/kawhi-leonard-rumors-draft-prep-and-other-nba-podcasts-you-need-to-listen-today/"
						title="Kawhi Leonard rumors, draft prep and other NBA podcasts you need to listen today"
						itemprop="url" 						>
							Kawhi Leonard rumors, draft prep and other NBA podcasts you need to listen today					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/podcasts/" class="category" itemprop="articleSection">Podcasts</a><span class="dot">&middot;</span>						<span class="time">June 19, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/hoopshype/" title="Posts by HoopsHype" class="author url fn" rel="author">HoopsHype</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/06/19/why-marvin-bagley-iii-could-hold-grudge-against-suns/"
						title="Why Marvin Bagley III could hold grudge against Suns"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2018/06/marvin-bagley.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2018/06/marvin-bagley.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Why Marvin Bagley III could hold grudge against Suns" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2018/06/19/why-marvin-bagley-iii-could-hold-grudge-against-suns/"
								title="Why Marvin Bagley III could hold grudge against Suns"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/06/19/why-marvin-bagley-iii-could-hold-grudge-against-suns/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/06/19/why-marvin-bagley-iii-could-hold-grudge-against-suns/"
			title="Why Marvin Bagley III could hold grudge against Suns"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/06/19/why-marvin-bagley-iii-could-hold-grudge-against-suns/" class="share-text">
	48</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				6hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/video/" class="category" itemprop="articleSection">Video</a>						<span class="block__time block__time--mobile">6hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/06/19/why-marvin-bagley-iii-could-hold-grudge-against-suns/"
						title="Why Marvin Bagley III could hold grudge against Suns"
						itemprop="url" 						>
							Why Marvin Bagley III could hold grudge against Suns					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/video/" class="category" itemprop="articleSection">Video</a><span class="dot">&middot;</span>						<span class="time">June 19, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/tdunhamusatoday/" title="Posts by USA TODAY Sports" class="author url fn" rel="author">USA TODAY Sports</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/06/19/kevin-durant-all-his-signature-sneakers-through-the-years/"
						title="Kevin Durant: All his signature sneakers through the years"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2018/06/https-hypebeast-com-image-2018-06-nike-kd-11-officially-revealed-release-date-1.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2018/06/https-hypebeast-com-image-2018-06-nike-kd-11-officially-revealed-release-date-1.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Kevin Durant: All his signature sneakers through the years" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2018/06/19/kevin-durant-all-his-signature-sneakers-through-the-years/"
								title="Kevin Durant: All his signature sneakers through the years"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/06/19/kevin-durant-all-his-signature-sneakers-through-the-years/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/06/19/kevin-durant-all-his-signature-sneakers-through-the-years/"
			title="Kevin Durant: All his signature sneakers through the years"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/06/19/kevin-durant-all-his-signature-sneakers-through-the-years/" class="share-text">
	73</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				7hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/fashion/" class="category" itemprop="articleSection">Fashion</a>						<span class="block__time block__time--mobile">7hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/06/19/kevin-durant-all-his-signature-sneakers-through-the-years/"
						title="Kevin Durant: All his signature sneakers through the years"
						itemprop="url" 						>
							Kevin Durant: All his signature sneakers through the years					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/fashion/" class="category" itemprop="articleSection">Fashion</a><span class="dot">&middot;</span>						<span class="time">June 19, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/drewruiz90/" title="Posts by Drew Ruiz" class="author url fn" rel="author">Drew Ruiz</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/06/19/nba-draft-best-player-each-year/"
						title="Picking the best player in each NBA draft over the last 20 years"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2018/06/gettyimages-685257986.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2018/06/gettyimages-685257986.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Picking the best player in each NBA draft over the last 20 years" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2018/06/19/nba-draft-best-player-each-year/"
								title="Picking the best player in each NBA draft over the last 20 years"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/06/19/nba-draft-best-player-each-year/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/06/19/nba-draft-best-player-each-year/"
			title="Picking the best player in each NBA draft over the last 20 years"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/06/19/nba-draft-best-player-each-year/" class="share-text">
	78</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				10hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a>						<span class="block__time block__time--mobile">10hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/06/19/nba-draft-best-player-each-year/"
						title="Picking the best player in each NBA draft over the last 20 years"
						itemprop="url" 						>
							Picking the best player in each NBA draft over the last 20 years					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a><span class="dot">&middot;</span>						<span class="time">June 19, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/nesbittandy1/" title="Posts by Andy Nesbitt" class="author url fn" rel="author">Andy Nesbitt</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/06/18/nba-draft-instagram-trae-young-luka-doncic-michael-porter-jr/"
						title="Which top 2018 NBA draft prospects have the most Instagram influence?"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2018/06/gettyimages-960230020.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2018/06/gettyimages-960230020.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Which top 2018 NBA draft prospects have the most Instagram influence?" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2018/06/18/nba-draft-instagram-trae-young-luka-doncic-michael-porter-jr/"
								title="Which top 2018 NBA draft prospects have the most Instagram influence?"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2018/06/18/nba-draft-instagram-trae-young-luka-doncic-michael-porter-jr/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2018/06/18/nba-draft-instagram-trae-young-luka-doncic-michael-porter-jr/"
			title="Which top 2018 NBA draft prospects have the most Instagram influence?"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2018/06/18/nba-draft-instagram-trae-young-luka-doncic-michael-porter-jr/" class="share-text">
	103</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				20hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a>						<span class="block__time block__time--mobile">20hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2018/06/18/nba-draft-instagram-trae-young-luka-doncic-michael-porter-jr/"
						title="Which top 2018 NBA draft prospects have the most Instagram influence?"
						itemprop="url" 						>
							Which top 2018 NBA draft prospects have the most Instagram influence?					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a><span class="dot">&middot;</span>						<span class="time">June 18, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="https://hoopshype.com/author/bryankalbrosky/" title="Posts by Bryan Kalbrosky" class="author url fn" rel="author">Bryan Kalbrosky</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	</div>
<div class="social-cta container column">

	<h2 class="social-cta__header">
		Follow HH!	</h2>

			<div class="social-cta__column social-cta__column--social">

			<h3 class="social-cta__type social-cta__type--social">Social</h3>
			<span class="social-cta__desc social-cta__desc--social">
				See HH stories in your feed			</span>

							<a
					href="http://facebook.com/hoopshype"
					class="social-cta__button social-cta__button--facebook"
					target="_blank"
				>Like HoopsHype</a>
			
							<a
					href="https://twitter.com/hoopshype"
					class="social-cta__button social-cta__button--twitter"
					target="_blank"
				>Follow HoopsHype</a>
			
		</div>
	
			<div class="social-cta__column social-cta__column--email">

			<h3 class="social-cta__type social-cta__type--email">Newsletter</h3>
			<span class="social-cta__desc social-cta__desc--email">
				Get the day&#039;s top stories			</span>

			<form action="https://hoopshype.com/wp-json/usat/v1/gems/subscribe/">

				<span class="social-cta__input-wrapper">
					<input
						type="email"
						class="social-cta__input"
						placeholder="name@domain.com"
						name="email"
						required
					>
				</span>
				<button
					type="submit"
					class="social-cta__button"
				>Sign me up!</button>

			</form>

			<div class="social-cta__state social-cta__state--success">

				<span class="social-cta__notice social-cta__notice--success">Success</span>

				<p>
					Thanks for signing up.<br>
					You'll be waking up a little more awesome tomorrow.
				</p>

			</div>

			<div class="social-cta__state social-cta__state--error">

				<span class="social-cta__notice social-cta__notice--error">Whoa!</span>

				<p class="social-cta__text--error">
					Something went wrong.
				</p>

				<button class="social-cta__button social-cta__button--dark social-cta__button--reset">
					Try again?
				</button>

			</div>

		</div>
	
			<div class="social-cta__column social-cta__column--podcast">

			<h3 class="social-cta__type social-cta__type--podcast">Podcast</h3>
			<span class="social-cta__desc social-cta__desc--podcast">
				Hear HH writers out loud			</span>

			<a
				href="https://hoopshype.com/category/podcast/"
				class="social-cta__button social-cta__button--podcast"
			>Latest podcast</a>

		</div>
	
</div>
<a href="https://hoopshype.com" class="article__back">More HoopsHype</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		
			<div class="widget sidebar-ad top">
				<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>			</div>

		
		
		<div class="widget HotStorylines_Widget" id="hotstorylines_widget-2"><div class="hype-wrapper hot-storylines-wrapper hot-storylines-simple" id="chartContainer-hot-storylines" style="width:100%;" data-url="https://hoopshype.com/post_stats/hot-storylines-stats">
	<div class="hype-title">
		<h2 class="hype-title-title">Hot Storylines</h2>
					</div>
		<ul class="hot-storylines-list">
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/sterling-brown-arrest/">
					Sterling Brown Arrest				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/draft-workouts/">
					Draft Workouts				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/sneaker-deals/">
					Sneaker Deals				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/kemba-walker-trade/">
					Kemba Walker Trade?				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/kemba-walker-to-cavs/">
					Kemba Walker to Cavs?				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/kawhi-leonard-trade/">
					Kawhi Leonard Trade?				</a>
			</li>
			</ul>

			<a class="all-rumors-link" href="https://hoopshype.com/rumors/">View all rumors</a>
	
</div>
</div><div class="widget salaries_widget tabbed_widget" id="salaries_widget-2"><div class="heading-small"><h2>Top salaries</h2></div><div class="tabs">
	<ul class="tab-controls hh-team-details">
					<li><a href="#hh-tab-team-payroll">Team Payrolls</a></li>
							<li><a href="#hh-tab-team-salaries">Player Salaries</a></li>
			</ul>
			<div id="hh-tab-team-payroll" class="hh-team-payroll">
			<table class="">
								<tbody>
											<tr>
							<td>
								1.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/cleveland_cavaliers/">
									Cleveland								</a>
							</td>
															<td>
									$137,718,426								</td>
													</tr>
											<tr>
							<td>
								2.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/golden_state_warriors/">
									Golden State								</a>
							</td>
															<td>
									$137,607,884								</td>
													</tr>
											<tr>
							<td>
								3.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/oklahoma_city_thunder/">
									Oklahoma City								</a>
							</td>
															<td>
									$134,530,140								</td>
													</tr>
											<tr>
							<td>
								4.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/miami_heat/">
									Miami								</a>
							</td>
															<td>
									$133,617,624								</td>
													</tr>
											<tr>
							<td>
								5.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/washington_wizards/">
									Washington								</a>
							</td>
															<td>
									$123,301,896								</td>
													</tr>
											<tr>
							<td>
								6.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/new_orleans_pelicans/">
									New Orleans								</a>
							</td>
															<td>
									$120,809,952								</td>
													</tr>
											<tr>
							<td>
								7.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/milwaukee_bucks/">
									Milwaukee								</a>
							</td>
															<td>
									$120,514,499								</td>
													</tr>
											<tr>
							<td>
								8.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/houston_rockets/">
									Houston								</a>
							</td>
															<td>
									$119,898,782								</td>
													</tr>
											<tr>
							<td>
								9.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/detroit_pistons/">
									Detroit								</a>
							</td>
															<td>
									$119,766,441								</td>
													</tr>
											<tr>
							<td>
								10.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/los_angeles_clippers/">
									LA Clippers								</a>
							</td>
															<td>
									$119,086,260								</td>
													</tr>
									</tbody>
			</table>
							<div class="hh-salaries-cta">
					<a href="https://hoopshype.com/salaries/#hh-tab-team-payroll">
						View more team payrolls
					</a>
				</div>
					</div>
				<div id="hh-tab-team-salaries" class="hh-team-salaries">
			<table>
				<tbody>
											<tr>
							<td class="player-rank">
								1.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/stephen-curry/">
										Stephen Curry									</a>
															</td>
							<td class="player-salary">
								$34,682,550							</td>
						</tr>
											<tr>
							<td class="player-rank">
								2.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/lebron-james/">
										LeBron James									</a>
															</td>
							<td class="player-salary">
								$33,285,709							</td>
						</tr>
											<tr>
							<td class="player-rank">
								3.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/paul-millsap/">
										Paul Millsap									</a>
															</td>
							<td class="player-salary">
								$30,769,231							</td>
						</tr>
											<tr>
							<td class="player-rank">
								4.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/gordon-hayward/">
										Gordon Hayward									</a>
															</td>
							<td class="player-salary">
								$29,727,900							</td>
						</tr>
											<tr>
							<td class="player-rank">
								5.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/blake-griffin/">
										Blake Griffin									</a>
															</td>
							<td class="player-salary">
								$29,512,900							</td>
						</tr>
											<tr>
							<td class="player-rank">
								6.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/kyle-lowry/">
										Kyle Lowry									</a>
															</td>
							<td class="player-salary">
								$28,903,704							</td>
						</tr>
											<tr>
							<td class="player-rank">
								7.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/mike-conley/">
										Mike Conley									</a>
															</td>
							<td class="player-salary">
								$28,530,608							</td>
						</tr>
											<tr>
							<td class="player-rank">
								8.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/james-harden/">
										James Harden									</a>
															</td>
							<td class="player-salary">
								$28,299,399							</td>
						</tr>
											<tr>
							<td class="player-rank">
								8.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/russell-westbrook/">
										Russell Westbrook									</a>
															</td>
							<td class="player-salary">
								$28,299,399							</td>
						</tr>
											<tr>
							<td class="player-rank">
								10.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/demar-derozan/">
										DeMar DeRozan									</a>
															</td>
							<td class="player-salary">
								$27,739,975							</td>
						</tr>
									</tbody>
			</table>
							<div class="hh-salaries-cta">
					<a href="https://hoopshype.com/salaries/#hh-tab-team-salaries">
						View more player salaries
					</a>
				</div>
					</div>
	</div><!-- /.tabs -->
</div><div class="widget widget--newsletter widget--box" id="newsletter_widget-2">
<div class="newsletter__wrapper " style="display: none;">

	<div class="newsletter__signup-wrapper">
		<form novalidate="novalidate" action="https://hoopshype.com/wp-json/usat/v1/gems/subscribe/">

							<h3 class="newsletter__header">NEWSLETTER</h3>
			
			<input
				type="email"
				class="newsletter__input"
				placeholder="Enter your email address"
				name="email"
				required
			>
			<button
					type="submit"
					class="newsletter__button"
			>Sign up			</button>

							<p class="newsletter__text">Always fresh, no spam, guaranteed!</p>
			
			
		</form>

			</div>

	<div class="newsletter__state newsletter__state--success">

		<h3 class="newsletter__header">Success</h3>

		<p class="newsletter__text">
			Thanks for signing up.<br>
			You&#039;ll be waking up a little more awesome tomorrow.		</p>

	</div>

	<div class="newsletter__state newsletter__state--error">

		<h3 class="newsletter__header">Whoa!</h3>

		<p class="newsletter__text newsletter__text--error">
			Something went wrong.		</p>

		<button class="newsletter__button newsletter__button--reset">
			Try again?		</button>

	</div>

	</div>

</div><div class="widget widget_wpcom_social_media_icons_widget" id="wpcom_social_media_icons_widget-2"><div class="heading-small"><h2>Social</h2></div><ul><li><a href="https://www.facebook.com/hoopshype/" class="genericon genericon-facebook" target="_blank"><span class="screen-reader-text">View hoopshype&#8217;s profile on Facebook</span></a></li><li><a href="https://twitter.com/hoopshype/" class="genericon genericon-twitter" target="_blank"><span class="screen-reader-text">View hoopshype&#8217;s profile on Twitter</span></a></li></ul></div><div class="widget tabs hoopshype-social-widget" id="usat_hoopshype_social-2">		<ul class="tab-controls social-widget">
							<li><a href="#usat_hoopshype_social-2-media" >Media</a></li>
							<li><a href="#usat_hoopshype_social-2-players" >Players</a></li>
							<li><a href="#usat_hoopshype_social-2-spanish" >Spanish</a></li>
					</ul>
					<ul id="usat_hoopshype_social-2-media" class="tab-pane social-widget-wrap">
																					<li>
							<header>
								<a class="username" href="https://twitter.com/mr_jasonjones" target="_blank"><img src="https://pbs.twimg.com/profile_images/537468012350033920/ww1mX-40_normal.jpeg" class="user-avatar" /></a>
								<div class="social-meta">
									<a class="fullname" href="https://twitter.com/mr_jasonjones" target="_blank">Jason Jones</a>
									<a class="username" href="https://twitter.com/mr_jasonjones" target="_blank">@mr_jasonjones</a>
								</div>
																	<p>When you play GM and upset a lot of Kings fans ... lol  <a href="https://t.co/vmg25nNcVX" target="_blank" rel="nofollow">sacbee.com/sports/nba/sac…</a></p>
															</header>
							<footer class="user-actions">
								<a class="time-posted" href="https://twitter.com/mr_jasonjones/status/1009135071209578497">14:05 - 19 June 18</a>
								<a href="https://twitter.com/intent/tweet?in_reply_to=1009135071209578497">Reply</a>
								<a href="https://twitter.com/intent/retweet?tweet_id=1009135071209578497">Retweet</a>
								<a href="https://twitter.com/intent/favorite?tweet_id=1009135071209578497">Favorite</a>
							</footer>
						</li>
																	<li>
							<header>
								<a class="username" href="https://twitter.com/PompeyOnSixers" target="_blank"><img src="https://pbs.twimg.com/profile_images/933381144443224064/8cuBiKoM_normal.jpg" class="user-avatar" /></a>
								<div class="social-meta">
									<a class="fullname" href="https://twitter.com/PompeyOnSixers" target="_blank">Keith Pompey</a>
									<a class="username" href="https://twitter.com/PompeyOnSixers" target="_blank">@PompeyOnSixers</a>
								</div>
																	<p><a href="https://twitter.com/search?q=%23Kentucky" target="_blank" rel="nofollow">#Kentucky</a> SF Kevin Knox looked tired in the portion of the draft workout open to the media on Tuesday. He’s had a busy weekend. He worked out here Friday, at Charlotte Saturday, with his mom in Miami on Sunday and flew back here yesterday.</p>
															</header>
							<footer class="user-actions">
								<a class="time-posted" href="https://twitter.com/PompeyOnSixers/status/1009134965748129795">14:04 - 19 June 18</a>
								<a href="https://twitter.com/intent/tweet?in_reply_to=1009134965748129795">Reply</a>
								<a href="https://twitter.com/intent/retweet?tweet_id=1009134965748129795">Retweet</a>
								<a href="https://twitter.com/intent/favorite?tweet_id=1009134965748129795">Favorite</a>
							</footer>
						</li>
																	<li>
							<header>
								<a class="username" href="https://twitter.com/kayte_c" target="_blank"><img src="https://pbs.twimg.com/profile_images/890273486375178240/409O80Gh_normal.jpg" class="user-avatar" /></a>
								<div class="social-meta">
									<a class="fullname" href="https://twitter.com/kayte_c" target="_blank">Kayte Christensen</a>
									<a class="username" href="https://twitter.com/kayte_c" target="_blank">@kayte_c</a>
								</div>
																	<p>Cleaning out the old photos in my camera roll today and stumbled upon those beauts taken a year ago today!! Neither of us had ANY idea where we would be a year later but man does happiness feel amazing! <a href="https://twitter.com/search?q=%23TheHunters" target="_blank" rel="nofollow">#TheHunters</a></p>
															</header>
							<footer class="user-actions">
								<a class="time-posted" href="https://twitter.com/kayte_c/status/1009134924928974848">14:04 - 19 June 18</a>
								<a href="https://twitter.com/intent/tweet?in_reply_to=1009134924928974848">Reply</a>
								<a href="https://twitter.com/intent/retweet?tweet_id=1009134924928974848">Retweet</a>
								<a href="https://twitter.com/intent/favorite?tweet_id=1009134924928974848">Favorite</a>
							</footer>
						</li>
																<li class="social-view-more">
							<a href="https://hoopshype.com/social/">View more NBA Media Twitter</a>
						</li>
												</ul>
					<ul id="usat_hoopshype_social-2-players" class="tab-pane social-widget-wrap">
																					<li>
							<header>
								<a class="username" href="https://twitter.com/hoopshype" target="_blank"><img src="https://pbs.twimg.com/profile_images/609457974415896576/yhzsQNk9_normal.png" class="user-avatar" /></a>
								<div class="social-meta">
									<a class="fullname" href="https://twitter.com/hoopshype" target="_blank">Jorge Sierra</a>
									<a class="username" href="https://twitter.com/hoopshype" target="_blank">@hoopshype</a>
								</div>
																	<p>Why Marvin Bagley III could hold grudge against Suns. <a href="https://t.co/ExbRigndAu" target="_blank" rel="nofollow">bit.ly/2MBi4xQ</a> <a href="https://t.co/6XShqYvut8" target="_blank" rel="nofollow">pic.twitter.com/6XShqYvut8</a></p>
															</header>
							<footer class="user-actions">
								<a class="time-posted" href="https://twitter.com/hoopshype/status/1009133768052002816">14:00 - 19 June 18</a>
								<a href="https://twitter.com/intent/tweet?in_reply_to=1009133768052002816">Reply</a>
								<a href="https://twitter.com/intent/retweet?tweet_id=1009133768052002816">Retweet</a>
								<a href="https://twitter.com/intent/favorite?tweet_id=1009133768052002816">Favorite</a>
							</footer>
						</li>
																	<li>
							<header>
								<a class="username" href="https://twitter.com/JaValeMcGee" target="_blank"><img src="https://pbs.twimg.com/profile_images/990269028865212416/QWcLNl91_normal.jpg" class="user-avatar" /></a>
								<div class="social-meta">
									<a class="fullname" href="https://twitter.com/JaValeMcGee" target="_blank">JaVale McGee</a>
									<a class="username" href="https://twitter.com/JaValeMcGee" target="_blank">@JaValeMcGee</a>
								</div>
																	<p>June 23rd <a href="https://t.co/o0NZky3qXM" target="_blank" rel="nofollow">pic.twitter.com/o0NZky3qXM</a></p>
															</header>
							<footer class="user-actions">
								<a class="time-posted" href="https://twitter.com/JaValeMcGee/status/1009132677704945664">13:55 - 19 June 18</a>
								<a href="https://twitter.com/intent/tweet?in_reply_to=1009132677704945664">Reply</a>
								<a href="https://twitter.com/intent/retweet?tweet_id=1009132677704945664">Retweet</a>
								<a href="https://twitter.com/intent/favorite?tweet_id=1009132677704945664">Favorite</a>
							</footer>
						</li>
																	<li>
							<header>
								<a class="username" href="https://twitter.com/imanshumpert" target="_blank"><img src="https://pbs.twimg.com/profile_images/996134990151847936/INJXhprI_normal.jpg" class="user-avatar" /></a>
								<div class="social-meta">
									<a class="fullname" href="https://twitter.com/imanshumpert" target="_blank">Iman Shumpert</a>
									<a class="username" href="https://twitter.com/imanshumpert" target="_blank">@imanshumpert</a>
								</div>
																	<p>My wife bought me the bag for fathers day. I'll never feed a parking meter again. <a href="https://twitter.com/search?q=%23yesterday" target="_blank" rel="nofollow">#yesterday</a> <a href="https://twitter.com/search?q=%23substanceabuse" target="_blank" rel="nofollow">#substanceabuse</a> <a href="https://t.co/CydVn1YP5i" target="_blank" rel="nofollow">pic.twitter.com/CydVn1YP5i</a></p>
															</header>
							<footer class="user-actions">
								<a class="time-posted" href="https://twitter.com/imanshumpert/status/1009132671979565058">13:55 - 19 June 18</a>
								<a href="https://twitter.com/intent/tweet?in_reply_to=1009132671979565058">Reply</a>
								<a href="https://twitter.com/intent/retweet?tweet_id=1009132671979565058">Retweet</a>
								<a href="https://twitter.com/intent/favorite?tweet_id=1009132671979565058">Favorite</a>
							</footer>
						</li>
																<li class="social-view-more">
							<a href="https://hoopshype.com/social/tweets/">View more NBA Players on Twitter</a>
						</li>
												</ul>
					<ul id="usat_hoopshype_social-2-spanish" class="tab-pane social-widget-wrap">
																					<li>
							<header>
								<a class="username" href="https://twitter.com/pantxopaniagua" target="_blank"><img src="https://pbs.twimg.com/profile_images/378800000425970580/a7896737046d956bcd7063566db33935_normal.jpeg" class="user-avatar" /></a>
								<div class="social-meta">
									<a class="fullname" href="https://twitter.com/pantxopaniagua" target="_blank">Miguel Angel Paniagua</a>
									<a class="username" href="https://twitter.com/pantxopaniagua" target="_blank">@pantxopaniagua</a>
								</div>
																	<p>¡Genial!. Solo un detalle, queridos camaradas de <a href="https://twitter.com/tjcope" target="_blank" rel="nofollow">@tjcope</a> : como dice un gran entrenador de basket -y viejo amigo- que trabajó allí, "rusa se debería escribir con R mayúscula" &#128521; <a href="https://t.co/HYZkN8Nzmx" target="_blank" rel="nofollow">twitter.com/tjcope/status/…</a></p>
															</header>
							<footer class="user-actions">
								<a class="time-posted" href="https://twitter.com/pantxopaniagua/status/1009135209042890753">14:05 - 19 June 18</a>
								<a href="https://twitter.com/intent/tweet?in_reply_to=1009135209042890753">Reply</a>
								<a href="https://twitter.com/intent/retweet?tweet_id=1009135209042890753">Retweet</a>
								<a href="https://twitter.com/intent/favorite?tweet_id=1009135209042890753">Favorite</a>
							</footer>
						</li>
																	<li>
							<header>
								<a class="username" href="https://twitter.com/chemadelucas" target="_blank"><img src="https://pbs.twimg.com/profile_images/980880523915616256/YYIlQS-d_normal.jpg" class="user-avatar" /></a>
								<div class="social-meta">
									<a class="fullname" href="https://twitter.com/chemadelucas" target="_blank">Chema de Lucas</a>
									<a class="username" href="https://twitter.com/chemadelucas" target="_blank">@chemadelucas</a>
								</div>
																	<p>Pau Gasol: “No me preocupa la posibilidad de ser traspasado” (vía <a href="https://twitter.com/europapress" target="_blank" rel="nofollow">@europapress</a>)</p>
<p>“San Antonio está en una situación bastante diferente de cierta tensión porque el jugador principal del equipo, Leonard, ha comunicado al equipo que no quiere seguir y que busca un traspaso”.</p>
															</header>
							<footer class="user-actions">
								<a class="time-posted" href="https://twitter.com/chemadelucas/status/1009135004507672578">14:05 - 19 June 18</a>
								<a href="https://twitter.com/intent/tweet?in_reply_to=1009135004507672578">Reply</a>
								<a href="https://twitter.com/intent/retweet?tweet_id=1009135004507672578">Retweet</a>
								<a href="https://twitter.com/intent/favorite?tweet_id=1009135004507672578">Favorite</a>
							</footer>
						</li>
																	<li>
							<header>
								<a class="username" href="https://twitter.com/JulianMozo" target="_blank"><img src="https://pbs.twimg.com/profile_images/905443465961635841/goqqqZJU_normal.jpg" class="user-avatar" /></a>
								<div class="social-meta">
									<a class="fullname" href="https://twitter.com/JulianMozo" target="_blank">Julian Mozo</a>
									<a class="username" href="https://twitter.com/JulianMozo" target="_blank">@JulianMozo</a>
								</div>
																	<p>Interesante punto de vista de <a href="https://twitter.com/SoyElChapu" target="_blank" rel="nofollow">@Andres Nocioni</a> sobre cómo debe encarar Gaby Deck su futura etapa en el Real Madrid. <a href="https://twitter.com/search?q=%23LNB" target="_blank" rel="nofollow">#LNB</a> <a href="https://twitter.com/search?q=%23LIGAEndesa" target="_blank" rel="nofollow">#LIGAEndesa</a> <a href="https://t.co/cK6tvxo3MH" target="_blank" rel="nofollow">twitter.com/kiaenzona/stat…</a></p>
															</header>
							<footer class="user-actions">
								<a class="time-posted" href="https://twitter.com/JulianMozo/status/1009134933841936384">14:04 - 19 June 18</a>
								<a href="https://twitter.com/intent/tweet?in_reply_to=1009134933841936384">Reply</a>
								<a href="https://twitter.com/intent/retweet?tweet_id=1009134933841936384">Retweet</a>
								<a href="https://twitter.com/intent/favorite?tweet_id=1009134933841936384">Favorite</a>
							</footer>
						</li>
																	</ul>
				</div><div class="widget latestnews_widget tabbed_widget" id="latestnews_widget-2"><div class="tabs">
	<ul class="tab-controls hh-team-details">
		<li><a href="#hh-tab-news">Latest News</a></li>
					<li><a href="#hh-tab-custom-tag">Trending</a></li>
			</ul>
	<div id="hh-tab-news" class="col1 right hh-latest-news">
		<ul>
			
<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2017/10/doncic-madrid.jpg?w=480 ');" href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-small-forwards/" title="NBA Mock Draft 2018: Small Forwards" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2017/10/doncic-madrid.jpg?w=100&#038;h=100&#038;crop=1" alt="NBA Mock Draft 2018: Small Forwards" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/draft/" class="category">Draft</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-small-forwards/" title="NBA Mock Draft 2018: Small Forwards">
			NBA Mock Draft 2018: Small Forwards		</a>
		<p class="widget-date">June 19, 2018</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2017/10/deandre-ayton.jpg?w=480 ');" href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-centers/" title="NBA Mock Draft 2018: Centers" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2017/10/deandre-ayton.jpg?w=100&#038;h=100&#038;crop=1" alt="NBA Mock Draft 2018: Centers" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/draft/" class="category">Draft</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-centers/" title="NBA Mock Draft 2018: Centers">
			NBA Mock Draft 2018: Centers		</a>
		<p class="widget-date"></p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2017/10/marvin-bagley.jpg?w=480 ');" href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-power-forwards/" title="NBA Mock Draft 2018: Power Forwards" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2017/10/marvin-bagley.jpg?w=100&#038;h=100&#038;crop=1" alt="NBA Mock Draft 2018: Power Forwards" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/draft/" class="category">Draft</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-power-forwards/" title="NBA Mock Draft 2018: Power Forwards">
			NBA Mock Draft 2018: Power Forwards		</a>
		<p class="widget-date"></p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2018/05/mikal-bridges.jpg?w=480 ');" href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-shooting-guards/" title="NBA Mock Draft 2018: Shooting Guards" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2018/05/mikal-bridges.jpg?w=100&#038;h=100&#038;crop=1" alt="NBA Mock Draft 2018: Shooting Guards" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/draft/" class="category">Draft</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-shooting-guards/" title="NBA Mock Draft 2018: Shooting Guards">
			NBA Mock Draft 2018: Shooting Guards		</a>
		<p class="widget-date"></p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2017/10/collin-sexton.jpg?w=480 ');" href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-point-guards/" title="NBA Mock Draft 2018: Point Guards" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2017/10/collin-sexton.jpg?w=100&#038;h=100&#038;crop=1" alt="NBA Mock Draft 2018: Point Guards" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/draft/" class="category">Draft</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/06/19/nba-mock-draft-2018-point-guards/" title="NBA Mock Draft 2018: Point Guards">
			NBA Mock Draft 2018: Point Guards		</a>
		<p class="widget-date"></p>
	</div>
</li>
		</ul>
	</div>
			<div id="hh-tab-custom-tag" class="col1 right hh-latest-news">
			<ul>
				
<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2017/03/photo146.jpg?w=480 ');" href="https://hoopshype.com/2018/06/14/trending-stories-the-nba-articles-you-should-read-this-morning-647/" title="Leonard-Spurs relationship and other NBA trending stories" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2017/03/photo146.jpg?w=100&#038;h=100&#038;crop=1" alt="Leonard-Spurs relationship and other NBA trending stories" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/social-media/" class="category">Social Media</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/06/14/trending-stories-the-nba-articles-you-should-read-this-morning-647/" title="Leonard-Spurs relationship and other NBA trending stories">
			Leonard-Spurs relationship and other NBA trending stories		</a>
		<p class="widget-date">June 14, 2018</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2018/02/larrynance2.jpg?w=480 ');" href="https://hoopshype.com/2018/06/13/trending-stories-the-nba-articles-you-should-read-this-morning-646/" title="Cavs, Larry Nance Jr. share interest in contract extension and other NBA trending stories" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2018/02/larrynance2.jpg?w=100&#038;h=100&#038;crop=1" alt="Cavs, Larry Nance Jr. share interest in contract extension and other NBA trending stories" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/social-media/" class="category">Social Media</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/06/13/trending-stories-the-nba-articles-you-should-read-this-morning-646/" title="Cavs, Larry Nance Jr. share interest in contract extension and other NBA trending stories">
			Cavs, Larry Nance Jr. share interest in contract extension and other NBA trending stories		</a>
		<p class="widget-date">June 13, 2018</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2018/05/lebron-dunk.jpg?w=480 ');" href="https://hoopshype.com/2018/06/12/trending-stories-the-nba-articles-you-should-read-this-morning-645/" title="NBA legends discuss LeBron James&#039; legacy and other trending stories" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2018/05/lebron-dunk.jpg?w=100&#038;h=100&#038;crop=1" alt="NBA legends discuss LeBron James&#039; legacy and other trending stories" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/social-media/" class="category">Social Media</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/06/12/trending-stories-the-nba-articles-you-should-read-this-morning-645/" title="NBA legends discuss LeBron James&#039; legacy and other trending stories">
			NBA legends discuss LeBron James' legacy and other trending stories		</a>
		<p class="widget-date">June 12, 2018</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2018/04/wade.jpg?w=480 ');" href="https://hoopshype.com/2018/06/11/trending-stories-the-nba-articles-you-should-read-this-morning-644/" title="Dwyane Wade talks future and other NBA trending stories" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2018/04/wade.jpg?w=100&#038;h=100&#038;crop=1" alt="Dwyane Wade talks future and other NBA trending stories" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/social-media/" class="category">Social Media</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/06/11/trending-stories-the-nba-articles-you-should-read-this-morning-644/" title="Dwyane Wade talks future and other NBA trending stories">
			Dwyane Wade talks future and other NBA trending stories		</a>
		<p class="widget-date">June 11, 2018</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2018/06/lebron-james-game-3.jpg?w=480 ');" href="https://hoopshype.com/2018/06/10/trending-stories-the-nba-articles-you-should-read-this-morning-643/" title="LeBron James has choices to make and other NBA trending stories" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2018/06/lebron-james-game-3.jpg?w=100&#038;h=100&#038;crop=1" alt="LeBron James has choices to make and other NBA trending stories" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/social-media/" class="category">Social Media</a>			</span>
						<a class="title" href="https://hoopshype.com/2018/06/10/trending-stories-the-nba-articles-you-should-read-this-morning-643/" title="LeBron James has choices to make and other NBA trending stories">
			LeBron James has choices to make and other NBA trending stories		</a>
		<p class="widget-date">June 10, 2018</p>
	</div>
</li>
			</ul>
		</div>
	</div>
</div>
		
			<div class="widget sidebar-ad bottom">
				<div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_bottom_300x250'); });</script></div>			</div>

		
		
<div id="footer-info">
	<p class="footer__logo">
		<a href="http://usatodaysports.com" rel="nofollow" target="_blank">
			<img src="https://usathoopshype.files.wordpress.com/2017/01/usatlogo.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-navigation-container"><ul id="menu-footer-navigation" class="menu"><li id="menu-item-1179959" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1179959"><a href="http://static.usatoday.com/privacy/">Privacy Notice/Your California Privacy Rights</a></li>
<li id="menu-item-1179960" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1179960"><a href="http://static.usatoday.com/terms/">Terms of Service</a></li>
<li id="menu-item-1179961" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1179961"><a href="http://static.usatoday.com/privacy/#adchoices">Ad Choices</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=hoopshype.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "More Information";
		var footer_collapse_text = "Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	
	<!-- wpcom_wp_footer -->
<script type="text/javascript">
	var _sf_async_config = {"uid":"89374","useCanonical":true,"domain":"hoopshype.com","authors":"jsierrafernandez","sections":"Draft"};

	(function(){
		function loadChartbeat() {
			window._sf_endpt = (new Date()).getTime();
			var e = document.createElement('script');
			e.setAttribute('language', 'javascript');
			e.setAttribute('type', 'text/javascript');
			e.setAttribute('src',
			(('https:' == document.location.protocol) ? 'https://s3.amazonaws.com/' : 'http://') +
			'static.chartbeat.com/js/chartbeat.js');
			document.body.appendChild(e);
		}
		var oldonload = window.onload;
		window.onload = ( 'function' !== typeof window.onload ) ?
		loadChartbeat : function() { oldonload(); loadChartbeat(); };
	})();
</script>
<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://usathoopshype.files.wordpress.com/2017/01/logo-hoopshype-header.png" alt="HoopsHype">
				<a class="mobile-nav__breadcrumb" href="https://hoopshype.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
			<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="http://facebook.com/hoopshype" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/hoopshype" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--podcast">
				<a href="https://hoopshype.com/category/podcast/" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--rumors mobile-nav__item--parent sub-menu-3columns sub-menu-columns-offset200"><a title="NBA Rumors" href="/rumors/">Rumors</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--atlanta-hawks"><a title="Atlanta Rumors" href="https://hoopshype.com/team/atlanta-hawks/">Atlanta Hawks</a></li>
	<li class="mobile-nav__item mobile-nav__item--boston-celtics"><a title="Boston Rumors" href="https://hoopshype.com/team/boston-celtics/">Boston Celtics</a></li>
	<li class="mobile-nav__item mobile-nav__item--brooklyn-nets"><a title="Brooklyn Rumors" href="https://hoopshype.com/team/brooklyn-nets/">Brooklyn Nets</a></li>
	<li class="mobile-nav__item mobile-nav__item--charlotte-hornets"><a title="Charlotte Rumors" href="https://hoopshype.com/team/charlotte-hornets/">Charlotte Hornets</a></li>
	<li class="mobile-nav__item mobile-nav__item--chicago-bulls"><a title="Chicago Rumors" href="https://hoopshype.com/team/chicago-bulls/">Chicago Bulls</a></li>
	<li class="mobile-nav__item mobile-nav__item--cleveland-cavaliers"><a title="Cleveland Rumors" href="https://hoopshype.com/team/cleveland-cavaliers/">Cleveland Cavaliers</a></li>
	<li class="mobile-nav__item mobile-nav__item--dallas-mavericks"><a title="Dallas Rumors" href="https://hoopshype.com/team/dallas-mavericks/">Dallas Mavericks</a></li>
	<li class="mobile-nav__item mobile-nav__item--denver-nuggets"><a title="Denver Rumors" href="https://hoopshype.com/team/denver-nuggets/">Denver Nuggets</a></li>
	<li class="mobile-nav__item mobile-nav__item--detroit-pistons"><a title="Detroit Rumors" href="https://hoopshype.com/team/detroit-pistons/">Detroit Pistons</a></li>
	<li class="mobile-nav__item mobile-nav__item--golden-state-warriors"><a title="Golden State Rumors" href="https://hoopshype.com/team/golden-state-warriors/">Golden State Warriors</a></li>
	<li class="mobile-nav__item mobile-nav__item--houston-rockets"><a title="Houston Rumors" href="https://hoopshype.com/team/houston-rockets/">Houston Rockets</a></li>
	<li class="mobile-nav__item mobile-nav__item--indiana-pacers"><a title="Indiana Rumors" href="https://hoopshype.com/team/indiana-pacers/">Indiana Pacers</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-clippers"><a title="LA Clippers Rumors" href="https://hoopshype.com/team/los-angeles-clippers/">Los Angeles Clippers</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-lakers"><a title="LA Lakers Rumors" href="https://hoopshype.com/team/los-angeles-lakers/">Los Angeles Lakers</a></li>
	<li class="mobile-nav__item mobile-nav__item--memphis-grizzlies"><a title="Memphis Rumors" href="https://hoopshype.com/team/memphis-grizzlies/">Memphis Grizzlies</a></li>
	<li class="mobile-nav__item mobile-nav__item--miami-heat"><a title="Miami Rumors" href="https://hoopshype.com/team/miami-heat/">Miami Heat</a></li>
	<li class="mobile-nav__item mobile-nav__item--milwaukee-bucks"><a title="Milwaukee Rumors" href="https://hoopshype.com/team/milwaukee-bucks/">Milwaukee Bucks</a></li>
	<li class="mobile-nav__item mobile-nav__item--minnesota-timberwolves"><a title="Minnesota Rumors" href="https://hoopshype.com/team/minnesota-timberwolves/">Minnesota Timberwolves</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-orleans-pelicans"><a title="New Orleans Rumors" href="https://hoopshype.com/team/new-orleans-pelicans/">New Orleans Pelicans</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-york-knicks"><a title="New York Rumors" href="https://hoopshype.com/team/new-york-knicks/">New York Knicks</a></li>
	<li class="mobile-nav__item mobile-nav__item--oklahoma-city-thunder"><a title="Oklahoma City Rumors" href="https://hoopshype.com/team/oklahoma-city-thunder/">Oklahoma City Thunder</a></li>
	<li class="mobile-nav__item mobile-nav__item--orlando-magic"><a title="Orlando Rumors" href="https://hoopshype.com/team/orlando-magic/">Orlando Magic</a></li>
	<li class="mobile-nav__item mobile-nav__item--philadelphia-76ers"><a title="Philadelphia Rumors" href="https://hoopshype.com/team/philadelphia-76ers/">Philadelphia 76ers</a></li>
	<li class="mobile-nav__item mobile-nav__item--phoenix-suns"><a title="Phoenix Rumors" href="https://hoopshype.com/team/phoenix-suns/">Phoenix Suns</a></li>
	<li class="mobile-nav__item mobile-nav__item--portland-trail-blazers"><a title="Portland Rumors" href="https://hoopshype.com/team/portland-trail-blazers/">Portland Trail Blazers</a></li>
	<li class="mobile-nav__item mobile-nav__item--sacramento-kings"><a title="Sacramento Rumors" href="https://hoopshype.com/team/sacramento-kings/">Sacramento Kings</a></li>
	<li class="mobile-nav__item mobile-nav__item--san-antonio-spurs"><a title="San Antonio Rumors" href="https://hoopshype.com/team/san-antonio-spurs/">San Antonio Spurs</a></li>
	<li class="mobile-nav__item mobile-nav__item--toronto-raptors"><a title="Toronto Rumors" href="https://hoopshype.com/team/toronto-raptors/">Toronto Raptors</a></li>
	<li class="mobile-nav__item mobile-nav__item--utah-jazz"><a title="Utah Rumors" href="https://hoopshype.com/team/utah-jazz/">Utah Jazz</a></li>
	<li class="mobile-nav__item mobile-nav__item--washington-wizards"><a title="Washington Rumors" href="https://hoopshype.com/team/washington-wizards/">Washington Wizards</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--salaries mobile-nav__item--parent sub-menu-minwidth140"><a title="NBA Salaries" href="/salaries/">Salaries</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--players"><a title="NBA Player Salaries" href="https://hoopshype.com/salaries/players/">Players</a></li>
	<li class="mobile-nav__item mobile-nav__item--teams"><a title="NBA Salaries" href="https://hoopshype.com/salaries/">Teams</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--twitter mobile-nav__item--parent sub-menu-minwidth140"><a title="NBA Media Twitters" href="/social/">Twitter</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--media"><a title="NBA Media Twitters" href="/social/">Media</a></li>
	<li class="mobile-nav__item mobile-nav__item--players"><a title="NBA Players on Twitter" href="/social/tweets/">Players</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--features mobile-nav__item--parent sub-menu-columns"><a href="#">Features</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--agents"><a title="NBA Agents" href="/reps/">Agents</a></li>
	<li class="mobile-nav__item mobile-nav__item--analytics"><a title="NBA Analytics" href="/category/analytics/">Analytics</a></li>
	<li class="mobile-nav__item mobile-nav__item--draft"><a title="NBA Draft" href="/2018/01/09/nba-mock-draft-2018/">Draft</a></li>
	<li class="mobile-nav__item mobile-nav__item--free-agency-2018"><a title="NBA Free Agency 2018" href="/2018/01/11/nba-free-agency-2018-the-top-players/">Free Agency 2018</a></li>
	<li class="mobile-nav__item mobile-nav__item--hoopshype-podcasts"><a href="/category/podcast/">HoopsHype Podcasts</a></li>
	<li class="mobile-nav__item mobile-nav__item--instagram"><a title="NBA Players on Instagram" href="/social/gallery/">Instagram</a></li>
	<li class="mobile-nav__item mobile-nav__item--longform"><a title="Longform" href="https://hoopshype.com/category/longform/">Longform</a></li>
	<li class="mobile-nav__item mobile-nav__item--players"><a title="NBA Players" href="/players/">Players</a></li>
	<li class="mobile-nav__item mobile-nav__item--re-drafts"><a href="https://hoopshype.com/tag/re-drafts/">Re-Drafts</a></li>
	<li class="mobile-nav__item mobile-nav__item--store"><a href="https://sportngoods.threadless.com/collections/hoops-hype/">Store</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-rumors"><a href="https://hoopshype.com/category/top-rumors/">Top Rumors</a></li>
	<li class="mobile-nav__item mobile-nav__item--trade-candidate-watch"><a href="https://hoopshype.com/tag/trade-candidate-watch/">Trade Candidate Watch</a></li>
	<li class="mobile-nav__item mobile-nav__item--transactions"><a title="NBA Transactions" href="/transactions.htm">Transactions</a></li>
	<li class="mobile-nav__item mobile-nav__item--trending-stories"><a href="https://hoopshype.com/tag/trending/">Trending Stories</a></li>
	<li class="mobile-nav__item mobile-nav__item--trivia"><a title="NBA Trivia" href="/category/trivia/">Trivia</a></li>
</ul>
</li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-1179959" class="mobile-nav__item mobile-nav__item--privacy-notice-your-california-privacy-rights"><a href="http://static.usatoday.com/privacy/">Privacy Notice/Your California Privacy Rights</a></li>
<li id="menu-item-1179960" class="mobile-nav__item mobile-nav__item--terms-of-service"><a href="http://static.usatoday.com/terms/">Terms of Service</a></li>
<li id="menu-item-1179961" class="mobile-nav__item mobile-nav__item--ad-choices"><a href="http://static.usatoday.com/privacy/#adchoices">Ad Choices</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=hoopshype.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</li>
			</ul>

	</div>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201825y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="85827622" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://hoopshype.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="HoopsHype" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="0337dac7c4" /><input type="hidden" name="_wp_http_referer" value="/2018/06/19/nba-mock-draft-2018-power-forwards/" />		</form>

		<div class="arrow"></div>
	</div>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1524699534h&cssminify=yes' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='all-css-2-2' href='https://s0.wp.com/wp-content/mu-plugins/genericons/genericons/genericons.css?m=1443615899h&cssminify=yes' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var comment_like_text = {"loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyVy0EOQDAQheELqVGCWIizUBNabZVRHB+xYSOx/d/7YHNMjHZBu4AiaHGVAt0eKgrgMRnPnPadtARaDkgwefTY17bVOH+cxWjMmdiN1KUboE06/INe4YSVKXnKC57HSRapAyLtR9U='></script>
<script type='text/javascript' src='https://native.sharethrough.com/assets/sfp.js?ver=1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var kruxTrackingId = "r5tams7gw";
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var stickyInlineVideosOptions = {"side":"right"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/s2.wp.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var newsletter = {"force_modal":"","force_abovenav":"","is_mobile":"","modal_enabled":"","abovenav_enabled":"","cookie_expiry":"30","inline_position":"10"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var _LAWRENCE_ADS_EXPORTS = {"right_rail_ad_delay":{"distance":"2000","seconds":"10","active":"1"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiFacebookReferral = "0";
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"1","maxDistance":"1300","medAdHeight":"239","maxDistanceMed":"600","largeAdHeight":"400","maxDistanceLarge":"0","isDesktop":"1","headerHeight":"60"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/hoopshype.com\/wp-admin\/admin-ajax.php","nonce":"83a87177cf","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/usathoopshype.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fhoopshype.com%2F2018%2F06%2F19%2Fkevin-durant-all-his-signature-sneakers-through-the-years%2F","blog_id":"85827622","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=85827622&v=wpcom&tz=-4&user_id=0&subd=usathoopshype","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyllN1OwzAMhV+ILGJoErtAPIubmNVt/oiTdn17skK7aVSwbnepa38+co4j+yCUdwldkqlGiyw7CjIzJK9hEAb6iE6hbFgmBEPZCjyWdCbveNPwk7yVYL3OpvwFB2ZIpFiwihQSn9htzEeRIqiW3OEWbDD5QI4lF1I7CHKGHIqONPoRuBRfw50DMVsfR2TzmTEOmw9D4UHSVWjVGEu5oWoSo7xvCScAOWWyxrFHqssAKn+cD2s098BQ0QnjsGeDKWEUPekDprViLZBbWwP610xsnsVtxamwGevF7KalGWSnMbLyETf2NhVTj9r7wPUQRjnzx90E6ysyKNgUHwoH3X13kROZVSa+uEbo6ACpLO199VyEVxDvK4ZYLsismt65eMk/F2YAXW5WFGklkYtLy0n4DmOkkwfm2ErC+BItWorDWc5l/Hsfp7W8zFpoqSD6zGhkgymUTmIK/EHOJK+NvJz1s6b/5iWo+KG1KIAK9flZeLdvz7vt63a/277smy+mwGk9'></script>
<script type='text/javascript' src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<script>
			(function ( $ ) {
				$( "#usat_hoopshype_social-2" ).tabs();
			}( jQuery ));
		</script>
		<script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'85827622','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'85827622','v':'wpcom','tz':'-4','user_id':'0','post':'1138657','subd':'usathoopshype'}]);
function st_vt() {var x=document.createElement("img");x.src="https://pixel.wp.com/g.gif?blog=85827622&v=wpcomvt&tz=-4&user_id=0&post=1138657&subd=usathoopshype&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcvN1dHVE8tU1Y5Tk5xJUNPdGUvNWlURCVDWHdySjhHMEF6azhRa2xxSC5tLj1TNUl6QnIlMTJrZzNGNDFEJmQyTnxoQ3BZYnNpVWxUZ1MuaX4yJT9ROVR0UTlLPUEmeCsmdWsvLWo0WWFoTTJPVStrY3xbRkJ8LUJMUlpUMVY0N2lOOF80LVpdMWJhSnksdTlLX0U/NzVOWkY/Yz1lXUJuRUZHMj16Qnd2R2lKTXIwc0lucEdOcXYuS0k3YmEsSHZFMzkrX1J1eDkramk/Vi5kY2ZvNUg/MXw9QUMtamRaUG9bXz1UYg=='}]);
_stq.push([ 'clickTrackerInit', '85827622', '1138657' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
