<!DOCTYPE html>
<!--[if IE 8]> <html lang="en" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://hoopshype.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="Larry Hughes discusses his 13-year NBA career, playing alongside Michael Jordan and LeBron James, battling injuries, fatherhood and more." />
<meta name="keywords" content="basketball, interview, nba, podcast, evergreen, featured, interview, podcast, top" />
<title>Larry Hughes Q&amp;A: &#8216;Injuries kept me from being the best I could be&#8217; | HoopsHype</title>
<meta name="google-site-verification" content="vjU_CGncz37FseIKJKx118S7FcYlPjyIGG9aFD-Mno8" />
<meta name="msvalidate.01" content="6C7AFE373C691E833D6444FFA7F6E8A2" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=hoopshype.com&amp;id=85827622&amp;t=1585671545&amp;back=https%3A%2F%2Fhoopshype.com%2F2020%2F03%2F31%2Fnba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//cdn.adsafeprotected.com' />
<link rel='dns-prefetch' href='//www.gannett-cdn.com' />
<link rel='dns-prefetch' href='//confiant-integrations.global.ssl.fastly.net' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//run.adrizer.com' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//cdn.onesignal.com' />
<link rel='dns-prefetch' href='//usathoopshype.wordpress.com' />
<link rel='dns-prefetch' href='//wordpress.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="HoopsHype &raquo; Feed" href="https://hoopshype.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="HoopsHype &raquo; Comments Feed" href="https://hoopshype.com/comments/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s0.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1582709031h&ver=5.4-RC5-47533"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJx9j9EKwjAMRX/Irgxx6IP4LWsbZlzTliZl7u/tnAwU2UtIbnK4uXpKysYgEERTUcmXAQPrKdlIigk9zD9TY5kPVVIYrC8OWFdBO2TRxkc7Ko8m93nWLLOHhjBsxB8jGzNUnVIvywWBwx48UD3bwyZ0A8hqvfZK4LmPvEMYkzIwq1oJCym5Vy/e/5CWb2qs8ZP1S1lR1CEKVpq3Zlnc6NqezqeuO17a7vECv8eIuQ==?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='galleria-theme-css'  href='//cdnjs.cloudflare.com/ajax/libs/galleria/1.4.2/themes/classic/galleria.classic.css?ver=1.4.2' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s0.wp.com/_static/??-eJylkN1OBCEMhV9ItvFndW+Mt/sGXnehQjdAkYKTeXuZSdRMNHPjHaXntKcfTMVYyY1ygxYokcIHF+iKTRzOpsTuOSsEkaJhLgRJXI+rzJEYjzFSnY0Gqc2KI0BVats2kx6s6g2MZZxt7G74xwc41MBjvR4S578l1/e+zO9sHGMUv1HuJY84VcqWvpqvqHjhf1jhvDA4Dwa/hqT+DWpi55f7VezIaxKN2Ga9EbTNcdfrB7EoFhtL3hTmLSLXPWuly4Aznn6l9lMuppf0fHs8PTzd350ej9dPAli8Fw==?cssminify=yes' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='google-fonts-ubuntu-css'  href='https://fonts.googleapis.com/css?family=Ubuntu:300,400,500,700' media='all' />
<link rel='stylesheet' id='all-css-4-1' href='https://s0.wp.com/wp-content/themes/h4/global.css?m=1420737423h&cssminify=yes' type='text/css' media='all' />
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script>
var amznAcctId = ["3090"];
</script>
<script type='text/javascript'>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");window.bidSlots=window.bidSlots||[];window._mweb=0;apstag.init({pubID: amznAcctId, adServer: "googletag"});
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJx9jdEOwiAMRX9Ihsap88H4LR3UCYGCtLjs72WJvhhj0uQ+3HNP9ZyVIxOqRda+3aNiWd7Red7of4CKbiog2EVHH9gkEiRZ2ZxYIjLDhD/amEYXUFXG0gCS9uaWvjm5YzPop8u6MkiysKgAc0EyuEpGZy0WFYGao7T1NV52h+N535+G7eBf2MRSfA=='></script>
<script src='https://js-sec.indexww.com/ht/p/184031-126856402220676.js?ver=5.4-RC5-47533'></script>
<script src='https://cdn.adsafeprotected.com/iasPET.1.js?ver=5.4-RC5-47533'></script>
<script>
var iasDataHandler, __iasPET = __iasPET || {};
				__iasPET.queue = __iasPET.queue || [];
				__iasPETSlots = [];
				__iasPET.pubId = '922805';
				bidManager.addBidder( 'ias' );
			
</script>
<script>
var gciDataLayer = {"event-type":"pageview","page-market-name":"smg","page-blogname":"hoopshype","page-has-video":"","page-use-canonical":"1","content-ssts-section":"sports","content-ssts-subsection":"sports:hoopshype","content-ssts-topic":"sports:hoopshype","content-ssts-subtopic":"sports:hoopshype","page-experience-type":"desktop","content-type":"story pages","content-id":"1331028","content-headline":"Larry Hughes Q&A: 'Injuries kept me from being the best I could be'","content-date-published":"2020-03-31T10:28:19Z","content-byline":"Alex Kennedy","content-contributor-names":"Alex Kennedy","content-keywords":"Evergreen,Featured,Interview,Podcast,Top","content-title":"Larry Hughes Q&A: \u2018Injuries kept me from being the best I could be\u2019 | "};
</script>
<script>
			window.gciAnalyticsUAID = "SMG-TEALIUM-HOOPSHYPE";
			gciDataLayer["page-full-url"] = window.location.href;
			gciDataLayer["content-name"] = window.location.pathname;
			

			var stateManager = {
				getActivePageInfo: function() {
					return {
						byline: gciDataLayer["content-byline"] || "",
						contentHeadline: gciDataLayer["content-headline"] || "",
						contentId: gciDataLayer["content-id"] || "",
						taxonomykeywords: gciDataLayer["content-keywords"] || "",
						contentType: gciDataLayer["content-type"] || "",
						cst: gciDataLayer["cst"] || "",
						pageHasVideo: (gciDataLayer["page-has-video"]) ? gciDataLayer["page-has-video"].toLowerCase() : "",
						ssts: gciDataLayer["content-ssts-subtopic"] || "",
					}
				}
			}
			
</script>
<script src='https://www.gannett-cdn.com/dcjs/prod/main.js?ver=1'></script>
<script>
			document.addEventListener("gciAnalyticsReady", function () {
				window.gciAnalytics.view(gciDataLayer);
			} );
			
</script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/modules/brightcove/js/tealium-brightcove.js?m=1500922554h'></script>
<script>
var lawrence_ad_marketplace_data = {"endpoint":"","suggest_endpoint":"https:\/\/usatoday_cps.cps.ampfeed.com\/suggestions?partner=usatoday_cps&sub1=nba&sub2=hoopshype.com&sub3=paidsuggest&v=1.1&callback=1585671545&out=json","sponsored_text":"Sponsored","ads_by_text":"Ads by adMarketplace"};
</script>
<script src='https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/modules/ad-marketplace/js/sponsored-search-results.js?m=1568040173h&#038;ver=1.0.0'></script>
<script async src='https://confiant-integrations.global.ssl.fastly.net/FvW3szAY_s729BZEa4_yfA6omyQ/gpt_and_prebid/config.js?ver=1.0.0'></script>
<script>
var usatoday_gallery_ajax_object = {"publisherGA":"UA-5226424-1","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-5226424-1","dfpid":"","pid":"SMG_HoopsHype","ads":{"poster":"\/7103\/SMG_HoopsHype\/300x250_1g\/sports\/basketball"},"tlmurl":"https:\/\/tags.tiqcdn.com\/utag\/gci\/hoopshype\/prod\/utag.js"};
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJylkNEOgjAMRX/I0QxCfDJ+S4WCHduYdAP5e0eiJr5BfGt6e07awhJUM/pIPkK8kyOBmQMkwTi2uKpgU89eAAOrHq2lifMIilAUMAKR0HJy72wtjJzgT2WSNuT+kiM166Lc47S4TOQb2ngZOCjLflDd2CRRHT+PKswjbcc4ZH8UtXz74BK5GXa95Gd9bqevIdeZv7qLrvW5qkutK/MCzHqjVw=='></script>
<script type="text/javascript" src="//run.adrizer.com/track.js?ver=5.4-RC5-47533" id="ADRIZER_JS" data-domain="hoopshype.com"></script><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://usathoopshype.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://wp.me/p5O7Gu-5Agc' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fhoopshype.com%2F2020%2F03%2F31%2Fnba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fhoopshype.com%2F2020%2F03%2F31%2Fnba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Larry Hughes Q&amp;A: &#039;Injuries kept me from being the best I could be&#039;" />
<meta property="og:url" content="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/" />
<meta property="og:description" content="Larry Hughes discusses his 13-year NBA career, playing alongside Michael Jordan and LeBron James, battling injuries, fatherhood and more." />
<meta property="article:published_time" content="2020-03-31T14:28:19+00:00" />
<meta property="article:modified_time" content="2020-03-31T14:28:19+00:00" />
<meta property="og:site_name" content="HoopsHype" />
<meta property="og:image" content="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=1024&amp;h=576&amp;crop=1" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@hoopshype" />
<meta name="twitter:text:title" content="Larry Hughes Q&amp;A: &#039;Injuries kept me from being the best I could be&#039;" />
<meta name="twitter:image" content="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="http://facebook.com/hoopshype" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/8195f692d09575689011557b84764b61?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/8195f692d09575689011557b84764b61?s=32" sizes="16x16" />
<link rel="apple-touch-icon" href="https://secure.gravatar.com/blavatar/8195f692d09575689011557b84764b61?s=114" />
<link rel='openid.server' href='https://hoopshype.com/?openidserver=1' />
<link rel='openid.delegate' href='https://hoopshype.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://hoopshype.com/osd.xml" title="HoopsHype" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />

<meta name="gdpr" content="false" />

<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "NewsArticle",
		"url": "https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/",
		"headline": "Larry Hughes Q&amp;A: &#039;Injuries kept me from being the best I could be&#039;",
		"thumbnailUrl": "https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=192&#038;h=150&#038;crop=1",
		"datePublished": "2020-03-31T10:28:19Z",
		"articleSection": "Basketball",
		"creator": ["Alex Kennedy"],
		"keywords": ["Evergreen","Featured","Interview","Podcast","Top"],
	}
</script>
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script><link rel="manifest" href="/manifest.json"><style type="text/css">
.articleBody a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2 > a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block .shares,
.widget--box .text-block > h2,
.widget--box .text-block > h2 > a,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover,
.hero__secondary .hero__link:hover .hero__title,
.widget_usat_sidebar_top_posts_widget .reply-block .social-count,
.ad-marketplace-search-result-link {
	color: #eb1e00;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #eb1e00;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #eb1e00;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #eb1e00;
}

.nav__item:hover,
.nav__item--current,
#footer-info,
.ad-marketplace-sponsored-text {
	border-top-color: #eb1e00;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #eb1e00;
}

.newsletter-modal {
	border-top: solid 8px #eb1e00;
}

.article__back {
	border-color: #eb1e00;
}

.vertical-gallery--icon,
.smg-event--icon,
.vertical-gallery__overlay,
.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.daily-newsletter__button {
	background-color: #eb1e00;
}

.newsletter__button {
	background-image: linear-gradient(to bottom, rgba(0, 0, 0, 0), rgba(0, 0, 0, 0.12)),
		linear-gradient(#eb1e00, #eb1e00)
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #eb1e00;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #eb1e00;
	}
}

.smg-event__ctabutton {
	background-color: #eb1e00;
	box-shadow: 0 2px 0 0 #eb1e00;
}
</style>
<link rel="canonical" href="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/" />
		<style>
			.wpcom-related-posts ul li {
				list-style-type: none;
				display: inline-block;
			}
		</style>
				<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="HoopsHype" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://hoopshype.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/8195f692d09575689011557b84764b61?s=16" />
<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
	bidManager.timeout = 2500;
	bidManager.addBidder('a9');
		bidManager.addBidSlot({ slotID: "videoSlot", mediaType : 'video' } );

	</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>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</script>
<link rel="amphtml" href="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/amp/">		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s2.wp.com/?custom-css=1&#038;csblog=5O7Gu&#038;cscache=6&#038;csrev=56" />
		
	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-1331028 single-format-standard customizer-styles-applied highlander-enabled highlander-light">

	
	<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_interstitial' style='width:2px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_interstitial'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_outstream' style='width:4px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_outstream'); });</script></div>
	
<div id="wrapper">

	
	<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>

	<div class="wrapper-holder">

		<div id="usat-newsletter-modal" class="widget newsletter-modal newsletter-modal--hidden widget--newsletter widget--box">
<div class="newsletter__wrapper modal" style="display: none;">

	<div class="newsletter__signup-wrapper">
					<div class="newsletter__logo">
				<img src="https://usathoopshype.files.wordpress.com/2017/01/logo-hoopshype-header.png"/>
			</div>
				<form novalidate="novalidate" class="newsletter_form" action="https://hoopshype.com/wp-json/usat/v1/gems/subscribe/">

			
			<label class="newsletter__input-label" for="newsletter-email-input">
				<span class="screen-reader-text">Email</span>
				<input
					type="email"
					class="newsletter__input"
					placeholder="you@domain.com"
					name="email"
					id="newsletter-email-input"
					required
				>
									<span class="newsletter__input-icon" aria-hidden="true">&#xE60B;</span>
							</label>

			<button
					type="submit"
					class="newsletter__button"
			>Sign up			</button>

			
							<div class="newsletter-close-alt">
					<a href="javascript:void(0);" class="newsletter__close-button">No, thanks</a>
				</div>
			
		</form>

					<div class="newsletter__sidetext">
				<h3>Are you in?</h3>
				<p>Sign up for the HoopsHype daily email newsletter for the top stories every day.</p>
			</div>
		
		<div class="newsletter__state newsletter__state--error">
			<h3 class="newsletter__header newsletter__header--error">An error has occured</h3>

			<p class="newsletter__text newsletter__text--error">
				Please re-enter your email address.			</p>
		</div>

	</div>

	<div class="newsletter__state newsletter__state--success">
		<h3 class="newsletter__header">Thanks for signing up!</h3>

		<p class="newsletter__text">
			You&#039;ll now receive the top HoopsHype stories each day directly in your inbox.		</p>

					<div class="newsletter-close-alt">
				<a href="javascript:void(0);" class="newsletter__close-button">Close</a>
			</div>
			</div>

			<div class="newsletter-phone-wrapper">
			<div class="daily-newsletter-phone-wrapper">
				<img src="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/modules/newsletter/images/phone.png" alt="newsletter" class="daily-newsletter-phone-image" />
				<div class="daily-newsletter-phone-wrapper-viewport">
					<div class="daily-newsletter__site-logo">
						<img src="https://usathoopshype.files.wordpress.com/2017/01/logo-hoopshype-header.png" class="daily-newsletter-logo-img"/>
					</div>
					<div class="daily-newsletter__site-top-stories">
						<img src="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/modules/newsletter/images/topstories.png" alt="top-stories"/>
					</div>
					<div class="daily-newsletter__latest-image">
													<img src="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=272&#038;h=250&#038;crop=1"/>
											</div>
				</div>
			</div>
		</div>
	</div>

	<div class="newsletter__close">
		<a href="javascript:void(0);" class="newsletter__close-button">&times;</a>
	</div>
</div><div
	class="branding "
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="https://hoopshype.com"
				title="HoopsHype"
				class="branding__logo-link "
			>
				<img
					src="https://usathoopshype.files.wordpress.com/2017/01/logo-hoopshype-header.png"
					alt="HoopsHype"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

	
	<span class="branding__search ui-front">
		<form method="get" class="branding__search-form" action="https://hoopshype.com" role="search">
			<input type="text" name="s" value="" placeholder="search HoopsHype" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="http://usatodaysports.com" target="_blank" title="USA TODAY Sports">
			<img src="https://usathoopshype.files.wordpress.com/2017/01/usat-logo-header.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-423204" class="nav__item nav__item--rumors nav__item--parent sub-menu-3columns sub-menu-columns-offset200"><a title="NBA Rumors" href="/rumors/">Rumors</a>
<ul class="sub-menu">
	<li id="menu-item-1023487" class="nav__item nav__item--atlanta-hawks"><a title="Atlanta Rumors" href="https://hoopshype.com/team/atlanta-hawks/">Atlanta Hawks</a></li>
	<li id="menu-item-1023488" class="nav__item nav__item--boston-celtics"><a title="Boston Rumors" href="https://hoopshype.com/team/boston-celtics/">Boston Celtics</a></li>
	<li id="menu-item-1023489" class="nav__item nav__item--brooklyn-nets"><a title="Brooklyn Rumors" href="https://hoopshype.com/team/brooklyn-nets/">Brooklyn Nets</a></li>
	<li id="menu-item-1023490" class="nav__item nav__item--charlotte-hornets"><a title="Charlotte Rumors" href="https://hoopshype.com/team/charlotte-hornets/">Charlotte Hornets</a></li>
	<li id="menu-item-1023491" class="nav__item nav__item--chicago-bulls"><a title="Chicago Rumors" href="https://hoopshype.com/team/chicago-bulls/">Chicago Bulls</a></li>
	<li id="menu-item-1023492" class="nav__item nav__item--cleveland-cavaliers"><a title="Cleveland Rumors" href="https://hoopshype.com/team/cleveland-cavaliers/">Cleveland Cavaliers</a></li>
	<li id="menu-item-1023493" class="nav__item nav__item--dallas-mavericks"><a title="Dallas Rumors" href="https://hoopshype.com/team/dallas-mavericks/">Dallas Mavericks</a></li>
	<li id="menu-item-1023494" class="nav__item nav__item--denver-nuggets"><a title="Denver Rumors" href="https://hoopshype.com/team/denver-nuggets/">Denver Nuggets</a></li>
	<li id="menu-item-1023495" class="nav__item nav__item--detroit-pistons"><a title="Detroit Rumors" href="https://hoopshype.com/team/detroit-pistons/">Detroit Pistons</a></li>
	<li id="menu-item-1023496" class="nav__item nav__item--golden-state-warriors"><a title="Golden State Rumors" href="https://hoopshype.com/team/golden-state-warriors/">Golden State Warriors</a></li>
	<li id="menu-item-1023497" class="nav__item nav__item--houston-rockets"><a title="Houston Rumors" href="https://hoopshype.com/team/houston-rockets/">Houston Rockets</a></li>
	<li id="menu-item-1023498" class="nav__item nav__item--indiana-pacers"><a title="Indiana Rumors" href="https://hoopshype.com/team/indiana-pacers/">Indiana Pacers</a></li>
	<li id="menu-item-1023499" class="nav__item nav__item--los-angeles-clippers"><a title="LA Clippers Rumors" href="https://hoopshype.com/team/los-angeles-clippers/">Los Angeles Clippers</a></li>
	<li id="menu-item-1023500" class="nav__item nav__item--los-angeles-lakers"><a title="LA Lakers Rumors" href="https://hoopshype.com/team/los-angeles-lakers/">Los Angeles Lakers</a></li>
	<li id="menu-item-1023501" class="nav__item nav__item--memphis-grizzlies"><a title="Memphis Rumors" href="https://hoopshype.com/team/memphis-grizzlies/">Memphis Grizzlies</a></li>
	<li id="menu-item-1023502" class="nav__item nav__item--miami-heat"><a title="Miami Rumors" href="https://hoopshype.com/team/miami-heat/">Miami Heat</a></li>
	<li id="menu-item-1023503" class="nav__item nav__item--milwaukee-bucks"><a title="Milwaukee Rumors" href="https://hoopshype.com/team/milwaukee-bucks/">Milwaukee Bucks</a></li>
	<li id="menu-item-1023504" class="nav__item nav__item--minnesota-timberwolves"><a title="Minnesota Rumors" href="https://hoopshype.com/team/minnesota-timberwolves/">Minnesota Timberwolves</a></li>
	<li id="menu-item-1023505" class="nav__item nav__item--new-orleans-pelicans"><a title="New Orleans Rumors" href="https://hoopshype.com/team/new-orleans-pelicans/">New Orleans Pelicans</a></li>
	<li id="menu-item-1023506" class="nav__item nav__item--new-york-knicks"><a title="New York Rumors" href="https://hoopshype.com/team/new-york-knicks/">New York Knicks</a></li>
	<li id="menu-item-1023507" class="nav__item nav__item--oklahoma-city-thunder"><a title="Oklahoma City Rumors" href="https://hoopshype.com/team/oklahoma-city-thunder/">Oklahoma City Thunder</a></li>
	<li id="menu-item-1023508" class="nav__item nav__item--orlando-magic"><a title="Orlando Rumors" href="https://hoopshype.com/team/orlando-magic/">Orlando Magic</a></li>
	<li id="menu-item-1023509" class="nav__item nav__item--philadelphia-76ers"><a title="Philadelphia Rumors" href="https://hoopshype.com/team/philadelphia-76ers/">Philadelphia 76ers</a></li>
	<li id="menu-item-1023510" class="nav__item nav__item--phoenix-suns"><a title="Phoenix Rumors" href="https://hoopshype.com/team/phoenix-suns/">Phoenix Suns</a></li>
	<li id="menu-item-1023511" class="nav__item nav__item--portland-trail-blazers"><a title="Portland Rumors" href="https://hoopshype.com/team/portland-trail-blazers/">Portland Trail Blazers</a></li>
	<li id="menu-item-1023512" class="nav__item nav__item--sacramento-kings"><a title="Sacramento Rumors" href="https://hoopshype.com/team/sacramento-kings/">Sacramento Kings</a></li>
	<li id="menu-item-1023513" class="nav__item nav__item--san-antonio-spurs"><a title="San Antonio Rumors" href="https://hoopshype.com/team/san-antonio-spurs/">San Antonio Spurs</a></li>
	<li id="menu-item-1023514" class="nav__item nav__item--toronto-raptors"><a title="Toronto Rumors" href="https://hoopshype.com/team/toronto-raptors/">Toronto Raptors</a></li>
	<li id="menu-item-1023515" class="nav__item nav__item--utah-jazz"><a title="Utah Rumors" href="https://hoopshype.com/team/utah-jazz/">Utah Jazz</a></li>
	<li id="menu-item-1023516" class="nav__item nav__item--washington-wizards"><a title="Washington Rumors" href="https://hoopshype.com/team/washington-wizards/">Washington Wizards</a></li>
</ul>
</li>
<li id="menu-item-458969" class="nav__item nav__item--salaries nav__item--parent sub-menu-minwidth140"><a title="NBA Salaries" href="/salaries/">Salaries</a>
<ul class="sub-menu">
	<li id="menu-item-16" class="nav__item nav__item--players"><a title="NBA Player Salaries" href="https://hoopshype.com/salaries/players/">Players</a></li>
	<li id="menu-item-12" class="nav__item nav__item--teams"><a title="NBA Salaries" href="https://hoopshype.com/salaries/">Teams</a></li>
	<li id="menu-item-1328720" class="nav__item nav__item--salary-cap"><a href="https://hoopshype.com/2020/03/16/los-angeles-lakers-their-salary-cap-situation-right-now/">Salary cap</a></li>
	<li id="menu-item-1278372" class="nav__item nav__item--history"><a href="https://hoopshype.com/salaries/2000-2001/">History</a></li>
</ul>
</li>
<li id="menu-item-1022515" class="nav__item nav__item--twitter nav__item--parent sub-menu-minwidth140"><a title="NBA Media Twitters" href="/social/">Twitter</a>
<ul class="sub-menu">
	<li id="menu-item-18" class="nav__item nav__item--media"><a title="NBA Media Twitters" href="/social/">Media</a></li>
	<li id="menu-item-999057" class="nav__item nav__item--players"><a title="NBA Players on Twitter" href="/social/tweets/">Players</a></li>
</ul>
</li>
<li id="menu-item-423198" class="nav__item nav__item--features nav__item--parent sub-menu-3columns sub-menu-columns-offset200"><a href="#">Features</a>
<ul class="sub-menu">
	<li id="menu-item-1000630" class="nav__item nav__item--agents"><a title="NBA Agents" href="/reps/">Agents</a></li>
	<li id="menu-item-1278971" class="nav__item nav__item--awards"><a href="https://hoopshype.com/2019/08/08/nba-awards-all-the-winners-in-league-history/">Awards</a></li>
	<li id="menu-item-1231160" class="nav__item nav__item--birthdays"><a href="https://hoopshype.com/2019/01/13/which-nba-player-was-born-the-same-day-as-you-find-out-here/">Birthdays</a></li>
	<li id="menu-item-1006555" class="nav__item nav__item--birthplaces"><a title="Birthplaces" href="/2019/08/20/nba-players-birthplaces/">Birthplaces</a></li>
	<li id="menu-item-1271888" class="nav__item nav__item--depth-charts"><a href="https://hoopshype.com/2019/07/10/nba-depth-charts/">Depth Charts</a></li>
	<li id="menu-item-11" class="nav__item nav__item--draft"><a title="NBA Draft" href="/2018/01/09/nba-mock-draft-2018/">Draft</a></li>
	<li id="menu-item-17" class="nav__item nav__item--free-agency-2019"><a title="NBA Free Agency 2019" href="/2018/08/09/nba-free-agency-2019-the-top-players">Free Agency 2019</a></li>
	<li id="menu-item-1118240" class="nav__item nav__item--free-agency-2020"><a href="https://hoopshype.com/2019/07/18/nba-free-agency-2020-the-top-players/">Free Agency 2020</a></li>
	<li id="menu-item-1207357" class="nav__item nav__item--hoopshype-explains"><a href="https://hoopshype.com/category/hoopshype-explains/">HoopsHype Explains</a></li>
	<li id="menu-item-1000631" class="nav__item nav__item--hoopshype-podcasts"><a href="/category/podcast/">HoopsHype Podcasts</a></li>
	<li id="menu-item-1006554" class="nav__item nav__item--instagram"><a title="NBA Players on Instagram" href="/social/gallery/">Instagram</a></li>
	<li id="menu-item-1265345" class="nav__item nav__item--key-contract-dates"><a href="https://hoopshype.com/2019/06/17/nba-contracts-key-dates-deadlines-options-trade-eligibility/">Key Contract Dates</a></li>
	<li id="menu-item-1000632" class="nav__item nav__item--longform"><a title="Longform" href="https://hoopshype.com/category/longform/">Longform</a></li>
	<li id="menu-item-1278805" class="nav__item nav__item--nba-2k-ratings"><a href="https://hoopshype.com/nba2k/">NBA 2K Ratings</a></li>
	<li id="menu-item-1241341" class="nav__item nav__item--nicknames"><a href="https://hoopshype.com/2019/02/24/all-the-nicknames-in-nba-history/">Nicknames</a></li>
	<li id="menu-item-423200" class="nav__item nav__item--players"><a title="NBA Players" href="/players/">Players</a></li>
	<li id="menu-item-1119544" class="nav__item nav__item--re-drafts"><a href="https://hoopshype.com/tag/re-drafts/">Re-Drafts</a></li>
	<li id="menu-item-1296517" class="nav__item nav__item--roster-details"><a href="https://hoopshype.com/2019/11/07/all-nba-rosters-in-one-page-with-some-extra-details/">Roster Details</a></li>
	<li id="menu-item-1160065" class="nav__item nav__item--top-rumors"><a href="https://hoopshype.com/category/top-rumors/">Top Rumors</a></li>
	<li id="menu-item-10" class="nav__item nav__item--transactions"><a title="NBA Transactions" href="/transactions.htm">Transactions</a></li>
</ul>
</li>
		</ul>
		<ul class="nav__social ">
			<li class="nav__item nav__item--social nav__item--facebook">
			<a href="http://facebook.com/hoopshype" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--twitter">
			<a href="https://twitter.com/hoopshype" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--podcast">
			<a href="https://hoopshype.com/category/podcast/" class="nav__item-link"></a>
		</li>
	</ul>
	</nav>
</header>

		
		
		<div id="main" class="site-main ">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-1331028" class="post-1331028 post type-post status-publish format-standard has-post-thumbnail hentry category-basketball category-interview category-nba category-podcast tag-evergreen tag-featured tag-interview tag-podcast tag-top player-allen-iverson player-antawn-jamison player-damian-lillard player-gilbert-arenas player-jayson-tatum player-kevin-durant player-larry-hughes player-lebron-james player-michael-jordan team-chicago-bulls team-cleveland-cavaliers team-golden-state-warriors team-philadelphia-76ers team-washington-wizards" itemscope
				itemtype="http://schema.org/NewsArticle">

				<link itemprop="mainEntityofPage" href="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/" />
<div itemprop="publisher" itemscope itemtype="https://www.schema.org/Organization">
	<div itemprop="logo" itemscope itemtype="https://www.schema.org/ImageObject">
		<link src="https://usathoopshype.files.wordpress.com/2017/01/logo-hoopshype-header.png"/>
		<meta itemprop="url" content="https://usathoopshype.files.wordpress.com/2017/01/logo-hoopshype-header.png">
	</div>
	<meta itemprop="name" content="HoopsHype">
</div>
<div class="article__title ">
	<h1 class="article__headline">Larry Hughes Q&amp;A: 'Injuries kept me from being the best I could be'</h1>

			<span itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
			<img width="1000" height="600" src="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=100&amp;h=600&amp;crop=1&amp;h=60" class="article__image wp-post-image lazy-load" alt data-attachment-id="1330269" data-permalink="https://hoopshype.com/big3-week-four/" data-orig-file="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg" data-orig-size="1280,900" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;BIG3\/Getty Images&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X&quot;,&quot;caption&quot;:&quot;PHILADELPHIA, PA - JULY 16: Larry Hughes #21 of the Killer 3&#039;s prepares in the locker room during week four of the BIG3 three on three basketball league at Wells Fargo Center on July 16, 2017 in Philadelphia, Pennsylvania.  (Photo by Mitchell Leff\/BIG3\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;1500229594&quot;,&quot;copyright&quot;:&quot;2017 Getty Images&quot;,&quot;focal_length&quot;:&quot;22&quot;,&quot;iso&quot;:&quot;4000&quot;,&quot;shutter_speed&quot;:&quot;0.004&quot;,&quot;title&quot;:&quot;BIG3 - Week Four&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="BIG3 &#8211; Week Four" data-image-description data-medium-file="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=1000" data-lazy-src="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=1000&amp;h=600&amp;crop=1" data-lazy-srcset="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=1000&amp;h=600&amp;crop=1 1000w, https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=190&amp;h=114&amp;crop=1 190w, https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=300&amp;h=180&amp;crop=1 300w, https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=768&amp;h=461&amp;crop=1 768w, https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=1024&amp;h=614&amp;crop=1 1024w" data-lazy-sizes="(max-width: 1000px) 100vw, 1000px"><noscript><img width="1000" height="600" src="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=1000&amp;h=600&amp;crop=1" class="article__image wp-post-image" alt="" srcset="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=1000&amp;h=600&amp;crop=1 1000w, https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=190&amp;h=114&amp;crop=1 190w, https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=300&amp;h=180&amp;crop=1 300w, https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=768&amp;h=461&amp;crop=1 768w, https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=1024&amp;h=614&amp;crop=1 1024w" sizes="(max-width: 1000px) 100vw, 1000px" data-attachment-id="1330269" data-permalink="https://hoopshype.com/big3-week-four/" data-orig-file="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg" data-orig-size="1280,900" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;BIG3\/Getty Images&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X&quot;,&quot;caption&quot;:&quot;PHILADELPHIA, PA - JULY 16: Larry Hughes #21 of the Killer 3&#039;s prepares in the locker room during week four of the BIG3 three on three basketball league at Wells Fargo Center on July 16, 2017 in Philadelphia, Pennsylvania.  (Photo by Mitchell Leff\/BIG3\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;1500229594&quot;,&quot;copyright&quot;:&quot;2017 Getty Images&quot;,&quot;focal_length&quot;:&quot;22&quot;,&quot;iso&quot;:&quot;4000&quot;,&quot;shutter_speed&quot;:&quot;0.004&quot;,&quot;title&quot;:&quot;BIG3 - Week Four&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="BIG3 &#8211; Week Four" data-image-description="" data-medium-file="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=1000" /></noscript>			<meta itemprop="url" content="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg">
		</span>
		<cite class="article__source"></cite>
		<div class="article__gradient"></div>
	</div>
<h1 class="article__headline article__headline--mobile">Larry Hughes Q&amp;A: 'Injuries kept me from being the best I could be'</h1>

				<header class="entry-header  ">

					
<h2 class="cat-show">
	<a href="https://hoopshype.com/category/podcast/" class="" itemprop="articleSection">Podcast</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">Larry Hughes Q&amp;A: 'Injuries kept me from being the best I could be'</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p>

	
		<span class="post-date updated">March 31, 2020</span>-
		by <span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://hoopshype.com/author/alexkennedynba/" title="Posts by Alex Kennedy" class="author url fn" rel="author">Alex Kennedy</a></span></span> 
	
	</p>
					</div>

					<div id='acm-ad-tag-lawrence_dfp_mobile_sponsor_by_logo' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_mobile_sponsor_by_logo'); });</script></div>
				</header>

				
				
				
				
				<div id="content-container">
					<div class="entry-content normal-format">

						<div class="article-container">
						<div class="story-share-buttons sms">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">12</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/"
		data-short-url=""
		data-track="hoopshypestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/"
		data-short-url=""
		data-track="hoopshypestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="hoopshype"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/"
		data-short-url=""
		data-track="hoopshypestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/"
		data-short-url=""
		data-track="hoopshypestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/"
		data-short-url=""
		data-track="hoopshypestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/"
			data-short-url=""
			data-track="hoopshypestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p>
		By 		<span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://hoopshype.com/author/alexkennedynba/" title="Posts by Alex Kennedy" class="author url fn" rel="author">Alex Kennedy</a></span></span> |
		<span itemprop="datePublished" content="2020-03-31T10:28:19-04:00">
			March 31, 2020		</span>
		<span class="article__author__widgets">
								</span>
	</p>

	</div>


						
						<div class="articleBody" itemprop="articleBody">		<form id="wpcom-iframe-form-24d5027094dd949fbcf6f915aa7354a3-5e836d79c39aa" target="wpcom-iframe-24d5027094dd949fbcf6f915aa7354a3-5e836d79c39aa" method="post" action="//wpcomwidgets.com/?wpcom_origin=https%3A%2F%2Fusathoopshype.wordpress.com" style="display: none">
							<input type="hidden" name="width" value="100%" />
							<input type="hidden" name="height" value="180" />
							<input type="hidden" name="frameborder" value="0" />
							<input type="hidden" name="style" value="" />
							<input type="hidden" name="class" value="" />
							<input type="hidden" name="scrolling" value="no" />
							<input type="hidden" name="webkitallowfullscreen" value="" />
							<input type="hidden" name="mozallowfullscreen" value="" />
							<input type="hidden" name="allowfullscreen" value="" />
							<input type="hidden" name="resize" value="0" />
							<input type="hidden" name="replace_attributes" value="1" />
							<input type="hidden" name="name" value="" />
							<input type="hidden" name="fallback" value="&lt;p class=&quot;protected-embed-fallback&quot;&gt;This embed is invalid&lt;/p&gt;" />
							<input type="hidden" name="_data" value="PGlmcmFtZSB0aXRsZT0iTGFycnkgSHVnaGVzIG9uIFBsYXlpbmcgd2l0aCBNaWNoYWVsIEpvcmRhbi9MZUJyb24gSmFtZXMsIEhpcyBOQkEgQ2FyZWVyLCBCYXR0bGluZyBJbmp1cmllcyBhbmQgTW9yZSAoRXAuIDE5NikiIHNyYz0iaHR0cHM6Ly9vbW55LmZtL3Nob3dzL3RoZS1ob29wc2h5cGUtcG9kY2FzdC13aXRoLWFsZXgta2VubmVkeS9sYXJyeS1odWdoZXMtb24tcGxheWluZy13aXRoLW1pY2hhZWwtam9yZGFuLWxlYnJvbi9lbWJlZCIgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTgwIiBmcmFtZWJvcmRlcj0iMCIgY2xhc3M9IiIgc2Nyb2xsaW5nPSJubyIgYWxsb3dmdWxsc2NyZWVuPSIiIHJlc2l6ZT0iMCIgcmVwbGFjZV9hdHRyaWJ1dGVzPSIxIiBuYW1lPSIiPjwvaWZyYW1lPg==,e19401e11e165ae477f2bdce3a79080c7ef39f14" />
							<input type="hidden" name="_tag" value="protected-iframe" />
							<input type="hidden" name="_hash" value="24d5027094dd949fbcf6f915aa7354a3" />
					</form>
		
				<iframe
						name="wpcom-iframe-24d5027094dd949fbcf6f915aa7354a3-5e836d79c39aa"
			id="wpcom-iframe-24d5027094dd949fbcf6f915aa7354a3-5e836d79c39aa"
			frameborder="0"
			scrolling="no"
			width="100%" 			height="180" 			webkitallowfullscreen mozallowfullscreen allowfullscreen			class="wpcom-protected-iframe "
		></iframe>
		
		<script type="text/javascript">
		( function() {
			var func = function() {
				var iframe_form = document.getElementById('wpcom-iframe-form-24d5027094dd949fbcf6f915aa7354a3-5e836d79c39aa');
				var iframe = document.getElementById('wpcom-iframe-24d5027094dd949fbcf6f915aa7354a3-5e836d79c39aa');
				if ( iframe_form && iframe ) {
					iframe_form.submit();
					iframe.onload = function() {
						iframe.contentWindow.postMessage( {
							'msg_type': 'poll_size',
							'frame_id': 'wpcom-iframe-24d5027094dd949fbcf6f915aa7354a3-5e836d79c39aa'
						}, window.location.protocol + '//wpcomwidgets.com' );
					}
				}

				// Autosize iframe
				var funcSizeResponse = function( e ) {
					var origin = document.createElement( 'a' );
					origin.href = e.origin;

					// Verify message origin
					if ( 'wpcomwidgets.com' !== origin.host )
						return;

					// Verify message is in a format we expect
					if ( 'object' !== typeof e.data || undefined === e.data.msg_type )
						return;

					switch ( e.data.msg_type ) {
						case 'poll_size:response':
							var iframe = document.getElementById( e.data._request.frame_id );

							if ( iframe && '' === iframe.width )
								iframe.width = '100%';
							if ( iframe && '' === iframe.height )
								iframe.height = parseInt( e.data.height );

							return;
						default:
							return;
					}
				}

				if ( 'function' === typeof window.addEventListener ) {
					window.addEventListener( 'message', funcSizeResponse, false );
				} else if ( 'function' === typeof window.attachEvent ) {
					window.attachEvent( 'onmessage', funcSizeResponse );
				}
			}
			if (document.readyState === 'complete') { func.apply(); /* compat for infinite scroll */ }
			else if ( document.addEventListener ) { document.addEventListener( 'readystatechange', function(){ 
if (document.readyState === 'complete') { 
func.apply(); 
} 
},  false ); }
			else if ( document.attachEvent ) { document.attachEvent( 'onreadystatechange', func ); }
		} )();
		</script>
		
<p>Former NBA player <strong>Larry Hughes</strong> was recently a guest on The HoopsHype Podcast to discuss his 13-year NBA career, what it was like playing alongside <strong>Michael Jordan</strong> and <strong>LeBron James</strong>, battling injuries, how raising his four children changed him and much more. Listen to the interview above or read a transcribed version of the conversation below.</p>
<p><strong>Growing up in St. Louis, when did you start playing basketball?</strong></p>
<p><strong>Larry Hughes</strong>: I started playing school-yard basketball probably around fifth grade. You had your pick-up games, your &#8220;21&#8221; games. Then, I got into organized basketball during my sixth-grade year, when I was about 12 years old. From there, that was really my starting point of organized basketball and I fell in love with the environment, the competition, and it was something that I was naturally good at so I was able to kind of have a head start.</p>
<p><strong>Was there a certain point when you realized that you were good enough to play college basketball or potentially make it to the NBA?</strong></p>
<p><strong>LH</strong>: No, I never really knew at each step if I was good enough to be successful at the next step. Playing youth basketball, I never translated that into whether I was going to be good in high school. I had a good high school career, but I never really thought, &#8220;Will I have a good college career?&#8221; I was just kind of in the moment at every step, and it really worked out for me that way because I didn&#8217;t get too far ahead of myself.</p>
<p><strong>You were drafted by the Philadelphia 76ers in 1998. What was your draft night like and what are some of your favorite memories from that evening?</strong></p>
<p><strong>LH</strong>: Oh, man, it was amazing. I had a lot of my family there. In my draft year, the draft was actually in Vancouver, Canada. Being from St. Louis and being in the Midwest, I got a chance to travel up to Canada to Vancouver and bring my family along &#8211; my grandmother, my great uncles, my high school coach. It was a big time for me.</p>
<p><strong>You played alongside Allen Iverson in Philadelphia. I know you two developed a close relationship, so what was it like playing with Iverson and becoming friends off the court?</strong></p>
<p><strong>LH</strong>: He was one of my good friends and still is one of my good friends. We played together for a short period of time; we&#8217;ve been friends way longer. We had a connection from day one, with our family history. I had a little brother that was struggling from some medical issues and he had a little sister that was struggling from some medical issues, so that was really our bonding point. My little brother, [<strong>Justin</strong>], who&#8217;s passed away since then, actually met him before I did. So, we had a great connection off the court first.</p>
<p><strong>I&#8217;m so sorry about your brother. When that happened, did that change your outlook on life?</strong></p>
<p><strong>LH</strong>: It&#8217;s perspective. It makes you live one day at a time. Nothing is promised. You have to love your family members and be there for them through tough times. That&#8217;s what it taught me, to really be in the moment and really recognize just the gift that we have.</p>
<p><strong>Absolutely. In your second NBA season, you averaged 22.7 points, 5.9 rebounds, 4.1 assists and 1.9 steals with the Golden State Warriors. What did that do for your confidence?</strong></p>
<p><strong>LH</strong>: It was huge for me. I came from a winning situation in Philadelphia. [But] I wanted to play more, I wanted to explore. I&#8217;ve never been a guy that didn&#8217;t get a lot of minutes, so that was a little foreign to me at the time. But it was a gift and a curse. Going to another team, it&#8217;s not always greener on the other side. But it did give me a chance to explore my game and understand what I could and could not do. It gave me some roles and responsibilities that I took advantage of, so I understood that I could score the basketball in the league. Then, it was just about finding out how to become a winner.</p>
<div id="attachment_1331048" class="wp-caption alignleft"><img aria-describedby="caption-attachment-1331048" data-attachment-id="1331048" data-permalink="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/larry-hughes-shoots/" data-orig-file="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg" data-orig-size="3108,2025" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;WASHINGTON - NOVEMBER 8:  Larry Hughes #20 of the Washington Wizards shoots the ball over Kobe Bryant #8 of the Los Angeles Lakers during the game at MCI Center on November 8, 2002 in Washington, D.C.  The Wizards won 100-99.  NOTE TO USER: User expressly acknowledges and agrees that, by downloading and\/or using this Photograph, User is consenting to the terms and conditions of the Getty Images License Agreement Mandatory Copyright Notice:  Copyright 2002 NBAE  (Photo by Doug Pensinger\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;2002 Getty Images&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;Larry Hughes shoots&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Larry Hughes shoots" data-image-description data-medium-file="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg?w=1000" class="size-full wp-image-1331048 lazy-load" src="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg?w=100&amp;h=65#038;h=652" alt width="1000" height="652" data-lazy-src="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg?w=1000&#038;h=652" srcset="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg?w=1000&amp;h=652 1000w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg?w=2000&amp;h=1304 2000w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg?w=190&amp;h=124 190w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg?w=300&amp;h=195 300w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg?w=768&amp;h=500 768w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg?w=1024&amp;h=667 1024w" sizes="(max-width: 1000px) 100vw, 1000px"><noscript><img aria-describedby="caption-attachment-1331048" data-attachment-id="1331048" data-permalink="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/larry-hughes-shoots/" data-orig-file="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg" data-orig-size="3108,2025" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;WASHINGTON - NOVEMBER 8:  Larry Hughes #20 of the Washington Wizards shoots the ball over Kobe Bryant #8 of the Los Angeles Lakers during the game at MCI Center on November 8, 2002 in Washington, D.C.  The Wizards won 100-99.  NOTE TO USER: User expressly acknowledges and agrees that, by downloading and\/or using this Photograph, User is consenting to the terms and conditions of the Getty Images License Agreement Mandatory Copyright Notice:  Copyright 2002 NBAE  (Photo by Doug Pensinger\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;2002 Getty Images&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;Larry Hughes shoots&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Larry Hughes shoots" data-image-description="" data-medium-file="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg?w=1000" class="size-full wp-image-1331048" src="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg?w=1000&#038;h=652" alt="" width="1000" height="652" srcset="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg?w=1000&amp;h=652 1000w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg?w=2000&amp;h=1304 2000w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg?w=190&amp;h=124 190w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg?w=300&amp;h=195 300w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg?w=768&amp;h=500 768w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-1643968.jpg?w=1024&amp;h=667 1024w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript><p id="caption-attachment-1331048" class="wp-caption-text">Photo by Doug Pensinger/Getty Images</p></div>
<p><strong>You then joined the Washington Wizards and played with Michael Jordan during his final NBA season. When <a href="https://omny.fm/shows/the-hoopshype-podcast-with-alex-kennedy/jared-jeffries-on-playing-with-michael-jordan-expe">Jared Jeffries was on the podcast</a>, he said that it was like traveling with The Beatles. What were some of the craziest fan interactions with Jordan that you witnessed?</strong></p>
<p><strong>LH</strong>: There were two, for me, that really stood out. On one road trip, we were going to Chicago and we were playing the Bulls. Obviously, MJ is the greatest thing since sliced bread in that city. We were going to a nightclub to hang out. And M would always hang out with the team, but he would just be there. He would just appear. He wouldn&#8217;t necessarily go through the front door and we didn&#8217;t know if he came through the back door or if they had a secret entrance for him, but he would always just be there. So we were walking in and we saw him coming in. And as we saw him coming in, all the heads turned. Also, camera phones were starting to become a big thing, so you&#8217;d see all the phones come up and now everybody is taking pictures and videos of him walking through. <strong>Charles Oakley</strong> was with him and there was one guy that would not respect the fact that M was trying to get to his seat. He would not move. Charles Oakley was a teammate, was a coach, but he was more so MJ&#8217;s enforcer. So, he had some words with the fan and the guy literally got down on his knees and waved his hands up and down like, &#8220;MJ, you are the king! You are the greatest!&#8221; Then, he just got up and he moved out of the way, and MJ sat down. I was just like, &#8220;Okay, I&#8217;ve never seen that happen in real life&#8230;&#8221; I&#8217;ve only seen that happen in the movies, so that was one time that stood out to me.</p>
<p>The other time, we were out at an event where they had families and kids around. We were doing some pictures and some autographs and things of that nature. M had a cigar deal and he would always have a cigar, whether it was lit or not lit. But I can remember that, at this occasion, the cigar was lit. There was this mom who wanted her kid to take a picture with MJ and she did not care that he had this stinky cigar that was lit. She forced her kid into MJ&#8217;s hands and basically forced the picture. I don&#8217;t know if this picture is still around or what, but there should be a picture around of MJ with a 12-to-18-month-old baby with a cigar in his hand. (laughs) Those were two things that stood out to me.</p>
<p><strong>At that point, you were 24 years old. Were you able to learn a lot from Jordan throughout that season?</strong></p>
<p><strong>LH</strong>: I learned a lot. A lot of it had to do with off-the-court situations, whether it was how he walked into our locker room before our games, how he would go in to get treatment at a certain time before our games, how he would address the media in a way that just commanded their attention and commanded their respect, how he walked in and out of rooms. He had this presence and there was a feeling that you got when he walked into a room and when he left a room. It was more [of that stuff]. And I&#8217;m naturally like that; I&#8217;m more of a thinker and more of a watcher, so those are the things that I remember most about MJ &#8211; him off the court and his persona.</p>
<p><strong>There are a lot of stories about how he was difficult to play with. In Washington, there was a lot of talk about how he was hard on the young guys (such as Kwame Brown, though <a href="https://hoopshype.com/2017/06/02/kwame-brown-opens-up-about-his-nba-career-facing-criticism-michael-jordan-and-more/">Kwame says it was blown out of proportion</a>). What was he like as a teammate and was he hard on you?</strong></p>
<p><strong>LH</strong>: We were good. I didn&#8217;t have any [issues]. We&#8217;d play cards together. I mean, I got a chance to play cards on the plane with MJ! So, I mean, that was just like a &#8220;wow&#8221; moment for me. He&#8217;s very sarcastic. He&#8217;ll get on you, he&#8217;ll poke you. And that&#8217;s sort of the things that he did with Kwame and some of the other guys. Like with <strong>Brendan Haywood</strong>, he would poke a little bit. But it was all, really, in fun and I really respected him. I guess the respect was mutual because we didn&#8217;t have any of those issues.</p>
<p><strong>A lot of people act like Jordan was awful during his Wizards stint. They say he was washed up, but he still averaged 20.0 points, 6.1 rebounds, 3.8 assists and 1.5 steals in that final season. He obviously wasn&#8217;t the same player that we saw in Chicago, but he was still very productive.</strong></p>
<p><strong>LH</strong>: I agree, 1,000 percent. He wasn&#8217;t the MJ of the Chicago Bulls, but all good players and great players have to go through that phase. But, man, I watched him in practice, I watched him do shooting games, I watched his hand-eye coordination, I watched his fitness level&#8230; I saw all the behind-the-scenes things that people may not have gotten a chance to see away from those 48 minutes. And MJ was great until he was done playing, in my opinion.</p>
<p><strong>Not many people can say they played with Michael Jordan <em>and </em>LeBron James. What were the biggest similarities between the two?</strong></p>
<p><strong>LH</strong>: I think the natural ability, the attention to detail, the respect that they [had for the game]; they were not going to waste their God-given talent. That stands out to me the most&#8230; They had a deeper understanding that they weren&#8217;t going to let their talent be wasted. And they were going to inspire other people. I mean, even though I played with Bron when he was younger, we still had young guys who were coming to the team that looked up to Bron. It was a situation where he took advantage of that, and I think MJ took advantage of that as well, knowing that he would impact and inspire a lot of kids through a lot of different generations.</p>
<p><strong>What were the biggest differences between the two?</strong></p>
<p><strong>LH</strong>: I think the trash talk. Bron would talk trash and make comments in a joking fashion, but MJ had this way of being really aggressive with the trash talk and really using body language and everything to really get his point across. He seemed to be serious, but he may or may not have been &#8211; maybe he was just trying to pull those things out of his teammates and out of his peers. But he just had this way about him [where he wanted] you to really understand that he was the greatest.</p>
<p><strong>LeBron James was 21 years old when you joined the Cavaliers. What was 21-year-old LeBron like?</strong></p>
<p><strong>LH</strong>: His ears were open. He was ready to listen. He was ready to incorporate ideas into his game. He had an idea of what he wanted his game to look like, but we had many conversations &#8211; you know, early-morning, late-night conversations &#8211; about how great he wanted to be and the sort of work that he was putting in to be that great. Also, just his team and who he was surrounding himself with was also a conversation. He felt that he could support in his team in a way that everyone around him could be successful. I think that was his initial goal: For him and everyone around him to gain some success and help their families out.</p>
<div id="attachment_1331049" class="wp-caption alignleft"><img aria-describedby="caption-attachment-1331049" data-attachment-id="1331049" data-permalink="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/detroit-pistons-v-cleveland-cavaliers-game-4/" data-orig-file="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg" data-orig-size="3000,2000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;Canon EOS-1D Mark II N&quot;,&quot;caption&quot;:&quot;CLEVELAND - MAY 29:  Larry Hughes #32 and Lebron James #23 of the Cleveland Cavaliers slap hands before taking on the Detroit Pistons in Game Four of the Eastern Conference Finals during the 2007 NBA Playoffs on May 29, 2007 at the Quicken Loans Arena in Cleveland, Ohio. NOTE TO USER: User expressly acknowledges and agrees that, by downloading and or using this photograph, User is consenting to the terms and conditions of the Getty Images License Agreement.  (Photo by Gregory Shamus\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;1180470605&quot;,&quot;copyright&quot;:&quot;2007 Getty Images&quot;,&quot;focal_length&quot;:&quot;300&quot;,&quot;iso&quot;:&quot;800&quot;,&quot;shutter_speed&quot;:&quot;0.0015625&quot;,&quot;title&quot;:&quot;Detroit Pistons v Cleveland Cavaliers, Game 4&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Detroit Pistons v Cleveland Cavaliers, Game 4" data-image-description data-medium-file="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg?w=1000" class="size-full wp-image-1331049 lazy-load" src="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg?w=100&amp;h=66#038;h=667" alt width="1000" height="667" data-lazy-src="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg?w=1000&#038;h=667" srcset="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg?w=1000&amp;h=667 1000w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg?w=2000&amp;h=1334 2000w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg?w=190&amp;h=127 190w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg?w=300&amp;h=200 300w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg?w=768&amp;h=512 768w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg?w=1024&amp;h=683 1024w" sizes="(max-width: 1000px) 100vw, 1000px"><noscript><img aria-describedby="caption-attachment-1331049" data-attachment-id="1331049" data-permalink="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/detroit-pistons-v-cleveland-cavaliers-game-4/" data-orig-file="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg" data-orig-size="3000,2000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;Canon EOS-1D Mark II N&quot;,&quot;caption&quot;:&quot;CLEVELAND - MAY 29:  Larry Hughes #32 and Lebron James #23 of the Cleveland Cavaliers slap hands before taking on the Detroit Pistons in Game Four of the Eastern Conference Finals during the 2007 NBA Playoffs on May 29, 2007 at the Quicken Loans Arena in Cleveland, Ohio. NOTE TO USER: User expressly acknowledges and agrees that, by downloading and or using this photograph, User is consenting to the terms and conditions of the Getty Images License Agreement.  (Photo by Gregory Shamus\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;1180470605&quot;,&quot;copyright&quot;:&quot;2007 Getty Images&quot;,&quot;focal_length&quot;:&quot;300&quot;,&quot;iso&quot;:&quot;800&quot;,&quot;shutter_speed&quot;:&quot;0.0015625&quot;,&quot;title&quot;:&quot;Detroit Pistons v Cleveland Cavaliers, Game 4&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Detroit Pistons v Cleveland Cavaliers, Game 4" data-image-description="" data-medium-file="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg?w=1000" class="size-full wp-image-1331049" src="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg?w=1000&#038;h=667" alt="" width="1000" height="667" srcset="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg?w=1000&amp;h=667 1000w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg?w=2000&amp;h=1334 2000w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg?w=190&amp;h=127 190w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg?w=300&amp;h=200 300w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg?w=768&amp;h=512 768w, https://usathoopshype.files.wordpress.com/2020/03/gettyimages-74354447.jpg?w=1024&amp;h=683 1024w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript><p id="caption-attachment-1331049" class="wp-caption-text">Photo by Gregory Shamus/Getty Images</p></div>
<p><strong>The hype and expectations were crazy when he entered the NBA, but he managed to live up to it. You had a front-row seat as he developed. What was it like watching him take those next steps as a player when all eyes were on him and there were so much hype and scrutiny?</strong></p>
<p><strong>LH</strong>: I love it, man. I love his progression and how he went about things. There was a certain point where he would not listen to anyone. Then, I think he understood that he could take the good out of the things that he didn&#8217;t want to listen to and start to make [positives] out of those things and put those things into his game &#8211; the post-ups and taking the late-game shots and, now, he&#8217;s shooting the three-ball. I think these are all things that he thought about early on in his foundation and when he came into the league, as far as how he would expand this game and grow his game, and he&#8217;s put that work in.</p>
<p><strong>In your opinion, who&#8217;s the GOAT?</strong></p>
<p><strong>LH</strong>: MJ is the GOAT, in my opinion. That&#8217;s really a no-brainer for me. Really, the inspiration behind wanting to push forward came from me watching MJ and how he worked and all of his videos and really instilling his work ethic in myself and trying to do the Breakfast Club. He paved the way so, for me, it&#8217;s an easy answer. LeBron, he&#8217;s not far behind. But, for me, it&#8217;s always been MJ.</p>
<p><strong>You played with Gilbert Arenas and Antawn Jamison in Golden State before reuniting with them in Washington. You put up some monster numbers at that point in your career too. How much fun were those Wizards teams?</strong></p>
<p><strong>LH: </strong>They were really fun. <strong>Eddie Jordan </strong>came in after MJ left and he put in a new system, which was the Princeton system. They were running it in Sacramento as well. And that was the change. I mean, we understood that system, we bought into it. We watched hours of film to understand where teammates would be, where we could get people in the best position to be successful. We really took ownership, along with Eddie allowing us to take ownership, in that offense and in that team. And we just kind of relied on our relationship that we had from another stop and were able to communicate and talk to each other, and we had some success there.</p>
<p><strong>Looking back on your career, is there a specific season that was the most fun for you?</strong></p>
<p><strong>LH</strong>: Yeah, my last year in Washington, we had a lot of fun. We had different characters on a team: <strong>Gilbert Arenas</strong>, <strong>Antawn Jamison</strong>, <strong>Brendan Haywood</strong>, <strong>Jared Jeffries</strong>, <strong>Jerry Stackhouse</strong>. We had a good time hanging out as teammates. Putting all of those guys on one team that may have come from different places or were trying to make a name for themselves, we kind of put our heads together and tried to figure it out. So we were able to get some different accolades individually, but we also got the opportunity to play some playoff basketball before I left.</p>
<p><strong>You were named to the All-Defensive 1st Team that year. What was the key to making an All-Defensive team? </strong></p>
<p><strong>LH</strong>: It&#8217;s really about scouting. Scouting and you need to have a want to play defense. But it really depends on how much film you want to watch. If you know the other team&#8217;s plays like the back of your hand and if you can call the other team&#8217;s plays out, once you see a set, then that really puts you in the best position to be a good defender. I wasn&#8217;t necessarily the strongest guy or even the quickest guy or the guy who could jump the highest, but being in position gave me an advantage, especially when you talk about steals. That&#8217;s really about understanding what the next play is before it happens and being in a position to get another possession for your team.</p>
<p><strong>Which season was the worst or most frustrating for you?</strong></p>
<p><strong>LH</strong>: Probably my first season in Cleveland after leaving Washington. I suffered a few hand injuries during my time in Washington and that was something that bothered me. Obviously, if you&#8217;re not healthy, then you can&#8217;t play and you can&#8217;t produce. The best thing you can do is actually be healthy enough to get out there on the floor. When I got to Cleveland, that was really my mindset &#8211; to be healthy. But I think I got hurt in the preseason. I didn&#8217;t tell anybody until around December or January that I was actually hurt, but I pretty much shattered my middle finger on my right hand, so that season was sort of a here-we-go-again sort of deal with being injured, not being able to play, not being able to live up to the contract that I just signed. So, that was a pretty tough season.</p>
<p><b>When you sign a big contract, that brings certain expectations and it looms over everything. I&#8217;ve talked to other players about the stress that comes with a big deal. It&#8217;s one of those things that players don&#8217;t like to discuss because you don&#8217;t want to seem like you&#8217;re complaining about getting millions of dollars, but it&#8217;s tough when everyone is criticizing you and bringing up the contract. What was that like for you?</b></p>
<p><strong>LH</strong>: It was tough because, I mean, I obviously felt like I earned it. But, for me, it was personal. It wasn&#8217;t really any outside noise that would sway me either way; it was just more so the thoughts that I had inside myself that I wanted to take that next jump and I wanted to be the best player that I can be. If you&#8217;re injured, you can&#8217;t continue to grow, you can&#8217;t continue to learn. That was the tough part for me. But as far as the contract goes, fans and the outside people don&#8217;t always understand the amount of hours and the amount of work that goes into being a professional basketball player&#8230; I completely know and believe that I put in enough hours and I was focused enough to earn the contract. Now, it was internal, for me to continue to grow as a player. Like I said, it&#8217;s hard to do that when you get injured and then you take those steps back.</p>
<p><strong>When you were dealing with different injuries and that&#8217;s what was holding you back from reaching your full potential, how tough was that?</strong></p>
<p><strong>LH</strong>: It&#8217;s tough because I think basketball is about rhythm, it&#8217;s about flow. And anytime that you get off and you break that flow, you break that cycle of consistent days of being productive and building and growing upon the next day. So, when you&#8217;re injured, you just pulled the plug on those consistent days. For every player that&#8217;s playing any sport, the more consistent days you can rope together, the more consistent you&#8217;ll be. Because we&#8217;re all learning and we&#8217;re all computing different things on the fly, so the more time that you can get to apply those things that you learn or you see, then the better you&#8217;ll be. If you&#8217;re injured, obviously you don&#8217;t get that opportunity. Meanwhile, other guys are in their flow, in their mix, and they&#8217;re still going. So, it&#8217;s tough. Then, you drop back into that [flow] and you have to play catch up while trying to recover from an injury as well.</p>
<div id="attachment_1331091" class="wp-caption alignleft"><img aria-describedby="caption-attachment-1331091" data-attachment-id="1331091" data-permalink="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/new-york-knicks-v-orlando-magic/" data-orig-file="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg" data-orig-size="1280,906" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;3.2&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;NIKON D3&quot;,&quot;caption&quot;:&quot;ORLANDO, FL - DECEMBER 02:  Larry Hughes #0 of the New York Knicks sets up a play during the game against the Orlando Magic at Amway Arena on December 2, 2009 in Orlando, Florida.  NOTE TO USER: User expressly acknowledges and agrees that, by downloading and\/or using this Photograph, user is consenting to the terms and conditions of the Getty Images License Agreement.  (Photo by Sam Greenwood\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;1259785460&quot;,&quot;copyright&quot;:&quot;2009 Getty Images&quot;,&quot;focal_length&quot;:&quot;175&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.00125&quot;,&quot;title&quot;:&quot;New York Knicks v Orlando Magic&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="New York Knicks v Orlando Magic" data-image-description data-medium-file="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg?w=1000" class="size-full wp-image-1331091 lazy-load" src="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg?w=100&amp;h=70#038;h=708" alt width="1000" height="708" data-lazy-src="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg?w=1000&#038;h=708" srcset="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg?w=1000&amp;h=708 1000w, https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg?w=190&amp;h=134 190w, https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg?w=300&amp;h=212 300w, https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg?w=768&amp;h=544 768w, https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg?w=1024&amp;h=725 1024w, https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg 1280w" sizes="(max-width: 1000px) 100vw, 1000px"><noscript><img aria-describedby="caption-attachment-1331091" data-attachment-id="1331091" data-permalink="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/new-york-knicks-v-orlando-magic/" data-orig-file="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg" data-orig-size="1280,906" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;3.2&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;NIKON D3&quot;,&quot;caption&quot;:&quot;ORLANDO, FL - DECEMBER 02:  Larry Hughes #0 of the New York Knicks sets up a play during the game against the Orlando Magic at Amway Arena on December 2, 2009 in Orlando, Florida.  NOTE TO USER: User expressly acknowledges and agrees that, by downloading and\/or using this Photograph, user is consenting to the terms and conditions of the Getty Images License Agreement.  (Photo by Sam Greenwood\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;1259785460&quot;,&quot;copyright&quot;:&quot;2009 Getty Images&quot;,&quot;focal_length&quot;:&quot;175&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.00125&quot;,&quot;title&quot;:&quot;New York Knicks v Orlando Magic&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="New York Knicks v Orlando Magic" data-image-description="" data-medium-file="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg?w=1000" class="size-full wp-image-1331091" src="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg?w=1000&#038;h=708" alt="" width="1000" height="708" srcset="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg?w=1000&amp;h=708 1000w, https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg?w=190&amp;h=134 190w, https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg?w=300&amp;h=212 300w, https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg?w=768&amp;h=544 768w, https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg?w=1024&amp;h=725 1024w, https://usathoopshype.files.wordpress.com/2020/03/larryhughes_knicks1.jpg 1280w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript><p id="caption-attachment-1331091" class="wp-caption-text">Photo by Sam Greenwood/Getty Images</p></div>
<p><strong>You have four children. How did fatherhood change you?</strong></p>
<p><strong>LH</strong>: It gave me something to look forward to and you have someone that&#8217;s looking up to you for direction, for comfort, and to make sure that they are heading in the right direction. They&#8217;re going to follow us, they&#8217;re going to watch us in every move that we make. They&#8217;re not able to critique us, but they&#8217;re watching. So, for me, I just gained more insight of who I wanted to be and how I wanted to conduct myself.</p>
<p><strong>Since retiring, you run the Larry Hughes Basketball Academy. What does that entail?</strong></p>
<p><strong>LH: </strong>Well, it&#8217;s really about getting a chance to inspire and impact young people with the thought process that they won&#8217;t all make it to the NBA or the WNBA or play overseas or be paid to play any sport, for that matter. So what we&#8217;re doing is we&#8217;re using basketball as an understanding of skill development, of building a foundation, but also implementing character development. Because we understand that, again, a lot of these young people will be dropped into our communities, they&#8217;ll be dropped into our workforce, so we want to teach them how to communicate with each other, how to work as a team, how to fight through adversity, how to follow direction and how to find and create mentorships. So, we&#8217;re using basketball as a vehicle to create even more social skills.</p>
<p><strong>What do you make of how the NBA has evolved in recent years?</strong></p>
<p><strong>LH</strong>: I think evolution is positive. I think that&#8217;s all a part of growth. I&#8217;m not one of those older guys that say, &#8220;The game should be played like we played it in the late &#8217;90s and early 2000s!&#8221; I&#8217;m not one of those guys. I think the game is in a good place. I think what we&#8217;re trying to accomplish is being more efficient, and I think, fundamentally, that sounds great. I think it&#8217;s just an ongoing process of <em>how</em> we become more efficient. Is that more threes? Or is that more mid-range two-pointers? Well, if you&#8217;re a great mid-range shooter, then that&#8217;s probably your most efficient shot [and you shouldn&#8217;t] be swayed by the fact that the number of threes that are taken in a game is escalating&#8230; But evolution is very positive, in my opinion.</p>
<p><strong>How much NBA basketball do you watch these days and are there any players who you enjoy watching the most?</strong></p>
<p><strong>LH</strong>: I watch my fair share. When I&#8217;m not spending time with the young people, I&#8217;m plopped in front of the TV watching any basketball game I can find. I&#8217;m mainly watching Boston because <strong>Jayson Tatum</strong> is from St. Louis and he&#8217;s my godson, my nephew. Every time they play, I&#8217;m pretty much tuned in. Man, <strong>Kevin Durant</strong> is out, but anytime KD is playing I like to watch him play. <strong>Damian Lillard</strong>, I&#8217;m checking him out whenever I can. There are a number of guys where I just like their journey and I liked the way that they appeared on the scene. Damian Lillard is one of those main guys that I like to watch today. The way that he goes about his businesses is &#8217;90s-like.</p>
<p><strong>As you mentioned, you and Tatum are both from St. Louis. When did you first get to know him?</strong></p>
<p><strong>LH</strong>: When he was born! Me and his dad are best friends, we&#8217;re like brothers, so I&#8217;ve known Jayson since he was in Pampers. I&#8217;ve seen his growth from his Little-League-football days to Little-League-baseball days to his [Little-League] basketball days. I talked about this on our podcast (<a href="https://bleav.com/podcast-show/bleav-in-wizards/">Bleav in Wizards)</a> that I&#8217;ve seen his growth the longest. I&#8217;d actually give him the Most Improved [award] because of the things that he&#8217;s applied to his game, his attention to detail, his taking on the challenge, his coming back after a year of adversity to make an All-Star team. These are the things that we talk about when we talk about progression. Jayson is right there atop the list.</p>
<p><strong>Speaking of St. Louis, you were in a Nelly music video! The song is &#8220;Dilemma&#8221; and it came out in 2002. You play Kelly Rowland&#8217;s boyfriend. How did that come together and what was that experience like?</strong></p>
<p><strong>LH</strong>: Well, being from St. Louis, <strong>Nelly</strong> is obviously from St. Louis as well. I was playing out in Golden State and I was really active in the entertainment space; I think I had just done a few commercials for a shoe brand or something. They asked me, &#8220;Hey, do you want to do a cameo in the video?&#8221; I thought it would be a quick scene where I would pop in, they would pan the camera, you&#8217;d see my face and that would be it. But when I got there, there was a little bit more to the script. I was the boyfriend in the video that actually had his girlfriend taken by Nelly. (laughs) It was a great experience for me. It allowed me an inside track on how videos are done, the kind of the hurry-up-and-wait sort of thing that goes on with the videos and the eight-hour days for a two-and-a-half-minute video. It was a good experience for me.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='1000' height='563' src='https://www.youtube.com/embed/8WYHDfJDPDc?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p><strong>You mentioned your podcast, which is called <a href="https://bleav.com/podcast-show/bleav-in-wizards/">Bleav in Wizards</a>. What&#8217;s it like entering the podcast space and how are you enjoying it?</strong></p>
<p><strong>LH: </strong>It&#8217;s new to me. I&#8217;m pretty much a laid-back type of person who&#8217;s pretty private, you may say. But I made a New Year&#8217;s Resolution that I would get more active and get more into the space because people do want to hear certain stories, and I have a ton of stories. People do want to hear certain insight from a guy that&#8217;s a natural thinker. So I just wanted to apply that to into the podcast. And I love the Wizards, so the opportunity came across my desk to talk about the Wizards and give some insight on how the team is doing, but also speak about the league and speak about different things that I understand to be true throughout the NBA, so I just kind of said, &#8220;Okay, let&#8217;s do it.&#8221; We&#8217;ve recorded two podcasts so far, so we&#8217;re just looking to do more and have some fun with it.</p>
<p><strong>To give people a little preview of what they can hear on your podcast, can you share one more fun story from your playing days?</strong></p>
<p><strong>LH</strong>: Oh man, this story has kind of been out there a little bit, but it&#8217;s a story with Allen Iverson. Obviously, when I was drafted to Philadelphia, he was there and had a name for itself and had a Reebok deal. This is the son of the city; everybody loved Allen Iverson, and it was known that he did it big as far as with the cars and the Bentley&#8217;s and the jewelry and all those things. When I came into the league, we had a lockout, so we weren&#8217;t necessarily getting NBA checks, but if you had any endorsements, obviously those things were still happening. So when I went to the bank, I went to the ATM machine and I put my card in and got a couple of dollars out for the day. But I went to the bank with Allen Iverson one day, he didn&#8217;t go to the ATM. He didn&#8217;t go into the bank to talk to the teller either. He actually went <em>into the vault</em>. Yeah, he actually went into the vault, and this is how he took out his deposit. This was really the first interaction I had with someone who had a lot of money. When they gave Allen his money, it was still wrapped in plastic and that was something completely different than I&#8217;d ever seen. Really, I&#8217;ve only seen it a couple of times after that. But that&#8217;s one of my initial welcome-to-the-NBA stories. That was one of the craziest things that I&#8217;d ever seen at that point.</p>
<div id=inline-newsletter-widget class=hidden data-position=10><div class="widget widget--newsletter widget--box">
<div class="newsletter__wrapper " style="display: none;">

	<div class="newsletter__signup-wrapper">
				<form novalidate="novalidate" class="newsletter_form" action="https://hoopshype.com/wp-json/usat/v1/gems/subscribe/">

			
			<label class="newsletter__input-label" for="newsletter-email-input">
				<span class="screen-reader-text">Email</span>
				<input
					type="email"
					class="newsletter__input"
					placeholder="you@domain.com"
					name="email"
					id="newsletter-email-input"
					required
				>
							</label>

			<button
					type="submit"
					class="newsletter__button"
			>Sign up			</button>

			
			
		</form>

					<div class="newsletter__sidetext">
				<h3>Like this article?</h3>
				<p>Sign up for the HoopsHype email newsletter to get our top stories in your inbox every morning</p>
			</div>
		
		<div class="newsletter__state newsletter__state--error">
			<h3 class="newsletter__header newsletter__header--error">An error has occured</h3>

			<p class="newsletter__text newsletter__text--error">
				Please re-enter your email address.			</p>
		</div>

	</div>

	<div class="newsletter__state newsletter__state--success">
		<h3 class="newsletter__header">Thanks for signing up!</h3>

		<p class="newsletter__text">
			You&#039;ll now receive the top HoopsHype stories each day directly in your inbox.		</p>

			</div>

	</div>

</div></div></div>

						<div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-'); });</script></div>
						
						
						<p class="post-tags post-tags--hide"><a href="https://hoopshype.com/tag/evergreen/" rel="tag">Evergreen</a>, <a href="https://hoopshype.com/tag/featured/" rel="tag">Featured</a>, <a href="https://hoopshype.com/tag/interview/" rel="tag">Interview</a>, <a href="https://hoopshype.com/tag/podcast/" rel="tag">Podcast</a>, <a href="https://hoopshype.com/tag/top/" rel="tag">Top</a>, <a href="https://hoopshype.com/category/basketball/" rel="category tag">Basketball</a>, <a href="https://hoopshype.com/category/interview/" rel="category tag">Interview</a>, <a href="https://hoopshype.com/category/nba/" rel="category tag">NBA</a>, <a href="https://hoopshype.com/category/podcast/" rel="category tag">Podcast</a></p><p>
			<span class="icomoon icon-tag"></span>
			<span class="post-terms"><a href="https://hoopshype.com/category/basketball/" rel="tag">Basketball</a>, <a href="https://hoopshype.com/category/interview/" rel="tag">Interview</a>, <a href="https://hoopshype.com/category/nba/" rel="tag">NBA</a>, <a href="https://hoopshype.com/category/podcast/" rel="tag">Podcast</a>, <a href="https://hoopshype.com/tag/evergreen/" rel="tag">Evergreen</a>, <a href="https://hoopshype.com/tag/featured/" rel="tag">Featured</a>, <a href="https://hoopshype.com/tag/interview/" rel="tag">Interview</a>, <a href="https://hoopshype.com/tag/podcast/" rel="tag">Podcast</a>, <a href="https://hoopshype.com/tag/top/" rel="tag">Top</a>, <a href="https://hoopshype.com/player/allen-iverson/" rel="tag">Allen Iverson</a>, <a href="https://hoopshype.com/player/antawn-jamison/" rel="tag">Antawn Jamison</a>, <a href="https://hoopshype.com/player/damian-lillard/" rel="tag">Damian Lillard</a>, <a href="https://hoopshype.com/player/gilbert-arenas/" rel="tag">Gilbert Arenas</a>, <a href="https://hoopshype.com/player/jayson-tatum/" rel="tag">Jayson Tatum</a>, <a href="https://hoopshype.com/player/kevin-durant/" rel="tag">Kevin Durant</a>, <a href="https://hoopshype.com/player/larry-hughes/" rel="tag">Larry Hughes</a>, <a href="https://hoopshype.com/player/lebron-james/" rel="tag">LeBron James</a>, <a href="https://hoopshype.com/player/michael-jordan/" rel="tag">Michael Jordan</a>, <a href="https://hoopshype.com/team/chicago-bulls/" rel="tag">Chicago Bulls</a>, <a href="https://hoopshype.com/team/cleveland-cavaliers/" rel="tag">Cleveland Cavaliers</a>, <a href="https://hoopshype.com/team/golden-state-warriors/" rel="tag">Golden State Warriors</a>, <a href="https://hoopshype.com/team/philadelphia-76ers/" rel="tag">Philadelphia 76ers</a>, <a href="https://hoopshype.com/team/washington-wizards/" rel="tag">Washington Wizards</a></span>
			</p>
						<div class="story-share-buttons sms">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">12</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/"
		data-short-url=""
		data-track="hoopshypestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/"
		data-short-url=""
		data-track="hoopshypestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="hoopshype"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/"
		data-short-url=""
		data-track="hoopshypestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/"
		data-short-url=""
		data-track="hoopshypestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/"
		data-short-url=""
		data-track="hoopshypestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/"
			data-short-url=""
			data-track="hoopshypestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
</div><div class="after-article widget_text">			<div class="textwidget"><div class="veeseoRA2VW"></div></div>
		</div>					</div><!-- .entry-content -->
				</div><!-- #content-container -->

				
			</article><!-- #post-## -->

		
		<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>RELATED <span>ARTICLES</span></h2>
	</div>
	
	<div class="holder-column">
		<div class="column">
			<article class="block block-single-related">
	<a href="https://hoopshype.com/2020/03/27/nba-rumors-jason-richardson-jrich-we-believe-warriors-sixers-magic-suns-goldenseed-cannabis-retirement-tanking-trust-process/"
		data-track="hoopshypefeaturedstories hoopshypemore-related-1"
		title="Jason Richardson Q&amp;A: &#039;I think I should&#039;ve made a few All-Star teams&#039;"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://usathoopshype.files.wordpress.com/2020/03/jasonrichardson_retired1.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://usathoopshype.files.wordpress.com/2020/03/jasonrichardson_retired1.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Jason Richardson Q&amp;A: &#039;I think I should&#039;ve made a few All-Star teams&#039;" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">108 shares</span><span class="block__time block__time--mobile">4d ago</span>
		<h2><a href="https://hoopshype.com/category/podcast/" class="category" itemprop="articleSection">Podcast</a></h2>

		<p>
			<a data-track="hoopshypefeaturedstories hoopshypemore-related-1" href="https://hoopshype.com/2020/03/27/nba-rumors-jason-richardson-jrich-we-believe-warriors-sixers-magic-suns-goldenseed-cannabis-retirement-tanking-trust-process/"
				title="Jason Richardson Q&amp;A: &#039;I think I should&#039;ve made a few All-Star teams&#039;" itemprop="url">
				Jason Richardson Q&amp;A: 'I think I should've made a few All-Star teams'			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://hoopshype.com/2020/03/29/nba-rumors-theo-ratliff-centers-hawks-allen-iverson-clint-capela-sixers-evolution-retired-interview/"
		data-track="hoopshypefeaturedstories hoopshypemore-related-2"
		title="Theo Ratliff Q&amp;A: &#039;I still don&#039;t know how Allen Iverson did what he did&#039;"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://usathoopshype.files.wordpress.com/2020/02/theoratliff_retired1.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://usathoopshype.files.wordpress.com/2020/02/theoratliff_retired1.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Theo Ratliff Q&amp;A: &#039;I still don&#039;t know how Allen Iverson did what he did&#039;" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">729 shares</span><span class="block__time block__time--mobile">2d ago</span>
		<h2><a href="https://hoopshype.com/category/interview/" class="category" itemprop="articleSection">Interview</a></h2>

		<p>
			<a data-track="hoopshypefeaturedstories hoopshypemore-related-2" href="https://hoopshype.com/2020/03/29/nba-rumors-theo-ratliff-centers-hawks-allen-iverson-clint-capela-sixers-evolution-retired-interview/"
				title="Theo Ratliff Q&amp;A: &#039;I still don&#039;t know how Allen Iverson did what he did&#039;" itemprop="url">
				Theo Ratliff Q&amp;A: 'I still don't know how Allen Iverson did what he did'			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://hoopshype.com/2020/03/23/nba-rumors-anfernee-penny-hardaway-shaq-magic-orlando-shaquille-memphis-tigers-coach-college-injuries-lil-interview-ncaa/"
		data-track="hoopshypefeaturedstories hoopshypemore-related-3"
		title="Penny Hardaway Q&amp;A: &#039;If Shaq stayed, we would&#039;ve won championships&#039;"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://usathoopshype.files.wordpress.com/2020/03/penny_hardaway_tigers2.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://usathoopshype.files.wordpress.com/2020/03/penny_hardaway_tigers2.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Penny Hardaway Q&amp;A: &#039;If Shaq stayed, we would&#039;ve won championships&#039;" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">341 shares</span><span class="block__time block__time--mobile">2w ago</span>
		<h2><a href="https://hoopshype.com/category/interview/" class="category" itemprop="articleSection">Interview</a></h2>

		<p>
			<a data-track="hoopshypefeaturedstories hoopshypemore-related-3" href="https://hoopshype.com/2020/03/23/nba-rumors-anfernee-penny-hardaway-shaq-magic-orlando-shaquille-memphis-tigers-coach-college-injuries-lil-interview-ncaa/"
				title="Penny Hardaway Q&amp;A: &#039;If Shaq stayed, we would&#039;ve won championships&#039;" itemprop="url">
				Penny Hardaway Q&amp;A: 'If Shaq stayed, we would've won championships'			</a>
		</p>

	</div>
</article>

		</div>
	</div>
</div>
<div class="container single-related single-related--zergnet is-wasabi" id="single-related-zergnet-lawrence">
		<div class="heading-small"><h2>From <span>The Web</span></h2></div>
		<div id="zergnet-widget-67304" class="zergnet-wrapper"></div>
	</div><div class="container column container--stories">
	<div class="heading-small">
		<h2>LATEST</h2>
	</div>
	<div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_native'); });</script></div>
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/30/2001-nba-re-draft/"
						title="2001 NBA re-draft: The way it should have been"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2020/03/pau-gasol-vs-tony-parker.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2020/03/pau-gasol-vs-tony-parker.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2001 NBA re-draft: The way it should have been" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2020/03/30/2001-nba-re-draft/"
								title="2001 NBA re-draft: The way it should have been"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2020/03/30/2001-nba-re-draft/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2020/03/30/2001-nba-re-draft/"
			title="2001 NBA re-draft: The way it should have been"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2020/03/30/2001-nba-re-draft/" class="share-text">
	166</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/gallery/" class="category" itemprop="articleSection">Gallery</a>						<span class="block__time block__time--mobile">1d ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/30/2001-nba-re-draft/"
						title="2001 NBA re-draft: The way it should have been"
						itemprop="url" 						>
							2001 NBA re-draft: The way it should have been					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/gallery/" class="category" itemprop="articleSection">Gallery</a><span class="dot">&middot;</span>						<span class="time">March 30, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/barrigon/" title="Posts by Raul Barrigon" class="author url fn" rel="author">Raul Barrigon</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/29/nba-rumors-theo-ratliff-centers-hawks-allen-iverson-clint-capela-sixers-evolution-retired-interview/"
						title="Theo Ratliff Q&amp;A: &#039;I still don&#039;t know how Allen Iverson did what he did&#039;"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2020/02/theoratliff_retired1.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2020/02/theoratliff_retired1.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Theo Ratliff Q&amp;A: &#039;I still don&#039;t know how Allen Iverson did what he did&#039;" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2020/03/29/nba-rumors-theo-ratliff-centers-hawks-allen-iverson-clint-capela-sixers-evolution-retired-interview/"
								title="Theo Ratliff Q&amp;A: &#039;I still don&#039;t know how Allen Iverson did what he did&#039;"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2020/03/29/nba-rumors-theo-ratliff-centers-hawks-allen-iverson-clint-capela-sixers-evolution-retired-interview/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2020/03/29/nba-rumors-theo-ratliff-centers-hawks-allen-iverson-clint-capela-sixers-evolution-retired-interview/"
			title="Theo Ratliff Q&amp;A: &#039;I still don&#039;t know how Allen Iverson did what he did&#039;"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2020/03/29/nba-rumors-theo-ratliff-centers-hawks-allen-iverson-clint-capela-sixers-evolution-retired-interview/" class="share-text">
	729</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/interview/" class="category" itemprop="articleSection">Interview</a>						<span class="block__time block__time--mobile">2d ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/29/nba-rumors-theo-ratliff-centers-hawks-allen-iverson-clint-capela-sixers-evolution-retired-interview/"
						title="Theo Ratliff Q&amp;A: &#039;I still don&#039;t know how Allen Iverson did what he did&#039;"
						itemprop="url" 						>
							Theo Ratliff Q&amp;A: &#039;I still don&#039;t know how Allen Iverson did what he did&#039;					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/interview/" class="category" itemprop="articleSection">Interview</a><span class="dot">&middot;</span>						<span class="time">March 29, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/alexkennedynba/" title="Posts by Alex Kennedy" class="author url fn" rel="author">Alex Kennedy</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/28/hoopshype-weekly-olympics-postponed-nba/"
						title="The HoopsHype Weekly: The Olympics getting postponed could have huge ramifications towards the NBA"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2020/03/tokyo-olympic-games.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2020/03/tokyo-olympic-games.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="The HoopsHype Weekly: The Olympics getting postponed could have huge ramifications towards the NBA" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2020/03/28/hoopshype-weekly-olympics-postponed-nba/"
								title="The HoopsHype Weekly: The Olympics getting postponed could have huge ramifications towards the NBA"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2020/03/28/hoopshype-weekly-olympics-postponed-nba/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2020/03/28/hoopshype-weekly-olympics-postponed-nba/"
			title="The HoopsHype Weekly: The Olympics getting postponed could have huge ramifications towards the NBA"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2020/03/28/hoopshype-weekly-olympics-postponed-nba/" class="share-text">
	40</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/newsletter/" class="category" itemprop="articleSection">Newsletter</a>						<span class="block__time block__time--mobile">3d ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/28/hoopshype-weekly-olympics-postponed-nba/"
						title="The HoopsHype Weekly: The Olympics getting postponed could have huge ramifications towards the NBA"
						itemprop="url" 						>
							The HoopsHype Weekly: The Olympics getting postponed could have huge ramifications towards the NBA					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/newsletter/" class="category" itemprop="articleSection">Newsletter</a><span class="dot">&middot;</span>						<span class="time">March 28, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/fau09fsu/" title="Posts by Frank Urbina" class="author url fn" rel="author">Frank Urbina</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/28/2000-nba-re-draft-the-way-it-should-have-been-2/"
						title="2000 NBA re-draft: The way it should have been"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2020/03/crawford-redd.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2020/03/crawford-redd.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2000 NBA re-draft: The way it should have been" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2020/03/28/2000-nba-re-draft-the-way-it-should-have-been-2/"
								title="2000 NBA re-draft: The way it should have been"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2020/03/28/2000-nba-re-draft-the-way-it-should-have-been-2/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2020/03/28/2000-nba-re-draft-the-way-it-should-have-been-2/"
			title="2000 NBA re-draft: The way it should have been"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2020/03/28/2000-nba-re-draft-the-way-it-should-have-been-2/" class="share-text">
	130</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/gallery/" class="category" itemprop="articleSection">Gallery</a>						<span class="block__time block__time--mobile">3d ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/28/2000-nba-re-draft-the-way-it-should-have-been-2/"
						title="2000 NBA re-draft: The way it should have been"
						itemprop="url" 						>
							2000 NBA re-draft: The way it should have been					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/gallery/" class="category" itemprop="articleSection">Gallery</a><span class="dot">&middot;</span>						<span class="time">March 28, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/barrigon/" title="Posts by Raul Barrigon" class="author url fn" rel="author">Raul Barrigon</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/27/nba-rumors-jason-richardson-jrich-we-believe-warriors-sixers-magic-suns-goldenseed-cannabis-retirement-tanking-trust-process/"
						title="Jason Richardson Q&amp;A: &#039;I think I should&#039;ve made a few All-Star teams&#039;"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2020/03/jasonrichardson_retired1.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2020/03/jasonrichardson_retired1.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Jason Richardson Q&amp;A: &#039;I think I should&#039;ve made a few All-Star teams&#039;" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2020/03/27/nba-rumors-jason-richardson-jrich-we-believe-warriors-sixers-magic-suns-goldenseed-cannabis-retirement-tanking-trust-process/"
								title="Jason Richardson Q&amp;A: &#039;I think I should&#039;ve made a few All-Star teams&#039;"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2020/03/27/nba-rumors-jason-richardson-jrich-we-believe-warriors-sixers-magic-suns-goldenseed-cannabis-retirement-tanking-trust-process/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2020/03/27/nba-rumors-jason-richardson-jrich-we-believe-warriors-sixers-magic-suns-goldenseed-cannabis-retirement-tanking-trust-process/"
			title="Jason Richardson Q&amp;A: &#039;I think I should&#039;ve made a few All-Star teams&#039;"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2020/03/27/nba-rumors-jason-richardson-jrich-we-believe-warriors-sixers-magic-suns-goldenseed-cannabis-retirement-tanking-trust-process/" class="share-text">
	108</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				4d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/podcast/" class="category" itemprop="articleSection">Podcast</a>						<span class="block__time block__time--mobile">4d ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/27/nba-rumors-jason-richardson-jrich-we-believe-warriors-sixers-magic-suns-goldenseed-cannabis-retirement-tanking-trust-process/"
						title="Jason Richardson Q&amp;A: &#039;I think I should&#039;ve made a few All-Star teams&#039;"
						itemprop="url" 						>
							Jason Richardson Q&amp;A: &#039;I think I should&#039;ve made a few All-Star teams&#039;					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/podcast/" class="category" itemprop="articleSection">Podcast</a><span class="dot">&middot;</span>						<span class="time">March 27, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/alexkennedynba/" title="Posts by Alex Kennedy" class="author url fn" rel="author">Alex Kennedy</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/26/nba-clutch-stats/"
						title="How clutch are your favorite NBA stars? You&#039;re in for some surprises"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2020/03/lillard-vs-kyrie.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2020/03/lillard-vs-kyrie.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="How clutch are your favorite NBA stars? You&#039;re in for some surprises" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2020/03/26/nba-clutch-stats/"
								title="How clutch are your favorite NBA stars? You&#039;re in for some surprises"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2020/03/26/nba-clutch-stats/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2020/03/26/nba-clutch-stats/"
			title="How clutch are your favorite NBA stars? You&#039;re in for some surprises"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2020/03/26/nba-clutch-stats/" class="share-text">
	86</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				5d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/gallery/" class="category" itemprop="articleSection">Gallery</a>						<span class="block__time block__time--mobile">5d ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/26/nba-clutch-stats/"
						title="How clutch are your favorite NBA stars? You&#039;re in for some surprises"
						itemprop="url" 						>
							How clutch are your favorite NBA stars? You&#039;re in for some surprises					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/gallery/" class="category" itemprop="articleSection">Gallery</a><span class="dot">&middot;</span>						<span class="time">March 26, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/hoopshype-staff/" title="Posts by HoopsHype staff" class="author url fn" rel="author">HoopsHype staff</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/26/nba-sneaker-free-agency-process/"
						title="How sneaker free agency works: The recruiting and pitch meetings"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2020/03/gettyimages-486422742.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2020/03/gettyimages-486422742.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="How sneaker free agency works: The recruiting and pitch meetings" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2020/03/26/nba-sneaker-free-agency-process/"
								title="How sneaker free agency works: The recruiting and pitch meetings"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2020/03/26/nba-sneaker-free-agency-process/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2020/03/26/nba-sneaker-free-agency-process/"
			title="How sneaker free agency works: The recruiting and pitch meetings"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2020/03/26/nba-sneaker-free-agency-process/" class="share-text">
	103</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				5d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/longform/" class="category" itemprop="articleSection">Longform</a>						<span class="block__time block__time--mobile">5d ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/26/nba-sneaker-free-agency-process/"
						title="How sneaker free agency works: The recruiting and pitch meetings"
						itemprop="url" 						>
							How sneaker free agency works: The recruiting and pitch meetings					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/longform/" class="category" itemprop="articleSection">Longform</a><span class="dot">&middot;</span>						<span class="time">March 26, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/alexkennedynba/" title="Posts by Alex Kennedy" class="author url fn" rel="author">Alex Kennedy</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/25/1999-nba-re-draft-the-way-it-should-have-been-2/"
						title="1999 NBA re-draft: The way it should have been"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2020/03/manu-matrix.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2020/03/manu-matrix.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="1999 NBA re-draft: The way it should have been" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2020/03/25/1999-nba-re-draft-the-way-it-should-have-been-2/"
								title="1999 NBA re-draft: The way it should have been"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2020/03/25/1999-nba-re-draft-the-way-it-should-have-been-2/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2020/03/25/1999-nba-re-draft-the-way-it-should-have-been-2/"
			title="1999 NBA re-draft: The way it should have been"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2020/03/25/1999-nba-re-draft-the-way-it-should-have-been-2/" class="share-text">
	324</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				6d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/gallery/" class="category" itemprop="articleSection">Gallery</a>						<span class="block__time block__time--mobile">6d ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/25/1999-nba-re-draft-the-way-it-should-have-been-2/"
						title="1999 NBA re-draft: The way it should have been"
						itemprop="url" 						>
							1999 NBA re-draft: The way it should have been					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/gallery/" class="category" itemprop="articleSection">Gallery</a><span class="dot">&middot;</span>						<span class="time">March 25, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/barrigon/" title="Posts by Raul Barrigon" class="author url fn" rel="author">Raul Barrigon</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/24/nba-rumors-donatas-motiejunas-china-cba-quarantine-coronavirus-covid-chinese-basketball-lithuania-interview/"
						title="Donatas Motiejunas Q&amp;A: &#039;Shanghai is back to life&#039;"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2020/03/donatasmotiejunas_12.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2020/03/donatasmotiejunas_12.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Donatas Motiejunas Q&amp;A: &#039;Shanghai is back to life&#039;" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2020/03/24/nba-rumors-donatas-motiejunas-china-cba-quarantine-coronavirus-covid-chinese-basketball-lithuania-interview/"
								title="Donatas Motiejunas Q&amp;A: &#039;Shanghai is back to life&#039;"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2020/03/24/nba-rumors-donatas-motiejunas-china-cba-quarantine-coronavirus-covid-chinese-basketball-lithuania-interview/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2020/03/24/nba-rumors-donatas-motiejunas-china-cba-quarantine-coronavirus-covid-chinese-basketball-lithuania-interview/"
			title="Donatas Motiejunas Q&amp;A: &#039;Shanghai is back to life&#039;"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2020/03/24/nba-rumors-donatas-motiejunas-china-cba-quarantine-coronavirus-covid-chinese-basketball-lithuania-interview/" class="share-text">
	156</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/podcast/" class="category" itemprop="articleSection">Podcast</a>						<span class="block__time block__time--mobile">1w ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/24/nba-rumors-donatas-motiejunas-china-cba-quarantine-coronavirus-covid-chinese-basketball-lithuania-interview/"
						title="Donatas Motiejunas Q&amp;A: &#039;Shanghai is back to life&#039;"
						itemprop="url" 						>
							Donatas Motiejunas Q&amp;A: &#039;Shanghai is back to life&#039;					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/podcast/" class="category" itemprop="articleSection">Podcast</a><span class="dot">&middot;</span>						<span class="time">March 24, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/alexkennedynba/" title="Posts by Alex Kennedy" class="author url fn" rel="author">Alex Kennedy</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/23/jazz-rookie-juwan-morgan-on-coronavirus-scare-it-felt-like-a-movie/"
						title="Jazz rookie Juwan Morgan on coronavirus scare: &#039;It felt like a movie&#039;"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2020/03/usatsi_14084441.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2020/03/usatsi_14084441.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Jazz rookie Juwan Morgan on coronavirus scare: &#039;It felt like a movie&#039;" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
													<a
								data-track="hoopshypemostrecent"
								href="https://hoopshype.com/2020/03/23/jazz-rookie-juwan-morgan-on-coronavirus-scare-it-felt-like-a-movie/"
								title="Jazz rookie Juwan Morgan on coronavirus scare: &#039;It felt like a movie&#039;"
								class="ico-comments"
								rel="nofollow"
								itemprop="url"
								>
									0							</a>
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2020/03/23/jazz-rookie-juwan-morgan-on-coronavirus-scare-it-felt-like-a-movie/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2020/03/23/jazz-rookie-juwan-morgan-on-coronavirus-scare-it-felt-like-a-movie/"
			title="Jazz rookie Juwan Morgan on coronavirus scare: &#039;It felt like a movie&#039;"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2020/03/23/jazz-rookie-juwan-morgan-on-coronavirus-scare-it-felt-like-a-movie/" class="share-text">
	73</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2w			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a>						<span class="block__time block__time--mobile">2w ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/03/23/jazz-rookie-juwan-morgan-on-coronavirus-scare-it-felt-like-a-movie/"
						title="Jazz rookie Juwan Morgan on coronavirus scare: &#039;It felt like a movie&#039;"
						itemprop="url" 						>
							Jazz rookie Juwan Morgan on coronavirus scare: &#039;It felt like a movie&#039;					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a><span class="dot">&middot;</span>						<span class="time">March 23, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/bryankalbrosky/" title="Posts by Bryan Kalbrosky" class="author url fn" rel="author">Bryan Kalbrosky</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	</div>
<div class="social-cta container column">

	<h2 class="social-cta__header">
		Follow HH!	</h2>

			<div class="social-cta__column social-cta__column--social">

			<h3 class="social-cta__type social-cta__type--social">Social</h3>
			<span class="social-cta__desc social-cta__desc--social">
				See HH stories in your feed			</span>

							<a
					href="http://facebook.com/hoopshype"
					class="social-cta__button social-cta__button--facebook"
					target="_blank"
				>Like HoopsHype</a>
			
							<a
					href="https://twitter.com/hoopshype"
					class="social-cta__button social-cta__button--twitter"
					target="_blank"
				>Follow HoopsHype</a>
			
		</div>
	
			<div class="social-cta__column social-cta__column--email">

			<h3 class="social-cta__type social-cta__type--email">Newsletter</h3>
			<span class="social-cta__desc social-cta__desc--email">
				Get the day&#039;s top stories			</span>

			<form action="https://hoopshype.com/wp-json/usat/v1/gems/subscribe/">

				<span class="social-cta__input-wrapper">
					<input
						type="email"
						class="social-cta__input"
						placeholder="name@domain.com"
						name="email"
						required
					>
				</span>
				<button
					type="submit"
					class="social-cta__button"
				>Sign me up!</button>

			</form>

			<div class="social-cta__state social-cta__state--success">

				<span class="social-cta__notice social-cta__notice--success">Success</span>

				<p>
					Thanks for signing up.<br>
					Please check your email for a confirmation.				</p>

			</div>

			<div class="social-cta__state social-cta__state--error">

				<span class="social-cta__notice social-cta__notice--error">Whoa!</span>

				<p class="social-cta__text--error">
					Something went wrong.
				</p>

				<button class="social-cta__button social-cta__button--dark social-cta__button--reset">
					Try again?
				</button>

			</div>

		</div>
	
			<div class="social-cta__column social-cta__column--podcast">

			<h3 class="social-cta__type social-cta__type--podcast">Podcast</h3>
			<span class="social-cta__desc social-cta__desc--podcast">
				Hear HH writers out loud			</span>

			<a
				href="https://hoopshype.com/category/podcast/"
				class="social-cta__button social-cta__button--podcast"
			>Latest podcast</a>

		</div>
	
</div>
<a href="https://hoopshype.com" class="article__back">More HoopsHype</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		
			<div class="widget sidebar-ad top">
				<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>			</div>

		
		
		<div class="widget_text widget widget_custom_html" id="custom_html-4"><div class="heading-small"><h2>GO IN-DEPTH</h2></div><div class="textwidget custom-html-widget"><div class="widget ui-widget ui-widget-content ui-corner-all" id="usat_hoopshype_social-2" style="line-height:1.5em;font-size:15px;font-family:Helvetica, Arial, sans-serif;">
	<ul class="ui-tabs-panel ui-widget-content ui-corner-bottom" style="padding-bottom:10px;list-style:none;margin-left:0;padding-left:0;">
		<li style="padding:5px 0;border-bottom:1px solid #eee;">💰 <a href="/salaries/" style="font-weight:normal;color:#000;">Salaries of players right now</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">💸 <a href="/salaries/players/2000-2001/" style="font-weight:normal;color:#000;">Salaries of players back in the day</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">💼 <a href="/reps/" style="font-weight:normal;color:#000;">Ranking agents by wages</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">📅 <a href="/2019/06/17/nba-contracts-key-dates-deadlines-options-trade-eligibility/" style="font-weight:normal;color:#000;">Key contract dates</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">📄 <a href="/all-nba-rosters-in-one-page-with-some-extra-details/" style="font-weight:normal;color:#000;">NBA rosters with details</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">🏀 <a href="/2019/07/10/nba-depth-charts/" style="font-weight:normal;color:#000;">Depth charts today</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">📞 <a href="/2019/07/02/nba-transactions-all-the-moves-of-the-2019-20-season/" style="font-weight:normal;color:#000;">Daily transactions</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">⭐ <a href="/2019/09/19/nba-free-agents-in-2020/" style="font-weight:normal;color:#000;">Upcoming free agents</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">🏆 <a href="/2019/08/08/nba-awards-all-the-winners-in-league-history/" style="font-weight:normal;color:#000;">All NBA awards in history</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">🎮 <a href="/nba2k/" style="font-weight:normal;color:#000;">NBA 2K ratings</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">🎓 <a href="/tag/re-drafts/" style="font-weight:normal;color:#000;">Re-ordering draft classes</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">🎙️ <a href="https://audioboom.com/channel/the-hoopshype-podcast" style="font-weight:normal;color:#000;">Listen to our podcast</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">📧 <a href="/newsletters/" style="font-weight:normal;color:#000;">Subscribe to our newsletter</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">📷 <a href="https://www.instagram.com/hoopshypeofficial/" style="font-weight:normal;color:#000;" rel="nofollow">Follow us on Instagram</a></li>
	</ul>
</div></div></div><div class="widget HotStorylines_Widget" id="hotstorylines_widget-2"><div class="hype-wrapper hot-storylines-wrapper hot-storylines-simple" id="chartContainer-hot-storylines" style="width:100%;" data-url="https://hoopshype.com/post_stats/hot-storylines-stats">
	<div class="hype-title">
		<h2 class="hype-title-title">Hot Storylines</h2>
					</div>
		<ul class="hot-storylines-list">
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/salary-reductions/">
					Salary Reductions				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/coronavirus/">
					Coronavirus				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/season-suspension/">
					Season Suspension				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/dwight-howard-free-agency/">
					Dwight Howard Free Agency				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/demarcus-cousins-free-agency/">
					DeMarcus Cousins Free Agency				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/caris-levert-trade/">
					Caris LeVert Trade?				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/joe-harris-free-agency/">
					Joe Harris Free Agency				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/olympic-games/">
					Olympic Games				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/nba-2k-league/">
					NBA 2K League				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/esports/">
					eSports				</a>
			</li>
			</ul>

			<a class="all-rumors-link" href="https://hoopshype.com/rumors/">View all rumors</a>
	
</div>
</div><div class="widget salaries_widget tabbed_widget" id="salaries_widget-2"><div class="heading-small"><h2>Top salaries</h2></div><div class="tabs">
	<ul class="tab-controls hh-team-details">
					<li><a href="#hh-tab-team-payroll">Team Payrolls</a></li>
							<li><a href="#hh-tab-team-salaries">Player Salaries</a></li>
			</ul>
			<div id="hh-tab-team-payroll" class="hh-team-payroll">
			<table class="">
								<tbody>
											<tr>
							<td>
								1.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/portland_trail_blazers/">
									Portland								</a>
							</td>
															<td>
									$137,371,388								</td>
													</tr>
											<tr>
							<td>
								2.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/miami_heat/">
									Miami								</a>
							</td>
															<td>
									$135,262,022								</td>
													</tr>
											<tr>
							<td>
								3.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/oklahoma_city_thunder/">
									Oklahoma City								</a>
							</td>
															<td>
									$133,757,694								</td>
													</tr>
											<tr>
							<td>
								4.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/orlando_magic/">
									Orlando								</a>
							</td>
															<td>
									$133,692,528								</td>
													</tr>
											<tr>
							<td>
								5.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/los_angeles_clippers/">
									LA Clippers								</a>
							</td>
															<td>
									$133,589,926								</td>
													</tr>
											<tr>
							<td>
								6.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/minnesota_timberwolves/">
									Minnesota								</a>
							</td>
															<td>
									$132,706,778								</td>
													</tr>
											<tr>
							<td>
								7.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/philadelphia_76ers/">
									Philadelphia								</a>
							</td>
															<td>
									$132,222,531								</td>
													</tr>
											<tr>
							<td>
								8.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/washington_wizards/">
									Washington								</a>
							</td>
															<td>
									$131,500,636								</td>
													</tr>
											<tr>
							<td>
								9.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/golden_state_warriors/">
									Golden State								</a>
							</td>
															<td>
									$131,477,176								</td>
													</tr>
											<tr>
							<td>
								10.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/milwaukee_bucks/">
									Milwaukee								</a>
							</td>
															<td>
									$131,332,989								</td>
													</tr>
									</tbody>
			</table>
							<div class="hh-salaries-cta">
					<a href="https://hoopshype.com/salaries/#hh-tab-team-payroll">
						View more team payrolls
					</a>
				</div>
					</div>
				<div id="hh-tab-team-salaries" class="hh-team-salaries">
			<table>
				<tbody>
											<tr>
							<td class="player-rank">
								1.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/stephen-curry/">
										Stephen Curry									</a>
															</td>
							<td class="player-salary">
								$40,231,758							</td>
						</tr>
											<tr>
							<td class="player-rank">
								2.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/russell-westbrook/">
										Russell Westbrook									</a>
															</td>
							<td class="player-salary">
								$38,506,482							</td>
						</tr>
											<tr>
							<td class="player-rank">
								2.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/chris-paul/">
										Chris Paul									</a>
															</td>
							<td class="player-salary">
								$38,506,482							</td>
						</tr>
											<tr>
							<td class="player-rank">
								4.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/james-harden/">
										James Harden									</a>
															</td>
							<td class="player-salary">
								$38,199,000							</td>
						</tr>
											<tr>
							<td class="player-rank">
								4.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/john-wall/">
										John Wall									</a>
															</td>
							<td class="player-salary">
								$38,199,000							</td>
						</tr>
											<tr>
							<td class="player-rank">
								6.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/lebron-james/">
										LeBron James									</a>
															</td>
							<td class="player-salary">
								$37,436,858							</td>
						</tr>
											<tr>
							<td class="player-rank">
								7.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/kevin-durant/">
										Kevin Durant									</a>
															</td>
							<td class="player-salary">
								$37,199,000							</td>
						</tr>
											<tr>
							<td class="player-rank">
								8.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/blake-griffin/">
										Blake Griffin									</a>
															</td>
							<td class="player-salary">
								$34,449,964							</td>
						</tr>
											<tr>
							<td class="player-rank">
								9.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/kyle-lowry/">
										Kyle Lowry									</a>
															</td>
							<td class="player-salary">
								$33,296,296							</td>
						</tr>
											<tr>
							<td class="player-rank">
								10.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/paul-george/">
										Paul George									</a>
															</td>
							<td class="player-salary">
								$33,005,556							</td>
						</tr>
									</tbody>
			</table>
							<div class="hh-salaries-cta">
					<a href="https://hoopshype.com/salaries/#hh-tab-team-salaries">
						View more player salaries
					</a>
				</div>
					</div>
	</div><!-- /.tabs -->
</div><div class="widget widget_wpcom_social_media_icons_widget" id="wpcom_social_media_icons_widget-2"><div class="heading-small"><h2>Social</h2></div><ul><li><a href="https://www.facebook.com/hoopshype/" class="genericon genericon-facebook" target="_blank"><span class="screen-reader-text">View hoopshype&#8217;s profile on Facebook</span></a></li><li><a href="https://twitter.com/hoopshype/" class="genericon genericon-twitter" target="_blank"><span class="screen-reader-text">View hoopshype&#8217;s profile on Twitter</span></a></li></ul></div><div class="widget latestnews_widget tabbed_widget" id="latestnews_widget-2"><div class="tabs">
	<ul class="tab-controls hh-team-details">
		<li><a href="#hh-tab-news">Latest News</a></li>
					<li><a href="#hh-tab-custom-tag">Newsletter</a></li>
			</ul>
	<div id="hh-tab-news" class="col1 right hh-latest-news">
		<ul>
			
<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=480 ');" href="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/" title="Larry Hughes Q&amp;A: &#039;Injuries kept me from being the best I could be&#039;" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2020/03/larryhughes_retired1.jpg?w=100&#038;h=100&#038;crop=1" alt="Larry Hughes Q&amp;A: &#039;Injuries kept me from being the best I could be&#039;" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/podcast/" class="category">Podcast</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/" title="Larry Hughes Q&amp;A: &#039;Injuries kept me from being the best I could be&#039;">
			Larry Hughes Q&amp;A: 'Injuries kept me from being the best I could be'		</a>
		<p class="widget-date">March 31, 2020</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2020/03/pau-gasol-vs-tony-parker.jpg?w=480 ');" href="https://hoopshype.com/2020/03/30/2001-nba-re-draft/" title="2001 NBA re-draft: The way it should have been" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2020/03/pau-gasol-vs-tony-parker.jpg?w=100&#038;h=100&#038;crop=1" alt="2001 NBA re-draft: The way it should have been" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/gallery/" class="category">Gallery</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/03/30/2001-nba-re-draft/" title="2001 NBA re-draft: The way it should have been">
			2001 NBA re-draft: The way it should have been		</a>
		<p class="widget-date">March 30, 2020</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2020/02/theoratliff_retired1.jpg?w=480 ');" href="https://hoopshype.com/2020/03/29/nba-rumors-theo-ratliff-centers-hawks-allen-iverson-clint-capela-sixers-evolution-retired-interview/" title="Theo Ratliff Q&amp;A: &#039;I still don&#039;t know how Allen Iverson did what he did&#039;" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2020/02/theoratliff_retired1.jpg?w=100&#038;h=100&#038;crop=1" alt="Theo Ratliff Q&amp;A: &#039;I still don&#039;t know how Allen Iverson did what he did&#039;" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/interview/" class="category">Interview</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/03/29/nba-rumors-theo-ratliff-centers-hawks-allen-iverson-clint-capela-sixers-evolution-retired-interview/" title="Theo Ratliff Q&amp;A: &#039;I still don&#039;t know how Allen Iverson did what he did&#039;">
			Theo Ratliff Q&amp;A: 'I still don't know how Allen Iverson did what he did'		</a>
		<p class="widget-date">March 29, 2020</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2020/03/tokyo-olympic-games.jpg?w=480 ');" href="https://hoopshype.com/2020/03/28/hoopshype-weekly-olympics-postponed-nba/" title="The HoopsHype Weekly: The Olympics getting postponed could have huge ramifications towards the NBA" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2020/03/tokyo-olympic-games.jpg?w=100&#038;h=100&#038;crop=1" alt="The HoopsHype Weekly: The Olympics getting postponed could have huge ramifications towards the NBA" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/newsletter/" class="category">Newsletter</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/03/28/hoopshype-weekly-olympics-postponed-nba/" title="The HoopsHype Weekly: The Olympics getting postponed could have huge ramifications towards the NBA">
			The HoopsHype Weekly: The Olympics getting postponed could have huge ramifications towards the NBA		</a>
		<p class="widget-date">March 28, 2020</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2020/03/crawford-redd.jpg?w=480 ');" href="https://hoopshype.com/2020/03/28/2000-nba-re-draft-the-way-it-should-have-been-2/" title="2000 NBA re-draft: The way it should have been" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2020/03/crawford-redd.jpg?w=100&#038;h=100&#038;crop=1" alt="2000 NBA re-draft: The way it should have been" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/gallery/" class="category">Gallery</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/03/28/2000-nba-re-draft-the-way-it-should-have-been-2/" title="2000 NBA re-draft: The way it should have been">
			2000 NBA re-draft: The way it should have been		</a>
		<p class="widget-date"></p>
	</div>
</li>
		</ul>
	</div>
			<div id="hh-tab-custom-tag" class="col1 right hh-latest-news">
			<ul>
				
<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2020/03/tokyo-olympic-games.jpg?w=480 ');" href="https://hoopshype.com/2020/03/28/hoopshype-weekly-olympics-postponed-nba/" title="The HoopsHype Weekly: The Olympics getting postponed could have huge ramifications towards the NBA" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2020/03/tokyo-olympic-games.jpg?w=100&#038;h=100&#038;crop=1" alt="The HoopsHype Weekly: The Olympics getting postponed could have huge ramifications towards the NBA" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/newsletter/" class="category">Newsletter</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/03/28/hoopshype-weekly-olympics-postponed-nba/" title="The HoopsHype Weekly: The Olympics getting postponed could have huge ramifications towards the NBA">
			The HoopsHype Weekly: The Olympics getting postponed could have huge ramifications towards the NBA		</a>
		<p class="widget-date"></p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2020/03/mark-cuban-doncic.jpg?w=480 ');" href="https://hoopshype.com/2020/03/21/hoopshype-weekly-nba-players-owners-coronavirus-outbreak/" title="The HoopsHype Weekly: NBA players and owners are giving back during coronavirus outbreak" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2020/03/mark-cuban-doncic.jpg?w=100&#038;h=100&#038;crop=1" alt="The HoopsHype Weekly: NBA players and owners are giving back during coronavirus outbreak" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/newsletter/" class="category">Newsletter</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/03/21/hoopshype-weekly-nba-players-owners-coronavirus-outbreak/" title="The HoopsHype Weekly: NBA players and owners are giving back during coronavirus outbreak">
			The HoopsHype Weekly: NBA players and owners are giving back during coronavirus outbreak		</a>
		<p class="widget-date">March 21, 2020</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2017/03/gettyimages-1177508794-1.jpg?w=480 ');" href="https://hoopshype.com/2020/03/18/hoopshype-daily-kevin-durant-coronavirus/" title="The HoopsHype Daily: Kevin Durant among four new positive coronavirus cases in the NBA" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2017/03/gettyimages-1177508794-1.jpg?w=100&#038;h=100&#038;crop=1" alt="The HoopsHype Daily: Kevin Durant among four new positive coronavirus cases in the NBA" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/newsletter/" class="category">Newsletter</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/03/18/hoopshype-daily-kevin-durant-coronavirus/" title="The HoopsHype Daily: Kevin Durant among four new positive coronavirus cases in the NBA">
			The HoopsHype Daily: Kevin Durant among four new positive coronavirus cases in the NBA		</a>
		<p class="widget-date">March 18, 2020</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2020/03/adam-silver.jpg?w=480 ');" href="https://hoopshype.com/2020/03/17/hoopshype-daily-nba-schedules-board-coronavirus/" title="The HoopsHype Daily: NBA schedules Board of Governors meeting over the phone to update on coronavirus" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2020/03/adam-silver.jpg?w=100&#038;h=100&#038;crop=1" alt="The HoopsHype Daily: NBA schedules Board of Governors meeting over the phone to update on coronavirus" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/newsletter/" class="category">Newsletter</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/03/17/hoopshype-daily-nba-schedules-board-coronavirus/" title="The HoopsHype Daily: NBA schedules Board of Governors meeting over the phone to update on coronavirus">
			The HoopsHype Daily: NBA schedules Board of Governors meeting over the phone to update on coronavirus		</a>
		<p class="widget-date">March 17, 2020</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2020/03/nba-logo.jpg?w=480 ');" href="https://hoopshype.com/2020/03/12/hoopshype-daily-coronavirus-nba-season-suspended/" title="The HoopsHype Daily: Following a positive coronavirus test from Rudy Gobert, the NBA season has been suspended" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2020/03/nba-logo.jpg?w=100&#038;h=100&#038;crop=1" alt="The HoopsHype Daily: Following a positive coronavirus test from Rudy Gobert, the NBA season has been suspended" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/newsletter/" class="category">Newsletter</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/03/12/hoopshype-daily-coronavirus-nba-season-suspended/" title="The HoopsHype Daily: Following a positive coronavirus test from Rudy Gobert, the NBA season has been suspended">
			The HoopsHype Daily: Following a positive coronavirus test from Rudy Gobert, the NBA season has been suspended		</a>
		<p class="widget-date">March 12, 2020</p>
	</div>
</li>
			</ul>
		</div>
	</div>
</div>
		
			<div class="widget sidebar-ad bottom">
				<div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_bottom_300x250'); });</script></div>			</div>

		
		
<div id="footer-info">
	<p class="footer__logo">
		<a href="http://usatodaysports.com" rel="nofollow" target="_blank">
			<img src="https://usathoopshype.files.wordpress.com/2017/01/usatlogo.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-navigation-container"><ul id="menu-footer-navigation" class="menu"><li id="menu-item-1179960" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1179960"><a href="https://cm.usatoday.com/terms">Terms of Service</a></li>
<li id="menu-item-1304766" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1304766"><a href="https://cm.usatoday.com/privacy">Privacy Policy</a></li>
<li id="menu-item-1179959" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1179959"><a href="https://cm.usatoday.com/privacy-policy">Your California Privacy Rights/Privacy Policy</a></li>
<li id="menu-item-1179961" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1179961"><a href="https://cm.usatoday.com/cookies">Do No Sell My Info/Cookie Policy</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=hoopshype.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "More Information";
		var footer_collapse_text = "Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	<div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-'); });</script></div>
	<!-- wpcom_wp_footer -->
<script type="text/javascript">
	var _sf_async_config = {"uid":"89374","useCanonical":true,"domain":"hoopshype.com","authors":"Alex Kennedy","sections":"Basketball,Interview,NBA,Podcast"};

	(function(){
		function loadChartbeat() {
			window._sf_endpt = (new Date()).getTime();
			var e = document.createElement('script');
			e.setAttribute('language', 'javascript');
			e.setAttribute('type', 'text/javascript');
			e.setAttribute('src',
			(('https:' == document.location.protocol) ? 'https://s3.amazonaws.com/' : 'http://') +
			'static.chartbeat.com/js/chartbeat.js');
			document.body.appendChild(e);
		}
		var oldonload = window.onload;
		window.onload = ( 'function' !== typeof window.onload ) ?
		loadChartbeat : function() { oldonload(); loadChartbeat(); };
	})();
</script>
<div id="daily-newsletter-error-email" class="daily-newsletter__state daily-newsletter__state--error thickbox" style="display: none;">
	<div class="daily-newsletter-error__wrapper">
		<h3 class="daily-newsletter-error__header"><span class="dashicons dashicons-warning"></span>Error</h3>
		<p id="daily-newsletter-error-message" class="daily-newsletter-error__message">
			Please enter an email address.		</p>
	</div>
</div>

<div id="newsletter-success" class="newsletter__state daily-newsletter__state--success thickbox" style="display: none;">
	<div class="daily-newsletter-error__wrapper">
		<h3 class="newsletter__header"><span class="dashicons dashicons-yes"></span>Success</h3>

		<p class="newsletter__text">Thanks for signing up.</p>
		<p class="newsletter__text">Please check your email for a confirmation.</p>
	</div>
</div>

<div id="daily-newsletter-error" class="daily-newsletter__state daily-newsletter__state--error thickbox" style="display: none;">
	<div class="daily-newsletter-error__wrapper">
		<h3 class="daily-newsletter__header"><span class="dashicons dashicons-warning"></span>Error</h3>

		<p id="daily-newsletter-error-message" class="daily-newsletter__text daily-newsletter__text--error daily-newsletter-error__message">
			Something went wrong.		</p>
	</div>
</div>
<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://usathoopshype.files.wordpress.com/2017/01/logo-hoopshype-header.png" alt="HoopsHype">
				<a class="mobile-nav__breadcrumb" href="https://hoopshype.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
			<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="http://facebook.com/hoopshype" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/hoopshype" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--podcast">
				<a href="https://hoopshype.com/category/podcast/" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--rumors mobile-nav__item--parent sub-menu-3columns sub-menu-columns-offset200"><a title="NBA Rumors" href="/rumors/">Rumors</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--atlanta-hawks"><a title="Atlanta Rumors" href="https://hoopshype.com/team/atlanta-hawks/">Atlanta Hawks</a></li>
	<li class="mobile-nav__item mobile-nav__item--boston-celtics"><a title="Boston Rumors" href="https://hoopshype.com/team/boston-celtics/">Boston Celtics</a></li>
	<li class="mobile-nav__item mobile-nav__item--brooklyn-nets"><a title="Brooklyn Rumors" href="https://hoopshype.com/team/brooklyn-nets/">Brooklyn Nets</a></li>
	<li class="mobile-nav__item mobile-nav__item--charlotte-hornets"><a title="Charlotte Rumors" href="https://hoopshype.com/team/charlotte-hornets/">Charlotte Hornets</a></li>
	<li class="mobile-nav__item mobile-nav__item--chicago-bulls"><a title="Chicago Rumors" href="https://hoopshype.com/team/chicago-bulls/">Chicago Bulls</a></li>
	<li class="mobile-nav__item mobile-nav__item--cleveland-cavaliers"><a title="Cleveland Rumors" href="https://hoopshype.com/team/cleveland-cavaliers/">Cleveland Cavaliers</a></li>
	<li class="mobile-nav__item mobile-nav__item--dallas-mavericks"><a title="Dallas Rumors" href="https://hoopshype.com/team/dallas-mavericks/">Dallas Mavericks</a></li>
	<li class="mobile-nav__item mobile-nav__item--denver-nuggets"><a title="Denver Rumors" href="https://hoopshype.com/team/denver-nuggets/">Denver Nuggets</a></li>
	<li class="mobile-nav__item mobile-nav__item--detroit-pistons"><a title="Detroit Rumors" href="https://hoopshype.com/team/detroit-pistons/">Detroit Pistons</a></li>
	<li class="mobile-nav__item mobile-nav__item--golden-state-warriors"><a title="Golden State Rumors" href="https://hoopshype.com/team/golden-state-warriors/">Golden State Warriors</a></li>
	<li class="mobile-nav__item mobile-nav__item--houston-rockets"><a title="Houston Rumors" href="https://hoopshype.com/team/houston-rockets/">Houston Rockets</a></li>
	<li class="mobile-nav__item mobile-nav__item--indiana-pacers"><a title="Indiana Rumors" href="https://hoopshype.com/team/indiana-pacers/">Indiana Pacers</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-clippers"><a title="LA Clippers Rumors" href="https://hoopshype.com/team/los-angeles-clippers/">Los Angeles Clippers</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-lakers"><a title="LA Lakers Rumors" href="https://hoopshype.com/team/los-angeles-lakers/">Los Angeles Lakers</a></li>
	<li class="mobile-nav__item mobile-nav__item--memphis-grizzlies"><a title="Memphis Rumors" href="https://hoopshype.com/team/memphis-grizzlies/">Memphis Grizzlies</a></li>
	<li class="mobile-nav__item mobile-nav__item--miami-heat"><a title="Miami Rumors" href="https://hoopshype.com/team/miami-heat/">Miami Heat</a></li>
	<li class="mobile-nav__item mobile-nav__item--milwaukee-bucks"><a title="Milwaukee Rumors" href="https://hoopshype.com/team/milwaukee-bucks/">Milwaukee Bucks</a></li>
	<li class="mobile-nav__item mobile-nav__item--minnesota-timberwolves"><a title="Minnesota Rumors" href="https://hoopshype.com/team/minnesota-timberwolves/">Minnesota Timberwolves</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-orleans-pelicans"><a title="New Orleans Rumors" href="https://hoopshype.com/team/new-orleans-pelicans/">New Orleans Pelicans</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-york-knicks"><a title="New York Rumors" href="https://hoopshype.com/team/new-york-knicks/">New York Knicks</a></li>
	<li class="mobile-nav__item mobile-nav__item--oklahoma-city-thunder"><a title="Oklahoma City Rumors" href="https://hoopshype.com/team/oklahoma-city-thunder/">Oklahoma City Thunder</a></li>
	<li class="mobile-nav__item mobile-nav__item--orlando-magic"><a title="Orlando Rumors" href="https://hoopshype.com/team/orlando-magic/">Orlando Magic</a></li>
	<li class="mobile-nav__item mobile-nav__item--philadelphia-76ers"><a title="Philadelphia Rumors" href="https://hoopshype.com/team/philadelphia-76ers/">Philadelphia 76ers</a></li>
	<li class="mobile-nav__item mobile-nav__item--phoenix-suns"><a title="Phoenix Rumors" href="https://hoopshype.com/team/phoenix-suns/">Phoenix Suns</a></li>
	<li class="mobile-nav__item mobile-nav__item--portland-trail-blazers"><a title="Portland Rumors" href="https://hoopshype.com/team/portland-trail-blazers/">Portland Trail Blazers</a></li>
	<li class="mobile-nav__item mobile-nav__item--sacramento-kings"><a title="Sacramento Rumors" href="https://hoopshype.com/team/sacramento-kings/">Sacramento Kings</a></li>
	<li class="mobile-nav__item mobile-nav__item--san-antonio-spurs"><a title="San Antonio Rumors" href="https://hoopshype.com/team/san-antonio-spurs/">San Antonio Spurs</a></li>
	<li class="mobile-nav__item mobile-nav__item--toronto-raptors"><a title="Toronto Rumors" href="https://hoopshype.com/team/toronto-raptors/">Toronto Raptors</a></li>
	<li class="mobile-nav__item mobile-nav__item--utah-jazz"><a title="Utah Rumors" href="https://hoopshype.com/team/utah-jazz/">Utah Jazz</a></li>
	<li class="mobile-nav__item mobile-nav__item--washington-wizards"><a title="Washington Rumors" href="https://hoopshype.com/team/washington-wizards/">Washington Wizards</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--salaries mobile-nav__item--parent sub-menu-minwidth140"><a title="NBA Salaries" href="/salaries/">Salaries</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--players"><a title="NBA Player Salaries" href="https://hoopshype.com/salaries/players/">Players</a></li>
	<li class="mobile-nav__item mobile-nav__item--teams"><a title="NBA Salaries" href="https://hoopshype.com/salaries/">Teams</a></li>
	<li class="mobile-nav__item mobile-nav__item--salary-cap"><a href="https://hoopshype.com/2020/03/16/los-angeles-lakers-their-salary-cap-situation-right-now/">Salary cap</a></li>
	<li class="mobile-nav__item mobile-nav__item--history"><a href="https://hoopshype.com/salaries/2000-2001/">History</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--twitter mobile-nav__item--parent sub-menu-minwidth140"><a title="NBA Media Twitters" href="/social/">Twitter</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--media"><a title="NBA Media Twitters" href="/social/">Media</a></li>
	<li class="mobile-nav__item mobile-nav__item--players"><a title="NBA Players on Twitter" href="/social/tweets/">Players</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--features mobile-nav__item--parent sub-menu-3columns sub-menu-columns-offset200"><a href="#">Features</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--agents"><a title="NBA Agents" href="/reps/">Agents</a></li>
	<li class="mobile-nav__item mobile-nav__item--awards"><a href="https://hoopshype.com/2019/08/08/nba-awards-all-the-winners-in-league-history/">Awards</a></li>
	<li class="mobile-nav__item mobile-nav__item--birthdays"><a href="https://hoopshype.com/2019/01/13/which-nba-player-was-born-the-same-day-as-you-find-out-here/">Birthdays</a></li>
	<li class="mobile-nav__item mobile-nav__item--birthplaces"><a title="Birthplaces" href="/2019/08/20/nba-players-birthplaces/">Birthplaces</a></li>
	<li class="mobile-nav__item mobile-nav__item--depth-charts"><a href="https://hoopshype.com/2019/07/10/nba-depth-charts/">Depth Charts</a></li>
	<li class="mobile-nav__item mobile-nav__item--draft"><a title="NBA Draft" href="/2018/01/09/nba-mock-draft-2018/">Draft</a></li>
	<li class="mobile-nav__item mobile-nav__item--free-agency-2019"><a title="NBA Free Agency 2019" href="/2018/08/09/nba-free-agency-2019-the-top-players">Free Agency 2019</a></li>
	<li class="mobile-nav__item mobile-nav__item--free-agency-2020"><a href="https://hoopshype.com/2019/07/18/nba-free-agency-2020-the-top-players/">Free Agency 2020</a></li>
	<li class="mobile-nav__item mobile-nav__item--hoopshype-explains"><a href="https://hoopshype.com/category/hoopshype-explains/">HoopsHype Explains</a></li>
	<li class="mobile-nav__item mobile-nav__item--hoopshype-podcasts"><a href="/category/podcast/">HoopsHype Podcasts</a></li>
	<li class="mobile-nav__item mobile-nav__item--instagram"><a title="NBA Players on Instagram" href="/social/gallery/">Instagram</a></li>
	<li class="mobile-nav__item mobile-nav__item--key-contract-dates"><a href="https://hoopshype.com/2019/06/17/nba-contracts-key-dates-deadlines-options-trade-eligibility/">Key Contract Dates</a></li>
	<li class="mobile-nav__item mobile-nav__item--longform"><a title="Longform" href="https://hoopshype.com/category/longform/">Longform</a></li>
	<li class="mobile-nav__item mobile-nav__item--nba-2k-ratings"><a href="https://hoopshype.com/nba2k/">NBA 2K Ratings</a></li>
	<li class="mobile-nav__item mobile-nav__item--nicknames"><a href="https://hoopshype.com/2019/02/24/all-the-nicknames-in-nba-history/">Nicknames</a></li>
	<li class="mobile-nav__item mobile-nav__item--players"><a title="NBA Players" href="/players/">Players</a></li>
	<li class="mobile-nav__item mobile-nav__item--re-drafts"><a href="https://hoopshype.com/tag/re-drafts/">Re-Drafts</a></li>
	<li class="mobile-nav__item mobile-nav__item--roster-details"><a href="https://hoopshype.com/2019/11/07/all-nba-rosters-in-one-page-with-some-extra-details/">Roster Details</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-rumors"><a href="https://hoopshype.com/category/top-rumors/">Top Rumors</a></li>
	<li class="mobile-nav__item mobile-nav__item--transactions"><a title="NBA Transactions" href="/transactions.htm">Transactions</a></li>
</ul>
</li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-1179960" class="mobile-nav__item mobile-nav__item--terms-of-service"><a href="https://cm.usatoday.com/terms">Terms of Service</a></li>
<li id="menu-item-1304766" class="mobile-nav__item mobile-nav__item--privacy-policy"><a href="https://cm.usatoday.com/privacy">Privacy Policy</a></li>
<li id="menu-item-1179959" class="mobile-nav__item mobile-nav__item--your-california-privacy-rights-privacy-policy"><a href="https://cm.usatoday.com/privacy-policy">Your California Privacy Rights/Privacy Policy</a></li>
<li id="menu-item-1179961" class="mobile-nav__item mobile-nav__item--do-no-sell-my-info-cookie-policy"><a href="https://cm.usatoday.com/cookies">Do No Sell My Info/Cookie Policy</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=hoopshype.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</li>
			</ul>

	</div>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><script src='//0.gravatar.com/js/gprofiles.js?ver=202014y'></script>
<script>
var WPGroHo = {"my_hash":""};
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="85827622" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://hoopshype.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="HoopsHype" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="e37008ccd7" /><input type="hidden" name="_wp_http_referer" value="/2020/03/31/nba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum/" />		</form>

		<div class="arrow"></div>
	</div>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/_static/??-eJx9jkEOwjAMBD9EsKqqlTgg3hJcK02bOFHsUOD1hEO5ILiNvJ7VwpaNZwx1IoFFQGeP6zXdP3BEkQO0L0ysxAqxmhyq8yyAtqQqFGAhzRZXsx/+SY6Yim/BD/xydabYxt18hipW02QfJtitECNBTFMNLX1ScUwKTd75XXSJ524Y+37sxtOwvAAf+lk6?cssminify=yes' type='text/css' media='all' />
<script>
var comment_like_text = {"loading":"Loading..."};
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyVy00KgCAQQOELZUOQmIvoLtkQY/7BaHb8bFfLtu/xQU3CxJAxZLAMG55kMF295Q5eyxeRXNkpMJjofUvC0YH8GEcrcKWEf9AnNLj4eZBq1GqSUtsbk082wA=='></script>
<script src='https://native.sharethrough.com/assets/sfp.js?ver=1'></script>
<script>
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
</script>
<script>
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/s2.wp.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
</script>
<script>
var newsletter = {"i18n":{"cancel":"Cancel","close":"Close","want_more":"Want More?","try_again":"Please try again"},"force_modal":"","force_abovenav":"","is_mobile":"","modal_enabled":"","abovenav_enabled":"","cookie_expiry":"30","inline_position":"10","confirm_url":"","wiresites":{"enabled":false,"url":"https:\/\/hoopshype.com\/daily-email-newsletter"}};
</script>
<script>
var _LAWRENCE_ADS_EXPORTS = {"ad_refresh":{"seconds":"90","refresh_type":"all","distance":"2000","active":"0"}};
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJylk91OwzAMhV+ILqrQJrhAPIubeJ27JA6xs1Keng7BBoj1R9xF9qcT5xzH9KmyHBWjGj1gQDEnSqYIKDsYKg99xmjRBHbFj11wldhMScV0YhJkCFyibjq5M6MWReuLw49m91IwD6aQsZxxEyhOUz25FnWeSyykxHGeDBjLLcqRqDlhdJzPrcR+2JP3k7jjUGUEN0xSUNc3getsUJQth+RRf3gzlUbypaUo10IugfM34c3eU/qn0q/SjMNcZEG0GYXeoPELUJehbZehTVFdsgaOwHO71OTLyo8anpovZy3zkfCvi/RA9tjw6+WwJoAeBBo6y0TsZVwGxVx9/oSVwwZY/0Bw54Cfw1O9fdjudveP9a57B5oGh6k='></script>
<script type='text/javascript'>
( 'fetch' in window ) || document.write( '<script src="https://s0.wp.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?m=1573572739h&#038;ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://s1.wp.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?m=1540208548h&#038;ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://s0.wp.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?m=1585663916h&#038;ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://s2.wp.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?m=1585663916h&#038;ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://s1.wp.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?m=1550600082h&#038;ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://s2.wp.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?m=1540208548h&#038;ver=2.0.2"></scr' + 'ipt>' );
</script>
<script src='https://www.googletagservices.com/tag/js/gpt.js?ver=1.0'></script>
<script>
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJytjFsKAjEMRTdkJj5owQ9xLWEatKVNC0l16uod/RhcgF8XLuccfDaYqxiLYenQcr9FUTzCIzZMiusACeVhcdYp6Q5/BLtz4S+DXclqoLEVMr0G5EoBeFnhwOGT296pRPlnLum1XA7O+/PJOb9Pb1+qT50='></script>
<script>
var OneSignalOptions = {"appId":"a8d17feb-85d9-47a3-bb52-ead9529a0b4c"};
</script>
<script type="text/javascript" src="//cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.0" async="async"></script>

				<script type="text/javascript">
					var OneSignal = window.OneSignal || [];
					setTimeout(
						function() {
							OneSignal.push(function() {
								OneSignal.init({"appId":"a8d17feb-85d9-47a3-bb52-ead9529a0b4c"})
							});
						},
						10000
					);
				</script>
			<script>
var wasabiFacebookReferral = "0";
</script>
<script>
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"1","headerHeight":"60","stickyAdSettings":"{\"66\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"90\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"250\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"}}"};
</script>
<script>
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/hoopshype.com\/wp-admin\/admin-ajax.php","nonce":"5016fa4d19","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/usathoopshype.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fhoopshype.com%2F2020%2F03%2F31%2Fnba-rumors-larry-hughes-lebron-james-michael-jordan-allen-iverson-wizards-cavaliers-bulls-washington-retired-basketball-academy-jayson-tatum%2F","blog_id":"85827622","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=85827622&v=wpcom&tz=-4&user_id=0&subd=usathoopshype","is_public":"1","reblog_enabled":""};
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJylku1OhTAMhm/IsRhFzx/jtZStgeK+XDsId+/OyRFINCbgr23N+z7t2uo5KQrGFYusR9YlWMxsYsbGU2hGftBVYWIQDKJlQF91EyVdGCRaWFRypafAeogx8bAkvGLWx2mCjx05VOzIogowHQHNwNDR7TtCjs9Za07qQSge6sLm51p4B/mcGbKQcYe6t5k9/JycL6sQbJ2sqqVVIQvmelNxwpzpugNr7CBBMpiPtdX7leK0lbOPj58F83I/mr3ql5QGciyMTo8oqWZS34E/yIW0QMf/WuQK6NCqmWyPUinv/u2xvTy/PF3a13b8AoAEOc8='></script>
<script src='https://www.zergnet.com/zerg.js?id=67304&#038;ver=1.0'></script>
<script src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?61" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'85827622','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'85827622','v':'wpcom','tz':'-4','user_id':'0','post':'1331028','subd':'usathoopshype'}]);
function st_vt() {var x=document.createElement("img");x.src="https://pixel.wp.com/g.gif?blog=85827622&v=wpcomvt&tz=-4&user_id=0&post=1331028&subd=usathoopshype&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcvN1dHVE8tU1Y5Tk5xJUNPdGUvNWlURCVDWHdySjhHMEF6azhRa2xxSC5tLj1TNUl6NDc0VSxyV0FZMElRYjEwR1hBMUVwJlpvYklvRS1IXWYwPXxvdis1XV1DJSVfaFQxTzh2XXRoLllMKyxKYlN+VyYwbl1SXW93X1RCVW9+TTlDM1glN3NNUj90WU5+bl1DPy56L0ZLb3V5dH5uZVVIY2hacW9zQzhuVEVdK1hkbkJbTUtkVFVUbTdZZFR2fkdhSCtRQ05VVnw1SFN4b0lndSVjUFVLYUl8R1RhdSxSNFFON1c9TWguRUZTflhndW1rYXFHSTVV'}]);
_stq.push([ 'clickTrackerInit', '85827622', '1331028' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
<!--
	generated 202 seconds ago
	generated in 0.423 seconds
	served from batcache in 0.003 seconds
	expires in 98 seconds
-->
