<!DOCTYPE html>
<!--[if IE 8]> <html lang="en" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://hoopshype.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="Raymond Felton on his 14-year NBA career, his free agency, how much longer he wants to play, his concerns about the &quot;bubble&quot; and more." />
<meta name="keywords" content="basketball, interview, nba, podcast, featured, interview, podcast, top" />
<title>Raymond Felton Q&amp;A: &#8216;I want to play, even if I have to go overseas&#8217; | HoopsHype</title>
<script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://fuzzybasketball.com/v2gowqTzhmRSoHingsdyT7hJbLj3e0evd8xJXkobyuVOqAKVqZLBte2XUwS5VNVDH",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(c,e,o,t,n){function r(o,t){(function n(){try{return 0<(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]}catch(o){}return!1})()&&(t=c[e].pubads())&&t.setTargeting("admiral-engaged","true")}(n=c[e]=c[e]||{}).cmd=n.cmd||[],typeof n.pubads===o?r():typeof n.cmd.unshift===o?n.cmd.unshift(r):n.cmd.push(r)})(window,"googletag","function");</script><meta name="google-site-verification" content="vjU_CGncz37FseIKJKx118S7FcYlPjyIGG9aFD-Mno8" />
<meta name="msvalidate.01" content="6C7AFE373C691E833D6444FFA7F6E8A2" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=hoopshype.com&amp;id=85827622&amp;t=1593792203&amp;back=https%3A%2F%2Fhoopshype.com%2F2020%2F07%2F03%2Fnba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//cdn.adsafeprotected.com' />
<link rel='dns-prefetch' href='//www.gannett-cdn.com' />
<link rel='dns-prefetch' href='//confiant-integrations.global.ssl.fastly.net' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//run.adrizer.com' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//usathoopshype.wordpress.com' />
<link rel='dns-prefetch' href='//wordpress.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="HoopsHype &raquo; Feed" href="https://hoopshype.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="HoopsHype &raquo; Comments Feed" href="https://hoopshype.com/comments/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s2.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1582709031h&ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJx9j9EKwjAMRX/IWiaI24P4LWsbZlzTliZl7u/tnAwU2UtIbnK4uXpKysYgEERTUcmXAQPrKdlIigk9zD/T0TIfqqQwWF8csK6CdsiijY92VB5N7vOsWWYPR8KwEX+MbMxQdUq9LBcEDnvwQPVsD5vQDSCr9dorgec+8g5hTMrArGolLKTkXr14/0Navqmxxk/WL2VFUYcoWGnemmVxo2tzbi9dd2ra5vECv+SIug==?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='galleria-theme-css'  href='//cdnjs.cloudflare.com/ajax/libs/galleria/1.4.2/themes/classic/galleria.classic.css?ver=1.4.2' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s2.wp.com/_static/??-eJylkMFOwzAMhl+IzOPARg+I696As5eYxFMSlzih6tuTVhqoAvXCLY7/3/79wTQaK7lSrlADJVL45BGaYhWHsxlj85wVgsioYR4JkrgWV5kjMR5jpDIbDVKqFUeAqlS3bSY9WNUH6Ms429hc9/cPcKiB+3o9JM5/S24fbZnf2DjGKH6j3EsecSqULd2bb6h45X9Y4bIwuHQGv4ak9g1qYueX+1Vsz2sS9dhmvRG0znHX6zuxKBYrS94U5j0ilz1roWuH059+pfZTLqbX9PL4NBxPw/n5ONy+AAJtvBw=?cssminify=yes' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='google-fonts-ubuntu-css'  href='https://fonts.googleapis.com/css?family=Ubuntu:300,400,500,700' media='all' />
<link rel='stylesheet' id='all-css-4-1' href='https://s0.wp.com/wp-content/themes/h4/global.css?m=1420737423h&cssminify=yes' type='text/css' media='all' />
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script>
var amznAcctId = ["3090"];
</script>
<script type='text/javascript'>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");window.bidSlots=window.bidSlots||[];window._mweb=0;apstag.init({pubID: amznAcctId[0], adServer: "googletag"});
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJx9jdEKwjAMRX/IrhOZuAfxW7I2zpY2rU26sb+3A30REQL34Z57otesHJlQLbL27Z4Vy/aOzvNB/wNUdHMBwS46+sAmkSDJzubEEpEZZvzRxjS5gKoylgaQtDf39M3JA5tBLy7ryiDJwqYCrAXJ4C6ZnLVYVARqjtLWt3g9DmN/7i/DafQv2JhSdw=='></script>
<script src='https://js-sec.indexww.com/ht/p/184031-126856402220676.js?ver=5.4.2'></script>
<script src='https://cdn.adsafeprotected.com/iasPET.1.js?ver=5.4.2'></script>
<script>
var iasDataHandler, __iasPET = __iasPET || {};
				__iasPET.queue = __iasPET.queue || [];
				__iasPETSlots = [];
				__iasPET.pubId = '922805';
				bidManager.addBidder( 'ias' );
			
</script>
<script>
var gciDataLayer = {"event-type":"pageview","page-market-name":"smg","page-blogname":"hoopshype","page-has-video":"","page-use-canonical":"1","content-ssts-section":"sports","content-ssts-subsection":"sports:hoopshype","content-ssts-topic":"sports:hoopshype","content-ssts-subtopic":"sports:hoopshype","page-experience-type":"desktop","content-type":"story pages","content-id":"1362966","content-headline":"Raymond Felton Q&A: 'I want to play, even if I have to go overseas'","content-date-published":"2020-07-03T11:02:04Z","content-byline":"Alex Kennedy","content-contributor-names":"Alex Kennedy","content-keywords":"Featured,Interview,Podcast,Top","content-title":"Raymond Felton Q&A: \u2018I want to play, even if I have to go overseas\u2019 | "};
</script>
<script>
			window.gciAnalyticsUAID = "SMG-TEALIUM-HOOPSHYPE";
			gciDataLayer["page-full-url"] = window.location.href;
			gciDataLayer["content-name"] = window.location.pathname;
			

			var stateManager = {
				getActivePageInfo: function() {
					return {
						byline: gciDataLayer["content-byline"] || "",
						contentHeadline: gciDataLayer["content-headline"] || "",
						contentId: gciDataLayer["content-id"] || "",
						taxonomykeywords: gciDataLayer["content-keywords"] || "",
						contentType: gciDataLayer["content-type"] || "",
						cst: gciDataLayer["cst"] || "",
						pageHasVideo: (gciDataLayer["page-has-video"]) ? gciDataLayer["page-has-video"].toLowerCase() : "",
						ssts: gciDataLayer["content-ssts-subtopic"] || "",
					}
				}
			}
			
</script>
<script src='https://www.gannett-cdn.com/dcjs/prod/main.js?ver=1'></script>
<script>
			document.addEventListener("gciAnalyticsReady", function () {
				window.gciAnalytics.view(gciDataLayer);
			} );
			
</script>
<script>
var lawrence_ad_marketplace_data = {"endpoint":"","suggest_endpoint":"https:\/\/usatoday_cps.cps.ampfeed.com\/suggestions?partner=usatoday_cps&sub1=nba&sub2=hoopshype.com&sub3=paidsuggest&v=1.1&callback=1593792203&out=json","sponsored_text":"Sponsored","ads_by_text":"Ads by adMarketplace"};
</script>
<script src='https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/modules/ad-marketplace/js/sponsored-search-results.js?m=1593541453h&#038;ver=1.0.0'></script>
<script async src='https://confiant-integrations.global.ssl.fastly.net/FvW3szAY_s729BZEa4_yfA6omyQ/gpt_and_prebid/config.js?ver=1.0.0'></script>
<script>
var usatoday_gallery_ajax_object = {"publisherGA":"UA-5226424-1","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-5226424-1","dfpid":"","pid":"SMG_HoopsHype","ads":{"poster":"\/7103\/SMG_HoopsHype\/300x250_1g\/sports\/basketball"},"tlmurl":"https:\/\/tags.tiqcdn.com\/utag\/gci\/hoopshype\/prod\/utag.js"};
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJylkNEOgjAMRX/I0QxCfDJ+S4WCHduYdAP5e0eiJr5BfGt6e07awhJUM/pIPkK8kyOBmQMkwTi2uKpgU89eAAOrHq2lifMIilAUMAKR0HJy72wtjJzgT2WSNuT+kiM166Lc47S4TOQb2ngZOCjLflDd2CRRHT+PKswjbcc4ZH8UtXz74BK5GXa95Gd9bqevIdeZv7qLrvW5qkutK/MCzHqjVw=='></script>
<script type="text/javascript" src="//run.adrizer.com/track.js?ver=5.4.2" id="ADRIZER_JS" data-domain="hoopshype.com"></script><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://usathoopshype.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://wp.me/p5O7Gu-5Izk' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fhoopshype.com%2F2020%2F07%2F03%2Fnba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fhoopshype.com%2F2020%2F07%2F03%2Fnba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Raymond Felton Q&amp;A: &#039;I want to play, even if I have to go overseas&#039;" />
<meta property="og:url" content="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/" />
<meta property="og:description" content="Raymond Felton on his 14-year NBA career, his free agency, how much longer he wants to play, his concerns about the &#8220;bubble&#8221; and more." />
<meta property="article:published_time" content="2020-07-03T15:02:04+00:00" />
<meta property="article:modified_time" content="2020-07-03T15:02:04+00:00" />
<meta property="og:site_name" content="HoopsHype" />
<meta property="og:image" content="https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=1024&amp;h=576&amp;crop=1" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@hoopshype" />
<meta name="twitter:text:title" content="Raymond Felton Q&amp;A: &#039;I want to play, even if I have to go overseas&#039;" />
<meta name="twitter:image" content="https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="http://facebook.com/hoopshype" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/8195f692d09575689011557b84764b61?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/8195f692d09575689011557b84764b61?s=32" sizes="16x16" />
<link rel="apple-touch-icon" href="https://secure.gravatar.com/blavatar/8195f692d09575689011557b84764b61?s=114" />
<link rel='openid.server' href='https://hoopshype.com/?openidserver=1' />
<link rel='openid.delegate' href='https://hoopshype.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://hoopshype.com/osd.xml" title="HoopsHype" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />

<meta name="gdpr" content="false" />

<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "NewsArticle"
		,"url": "https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/"
		,"headline": "Raymond Felton Q&amp;A: &#039;I want to play, even if I have to go overseas&#039;"
		,"thumbnailUrl": "https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=192&#038;h=150&#038;crop=1"
		,"datePublished": "2020-07-03T11:02:04Z"
		,"articleSection": "Basketball"
		,"creator": ["Alex Kennedy"]
		,"keywords": ["Featured","Interview","Podcast","Top"]
	}
</script>
<style type="text/css">
.articleBody a,
.article__pagination a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2 > a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block .shares,
.widget--box .text-block > h2,
.widget--box .text-block > h2 > a,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover,
.hero__secondary .hero__link:hover .hero__title,
.widget_usat_sidebar_top_posts_widget .reply-block .social-count,
.ad-marketplace-search-result-link {
	color: #eb1e00;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #eb1e00;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #eb1e00;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #eb1e00;
}

.nav__item:hover,
.nav__item--current,
#footer-info,
.ad-marketplace-sponsored-text {
	border-top-color: #eb1e00;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #eb1e00;
}

.newsletter-modal {
	border-top: solid 8px #eb1e00;
}

.article__back {
	border-color: #eb1e00;
}

.vertical-gallery--icon,
.smg-event--icon,
.vertical-gallery__overlay,
.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.daily-newsletter__button {
	background-color: #eb1e00;
}

.newsletter__button {
	background-image: linear-gradient(to bottom, rgba(0, 0, 0, 0), rgba(0, 0, 0, 0.12)),
		linear-gradient(#eb1e00, #eb1e00)
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #eb1e00;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #eb1e00;
	}
}

.smg-event__ctabutton {
	background-color: #eb1e00;
	box-shadow: 0 2px 0 0 #eb1e00;
}
</style>
<link rel="canonical" href="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/" />
		<style>
			.wpcom-related-posts ul li {
				list-style-type: none;
				display: inline-block;
			}
		</style>
				<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="HoopsHype" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://hoopshype.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/8195f692d09575689011557b84764b61?s=16" />
<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
	bidManager.timeout = 2500;
	bidManager.addBidder('a9');
		bidManager.addBidSlot({ slotID: "videoSlot", mediaType : 'video' } );

	</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>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</script>
      <meta name="onesignal" content="wordpress-plugin"/>
            <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://usathoopshype.wordpress.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'a8d17feb-85d9-47a3-bb52-ead9529a0b4c';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://s0.wp.com/wp-content/themes/vip/usatoday-plugins/onesignal/sdk_files/";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<link rel="amphtml" href="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/amp/">		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s2.wp.com/?custom-css=1&#038;csblog=5O7Gu&#038;cscache=6&#038;csrev=56" />
		
	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-1362966 single-format-standard customizer-styles-applied highlander-enabled highlander-light">

	
	<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_interstitial' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_interstitial'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_outstream' style='width:4px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_outstream'); });</script></div>
	
<div id="wrapper">

	
	<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>

	<div class="wrapper-holder">

		<div id="usat-newsletter-modal" class="widget newsletter-modal newsletter-modal--hidden widget--newsletter widget--box">
<div class="newsletter__wrapper modal" style="display: none;">

	<div class="newsletter__signup-wrapper">
					<div class="newsletter__logo">
				<img src="https://usathoopshype.files.wordpress.com/2017/01/logo-hoopshype-header.png"/>
			</div>
				<form novalidate="novalidate" class="newsletter_form" action="https://hoopshype.com/wp-json/usat/v1/gems/subscribe/">

			
			<label class="newsletter__input-label" for="newsletter-email-input">
				<span class="screen-reader-text">Email</span>
				<input
					type="email"
					class="newsletter__input"
					placeholder="you@domain.com"
					name="email"
					id="newsletter-email-input"
					required
				>
									<span class="newsletter__input-icon" aria-hidden="true">&#xE60B;</span>
							</label>

			<button
					type="submit"
					class="newsletter__button"
			>Sign up			</button>

			
							<div class="newsletter-close-alt">
					<a href="javascript:void(0);" class="newsletter__close-button">No, thanks</a>
				</div>
			
		</form>

					<div class="newsletter__sidetext">
				<h3>Are you in?</h3>
				<p>Sign up for the HoopsHype daily email newsletter for the top stories every day.</p>
			</div>
		
		<div class="newsletter__state newsletter__state--error">
			<h3 class="newsletter__header newsletter__header--error">An error has occured</h3>

			<p class="newsletter__text newsletter__text--error">
				Please re-enter your email address.			</p>
		</div>

	</div>

	<div class="newsletter__state newsletter__state--success">
		<h3 class="newsletter__header">Thanks for signing up!</h3>

		<p class="newsletter__text">
			You&#039;ll now receive the top HoopsHype stories each day directly in your inbox.		</p>

					<div class="newsletter-close-alt">
				<a href="javascript:void(0);" class="newsletter__close-button">Close</a>
			</div>
			</div>

			<div class="newsletter-phone-wrapper">
			<div class="daily-newsletter-phone-wrapper">
				<img src="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/modules/newsletter/images/phone.png" alt="newsletter" class="daily-newsletter-phone-image" />
				<div class="daily-newsletter-phone-wrapper-viewport">
					<div class="daily-newsletter__site-logo">
						<img src="https://usathoopshype.files.wordpress.com/2017/01/logo-hoopshype-header.png" class="daily-newsletter-logo-img"/>
					</div>
					<div class="daily-newsletter__site-top-stories">
						<img src="https://s2.wp.com/wp-content/themes/vip/usatoday-lawrence/modules/newsletter/images/topstories.png" alt="top-stories"/>
					</div>
					<div class="daily-newsletter__latest-image">
													<img src="https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=272&#038;h=250&#038;crop=1"/>
											</div>
				</div>
			</div>
		</div>
	</div>

	<div class="newsletter__close">
		<a href="javascript:void(0);" class="newsletter__close-button">&times;</a>
	</div>
</div><div
	class="branding "
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="https://hoopshype.com"
				title="HoopsHype"
				class="branding__logo-link "
			>
				<img
					src="https://usathoopshype.files.wordpress.com/2017/01/logo-hoopshype-header.png"
					alt="HoopsHype"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

	
	<span class="branding__search ui-front">
		<form method="get" class="branding__search-form" action="https://hoopshype.com" role="search">
			<input type="text" name="s" value="" placeholder="search HoopsHype" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="http://usatodaysports.com" target="_blank" title="USA TODAY Sports">
			<img src="https://usathoopshype.files.wordpress.com/2017/01/usat-logo-header.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-423204" class="nav__item nav__item--rumors nav__item--parent sub-menu-3columns sub-menu-columns-offset200"><a title="NBA Rumors" href="/rumors/">Rumors</a>
<ul class="sub-menu">
	<li id="menu-item-1023487" class="nav__item nav__item--atlanta-hawks"><a title="Atlanta Rumors" href="https://hoopshype.com/team/atlanta-hawks/">Atlanta Hawks</a></li>
	<li id="menu-item-1023488" class="nav__item nav__item--boston-celtics"><a title="Boston Rumors" href="https://hoopshype.com/team/boston-celtics/">Boston Celtics</a></li>
	<li id="menu-item-1023489" class="nav__item nav__item--brooklyn-nets"><a title="Brooklyn Rumors" href="https://hoopshype.com/team/brooklyn-nets/">Brooklyn Nets</a></li>
	<li id="menu-item-1023490" class="nav__item nav__item--charlotte-hornets"><a title="Charlotte Rumors" href="https://hoopshype.com/team/charlotte-hornets/">Charlotte Hornets</a></li>
	<li id="menu-item-1023491" class="nav__item nav__item--chicago-bulls"><a title="Chicago Rumors" href="https://hoopshype.com/team/chicago-bulls/">Chicago Bulls</a></li>
	<li id="menu-item-1023492" class="nav__item nav__item--cleveland-cavaliers"><a title="Cleveland Rumors" href="https://hoopshype.com/team/cleveland-cavaliers/">Cleveland Cavaliers</a></li>
	<li id="menu-item-1023493" class="nav__item nav__item--dallas-mavericks"><a title="Dallas Rumors" href="https://hoopshype.com/team/dallas-mavericks/">Dallas Mavericks</a></li>
	<li id="menu-item-1023494" class="nav__item nav__item--denver-nuggets"><a title="Denver Rumors" href="https://hoopshype.com/team/denver-nuggets/">Denver Nuggets</a></li>
	<li id="menu-item-1023495" class="nav__item nav__item--detroit-pistons"><a title="Detroit Rumors" href="https://hoopshype.com/team/detroit-pistons/">Detroit Pistons</a></li>
	<li id="menu-item-1023496" class="nav__item nav__item--golden-state-warriors"><a title="Golden State Rumors" href="https://hoopshype.com/team/golden-state-warriors/">Golden State Warriors</a></li>
	<li id="menu-item-1023497" class="nav__item nav__item--houston-rockets"><a title="Houston Rumors" href="https://hoopshype.com/team/houston-rockets/">Houston Rockets</a></li>
	<li id="menu-item-1023498" class="nav__item nav__item--indiana-pacers"><a title="Indiana Rumors" href="https://hoopshype.com/team/indiana-pacers/">Indiana Pacers</a></li>
	<li id="menu-item-1023499" class="nav__item nav__item--los-angeles-clippers"><a title="LA Clippers Rumors" href="https://hoopshype.com/team/los-angeles-clippers/">Los Angeles Clippers</a></li>
	<li id="menu-item-1023500" class="nav__item nav__item--los-angeles-lakers"><a title="LA Lakers Rumors" href="https://hoopshype.com/team/los-angeles-lakers/">Los Angeles Lakers</a></li>
	<li id="menu-item-1023501" class="nav__item nav__item--memphis-grizzlies"><a title="Memphis Rumors" href="https://hoopshype.com/team/memphis-grizzlies/">Memphis Grizzlies</a></li>
	<li id="menu-item-1023502" class="nav__item nav__item--miami-heat"><a title="Miami Rumors" href="https://hoopshype.com/team/miami-heat/">Miami Heat</a></li>
	<li id="menu-item-1023503" class="nav__item nav__item--milwaukee-bucks"><a title="Milwaukee Rumors" href="https://hoopshype.com/team/milwaukee-bucks/">Milwaukee Bucks</a></li>
	<li id="menu-item-1023504" class="nav__item nav__item--minnesota-timberwolves"><a title="Minnesota Rumors" href="https://hoopshype.com/team/minnesota-timberwolves/">Minnesota Timberwolves</a></li>
	<li id="menu-item-1023505" class="nav__item nav__item--new-orleans-pelicans"><a title="New Orleans Rumors" href="https://hoopshype.com/team/new-orleans-pelicans/">New Orleans Pelicans</a></li>
	<li id="menu-item-1023506" class="nav__item nav__item--new-york-knicks"><a title="New York Rumors" href="https://hoopshype.com/team/new-york-knicks/">New York Knicks</a></li>
	<li id="menu-item-1023507" class="nav__item nav__item--oklahoma-city-thunder"><a title="Oklahoma City Rumors" href="https://hoopshype.com/team/oklahoma-city-thunder/">Oklahoma City Thunder</a></li>
	<li id="menu-item-1023508" class="nav__item nav__item--orlando-magic"><a title="Orlando Rumors" href="https://hoopshype.com/team/orlando-magic/">Orlando Magic</a></li>
	<li id="menu-item-1023509" class="nav__item nav__item--philadelphia-76ers"><a title="Philadelphia Rumors" href="https://hoopshype.com/team/philadelphia-76ers/">Philadelphia 76ers</a></li>
	<li id="menu-item-1023510" class="nav__item nav__item--phoenix-suns"><a title="Phoenix Rumors" href="https://hoopshype.com/team/phoenix-suns/">Phoenix Suns</a></li>
	<li id="menu-item-1023511" class="nav__item nav__item--portland-trail-blazers"><a title="Portland Rumors" href="https://hoopshype.com/team/portland-trail-blazers/">Portland Trail Blazers</a></li>
	<li id="menu-item-1023512" class="nav__item nav__item--sacramento-kings"><a title="Sacramento Rumors" href="https://hoopshype.com/team/sacramento-kings/">Sacramento Kings</a></li>
	<li id="menu-item-1023513" class="nav__item nav__item--san-antonio-spurs"><a title="San Antonio Rumors" href="https://hoopshype.com/team/san-antonio-spurs/">San Antonio Spurs</a></li>
	<li id="menu-item-1023514" class="nav__item nav__item--toronto-raptors"><a title="Toronto Rumors" href="https://hoopshype.com/team/toronto-raptors/">Toronto Raptors</a></li>
	<li id="menu-item-1023515" class="nav__item nav__item--utah-jazz"><a title="Utah Rumors" href="https://hoopshype.com/team/utah-jazz/">Utah Jazz</a></li>
	<li id="menu-item-1023516" class="nav__item nav__item--washington-wizards"><a title="Washington Rumors" href="https://hoopshype.com/team/washington-wizards/">Washington Wizards</a></li>
</ul>
</li>
<li id="menu-item-458969" class="nav__item nav__item--salaries nav__item--parent sub-menu-minwidth140"><a title="NBA Salaries" href="/salaries/">Salaries</a>
<ul class="sub-menu">
	<li id="menu-item-16" class="nav__item nav__item--players"><a title="NBA Player Salaries" href="https://hoopshype.com/salaries/players/">Players</a></li>
	<li id="menu-item-12" class="nav__item nav__item--teams"><a title="NBA Salaries" href="https://hoopshype.com/salaries/">Teams</a></li>
	<li id="menu-item-1328720" class="nav__item nav__item--salary-cap"><a href="https://hoopshype.com/2020/03/16/los-angeles-lakers-their-salary-cap-situation-right-now/">Salary cap</a></li>
	<li id="menu-item-1278372" class="nav__item nav__item--history"><a href="https://hoopshype.com/salaries/2000-2001/">History</a></li>
</ul>
</li>
<li id="menu-item-1022515" class="nav__item nav__item--twitter nav__item--parent sub-menu-minwidth140"><a title="NBA Media Twitters" href="/social/">Twitter</a>
<ul class="sub-menu">
	<li id="menu-item-18" class="nav__item nav__item--media"><a title="NBA Media Twitters" href="/social/">Media</a></li>
	<li id="menu-item-999057" class="nav__item nav__item--players"><a title="NBA Players on Twitter" href="/social/tweets/">Players</a></li>
</ul>
</li>
<li id="menu-item-423198" class="nav__item nav__item--features nav__item--parent sub-menu-3columns sub-menu-columns-offset200"><a href="#">Features</a>
<ul class="sub-menu">
	<li id="menu-item-1000630" class="nav__item nav__item--agents"><a title="NBA Agents" href="/reps/">Agents</a></li>
	<li id="menu-item-1278971" class="nav__item nav__item--awards"><a href="https://hoopshype.com/2019/08/08/nba-awards-all-the-winners-in-league-history/">Awards</a></li>
	<li id="menu-item-1231160" class="nav__item nav__item--birthdays"><a href="https://hoopshype.com/2019/01/13/which-nba-player-was-born-the-same-day-as-you-find-out-here/">Birthdays</a></li>
	<li id="menu-item-1006555" class="nav__item nav__item--birthplaces"><a title="Birthplaces" href="/2019/08/20/nba-players-birthplaces/">Birthplaces</a></li>
	<li id="menu-item-1271888" class="nav__item nav__item--depth-charts"><a href="https://hoopshype.com/2019/07/10/nba-depth-charts/">Depth Charts</a></li>
	<li id="menu-item-11" class="nav__item nav__item--draft"><a title="NBA Draft" href="/2018/01/09/nba-mock-draft-2018/">Draft</a></li>
	<li id="menu-item-17" class="nav__item nav__item--free-agency-2019"><a title="NBA Free Agency 2019" href="/2018/08/09/nba-free-agency-2019-the-top-players">Free Agency 2019</a></li>
	<li id="menu-item-1118240" class="nav__item nav__item--free-agency-2020"><a href="https://hoopshype.com/2019/07/18/nba-free-agency-2020-the-top-players/">Free Agency 2020</a></li>
	<li id="menu-item-1207357" class="nav__item nav__item--hoopshype-explains"><a href="https://hoopshype.com/category/hoopshype-explains/">HoopsHype Explains</a></li>
	<li id="menu-item-1000631" class="nav__item nav__item--hoopshype-podcasts"><a href="/category/podcast/">HoopsHype Podcasts</a></li>
	<li id="menu-item-1006554" class="nav__item nav__item--instagram"><a title="NBA Players on Instagram" href="/social/gallery/">Instagram</a></li>
	<li id="menu-item-1265345" class="nav__item nav__item--key-contract-dates"><a href="https://hoopshype.com/2019/06/17/nba-contracts-key-dates-deadlines-options-trade-eligibility/">Key Contract Dates</a></li>
	<li id="menu-item-1000632" class="nav__item nav__item--longform"><a title="Longform" href="https://hoopshype.com/category/longform/">Longform</a></li>
	<li id="menu-item-1278805" class="nav__item nav__item--nba-2k-ratings"><a href="https://hoopshype.com/nba2k/">NBA 2K Ratings</a></li>
	<li id="menu-item-1358034" class="nav__item nav__item--nba-player-follows"><a href="https://hoopshype.com/2020/06/11/nba-player-twitter-follows/">NBA Player Follows</a></li>
	<li id="menu-item-1241341" class="nav__item nav__item--nicknames"><a href="https://hoopshype.com/2019/02/24/all-the-nicknames-in-nba-history/">Nicknames</a></li>
	<li id="menu-item-423200" class="nav__item nav__item--players"><a title="NBA Players" href="/players/">Players</a></li>
	<li id="menu-item-1119544" class="nav__item nav__item--re-drafts"><a href="https://hoopshype.com/tag/re-drafts/">Re-Drafts</a></li>
	<li id="menu-item-1296517" class="nav__item nav__item--roster-details"><a href="https://hoopshype.com/2019/11/07/all-nba-rosters-in-one-page-with-some-extra-details/">Roster Details</a></li>
	<li id="menu-item-1160065" class="nav__item nav__item--top-rumors"><a href="https://hoopshype.com/category/top-rumors/">Top Rumors</a></li>
	<li id="menu-item-10" class="nav__item nav__item--transactions"><a title="NBA Transactions" href="/transactions.htm">Transactions</a></li>
</ul>
</li>
<li id="menu-item-1356950" class="nav__item nav__item--%f0%9f%91%89follows"><a href="https://hoopshype.com/2020/06/11/nba-player-twitter-follows/">👉Follows</a></li>
		</ul>
		<ul class="nav__social ">
			<li class="nav__item nav__item--social nav__item--facebook">
			<a href="http://facebook.com/hoopshype" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--twitter">
			<a href="https://twitter.com/hoopshype" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--podcast">
			<a href="https://hoopshype.com/category/podcast/" class="nav__item-link"></a>
		</li>
	</ul>
	</nav>
</header>

		
		
		<div id="main" class="site-main ">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-1362966" class="post-1362966 post type-post status-publish format-standard has-post-thumbnail hentry category-basketball category-interview category-nba category-podcast tag-featured tag-interview tag-podcast tag-top player-amare-stoudemire player-carmelo-anthony player-dirk-nowitzki player-juwan-howard player-raymond-felton player-stephen-jackson team-charlotte-hornets team-new-york-knicks team-oklahoma-city-thunder" itemscope
				itemtype="http://schema.org/NewsArticle">

				<link itemprop="mainEntityofPage" href="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/" />
<div itemprop="publisher" itemscope itemtype="https://www.schema.org/Organization">
	<div itemprop="logo" itemscope itemtype="https://www.schema.org/ImageObject">
		<link src="https://usathoopshype.files.wordpress.com/2017/01/logo-hoopshype-header.png"/>
		<meta itemprop="url" content="https://usathoopshype.files.wordpress.com/2017/01/logo-hoopshype-header.png">
	</div>
	<meta itemprop="name" content="HoopsHype">
</div>
<div class="article__title ">
	<h1 class="article__headline">Raymond Felton Q&amp;A: 'I want to play, even if I have to go overseas'</h1>

			<span itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
			<img width="1000" height="600" src="https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=100&amp;h=600&amp;crop=1&amp;h=60" class="article__image wp-post-image lazy-load" alt data-attachment-id="1362968" data-permalink="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/oklahoma-city-thunder-v-new-york-knicks-5/" data-orig-file="https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg" data-orig-size="1279,906" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X Mark II&quot;,&quot;caption&quot;:&quot;NEW YORK, NEW YORK - JANUARY 21:   Former New York Knicks guard Raymond Felton #2 of the Oklahoma City Thunder looks on from the bench in the second half at Madison Square Garden on January 21, 2019 in New York City.NOTE TO USER: User expressly acknowledges and agrees that, by downloading and or using this photograph, User is consenting to the terms and conditions of the Getty Images License Agreement.  (Photo by Elsa\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;1548082529&quot;,&quot;copyright&quot;:&quot;2019 Getty Images&quot;,&quot;focal_length&quot;:&quot;85&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.0008&quot;,&quot;title&quot;:&quot;Oklahoma City Thunder v New York Knicks&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Oklahoma City Thunder v New York Knicks" data-image-description data-medium-file="https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=1000" data-lazy-src="https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=1000&amp;h=600&amp;crop=1" data-lazy-srcset="https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=1000&amp;h=600&amp;crop=1 1000w, https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=190&amp;h=114&amp;crop=1 190w, https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=300&amp;h=180&amp;crop=1 300w, https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=768&amp;h=461&amp;crop=1 768w, https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=1024&amp;h=614&amp;crop=1 1024w" data-lazy-sizes="(max-width: 1000px) 100vw, 1000px"><noscript><img width="1000" height="600" src="https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=1000&amp;h=600&amp;crop=1" class="article__image wp-post-image" alt="" srcset="https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=1000&amp;h=600&amp;crop=1 1000w, https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=190&amp;h=114&amp;crop=1 190w, https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=300&amp;h=180&amp;crop=1 300w, https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=768&amp;h=461&amp;crop=1 768w, https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=1024&amp;h=614&amp;crop=1 1024w" sizes="(max-width: 1000px) 100vw, 1000px" data-attachment-id="1362968" data-permalink="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/oklahoma-city-thunder-v-new-york-knicks-5/" data-orig-file="https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg" data-orig-size="1279,906" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X Mark II&quot;,&quot;caption&quot;:&quot;NEW YORK, NEW YORK - JANUARY 21:   Former New York Knicks guard Raymond Felton #2 of the Oklahoma City Thunder looks on from the bench in the second half at Madison Square Garden on January 21, 2019 in New York City.NOTE TO USER: User expressly acknowledges and agrees that, by downloading and or using this photograph, User is consenting to the terms and conditions of the Getty Images License Agreement.  (Photo by Elsa\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;1548082529&quot;,&quot;copyright&quot;:&quot;2019 Getty Images&quot;,&quot;focal_length&quot;:&quot;85&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.0008&quot;,&quot;title&quot;:&quot;Oklahoma City Thunder v New York Knicks&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Oklahoma City Thunder v New York Knicks" data-image-description="" data-medium-file="https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=1000" /></noscript>			<meta itemprop="url" content="https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg">
		</span>
		<cite class="article__source">Photo by Elsa/Getty Images</cite>
		<div class="article__gradient"></div>
	</div>
<h1 class="article__headline article__headline--mobile">Raymond Felton Q&amp;A: 'I want to play, even if I have to go overseas'</h1>

				<header class="entry-header  ">

					
<h2 class="cat-show">
	<a href="https://hoopshype.com/category/podcast/" class="" itemprop="articleSection">Podcast</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">Raymond Felton Q&amp;A: 'I want to play, even if I have to go overseas'</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p>

	
		<span class="post-date updated">July 3, 2020</span>-
		by <span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://hoopshype.com/author/alexkennedynba/" title="Posts by Alex Kennedy" class="author url fn" rel="author">Alex Kennedy</a></span></span> 
	
	</p>
					</div>

					<div id='acm-ad-tag-lawrence_dfp_mobile_sponsor_by_logo' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_mobile_sponsor_by_logo'); });</script></div>
				</header>

				
				
				
				
				<div id="content-container">
					<div class="entry-content normal-format">

						<div class="article-container">
						<div class="story-share-buttons sms">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">8</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/"
		data-short-url=""
		data-track="hoopshypestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/"
		data-short-url=""
		data-track="hoopshypestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="hoopshype"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/"
		data-short-url=""
		data-track="hoopshypestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/"
		data-short-url=""
		data-track="hoopshypestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/"
		data-short-url=""
		data-track="hoopshypestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/"
			data-short-url=""
			data-track="hoopshypestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p>
		By 		<span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://hoopshype.com/author/alexkennedynba/" title="Posts by Alex Kennedy" class="author url fn" rel="author">Alex Kennedy</a></span></span> |
		<span itemprop="datePublished" content="2020-07-03T11:02:04-04:00">
			July 3, 2020		</span>
		<span class="article__author__widgets">
								</span>
	</p>

	</div>


						
						<div class="articleBody" itemprop="articleBody">		<form id="wpcom-iframe-form-9a544df855d19567fe94b2e801715f7b-5eff56cbe330f" target="wpcom-iframe-9a544df855d19567fe94b2e801715f7b-5eff56cbe330f" method="post" action="//wpcomwidgets.com/?wpcom_origin=https%3A%2F%2Fusathoopshype.wordpress.com" style="display: none">
							<input type="hidden" name="width" value="100%" />
							<input type="hidden" name="height" value="180" />
							<input type="hidden" name="frameborder" value="0" />
							<input type="hidden" name="style" value="" />
							<input type="hidden" name="class" value="" />
							<input type="hidden" name="scrolling" value="no" />
							<input type="hidden" name="webkitallowfullscreen" value="" />
							<input type="hidden" name="mozallowfullscreen" value="" />
							<input type="hidden" name="allowfullscreen" value="" />
							<input type="hidden" name="resize" value="0" />
							<input type="hidden" name="replace_attributes" value="1" />
							<input type="hidden" name="name" value="" />
							<input type="hidden" name="fallback" value="&lt;p class=&quot;protected-embed-fallback&quot;&gt;This embed is invalid&lt;/p&gt;" />
							<input type="hidden" name="_data" value="PGlmcmFtZSB0aXRsZT0iUmF5bW9uZCBGZWx0b24gb24gSGlzIEZyZWUgQWdlbmN5LCBIaXMgMTQtWWVhciBOQkEgQ2FyZWVyLCBDb25jZXJucyBBYm91dCB0aGUgQnViYmxlIGFuZCBNb3JlIChFcC4gMjI0KSIgc3JjPSJodHRwczovL29tbnkuZm0vc2hvd3MvdGhlLWhvb3BzaHlwZS1wb2RjYXN0LXdpdGgtYWxleC1rZW5uZWR5L3JheW1vbmQtZmVsdG9uLW9uLWhpcy1mcmVlLWFnZW5jeS1oaXMtMTQteWVhci1uYmEvZW1iZWQiIHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjE4MCIgZnJhbWVib3JkZXI9IjAiIGNsYXNzPSIiIHNjcm9sbGluZz0ibm8iIGFsbG93ZnVsbHNjcmVlbj0iIiByZXNpemU9IjAiIHJlcGxhY2VfYXR0cmlidXRlcz0iMSIgbmFtZT0iIj48L2lmcmFtZT4=,415f7f6d90985809ebe8f994445cf85bbc4dd78e" />
							<input type="hidden" name="_tag" value="protected-iframe" />
							<input type="hidden" name="_hash" value="9a544df855d19567fe94b2e801715f7b" />
					</form>
		
				<iframe
						name="wpcom-iframe-9a544df855d19567fe94b2e801715f7b-5eff56cbe330f"
			id="wpcom-iframe-9a544df855d19567fe94b2e801715f7b-5eff56cbe330f"
			frameborder="0"
			scrolling="no"
			width="100%" 			height="180" 			webkitallowfullscreen mozallowfullscreen allowfullscreen			class="wpcom-protected-iframe "
		></iframe>
		
		<script type="text/javascript">
		( function() {
			var func = function() {
				var iframe_form = document.getElementById('wpcom-iframe-form-9a544df855d19567fe94b2e801715f7b-5eff56cbe330f');
				var iframe = document.getElementById('wpcom-iframe-9a544df855d19567fe94b2e801715f7b-5eff56cbe330f');
				if ( iframe_form && iframe ) {
					iframe_form.submit();
					iframe.onload = function() {
						iframe.contentWindow.postMessage( {
							'msg_type': 'poll_size',
							'frame_id': 'wpcom-iframe-9a544df855d19567fe94b2e801715f7b-5eff56cbe330f'
						}, window.location.protocol + '//wpcomwidgets.com' );
					}
				}

				// Autosize iframe
				var funcSizeResponse = function( e ) {
					var origin = document.createElement( 'a' );
					origin.href = e.origin;

					// Verify message origin
					if ( 'wpcomwidgets.com' !== origin.host )
						return;

					// Verify message is in a format we expect
					if ( 'object' !== typeof e.data || undefined === e.data.msg_type )
						return;

					switch ( e.data.msg_type ) {
						case 'poll_size:response':
							var iframe = document.getElementById( e.data._request.frame_id );

							if ( iframe && '' === iframe.width )
								iframe.width = '100%';
							if ( iframe && '' === iframe.height )
								iframe.height = parseInt( e.data.height );

							return;
						default:
							return;
					}
				}

				if ( 'function' === typeof window.addEventListener ) {
					window.addEventListener( 'message', funcSizeResponse, false );
				} else if ( 'function' === typeof window.attachEvent ) {
					window.attachEvent( 'onmessage', funcSizeResponse );
				}
			}
			if (document.readyState === 'complete') { func.apply(); /* compat for infinite scroll */ }
			else if ( document.addEventListener ) { document.addEventListener( 'readystatechange', function(){ 
if (document.readyState === 'complete') { 
func.apply(); 
} 
},  false ); }
			else if ( document.attachEvent ) { document.attachEvent( 'onreadystatechange', func ); }
		} )();
		</script>
		
<p><span style="font-weight:400;">This week, 14-year NBA veteran </span><b>Raymond Felton </b><span style="font-weight:400;">was a guest on The HoopsHype Podcast. He discussed his NBA career, his free agency, how much longer he wants to play, his concerns about the NBA resuming the season, whether he’s open to signing overseas and more. Listen to the interview above or read a transcribed version of the Q&amp;A below.</span></p>
<p><b>You won an NCAA championship at UNC alongside Rashad McCants, Sean May and Marvin Williams among others. That team was so much fun to watch and then all four of you were lottery picks in the 2005 NBA Draft. What was it like to be part of that championship team?</b></p>
<p><b>Raymond Felton: </b><span style="font-weight:400;">Ah, man, it was fun. We went through a lot together. Our freshman year, we went to the NIT and </span><b>Sean May</b><span style="font-weight:400;"> got hurt – he broke his foot. We went from making the NIT to winning a championship. It was a journey for us. It’s something that we worked really hard for and we just continued to get better each and every year. In our junior year, we really put it all together along with </span><b>Jawad Williams</b><span style="font-weight:400;">,</span><b> Jackie Manuel</b><span style="font-weight:400;">, </span><b>Melvin Scott</b><span style="font-weight:400;"> and others. Those guys were there as well and they played a big, vital part in us winning that title.</span></p>
<p><b>You spent three years at UNC. Now, many players enter the NBA after just one year in college. Do you think some players would benefit from staying in college longer?</b></p>
<p><b>RF: </b><span style="font-weight:400;">Yes, I think it gives you time to mature and gives you time to learn the game a lot more than coming straight out of high school and going into the big leagues. I don’t think a year [is enough]. I think two years is a good amount of time for a kid to develop and learn how to be on his own and be a professional and be his own person. And, at the same time, they’re continuing to get better and learning the game. You learn so much in college and those basics will help you when you get to the league.</span></p>
<p><b>Of all the teams that you’ve played on, which team was the closest or had the best chemistry?</b></p>
<p><b>RF: </b><span style="font-weight:400;">I played on a lot of teams that had great chemistry. That [2012-13] Knicks team that won about 55 games and was the No. 2 seed in the East, that was a </span><i><span style="font-weight:400;">great </span></i><span style="font-weight:400;">chemistry team. We were all tight-knit and close. My first time around with the Knicks [in 2010-11] when we were young – with </span><b>Amare Stoudemire</b><span style="font-weight:400;">, </span><b>Danilo Gallinari</b><span style="font-weight:400;">, </span><b>Wilson Chandler</b><span style="font-weight:400;">, </span><b>Timofey Mozgov</b><span style="font-weight:400;">, </span><b>Landry Fields</b><span style="font-weight:400;">, </span><b>Toney Douglas – </b><span style="font-weight:400;">even with that team, we were really close too. The [2009-10] Bobcats team that I was on in my fifth season when we finally got over the hump and made the playoffs, we were really close and tight. I had a really good friend, who was almost like a big brother to me, in </span><b>Stephen Jackson</b><span style="font-weight:400;"> on that team. Me and </span><b>Gerald Wallace</b><span style="font-weight:400;"> are really close. </span><b>Tyson Chandler </b><span style="font-weight:400;">was on that team and we are really close. </span><b>DJ Augustin</b><span style="font-weight:400;">, who’s still my little young fella to this day… There were a lot of guys. I could name a lot of teams that I’ve played for. In Dallas, I was really close with </span><b>Monta Ellis</b><span style="font-weight:400;">, </span><b>Dirk Nowitzki</b><span style="font-weight:400;">,</span><b> JJ Barea</b><span style="font-weight:400;">,</span><b> Devin Harris</b><span style="font-weight:400;">… The list could go on and on. I was close with a lot of guys.</span></p>
<p><b>You’ve played in big markets and small markets throughout your career. What are the biggest differences when you’re in a big market versus a small market?</b></p>
<p><b>RF: </b><span style="font-weight:400;">To me, it didn’t really matter. It was all about the team to me. I’m all about winning. Thus far, I’ve yet to win an NBA championship, but I’ve won a championship at every other level I’ve played at. It was all about going to a good team; I couldn’t care less if it was in a smaller market or if it was New York or Los Angeles. It doesn’t really matter to me. I just want to play on a good team that’s going to win&#8230; Every city that I’ve played in embraced me with love.</span></p>
<div id="attachment_1362963" class="wp-caption alignleft"><img aria-describedby="caption-attachment-1362963" data-attachment-id="1362963" data-permalink="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/nba-oklahoma-city-thunder-at-dallas-mavericks-6/" data-orig-file="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg" data-orig-size="1281,898" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;Jerome Miron-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;NIKON D500&quot;,&quot;caption&quot;:&quot;Dec 30, 2018; Dallas, TX, USA; Oklahoma City Thunder guard Raymond Felton (2) warms up before a game against the Dallas Mavericks at American Airlines Center. Mandatory Credit: Jerome Miron-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1546211043&quot;,&quot;copyright&quot;:&quot;Jerome Miron&quot;,&quot;focal_length&quot;:&quot;100&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.0008&quot;,&quot;title&quot;:&quot;NBA: Oklahoma City Thunder at Dallas Mavericks&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NBA: Oklahoma City Thunder at Dallas Mavericks" data-image-description data-medium-file="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg?w=1000" class="size-full wp-image-1362963 lazy-load" src="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg?w=100&amp;h=70#038;h=701" alt width="1000" height="701" data-lazy-src="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg?w=1000&#038;h=701" srcset="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg?w=1000&amp;h=701 1000w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg?w=190&amp;h=133 190w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg?w=300&amp;h=210 300w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg?w=768&amp;h=538 768w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg?w=1024&amp;h=718 1024w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg 1281w" sizes="(max-width: 1000px) 100vw, 1000px"><noscript><img aria-describedby="caption-attachment-1362963" data-attachment-id="1362963" data-permalink="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/nba-oklahoma-city-thunder-at-dallas-mavericks-6/" data-orig-file="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg" data-orig-size="1281,898" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;Jerome Miron-USA TODAY Sports&quot;,&quot;camera&quot;:&quot;NIKON D500&quot;,&quot;caption&quot;:&quot;Dec 30, 2018; Dallas, TX, USA; Oklahoma City Thunder guard Raymond Felton (2) warms up before a game against the Dallas Mavericks at American Airlines Center. Mandatory Credit: Jerome Miron-USA TODAY Sports&quot;,&quot;created_timestamp&quot;:&quot;1546211043&quot;,&quot;copyright&quot;:&quot;Jerome Miron&quot;,&quot;focal_length&quot;:&quot;100&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.0008&quot;,&quot;title&quot;:&quot;NBA: Oklahoma City Thunder at Dallas Mavericks&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NBA: Oklahoma City Thunder at Dallas Mavericks" data-image-description="" data-medium-file="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg?w=1000" class="size-full wp-image-1362963" src="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg?w=1000&#038;h=701" alt="" width="1000" height="701" srcset="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg?w=1000&amp;h=701 1000w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg?w=190&amp;h=133 190w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg?w=300&amp;h=210 300w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg?w=768&amp;h=538 768w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg?w=1024&amp;h=718 1024w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba3.jpg 1281w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript><p id="caption-attachment-1362963" class="wp-caption-text">(Jerome Miron-USA TODAY Sports)</p></div>
<p><b>You’ve played in the NBA for 14 years, which is the kind of longevity that every player wants to have. What advice would you give to younger players who want to have a long, successful career in the NBA?</b></p>
<p><b>RF: </b><span style="font-weight:400;">You just have to continue to work on your game and continue to get better, and learn how to adapt. Your style of play may not fit the team that you’re with, but you gotta find a way to get on the court and you gotta find a way to </span><i><span style="font-weight:400;">stay </span></i><span style="font-weight:400;">on the court. You have to figure those things out. I think those are the big things for the young guys, just learning how to adapt and learning how to play in different systems. Every system isn’t going to be a fit for you, but you still have to find a way to convince your coach to put you on the court and give you playing time.</span></p>
<p><b>How much has the game evolved from the start of your NBA career in 2005 to now?</b></p>
<p><b>RF: </b><span style="font-weight:400;">It’s a </span><i><span style="font-weight:400;">big </span></i><span style="font-weight:400;">difference, man. When I came into the league, there was a need for natural point guards – pass-first point guards. Now, point guards are scoring almost 30 points per game. You’ve got guys like <strong>Russell Westbrook</strong>, <strong>Stephen Curry</strong>, <strong>Kyrie Irving</strong>, <strong>Kemba Walker</strong> and these guys who can average 25-plus points per game. Now, point guards are scorers rather than being passers with 15 assists, 16 assists. Those guys still do that sometimes, but they’re also scoring at a high volume.</span></p>
<p><b>Yeah, there are so many dominant point guards around the league. If you’re an opposing point guard, you’re matched up against a star in most games and you don’t get many nights off. What do you think of the point guard play in today’s NBA?</b></p>
<p><b>RF: </b><span style="font-weight:400;">Oh man, it’s amazing. To me, when they talk about the toughest position, I think it’s the point guard position because you have to bring it every night. From the time I stepped into the league and still to this day, it’s one of the toughest positions. You have to bring it every night because there’s always somebody on the other team who’s fast, quick, can score and can do a lot of different things. To me, the point guard position is probably one of the toughest [in sports].</span></p>
<p><b>There was a rumor that surfaced a few months ago that you had signed with a second-division team in the Czech Republic, but it wasn&#8217;t true. What was your reaction when you saw that report?</b></p>
<p><b>RF: </b><span style="font-weight:400;">Well, I was just upset. I had a conversation with a good friend of mine who’s over there training and who’s been coaching a bit overseas. We had a conversation and he asked me about coming over there. I even spoke to the general manager. But I did my research and had some people look into the team and I realized that it’s a small-division team, so I didn’t go. I never signed any deal. I never had my agent call them – they never even had a conversation. So, when that came out, I was just upset. It just felt like it wasn’t an appropriate thing for them to do, but it is what it is. I’m glad I had an opportunity to clear that up. I never had a deal over there, I never went over there and I never had any plans to go over there. It was just simply having a friend who’s over there within that team and having a conversation; that’s all it was.</span></p>
<p><b>You’re still a free agent right now and you are eligible to be a replacement player when the NBA season resumes in Orlando. Have you had any conversations with teams about the possibility of getting signed as a replacement player?</b></p>
<p><b>RF: </b><span style="font-weight:400;">I think my agent has, man. But, to me, I’m up in the air about that whole situation because we don’t have this coronavirus thing under control. I have a family, I have kids, and I have other things to worry about. Do I want to play basketball? Yes, I love basketball. I’ve been out for a whole year, so I definitely want to play and I definitely want to be on somebody’s roster. I want to help out, being that leader in the locker room and on the court and playing my role. But it’s kind of hard when six more guys just had a positive test, so we’re talking about more and more guys every week who are coming up positive when tested. Now, you’re going to put everyone together all in one place and play these games? To me, man, it’s just not safe. </span><span style="font-weight:400;">I ain’t no expert on this. But, in my opinion, it’s not safe. I’m just not 100-percent comfortable with playing right now because it’s not okay. The cases are steady going up. And they’re going to Florida, which is one of the worst places to go at this moment! I don’t know, man. It’s kind of tough for me. I do want to play. I do love to play basketball, and I’m ready to play and want to play. But it’s a tough situation right now, man. It really is.</span></p>
<p><b>If you decide against playing in Orlando, would you then focus on signing with a team next season (when things are hopefully getting back to normal a bit)?</b></p>
<p><b>RF: </b><span style="font-weight:400;">Oh, no question… It’d be like I was away for just one season and I would definitely be looking to try to get with somebody next season. I just want to play. I’m not retiring. I want to play. Even if I have to go across that water to play, I will. I just want to play basketball. I’m not ready to let the game go yet.</span></p>
<p><b>It seems like NBA teams are going after younger players rather than signing veterans who can make an impact on the court and off the court (as a leader and mentor). Has that been frustrating?</b></p>
<p><b>RF: </b><span style="font-weight:400;">I think it’s very frustrating because I think it’s what these young guys need. The player-development coaches are great and it’s something that the kids need, but you also need a veteran. When I came into the league, I had a bunch of veterans who helped me out – <strong>Juwan Howard</strong>, <strong>Kurt Thomas</strong>, <strong>Derek Anderson</strong>, <strong>Brevin Knight</strong>. I had guys like that – older guys who had played 14+ years in the league already – who took me under their wing and taught me a lot of things (not just on the court, but off the court too). I think that’s missing now. That’s a vital thing that a lot of teams don’t take into consideration. You still need that. You still need an older, veteran player on the team who’s been in the league, who’s been around this for a while and who’s used to being in the NBA and [knows] everything that comes with being an NBA player because this is stuff that some of these young guys need to know! These guys are coming into the NBA younger and younger – at 18 and 19 years old – so they need some guidance. Sometimes, coaches aren’t able to get across to them what they need to hear and how they need to hear it. Sometimes, they need to hear it from somebody who’s been through it for 15 years and who they really trust and will listen to. I think that’s a vital thing that’s missing, man. Hopefully one day that will change, but I don’t know…</span></p>
<div id="attachment_1362964" class="wp-caption alignleft"><img aria-describedby="caption-attachment-1362964" data-attachment-id="1362964" data-permalink="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/oklahoma-city-thunder-v-utah-jazz-game-three-2/" data-orig-file="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg" data-orig-size="1286,898" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;NIKON D5&quot;,&quot;caption&quot;:&quot;SALT LAKE CITY, UT - APRIL 21: Raymond Felton #2 of the Oklahoma City Thunder brings the ball up court against the Utah Jazz in the first half during Game Three of Round One of the 2018 NBA Playoffs at Vivint Smart Home Arena on April 21, 2018 in Salt Lake City, Utah.  NOTE TO USER: User expressly acknowledges and agrees that, by downloading and or using this photograph, User is consenting to the terms and conditions of the Getty Images License Agreement. (Photo by Gene Sweeney Jr.\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;1524339634&quot;,&quot;copyright&quot;:&quot;2018 Getty Images&quot;,&quot;focal_length&quot;:&quot;280&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.0008&quot;,&quot;title&quot;:&quot;Oklahoma City Thunder v Utah Jazz - Game Three&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Oklahoma City Thunder v Utah Jazz &#8211; Game Three" data-image-description data-medium-file="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg?w=1000" class="size-full wp-image-1362964 lazy-load" src="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg?w=100&amp;h=69#038;h=698" alt width="1000" height="698" data-lazy-src="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg?w=1000&#038;h=698" srcset="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg?w=1000&amp;h=698 1000w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg?w=190&amp;h=133 190w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg?w=300&amp;h=209 300w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg?w=768&amp;h=536 768w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg?w=1024&amp;h=715 1024w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg 1286w" sizes="(max-width: 1000px) 100vw, 1000px"><noscript><img aria-describedby="caption-attachment-1362964" data-attachment-id="1362964" data-permalink="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/oklahoma-city-thunder-v-utah-jazz-game-three-2/" data-orig-file="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg" data-orig-size="1286,898" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;NIKON D5&quot;,&quot;caption&quot;:&quot;SALT LAKE CITY, UT - APRIL 21: Raymond Felton #2 of the Oklahoma City Thunder brings the ball up court against the Utah Jazz in the first half during Game Three of Round One of the 2018 NBA Playoffs at Vivint Smart Home Arena on April 21, 2018 in Salt Lake City, Utah.  NOTE TO USER: User expressly acknowledges and agrees that, by downloading and or using this photograph, User is consenting to the terms and conditions of the Getty Images License Agreement. (Photo by Gene Sweeney Jr.\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;1524339634&quot;,&quot;copyright&quot;:&quot;2018 Getty Images&quot;,&quot;focal_length&quot;:&quot;280&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.0008&quot;,&quot;title&quot;:&quot;Oklahoma City Thunder v Utah Jazz - Game Three&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Oklahoma City Thunder v Utah Jazz &#8211; Game Three" data-image-description="" data-medium-file="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg?w=1000" class="size-full wp-image-1362964" src="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg?w=1000&#038;h=698" alt="" width="1000" height="698" srcset="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg?w=1000&amp;h=698 1000w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg?w=190&amp;h=133 190w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg?w=300&amp;h=209 300w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg?w=768&amp;h=536 768w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg?w=1024&amp;h=715 1024w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba2.jpg 1286w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript><p id="caption-attachment-1362964" class="wp-caption-text">(Photo by Gene Sweeney Jr./Getty Images)</p></div>
<p><b>How much longer do you want to continue playing? </b></p>
<p><b>RF: </b><span style="font-weight:400;">My ultimate goal was always 16 years. I’ve played 14 before this season, so this year would’ve been 15. I want to play another two years and if I can stretch it to three, I will. But I definitely want to play another two because I still want to reach my goal of playing 16 years.</span></p>
<p><b>You mentioned that you’re open to going overseas if you have to and I’m sure international teams have been reaching out to your agent. Have you received interest from a lot of overseas teams this year?</b></p>
<p><b>RF</b><span style="font-weight:400;">: They’ve been having talks. They’re having some conversations now, just to kind of get on top of it. This is the first time that I’ve actually been open to, just seeing the changes in the league and how they want to go younger and want to basically not even have veterans that much anymore. It’s just one of those things where I’m like, “Okay, well, I still want to play…” So even if I have to go play over there, that’s what I’m going to do. That’s how that came about.</span></p>
<p><b>During this year that you haven’t been in the NBA, how have you spent your time and what have you been doing to stay in shape?</b></p>
<p><b>RF: </b><span style="font-weight:400;">Before the season was [suspended], I was in Houston; I was working out every day, training, playing pick-up and all of that. But once the gyms closed, I really didn’t have anything to do but try to do what I can at home. From being in the basketball world for so long, I have friends and people I know who have gyms and stuff that I can get in. But, for the most part, a lot of people shut their gym down for almost a month and a half – even my friends had to shut down because they were going to get in trouble since the state required it. In a lot of situations, it was tough. Over the last month, I’ve been able to get back in the gym and get back on the basketball court again – touching a ball again and getting shots up and getting back to it – and it’s just been great. I’ve been going at it every day. I’m still trying to spend time with my kids and do all of that, but I’m trying to keep myself ready and safe at the same time. I’m staying prepared for that phone call.</span></p>
<p><b>Some NBA coaches and trainers have suggested that veterans may have an advantage coming out of this break since they have experience keeping their body in shape and can do everything on their own whereas young players rely on their trainers and coaches a lot more. Do you agree that veterans may have had an edge during the break? </b></p>
<p><b>RF: </b><span style="font-weight:400;">No question. You know how to take care of your body and you know the things to do for recovery. I have pretty much everything that we get at the facility here at my house; I have all of the things that I need to recover here. So, yeah, I think that is an advantage – knowing your body and knowing what you have to do to be in shape and to be game-ready without having somebody with you 24/7 who’s helping you and walking you through stuff. Knowing that stuff is a big difference between veterans and young guys.</span></p>
<p><b>You won multiple state championships in high school, you won an NCAA championship at UNC. What would it mean for you to add an NBA championship to your list of accomplishments?</b></p>
<p><b>RF: </b><span style="font-weight:400;">Ah, man, that would be the like icing on the cake of my career. Just being able to say that I’ve won a ‘ship at all three levels, that would be amazing. Hopefully, before I walk away from this game, I can say that I did that. But we’ll have to see what happens.</span></p>
<p><b>You’ve played for seven teams in 14 years. When you change teams, you’re adjusting to new coaches, new teammates, new cities and so on. Was moving from team to team in recent years difficult for you?</b></p>
<p><b>RF: </b><span style="font-weight:400;">I think the moving part is more difficult. Like, moving from team to team and getting adjusted to different coaches isn’t a hard thing for me because I’m a student of the game. I study the game and I like to get to know coaches and their plays. I’m a student, so it’s never difficult for me because I like to watch film and see how I can be successful in the offense and learn the defensive scheme and how they do things. I’m just a student of the game; I love to watch other players and see what other coaches do. It was never really a tough moment for me. It was all about just growing relationships with my coaches and that’s something that I did with pretty much all the coaches that I played for.</span></p>
<div id="attachment_1362962" class="wp-caption alignleft"><img aria-describedby="caption-attachment-1362962" data-attachment-id="1362962" data-permalink="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/new-york-knicks-v-sacramento-kings/" data-orig-file="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg" data-orig-size="1280,896" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;4.5&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X&quot;,&quot;caption&quot;:&quot;SACRAMENTO, CA - MARCH 26:  Raymond Felton #2 of the New York Knicks in action against the Sacramento Kings at Sleep Train Arena on March 26, 2014 in Sacramento, California. NOTE TO USER: User expressly acknowledges and agrees that, by downloading and or using this photograph, User is consenting to the terms and conditions of the Getty Images License Agreement.  (Photo by Ezra Shaw\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;1395905282&quot;,&quot;copyright&quot;:&quot;2014 Getty Images&quot;,&quot;focal_length&quot;:&quot;135&quot;,&quot;iso&quot;:&quot;250&quot;,&quot;shutter_speed&quot;:&quot;0.004&quot;,&quot;title&quot;:&quot;New York Knicks v Sacramento Kings&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="New York Knicks v Sacramento Kings" data-image-description data-medium-file="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg?w=1000" class="size-full wp-image-1362962 lazy-load" src="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg?w=100&amp;h=70#038;h=700" alt width="1000" height="700" data-lazy-src="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg?w=1000&#038;h=700" srcset="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg?w=1000&amp;h=700 1000w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg?w=190&amp;h=133 190w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg?w=300&amp;h=210 300w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg?w=768&amp;h=538 768w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg?w=1024&amp;h=717 1024w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg 1280w" sizes="(max-width: 1000px) 100vw, 1000px"><noscript><img aria-describedby="caption-attachment-1362962" data-attachment-id="1362962" data-permalink="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/new-york-knicks-v-sacramento-kings/" data-orig-file="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg" data-orig-size="1280,896" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;4.5&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X&quot;,&quot;caption&quot;:&quot;SACRAMENTO, CA - MARCH 26:  Raymond Felton #2 of the New York Knicks in action against the Sacramento Kings at Sleep Train Arena on March 26, 2014 in Sacramento, California. NOTE TO USER: User expressly acknowledges and agrees that, by downloading and or using this photograph, User is consenting to the terms and conditions of the Getty Images License Agreement.  (Photo by Ezra Shaw\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;1395905282&quot;,&quot;copyright&quot;:&quot;2014 Getty Images&quot;,&quot;focal_length&quot;:&quot;135&quot;,&quot;iso&quot;:&quot;250&quot;,&quot;shutter_speed&quot;:&quot;0.004&quot;,&quot;title&quot;:&quot;New York Knicks v Sacramento Kings&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="New York Knicks v Sacramento Kings" data-image-description="" data-medium-file="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg?w=300" data-large-file="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg?w=1000" class="size-full wp-image-1362962" src="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg?w=1000&#038;h=700" alt="" width="1000" height="700" srcset="https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg?w=1000&amp;h=700 1000w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg?w=190&amp;h=133 190w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg?w=300&amp;h=210 300w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg?w=768&amp;h=538 768w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg?w=1024&amp;h=717 1024w, https://usathoopshype.files.wordpress.com/2020/07/raymond_felton_nba4.jpg 1280w" sizes="(max-width: 1000px) 100vw, 1000px" /></noscript><p id="caption-attachment-1362962" class="wp-caption-text">(Photo by Ezra Shaw/Getty Images)</p></div>
<p><b>Moving is the rough part. There aren’t many professions where your employer tells you, “We’re moving you across the country permanently and you need to leave tomorrow.” How did you react the first time you were traded?</b></p>
<p><b>RF: </b><span style="font-weight:400;">Ah man, I was hurt. I was hurt. I mean, I was having one of my best seasons in my career. In my first time with New York, I was averaging like 17.0 or 18.0 points and 9.0 assists. I was having a great year and it was just tough when that trade happened. I got sent to Denver [in the <strong>Carmelo Anthony</strong> deal] and it was tough… It was just tough. I was hurt about that one, I ain’t even going to lie to you. (laughs)</span></p>
<p><b>Does it get easier the more times you get traded? Do you sort of get used to it?</b></p>
<p><b>RF: </b><span style="font-weight:400;">Yeah, it’s just one of those things where I try to look at the positive part of it and say, “Listen, at least somebody wants you!” When nobody wants you, that’s when it gets worse. When you have people inquiring about you, that’s always a good thing.</span></p>
<p><b>I’m sure you’re used to dealing with rumors by now. I know some players read every rumor while others try to ignore them. What is your approach to rumors?</b></p>
<p><b>RF: </b><span style="font-weight:400;">I just don’t read it, man. I don’t read what people say, and I don’t read what the media writes when it comes to rumors. When it comes to that stuff, I just block it out. If my agent calls me, then I’m like, “Okay, now </span><i><span style="font-weight:400;">this </span></i><span style="font-weight:400;">is something serious.” If he calls me and says that a team is inquiring about me and the team that I’m with is talking to him and they’re trying to figure out a deal, that’s when I’m like, “Okay, I might be on the move.” That’s different, when you get </span><i><span style="font-weight:400;">that </span></i><span style="font-weight:400;">phone call.</span></p>
<p><b>After your playing days are over, what career path do you want to pursue?</b></p>
<p><b>RF: </b><span style="font-weight:400;">I’ve thought about it, but I don’t know. It’s going to be something within basketball – training kids, getting kids prepared for the NBA Draft, getting kids prepared for their season, just helping out and being a mentor. I thought about coaching, but I’m not sure about that. I’m still up in the air about that. But that’s something where I could give my knowledge back to the game. I don’t know. I have kids who are coming up and who want to play as well, so I don’t know if I want to put all of that time back into the game after I’m done and not be able to coach [my kids] and be at their games and be around. I just have a lot to think about when it comes to all of that.</span></p>
<p><b>How has fatherhood changed you?</b></p>
<p><b>RF</b><span style="font-weight:400;">: It’s made me grow up as a man and it’s made me look at life and a whole lot of things differently. It’s great being a dad. I get to see all of the things that my dad got to see when I was coming up – the things that used to make him happy and proud, and the things that used to make him upset (laughs). I see all of those things now. It’s a beautiful thing. I love being a dad.</span></p>
<div id=inline-newsletter-widget class=hidden data-position=10><div class="widget widget--newsletter widget--box">
<div class="newsletter__wrapper " style="display: none;">

	<div class="newsletter__signup-wrapper">
				<form novalidate="novalidate" class="newsletter_form" action="https://hoopshype.com/wp-json/usat/v1/gems/subscribe/">

			
			<label class="newsletter__input-label" for="newsletter-email-input">
				<span class="screen-reader-text">Email</span>
				<input
					type="email"
					class="newsletter__input"
					placeholder="you@domain.com"
					name="email"
					id="newsletter-email-input"
					required
				>
							</label>

			<button
					type="submit"
					class="newsletter__button"
			>Sign up			</button>

			
			
		</form>

					<div class="newsletter__sidetext">
				<h3>Like this article?</h3>
				<p>Sign up for the HoopsHype email newsletter to get our top stories in your inbox every morning</p>
			</div>
		
		<div class="newsletter__state newsletter__state--error">
			<h3 class="newsletter__header newsletter__header--error">An error has occured</h3>

			<p class="newsletter__text newsletter__text--error">
				Please re-enter your email address.			</p>
		</div>

	</div>

	<div class="newsletter__state newsletter__state--success">
		<h3 class="newsletter__header">Thanks for signing up!</h3>

		<p class="newsletter__text">
			You&#039;ll now receive the top HoopsHype stories each day directly in your inbox.		</p>

			</div>

	</div>

</div></div></div>

						<div id='acm-ad-tag-lawrence_dfp_desktop_arkadium' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_arkadium'); });</script></div>
						
						
						
						<p class="post-tags post-tags--hide"><a href="https://hoopshype.com/tag/featured/" rel="tag">Featured</a>, <a href="https://hoopshype.com/tag/interview/" rel="tag">Interview</a>, <a href="https://hoopshype.com/tag/podcast/" rel="tag">Podcast</a>, <a href="https://hoopshype.com/tag/top/" rel="tag">Top</a>, <a href="https://hoopshype.com/category/basketball/" rel="category tag">Basketball</a>, <a href="https://hoopshype.com/category/interview/" rel="category tag">Interview</a>, <a href="https://hoopshype.com/category/nba/" rel="category tag">NBA</a>, <a href="https://hoopshype.com/category/podcast/" rel="category tag">Podcast</a></p><p>
			<span class="icomoon icon-tag"></span>
			<span class="post-terms"><a href="https://hoopshype.com/category/basketball/" rel="tag">Basketball</a>, <a href="https://hoopshype.com/category/interview/" rel="tag">Interview</a>, <a href="https://hoopshype.com/category/nba/" rel="tag">NBA</a>, <a href="https://hoopshype.com/category/podcast/" rel="tag">Podcast</a>, <a href="https://hoopshype.com/tag/featured/" rel="tag">Featured</a>, <a href="https://hoopshype.com/tag/interview/" rel="tag">Interview</a>, <a href="https://hoopshype.com/tag/podcast/" rel="tag">Podcast</a>, <a href="https://hoopshype.com/tag/top/" rel="tag">Top</a>, <a href="https://hoopshype.com/player/amare-stoudemire/" rel="tag">Amare Stoudemire</a>, <a href="https://hoopshype.com/player/carmelo-anthony/" rel="tag">Carmelo Anthony</a>, <a href="https://hoopshype.com/player/dirk-nowitzki/" rel="tag">Dirk Nowitzki</a>, <a href="https://hoopshype.com/player/juwan-howard/" rel="tag">Juwan Howard</a>, <a href="https://hoopshype.com/player/raymond-felton/" rel="tag">Raymond Felton</a>, <a href="https://hoopshype.com/player/stephen-jackson/" rel="tag">Stephen Jackson</a>, <a href="https://hoopshype.com/team/charlotte-hornets/" rel="tag">Charlotte Hornets</a>, <a href="https://hoopshype.com/team/new-york-knicks/" rel="tag">New York Knicks</a>, <a href="https://hoopshype.com/team/oklahoma-city-thunder/" rel="tag">Oklahoma City Thunder</a></span>
			</p>
						<div class="story-share-buttons sms">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">8</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/"
		data-short-url=""
		data-track="hoopshypestoryfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/"
		data-short-url=""
		data-track="hoopshypestorytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="hoopshype"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/"
		data-short-url=""
		data-track="hoopshypestorypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/"
		data-short-url=""
		data-track="hoopshypestorysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/"
		data-short-url=""
		data-track="hoopshypestorywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/"
			data-short-url=""
			data-track="hoopshypestoryemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
</div><div class="after-article widget_text">			<div class="textwidget"><div class="veeseoRA2VW"></div></div>
		</div><iframe
	style= "border: none; margin: 0px; width: 100%; height: 300px"
	src="https://www.stanza.co/@nba?embed=true&#038;banner=true&#038;site=hoopshype" >
	</iframe>					</div><!-- .entry-content -->
				</div><!-- #content-container -->

				
			</article><!-- #post-## -->

		
		<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>RELATED <span>ARTICLES</span></h2>
	</div>
	
	<div class="holder-column">
		<div class="column">
			<article class="block block-single-related">
	<a href="https://hoopshype.com/2020/06/01/nba-rumors-podcast-corey-brewer-florida-gators-timberwolves-rockets-interview-championship-superlatives/"
		data-track="hoopshypefeaturedstories hoopshypemore-related-1"
		title="Corey Brewer Q&amp;A: &#039;I feel like I have a few good years left&#039;"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://usathoopshype.files.wordpress.com/2020/05/coreybrewer_6.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://usathoopshype.files.wordpress.com/2020/05/coreybrewer_6.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Corey Brewer Q&amp;A: &#039;I feel like I have a few good years left&#039;" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">210 shares</span><span class="block__time block__time--mobile">01 Jun</span>
		<h2><a href="https://hoopshype.com/category/podcast/" class="category" itemprop="articleSection">Podcast</a></h2>

		<p>
			<a data-track="hoopshypefeaturedstories hoopshypemore-related-1" href="https://hoopshype.com/2020/06/01/nba-rumors-podcast-corey-brewer-florida-gators-timberwolves-rockets-interview-championship-superlatives/"
				title="Corey Brewer Q&amp;A: &#039;I feel like I have a few good years left&#039;" itemprop="url">
				Corey Brewer Q&amp;A: 'I feel like I have a few good years left'			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://hoopshype.com/2020/06/23/nba-rumors-schea-cotton-documentary-manchild-podcast-lebron-james-kobe-bryant-ucla-high-school-college-overseas-story-film-movie/"
		data-track="hoopshypefeaturedstories hoopshypemore-related-2"
		title="Schea Cotton: &#039;Zion Williamson is probably the closest to what I was&#039;"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://usathoopshype.files.wordpress.com/2020/06/schea_cotton_doc.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://usathoopshype.files.wordpress.com/2020/06/schea_cotton_doc.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Schea Cotton: &#039;Zion Williamson is probably the closest to what I was&#039;" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">980 shares</span><span class="block__time block__time--mobile">2w ago</span>
		<h2><a href="https://hoopshype.com/category/podcast/" class="category" itemprop="articleSection">Podcast</a></h2>

		<p>
			<a data-track="hoopshypefeaturedstories hoopshypemore-related-2" href="https://hoopshype.com/2020/06/23/nba-rumors-schea-cotton-documentary-manchild-podcast-lebron-james-kobe-bryant-ucla-high-school-college-overseas-story-film-movie/"
				title="Schea Cotton: &#039;Zion Williamson is probably the closest to what I was&#039;" itemprop="url">
				Schea Cotton: 'Zion Williamson is probably the closest to what I was'			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://hoopshype.com/2020/06/02/kendrick-perkins-qa-our-kids-kids-will-thank-us-for-standing-up/"
		data-track="hoopshypefeaturedstories hoopshypemore-related-3"
		title="Kendrick Perkins Q&amp;A: &#039;Our kids&#039; kids will thank us for standing up&#039;"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://usathoopshype.files.wordpress.com/2020/06/kendrickperkins_espn1.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://usathoopshype.files.wordpress.com/2020/06/kendrickperkins_espn1.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Kendrick Perkins Q&amp;A: &#039;Our kids&#039; kids will thank us for standing up&#039;" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">55 shares</span><span class="block__time block__time--mobile">02 Jun</span>
		<h2><a href="https://hoopshype.com/category/podcast/" class="category" itemprop="articleSection">Podcast</a></h2>

		<p>
			<a data-track="hoopshypefeaturedstories hoopshypemore-related-3" href="https://hoopshype.com/2020/06/02/kendrick-perkins-qa-our-kids-kids-will-thank-us-for-standing-up/"
				title="Kendrick Perkins Q&amp;A: &#039;Our kids&#039; kids will thank us for standing up&#039;" itemprop="url">
				Kendrick Perkins Q&amp;A: 'Our kids' kids will thank us for standing up'			</a>
		</p>

	</div>
</article>

		</div>
	</div>
</div>
<div class="container single-related single-related--zergnet is-wasabi" id="single-related-zergnet-lawrence">
		<div class="heading-small"><h2>From <span>The Web</span></h2></div>
		<div id="zergnet-widget-67304" class="zergnet-wrapper"></div>
	</div><div class="container column container--stories">
	<div class="heading-small">
		<h2>LATEST</h2>
	</div>
	<div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_native'); });</script></div>
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/07/03/lebron-james-free-agency-rumors-2010-the-decision-knicks-heat/"
						title="Reliving LeBron James&#039; Decision (Day 3): Bulls give strong pitch"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2020/07/usatsi_14044781.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2020/07/usatsi_14044781.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Reliving LeBron James&#039; Decision (Day 3): Bulls give strong pitch" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2020/07/03/lebron-james-free-agency-rumors-2010-the-decision-knicks-heat/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2020/07/03/lebron-james-free-agency-rumors-2010-the-decision-knicks-heat/"
			title="Reliving LeBron James&#039; Decision (Day 3): Bulls give strong pitch"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2020/07/03/lebron-james-free-agency-rumors-2010-the-decision-knicks-heat/" class="share-text">
	9</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				5hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/free-agency/" class="category" itemprop="articleSection">Free Agency</a>						<span class="block__time block__time--mobile">5hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/07/03/lebron-james-free-agency-rumors-2010-the-decision-knicks-heat/"
						title="Reliving LeBron James&#039; Decision (Day 3): Bulls give strong pitch"
						itemprop="url" 						>
							Reliving LeBron James&#039; Decision (Day 3): Bulls give strong pitch					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/free-agency/" class="category" itemprop="articleSection">Free Agency</a><span class="dot">&middot;</span>						<span class="time">July 3, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/fau09fsu/" title="Posts by Frank Urbina" class="author url fn" rel="author">Frank Urbina</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/07/03/basketball-you-can-watch-today-jeremy-lin-and-ekpe-udoh-team-up-in-china/"
						title="Basketball you can watch today: Jeremy Lin and Ekpe Udoh team up in China"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2020/06/photo-1.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2020/06/photo-1.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Basketball you can watch today: Jeremy Lin and Ekpe Udoh team up in China" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2020/07/03/basketball-you-can-watch-today-jeremy-lin-and-ekpe-udoh-team-up-in-china/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2020/07/03/basketball-you-can-watch-today-jeremy-lin-and-ekpe-udoh-team-up-in-china/"
			title="Basketball you can watch today: Jeremy Lin and Ekpe Udoh team up in China"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2020/07/03/basketball-you-can-watch-today-jeremy-lin-and-ekpe-udoh-team-up-in-china/" class="share-text">
	74</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				11hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/nba/" class="category" itemprop="articleSection">NBA</a>						<span class="block__time block__time--mobile">11hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/07/03/basketball-you-can-watch-today-jeremy-lin-and-ekpe-udoh-team-up-in-china/"
						title="Basketball you can watch today: Jeremy Lin and Ekpe Udoh team up in China"
						itemprop="url" 						>
							Basketball you can watch today: Jeremy Lin and Ekpe Udoh team up in China					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/nba/" class="category" itemprop="articleSection">NBA</a><span class="dot">&middot;</span>						<span class="time">July 3, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/albertoderoa/" title="Posts by Alberto De Roa" class="author url fn" rel="author">Alberto De Roa</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/07/02/golden-state-warriors-juan-toscano-anderson-protest-black-lives-matter/"
						title="Warriors&#039; Juan Toscano-Anderson: &#039;If you have a voice and you care, you need to speak up&#039;"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2020/06/usatsi_14099143.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2020/06/usatsi_14099143.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Warriors&#039; Juan Toscano-Anderson: &#039;If you have a voice and you care, you need to speak up&#039;" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

									</div>

			
			<div class="mobile-date">
				17hr			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a>						<span class="block__time block__time--mobile">17hr ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/07/02/golden-state-warriors-juan-toscano-anderson-protest-black-lives-matter/"
						title="Warriors&#039; Juan Toscano-Anderson: &#039;If you have a voice and you care, you need to speak up&#039;"
						itemprop="url" 						>
							Warriors&#039; Juan Toscano-Anderson: &#039;If you have a voice and you care, you need to speak up&#039;					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/dunkwire/" class="category" itemprop="articleSection">DunkWire</a><span class="dot">&middot;</span>						<span class="time">July 2, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/bryankalbrosky/" title="Posts by Bryan Kalbrosky" class="author url fn" rel="author">Bryan Kalbrosky</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/07/02/basketball-you-can-watch-today-top-draft-prospect-deni-avdija-back-in-action/"
						title="Basketball you can watch today: Top draft prospect Deni Avdija back in action"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2020/06/photo-2.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2020/06/photo-2.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Basketball you can watch today: Top draft prospect Deni Avdija back in action" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2020/07/02/basketball-you-can-watch-today-top-draft-prospect-deni-avdija-back-in-action/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2020/07/02/basketball-you-can-watch-today-top-draft-prospect-deni-avdija-back-in-action/"
			title="Basketball you can watch today: Top draft prospect Deni Avdija back in action"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2020/07/02/basketball-you-can-watch-today-top-draft-prospect-deni-avdija-back-in-action/" class="share-text">
	33</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/streams/" class="category" itemprop="articleSection">Streams</a>						<span class="block__time block__time--mobile">1d ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/07/02/basketball-you-can-watch-today-top-draft-prospect-deni-avdija-back-in-action/"
						title="Basketball you can watch today: Top draft prospect Deni Avdija back in action"
						itemprop="url" 						>
							Basketball you can watch today: Top draft prospect Deni Avdija back in action					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/streams/" class="category" itemprop="articleSection">Streams</a><span class="dot">&middot;</span>						<span class="time">July 2, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/albertoderoa/" title="Posts by Alberto De Roa" class="author url fn" rel="author">Alberto De Roa</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/07/02/reliving-lebron-james-decision-day-2-wade-lbj-hit-impasse/"
						title="Reliving LeBron James&#039; Decision (Day 2): Wade, LBJ hit impasse?"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2020/06/gettyimages-107803364.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2020/06/gettyimages-107803364.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Reliving LeBron James&#039; Decision (Day 2): Wade, LBJ hit impasse?" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2020/07/02/reliving-lebron-james-decision-day-2-wade-lbj-hit-impasse/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2020/07/02/reliving-lebron-james-decision-day-2-wade-lbj-hit-impasse/"
			title="Reliving LeBron James&#039; Decision (Day 2): Wade, LBJ hit impasse?"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2020/07/02/reliving-lebron-james-decision-day-2-wade-lbj-hit-impasse/" class="share-text">
	22</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/free-agency/" class="category" itemprop="articleSection">Free Agency</a>						<span class="block__time block__time--mobile">1d ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/07/02/reliving-lebron-james-decision-day-2-wade-lbj-hit-impasse/"
						title="Reliving LeBron James&#039; Decision (Day 2): Wade, LBJ hit impasse?"
						itemprop="url" 						>
							Reliving LeBron James&#039; Decision (Day 2): Wade, LBJ hit impasse?					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/free-agency/" class="category" itemprop="articleSection">Free Agency</a><span class="dot">&middot;</span>						<span class="time">July 2, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/fau09fsu/" title="Posts by Frank Urbina" class="author url fn" rel="author">Frank Urbina</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://usathoopshype.wordpress.com/?post_type=listicle&#038;p=1360226&#038;preview=true"
						title="2002 NBA re-draft: The way it should have been"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2016/03/745862331.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2016/03/745862331.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2002 NBA re-draft: The way it should have been" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://usathoopshype.wordpress.com/?post_type=listicle&#038;p=1360226&#038;preview=true';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://usathoopshype.wordpress.com/?post_type=listicle&#038;p=1360226&#038;preview=true"
			title="2002 NBA re-draft: The way it should have been"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://usathoopshype.wordpress.com/?post_type=listicle&#038;p=1360226&#038;preview=true" class="share-text">
	38</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/draft/" class="category" itemprop="articleSection">Draft</a>						<span class="block__time block__time--mobile">2d ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://usathoopshype.wordpress.com/?post_type=listicle&#038;p=1360226&#038;preview=true"
						title="2002 NBA re-draft: The way it should have been"
						itemprop="url" 						>
							2002 NBA re-draft: The way it should have been					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/draft/" class="category" itemprop="articleSection">Draft</a><span class="dot">&middot;</span>						<span class="time">July 1, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/hoopshype-staff/" title="Posts by HoopsHype staff" class="author url fn" rel="author">HoopsHype staff</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/07/01/basketball-you-can-watch-today-head-coach-stephon-marbury-against-yi-jianlian-in-china/"
						title="Basketball you can watch today: Head coach Stephon Marbury against Yi Jianlian in China"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2020/06/photo-8.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2020/06/photo-8.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Basketball you can watch today: Head coach Stephon Marbury against Yi Jianlian in China" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2020/07/01/basketball-you-can-watch-today-head-coach-stephon-marbury-against-yi-jianlian-in-china/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2020/07/01/basketball-you-can-watch-today-head-coach-stephon-marbury-against-yi-jianlian-in-china/"
			title="Basketball you can watch today: Head coach Stephon Marbury against Yi Jianlian in China"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2020/07/01/basketball-you-can-watch-today-head-coach-stephon-marbury-against-yi-jianlian-in-china/" class="share-text">
	108</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				2d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/streams/" class="category" itemprop="articleSection">Streams</a>						<span class="block__time block__time--mobile">2d ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/07/01/basketball-you-can-watch-today-head-coach-stephon-marbury-against-yi-jianlian-in-china/"
						title="Basketball you can watch today: Head coach Stephon Marbury against Yi Jianlian in China"
						itemprop="url" 						>
							Basketball you can watch today: Head coach Stephon Marbury against Yi Jianlian in China					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/streams/" class="category" itemprop="articleSection">Streams</a><span class="dot">&middot;</span>						<span class="time">July 1, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/albertoderoa/" title="Posts by Alberto De Roa" class="author url fn" rel="author">Alberto De Roa</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/06/30/lebron-james-the-decision-2010-free-agency-rumors-meetings-july-1/"
						title="Reliving LeBron James&#039; Decision (Day 1): Nets, Knicks get first meetings"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2020/06/gettyimages-102731523.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2020/06/gettyimages-102731523.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Reliving LeBron James&#039; Decision (Day 1): Nets, Knicks get first meetings" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2020/06/30/lebron-james-the-decision-2010-free-agency-rumors-meetings-july-1/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2020/06/30/lebron-james-the-decision-2010-free-agency-rumors-meetings-july-1/"
			title="Reliving LeBron James&#039; Decision (Day 1): Nets, Knicks get first meetings"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2020/06/30/lebron-james-the-decision-2010-free-agency-rumors-meetings-july-1/" class="share-text">
	90</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/free-agency/" class="category" itemprop="articleSection">Free Agency</a>						<span class="block__time block__time--mobile">3d ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/06/30/lebron-james-the-decision-2010-free-agency-rumors-meetings-july-1/"
						title="Reliving LeBron James&#039; Decision (Day 1): Nets, Knicks get first meetings"
						itemprop="url" 						>
							Reliving LeBron James&#039; Decision (Day 1): Nets, Knicks get first meetings					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/free-agency/" class="category" itemprop="articleSection">Free Agency</a><span class="dot">&middot;</span>						<span class="time">June 30, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/fau09fsu/" title="Posts by Frank Urbina" class="author url fn" rel="author">Frank Urbina</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/gallery/nba-2k-covers-history/"
						title="NBA 2K covers through the years"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2020/06/damian-lillard-2k21.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2020/06/damian-lillard-2k21.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="NBA 2K covers through the years" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/gallery/nba-2k-covers-history/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/gallery/nba-2k-covers-history/"
			title="NBA 2K covers through the years"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/gallery/nba-2k-covers-history/" class="share-text">
	82</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/gallery/" class="category" itemprop="articleSection">Gallery</a>						<span class="block__time block__time--mobile">3d ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/gallery/nba-2k-covers-history/"
						title="NBA 2K covers through the years"
						itemprop="url" 						>
							NBA 2K covers through the years					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/gallery/" class="category" itemprop="articleSection">Gallery</a><span class="dot">&middot;</span>						<span class="time">June 30, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/hoopshype-staff/" title="Posts by HoopsHype staff" class="author url fn" rel="author">HoopsHype staff</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/06/30/nba-rumors-season-resume-wilson-chandler-brooklyn-nets-sit-out-play-kyrie-durant-irving-dinwiddie/"
						title="Wilson Chandler explains why he&#039;s sitting out when NBA season resumes"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathoopshype.files.wordpress.com/2020/06/usatsi_14073108.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathoopshype.files.wordpress.com/2020/06/usatsi_14073108.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Wilson Chandler explains why he&#039;s sitting out when NBA season resumes" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://hoopshype.com/2020/06/30/nba-rumors-season-resume-wilson-chandler-brooklyn-nets-sit-out-play-kyrie-durant-irving-dinwiddie/';">
	<div class="reply-block">
		<a
			data-track="hoopshypemostrecent"
			href="https://hoopshype.com/2020/06/30/nba-rumors-season-resume-wilson-chandler-brooklyn-nets-sit-out-play-kyrie-durant-irving-dinwiddie/"
			title="Wilson Chandler explains why he&#039;s sitting out when NBA season resumes"
			class="reply" rel="nofollow"
			>reply </a>
					<a href="https://hoopshype.com/2020/06/30/nba-rumors-season-resume-wilson-chandler-brooklyn-nets-sit-out-play-kyrie-durant-irving-dinwiddie/" class="share-text">
	54</a>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3d			</div>

			<div class="content  ">
									<h4 class="block-content-post-category">
						<a href="https://hoopshype.com/category/nba/" class="category" itemprop="articleSection">NBA</a>						<span class="block__time block__time--mobile">3d ago</span>					</h4>
				
				<h3>
										<a
						data-track="hoopshypemostrecent"
						href="https://hoopshype.com/2020/06/30/nba-rumors-season-resume-wilson-chandler-brooklyn-nets-sit-out-play-kyrie-durant-irving-dinwiddie/"
						title="Wilson Chandler explains why he&#039;s sitting out when NBA season resumes"
						itemprop="url" 						>
							Wilson Chandler explains why he&#039;s sitting out when NBA season resumes					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://hoopshype.com/category/nba/" class="category" itemprop="articleSection">NBA</a><span class="dot">&middot;</span>						<span class="time">June 30, 2020 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://hoopshype.com/author/alexkennedynba/" title="Posts by Alex Kennedy" class="author url fn" rel="author">Alex Kennedy</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	</div>
<div class="social-cta container column">

	<h2 class="social-cta__header">
		Follow HH!	</h2>

			<div class="social-cta__column social-cta__column--social">

			<h3 class="social-cta__type social-cta__type--social">Social</h3>
			<span class="social-cta__desc social-cta__desc--social">
				See HH stories in your feed			</span>

							<a
					href="http://facebook.com/hoopshype"
					class="social-cta__button social-cta__button--facebook"
					target="_blank"
				>Like HoopsHype</a>
			
							<a
					href="https://twitter.com/hoopshype"
					class="social-cta__button social-cta__button--twitter"
					target="_blank"
				>Follow HoopsHype</a>
			
		</div>
	
			<div class="social-cta__column social-cta__column--email">

			<h3 class="social-cta__type social-cta__type--email">Newsletter</h3>
			<span class="social-cta__desc social-cta__desc--email">
				Get the day&#039;s top stories			</span>

			<form action="https://hoopshype.com/wp-json/usat/v1/gems/subscribe/">

				<span class="social-cta__input-wrapper">
					<input
						type="email"
						class="social-cta__input"
						placeholder="name@domain.com"
						name="email"
						required
					>
				</span>
				<button
					type="submit"
					class="social-cta__button"
				>Sign me up!</button>

			</form>

			<div class="social-cta__state social-cta__state--success">

				<span class="social-cta__notice social-cta__notice--success">Success</span>

				<p>
					Thanks for signing up.<br>
					Please check your email for a confirmation.				</p>

			</div>

			<div class="social-cta__state social-cta__state--error">

				<span class="social-cta__notice social-cta__notice--error">Whoa!</span>

				<p class="social-cta__text--error">
					Something went wrong.
				</p>

				<button class="social-cta__button social-cta__button--dark social-cta__button--reset">
					Try again?
				</button>

			</div>

		</div>
	
			<div class="social-cta__column social-cta__column--podcast">

			<h3 class="social-cta__type social-cta__type--podcast">Podcast</h3>
			<span class="social-cta__desc social-cta__desc--podcast">
				Hear HH writers out loud			</span>

			<a
				href="https://hoopshype.com/category/podcast/"
				class="social-cta__button social-cta__button--podcast"
			>Latest podcast</a>

		</div>
	
</div>
<a href="https://hoopshype.com" class="article__back">More HoopsHype</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		
			<div class="widget sidebar-ad top">
				<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>			</div>

		
		
		<div class="widget_text widget widget_custom_html" id="custom_html-4"><div class="heading-small"><h2>GO IN-DEPTH</h2></div><div class="textwidget custom-html-widget"><div class="widget ui-widget ui-widget-content ui-corner-all" id="usat_hoopshype_social-2" style="line-height:1.5em;font-size:15px;font-family:Helvetica, Arial, sans-serif;">
	<ul class="ui-tabs-panel ui-widget-content ui-corner-bottom" style="padding-bottom:10px;list-style:none;margin-left:0;padding-left:0;">
		<li style="padding:5px 0;border-bottom:1px solid #eee;">💰 <a href="/salaries/" style="font-weight:normal;color:#000;">Salaries of players right now</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">💸 <a href="/salaries/players/2000-2001/" style="font-weight:normal;color:#000;">Salaries of players back in the day</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">💼 <a href="/reps/" style="font-weight:normal;color:#000;">Ranking agents by wages</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">📅 <a href="/2019/06/17/nba-contracts-key-dates-deadlines-options-trade-eligibility/" style="font-weight:normal;color:#000;">Key contract dates</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">📄 <a href="/all-nba-rosters-in-one-page-with-some-extra-details/" style="font-weight:normal;color:#000;">NBA rosters with details</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">🏀 <a href="/2019/07/10/nba-depth-charts/" style="font-weight:normal;color:#000;">Depth charts today</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">📞 <a href="/2019/07/02/nba-transactions-all-the-moves-of-the-2019-20-season/" style="font-weight:normal;color:#000;">Daily transactions</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">⭐ <a href="/2019/09/19/nba-free-agents-in-2020/" style="font-weight:normal;color:#000;">Upcoming free agents</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">🏆 <a href="/2019/08/08/nba-awards-all-the-winners-in-league-history/" style="font-weight:normal;color:#000;">All NBA awards in history</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">🎮 <a href="/nba2k/" style="font-weight:normal;color:#000;">NBA 2K ratings</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">🎓 <a href="/tag/re-drafts/" style="font-weight:normal;color:#000;">Re-ordering draft classes</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">🎙️ <a href="https://audioboom.com/channel/the-hoopshype-podcast" style="font-weight:normal;color:#000;">Listen to our podcast</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">📧 <a href="/newsletters/" style="font-weight:normal;color:#000;">Subscribe to our newsletter</a></li>
		<li style="padding:5px 0;border-bottom:1px solid #eee;">📷 <a href="https://www.instagram.com/hoopshypeofficial/" style="font-weight:normal;color:#000;" rel="nofollow">Follow us on Instagram</a></li>
	</ul>
</div></div></div><div class="widget HotStorylines_Widget" id="hotstorylines_widget-2"><div class="hype-wrapper hot-storylines-wrapper hot-storylines-simple" id="chartContainer-hot-storylines" style="width:100%;" data-url="https://hoopshype.com/post_stats/hot-storylines-stats">
	<div class="hype-title">
		<h2 class="hype-title-title">Hot Storylines</h2>
					</div>
		<ul class="hot-storylines-list">
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/evan-fournier-free-agency/">
					Evan Fournier Free Agency				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/orlando-bubble/">
					Orlando Bubble				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/gordon-hayward-injury/">
					Gordon Hayward Injury				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/jerami-grant-free-agency/">
					Jerami Grant Free Agency				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/coronavirus/">
					Coronavirus				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/nets-coaching-search/">
					Nets Coaching Search				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/joe-harris-free-agency/">
					Joe Harris Free Agency				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/coronavirus-infections/">
					Coronavirus Infections				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/season-resuming/">
					Season Resuming?				</a>
			</li>
					<li class="hot-storyline-item">
				<a href="https://hoopshype.com/storyline/stephen-curry-injury/">
					Stephen Curry Injury				</a>
			</li>
			</ul>

			<a class="all-rumors-link" href="https://hoopshype.com/rumors/">View all rumors</a>
	
</div>
</div><div class="widget salaries_widget tabbed_widget" id="salaries_widget-2"><div class="heading-small"><h2>Top salaries</h2></div><div class="tabs">
	<ul class="tab-controls hh-team-details">
					<li><a href="#hh-tab-team-payroll">Team Payrolls</a></li>
							<li><a href="#hh-tab-team-salaries">Player Salaries</a></li>
			</ul>
			<div id="hh-tab-team-payroll" class="hh-team-payroll">
			<table class="">
								<tbody>
											<tr>
							<td>
								1.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/portland_trail_blazers/">
									Portland								</a>
							</td>
															<td>
									$137,534,744								</td>
													</tr>
											<tr>
							<td>
								2.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/miami_heat/">
									Miami								</a>
							</td>
															<td>
									$135,262,022								</td>
													</tr>
											<tr>
							<td>
								3.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/oklahoma_city_thunder/">
									Oklahoma City								</a>
							</td>
															<td>
									$133,935,277								</td>
													</tr>
											<tr>
							<td>
								4.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/los_angeles_clippers/">
									LA Clippers								</a>
							</td>
															<td>
									$133,826,385								</td>
													</tr>
											<tr>
							<td>
								5.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/orlando_magic/">
									Orlando								</a>
							</td>
															<td>
									$133,692,528								</td>
													</tr>
											<tr>
							<td>
								6.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/philadelphia_76ers/">
									Philadelphia								</a>
							</td>
															<td>
									$133,639,383								</td>
													</tr>
											<tr>
							<td>
								7.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/minnesota_timberwolves/">
									Minnesota								</a>
							</td>
															<td>
									$132,706,778								</td>
													</tr>
											<tr>
							<td>
								8.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/washington_wizards/">
									Washington								</a>
							</td>
															<td>
									$131,500,636								</td>
													</tr>
											<tr>
							<td>
								9.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/golden_state_warriors/">
									Golden State								</a>
							</td>
															<td>
									$131,477,176								</td>
													</tr>
											<tr>
							<td>
								10.
							</td>
							<td class="name">
								<a href="https://hoopshype.com/salaries/cleveland_cavaliers/">
									Cleveland								</a>
							</td>
															<td>
									$131,371,296								</td>
													</tr>
									</tbody>
			</table>
							<div class="hh-salaries-cta">
					<a href="https://hoopshype.com/salaries/#hh-tab-team-payroll">
						View more team payrolls
					</a>
				</div>
					</div>
				<div id="hh-tab-team-salaries" class="hh-team-salaries">
			<table>
				<tbody>
											<tr>
							<td class="player-rank">
								1.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/stephen-curry/">
										Stephen Curry									</a>
															</td>
							<td class="player-salary">
								$40,231,758							</td>
						</tr>
											<tr>
							<td class="player-rank">
								2.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/russell-westbrook/">
										Russell Westbrook									</a>
															</td>
							<td class="player-salary">
								$38,506,482							</td>
						</tr>
											<tr>
							<td class="player-rank">
								2.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/chris-paul/">
										Chris Paul									</a>
															</td>
							<td class="player-salary">
								$38,506,482							</td>
						</tr>
											<tr>
							<td class="player-rank">
								4.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/james-harden/">
										James Harden									</a>
															</td>
							<td class="player-salary">
								$38,199,000							</td>
						</tr>
											<tr>
							<td class="player-rank">
								4.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/john-wall/">
										John Wall									</a>
															</td>
							<td class="player-salary">
								$38,199,000							</td>
						</tr>
											<tr>
							<td class="player-rank">
								6.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/lebron-james/">
										LeBron James									</a>
															</td>
							<td class="player-salary">
								$37,436,858							</td>
						</tr>
											<tr>
							<td class="player-rank">
								7.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/kevin-durant/">
										Kevin Durant									</a>
															</td>
							<td class="player-salary">
								$37,199,000							</td>
						</tr>
											<tr>
							<td class="player-rank">
								8.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/blake-griffin/">
										Blake Griffin									</a>
															</td>
							<td class="player-salary">
								$34,449,964							</td>
						</tr>
											<tr>
							<td class="player-rank">
								9.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/kyle-lowry/">
										Kyle Lowry									</a>
															</td>
							<td class="player-salary">
								$33,296,296							</td>
						</tr>
											<tr>
							<td class="player-rank">
								10.
							</td>
							<td class="player-name">
																	<a href="https://hoopshype.com/player/paul-george/">
										Paul George									</a>
															</td>
							<td class="player-salary">
								$33,005,556							</td>
						</tr>
									</tbody>
			</table>
							<div class="hh-salaries-cta">
					<a href="https://hoopshype.com/salaries/#hh-tab-team-salaries">
						View more player salaries
					</a>
				</div>
					</div>
	</div><!-- /.tabs -->
</div><div class="widget widget_wpcom_social_media_icons_widget" id="wpcom_social_media_icons_widget-2"><div class="heading-small"><h2>Social</h2></div><ul><li><a href="https://www.facebook.com/hoopshype/" class="genericon genericon-facebook" target="_blank"><span class="screen-reader-text">View hoopshype&#8217;s profile on Facebook</span></a></li><li><a href="https://twitter.com/hoopshype/" class="genericon genericon-twitter" target="_blank"><span class="screen-reader-text">View hoopshype&#8217;s profile on Twitter</span></a></li></ul></div><div class="widget latestnews_widget tabbed_widget" id="latestnews_widget-2"><div class="tabs">
	<ul class="tab-controls hh-team-details">
		<li><a href="#hh-tab-news">Latest News</a></li>
					<li><a href="#hh-tab-custom-tag">Newsletter</a></li>
			</ul>
	<div id="hh-tab-news" class="col1 right hh-latest-news">
		<ul>
			
<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=480 ');" href="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/" title="Raymond Felton Q&amp;A: &#039;I want to play, even if I have to go overseas&#039;" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2020/07/ray_felton1.jpg?w=100&#038;h=100&#038;crop=1" alt="Raymond Felton Q&amp;A: &#039;I want to play, even if I have to go overseas&#039;" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/podcast/" class="category">Podcast</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/" title="Raymond Felton Q&amp;A: &#039;I want to play, even if I have to go overseas&#039;">
			Raymond Felton Q&amp;A: 'I want to play, even if I have to go overseas'		</a>
		<p class="widget-date">July 3, 2020</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2020/07/usatsi_14044781.jpg?w=480 ');" href="https://hoopshype.com/2020/07/03/lebron-james-free-agency-rumors-2010-the-decision-knicks-heat/" title="Reliving LeBron James&#039; Decision (Day 3): Bulls give strong pitch" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2020/07/usatsi_14044781.jpg?w=100&#038;h=100&#038;crop=1" alt="Reliving LeBron James&#039; Decision (Day 3): Bulls give strong pitch" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/free-agency/" class="category">Free Agency</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/07/03/lebron-james-free-agency-rumors-2010-the-decision-knicks-heat/" title="Reliving LeBron James&#039; Decision (Day 3): Bulls give strong pitch">
			Reliving LeBron James' Decision (Day 3): Bulls give strong pitch		</a>
		<p class="widget-date"></p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2020/06/photo-1.jpg?w=480 ');" href="https://hoopshype.com/2020/07/03/basketball-you-can-watch-today-jeremy-lin-and-ekpe-udoh-team-up-in-china/" title="Basketball you can watch today: Jeremy Lin and Ekpe Udoh team up in China" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2020/06/photo-1.jpg?w=100&#038;h=100&#038;crop=1" alt="Basketball you can watch today: Jeremy Lin and Ekpe Udoh team up in China" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/nba/" class="category">NBA</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/07/03/basketball-you-can-watch-today-jeremy-lin-and-ekpe-udoh-team-up-in-china/" title="Basketball you can watch today: Jeremy Lin and Ekpe Udoh team up in China">
			Basketball you can watch today: Jeremy Lin and Ekpe Udoh team up in China		</a>
		<p class="widget-date"></p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2020/06/usatsi_14099143.jpg?w=480 ');" href="https://hoopshype.com/2020/07/02/golden-state-warriors-juan-toscano-anderson-protest-black-lives-matter/" title="Warriors&#039; Juan Toscano-Anderson: &#039;If you have a voice and you care, you need to speak up&#039;" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2020/06/usatsi_14099143.jpg?w=100&#038;h=100&#038;crop=1" alt="Warriors&#039; Juan Toscano-Anderson: &#039;If you have a voice and you care, you need to speak up&#039;" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/dunkwire/" class="category">DunkWire</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/07/02/golden-state-warriors-juan-toscano-anderson-protest-black-lives-matter/" title="Warriors&#039; Juan Toscano-Anderson: &#039;If you have a voice and you care, you need to speak up&#039;">
			Warriors' Juan Toscano-Anderson: 'If you have a voice and you care, you need to speak up'		</a>
		<p class="widget-date">July 2, 2020</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2020/06/photo-2.jpg?w=480 ');" href="https://hoopshype.com/2020/07/02/basketball-you-can-watch-today-top-draft-prospect-deni-avdija-back-in-action/" title="Basketball you can watch today: Top draft prospect Deni Avdija back in action" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2020/06/photo-2.jpg?w=100&#038;h=100&#038;crop=1" alt="Basketball you can watch today: Top draft prospect Deni Avdija back in action" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/streams/" class="category">Streams</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/07/02/basketball-you-can-watch-today-top-draft-prospect-deni-avdija-back-in-action/" title="Basketball you can watch today: Top draft prospect Deni Avdija back in action">
			Basketball you can watch today: Top draft prospect Deni Avdija back in action		</a>
		<p class="widget-date"></p>
	</div>
</li>
		</ul>
	</div>
			<div id="hh-tab-custom-tag" class="col1 right hh-latest-news">
			<ul>
				
<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2020/02/isaiahthomas_wizards_2.jpg?w=480 ');" href="https://hoopshype.com/2020/06/27/hoopshype-weekly-top-10-available-free-agents-restart/" title="The HoopsHype Weekly: We rank the Top 10 available free agents ahead of the 2019-20 season restart" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2020/02/isaiahthomas_wizards_2.jpg?w=100&#038;h=100&#038;crop=1" alt="The HoopsHype Weekly: We rank the Top 10 available free agents ahead of the 2019-20 season restart" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/newsletter/" class="category">Newsletter</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/06/27/hoopshype-weekly-top-10-available-free-agents-restart/" title="The HoopsHype Weekly: We rank the Top 10 available free agents ahead of the 2019-20 season restart">
			The HoopsHype Weekly: We rank the Top 10 available free agents ahead of the 2019-20 season restart		</a>
		<p class="widget-date">June 27, 2020</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2017/03/photo-258.jpg?w=480 ');" href="https://hoopshype.com/2020/06/20/hoopshype-weekly-knicks-head-coaching-job-list/" title="The HoopsHype Weekly: Breaking down the top candidates for the Knicks head coaching job" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2017/03/photo-258.jpg?w=100&#038;h=100&#038;crop=1" alt="The HoopsHype Weekly: Breaking down the top candidates for the Knicks head coaching job" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/newsletter/" class="category">Newsletter</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/06/20/hoopshype-weekly-knicks-head-coaching-job-list/" title="The HoopsHype Weekly: Breaking down the top candidates for the Knicks head coaching job">
			The HoopsHype Weekly: Breaking down the top candidates for the Knicks head coaching job		</a>
		<p class="widget-date">June 20, 2020</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2017/03/usatsi_13987245-1-1.jpg?w=480 ');" href="https://hoopshype.com/2020/06/13/hoopshype-weekly-players-question-nba-return-plan/" title="The HoopsHype Weekly: Inner turmoil strikes among players as questions arise regarding the NBA&#039;s return plan" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2017/03/usatsi_13987245-1-1.jpg?w=100&#038;h=100&#038;crop=1" alt="The HoopsHype Weekly: Inner turmoil strikes among players as questions arise regarding the NBA&#039;s return plan" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/newsletter/" class="category">Newsletter</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/06/13/hoopshype-weekly-players-question-nba-return-plan/" title="The HoopsHype Weekly: Inner turmoil strikes among players as questions arise regarding the NBA&#039;s return plan">
			The HoopsHype Weekly: Inner turmoil strikes among players as questions arise regarding the NBA's return plan		</a>
		<p class="widget-date">June 13, 2020</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2017/03/gettyimages-477149965-1.jpg?w=480 ');" href="https://hoopshype.com/2020/05/30/the-hoopshype-weekly-at-last-a-potential-end-to-the-nbas-months-long-hiatus-is-in-sight/" title="The HoopsHype Weekly: At last, a potential end to the NBA&#039;s months-long hiatus is in sight" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2017/03/gettyimages-477149965-1.jpg?w=100&#038;h=100&#038;crop=1" alt="The HoopsHype Weekly: At last, a potential end to the NBA&#039;s months-long hiatus is in sight" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/newsletter/" class="category">Newsletter</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/05/30/the-hoopshype-weekly-at-last-a-potential-end-to-the-nbas-months-long-hiatus-is-in-sight/" title="The HoopsHype Weekly: At last, a potential end to the NBA&#039;s months-long hiatus is in sight">
			The HoopsHype Weekly: At last, a potential end to the NBA's months-long hiatus is in sight		</a>
		<p class="widget-date">May 30, 2020</p>
	</div>
</li>

<li>

			<div class="thumbnail-holder">
			<a class="thumbnail" style="background-image:url(' https://usathoopshype.files.wordpress.com/2019/10/kawhi-leonard-lebron.jpg?w=480 ');" href="https://hoopshype.com/2020/05/24/the-hoopshype-weekly-seven-one-on-one-matchups-between-current-nba-stars-we-most-want-to-see/" title="The HoopsHype Weekly: Seven one-on-one matchups between current NBA stars we most want to see" rel="nofollow">
				<img src="https://usathoopshype.files.wordpress.com/2019/10/kawhi-leonard-lebron.jpg?w=100&#038;h=100&#038;crop=1" alt="The HoopsHype Weekly: Seven one-on-one matchups between current NBA stars we most want to see" itemprop="image">
								<span class="ie-overlay-hack"></span>
			</a>
					</div>
	
	<div class="text-block">
					<span class="block-content-post-category">
				<a href="https://hoopshype.com/category/newsletter/" class="category">Newsletter</a>			</span>
						<a class="title" href="https://hoopshype.com/2020/05/24/the-hoopshype-weekly-seven-one-on-one-matchups-between-current-nba-stars-we-most-want-to-see/" title="The HoopsHype Weekly: Seven one-on-one matchups between current NBA stars we most want to see">
			The HoopsHype Weekly: Seven one-on-one matchups between current NBA stars we most want to see		</a>
		<p class="widget-date">May 24, 2020</p>
	</div>
</li>
			</ul>
		</div>
	</div>
</div>
		
			<div class="widget sidebar-ad bottom">
				<div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_bottom_300x250'); });</script></div>			</div>

		
		
<div id="footer-info">
	<p class="footer__logo">
		<a href="http://usatodaysports.com" rel="nofollow" target="_blank">
			<img src="https://usathoopshype.files.wordpress.com/2017/01/usatlogo.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-navigation-container"><ul id="menu-footer-navigation" class="menu"><li id="menu-item-1179960" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1179960"><a href="https://cm.usatoday.com/terms">Terms of Service</a></li>
<li id="menu-item-1304766" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1304766"><a href="https://cm.usatoday.com/privacy">Privacy Policy</a></li>
<li id="menu-item-1179959" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1179959"><a href="https://cm.usatoday.com/privacy-policy">Your California Privacy Rights/Privacy Policy</a></li>
<li id="menu-item-1179961" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1179961"><a href="https://cm.usatoday.com/cookies">Do No Sell My Info/Cookie Policy</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=hoopshype.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "More Information";
		var footer_collapse_text = "Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	<div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-'); });</script></div>
	<!-- wpcom_wp_footer -->
<div id="daily-newsletter-error-email" class="daily-newsletter__state daily-newsletter__state--error thickbox" style="display: none;">
	<div class="daily-newsletter-error__wrapper">
		<h3 class="daily-newsletter-error__header"><span class="dashicons dashicons-warning"></span>Error</h3>
		<p id="daily-newsletter-error-message" class="daily-newsletter-error__message">
			Please enter an email address.		</p>
	</div>
</div>

<div id="newsletter-success" class="newsletter__state daily-newsletter__state--success thickbox" style="display: none;">
	<div class="daily-newsletter-error__wrapper">
		<h3 class="newsletter__header"><span class="dashicons dashicons-yes"></span>Success</h3>

		<p class="newsletter__text">Thanks for signing up.</p>
		<p class="newsletter__text">Please check your email for a confirmation.</p>
	</div>
</div>

<div id="daily-newsletter-error" class="daily-newsletter__state daily-newsletter__state--error thickbox" style="display: none;">
	<div class="daily-newsletter-error__wrapper">
		<h3 class="daily-newsletter__header"><span class="dashicons dashicons-warning"></span>Error</h3>

		<p id="daily-newsletter-error-message" class="daily-newsletter__text daily-newsletter__text--error daily-newsletter-error__message">
			Something went wrong.		</p>
	</div>
</div>
<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://usathoopshype.files.wordpress.com/2017/01/logo-hoopshype-header.png" alt="HoopsHype">
				<a class="mobile-nav__breadcrumb" href="https://hoopshype.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
			<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="http://facebook.com/hoopshype" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/hoopshype" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--podcast">
				<a href="https://hoopshype.com/category/podcast/" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--rumors mobile-nav__item--parent sub-menu-3columns sub-menu-columns-offset200"><a title="NBA Rumors" href="/rumors/">Rumors</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--atlanta-hawks"><a title="Atlanta Rumors" href="https://hoopshype.com/team/atlanta-hawks/">Atlanta Hawks</a></li>
	<li class="mobile-nav__item mobile-nav__item--boston-celtics"><a title="Boston Rumors" href="https://hoopshype.com/team/boston-celtics/">Boston Celtics</a></li>
	<li class="mobile-nav__item mobile-nav__item--brooklyn-nets"><a title="Brooklyn Rumors" href="https://hoopshype.com/team/brooklyn-nets/">Brooklyn Nets</a></li>
	<li class="mobile-nav__item mobile-nav__item--charlotte-hornets"><a title="Charlotte Rumors" href="https://hoopshype.com/team/charlotte-hornets/">Charlotte Hornets</a></li>
	<li class="mobile-nav__item mobile-nav__item--chicago-bulls"><a title="Chicago Rumors" href="https://hoopshype.com/team/chicago-bulls/">Chicago Bulls</a></li>
	<li class="mobile-nav__item mobile-nav__item--cleveland-cavaliers"><a title="Cleveland Rumors" href="https://hoopshype.com/team/cleveland-cavaliers/">Cleveland Cavaliers</a></li>
	<li class="mobile-nav__item mobile-nav__item--dallas-mavericks"><a title="Dallas Rumors" href="https://hoopshype.com/team/dallas-mavericks/">Dallas Mavericks</a></li>
	<li class="mobile-nav__item mobile-nav__item--denver-nuggets"><a title="Denver Rumors" href="https://hoopshype.com/team/denver-nuggets/">Denver Nuggets</a></li>
	<li class="mobile-nav__item mobile-nav__item--detroit-pistons"><a title="Detroit Rumors" href="https://hoopshype.com/team/detroit-pistons/">Detroit Pistons</a></li>
	<li class="mobile-nav__item mobile-nav__item--golden-state-warriors"><a title="Golden State Rumors" href="https://hoopshype.com/team/golden-state-warriors/">Golden State Warriors</a></li>
	<li class="mobile-nav__item mobile-nav__item--houston-rockets"><a title="Houston Rumors" href="https://hoopshype.com/team/houston-rockets/">Houston Rockets</a></li>
	<li class="mobile-nav__item mobile-nav__item--indiana-pacers"><a title="Indiana Rumors" href="https://hoopshype.com/team/indiana-pacers/">Indiana Pacers</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-clippers"><a title="LA Clippers Rumors" href="https://hoopshype.com/team/los-angeles-clippers/">Los Angeles Clippers</a></li>
	<li class="mobile-nav__item mobile-nav__item--los-angeles-lakers"><a title="LA Lakers Rumors" href="https://hoopshype.com/team/los-angeles-lakers/">Los Angeles Lakers</a></li>
	<li class="mobile-nav__item mobile-nav__item--memphis-grizzlies"><a title="Memphis Rumors" href="https://hoopshype.com/team/memphis-grizzlies/">Memphis Grizzlies</a></li>
	<li class="mobile-nav__item mobile-nav__item--miami-heat"><a title="Miami Rumors" href="https://hoopshype.com/team/miami-heat/">Miami Heat</a></li>
	<li class="mobile-nav__item mobile-nav__item--milwaukee-bucks"><a title="Milwaukee Rumors" href="https://hoopshype.com/team/milwaukee-bucks/">Milwaukee Bucks</a></li>
	<li class="mobile-nav__item mobile-nav__item--minnesota-timberwolves"><a title="Minnesota Rumors" href="https://hoopshype.com/team/minnesota-timberwolves/">Minnesota Timberwolves</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-orleans-pelicans"><a title="New Orleans Rumors" href="https://hoopshype.com/team/new-orleans-pelicans/">New Orleans Pelicans</a></li>
	<li class="mobile-nav__item mobile-nav__item--new-york-knicks"><a title="New York Rumors" href="https://hoopshype.com/team/new-york-knicks/">New York Knicks</a></li>
	<li class="mobile-nav__item mobile-nav__item--oklahoma-city-thunder"><a title="Oklahoma City Rumors" href="https://hoopshype.com/team/oklahoma-city-thunder/">Oklahoma City Thunder</a></li>
	<li class="mobile-nav__item mobile-nav__item--orlando-magic"><a title="Orlando Rumors" href="https://hoopshype.com/team/orlando-magic/">Orlando Magic</a></li>
	<li class="mobile-nav__item mobile-nav__item--philadelphia-76ers"><a title="Philadelphia Rumors" href="https://hoopshype.com/team/philadelphia-76ers/">Philadelphia 76ers</a></li>
	<li class="mobile-nav__item mobile-nav__item--phoenix-suns"><a title="Phoenix Rumors" href="https://hoopshype.com/team/phoenix-suns/">Phoenix Suns</a></li>
	<li class="mobile-nav__item mobile-nav__item--portland-trail-blazers"><a title="Portland Rumors" href="https://hoopshype.com/team/portland-trail-blazers/">Portland Trail Blazers</a></li>
	<li class="mobile-nav__item mobile-nav__item--sacramento-kings"><a title="Sacramento Rumors" href="https://hoopshype.com/team/sacramento-kings/">Sacramento Kings</a></li>
	<li class="mobile-nav__item mobile-nav__item--san-antonio-spurs"><a title="San Antonio Rumors" href="https://hoopshype.com/team/san-antonio-spurs/">San Antonio Spurs</a></li>
	<li class="mobile-nav__item mobile-nav__item--toronto-raptors"><a title="Toronto Rumors" href="https://hoopshype.com/team/toronto-raptors/">Toronto Raptors</a></li>
	<li class="mobile-nav__item mobile-nav__item--utah-jazz"><a title="Utah Rumors" href="https://hoopshype.com/team/utah-jazz/">Utah Jazz</a></li>
	<li class="mobile-nav__item mobile-nav__item--washington-wizards"><a title="Washington Rumors" href="https://hoopshype.com/team/washington-wizards/">Washington Wizards</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--salaries mobile-nav__item--parent sub-menu-minwidth140"><a title="NBA Salaries" href="/salaries/">Salaries</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--players"><a title="NBA Player Salaries" href="https://hoopshype.com/salaries/players/">Players</a></li>
	<li class="mobile-nav__item mobile-nav__item--teams"><a title="NBA Salaries" href="https://hoopshype.com/salaries/">Teams</a></li>
	<li class="mobile-nav__item mobile-nav__item--salary-cap"><a href="https://hoopshype.com/2020/03/16/los-angeles-lakers-their-salary-cap-situation-right-now/">Salary cap</a></li>
	<li class="mobile-nav__item mobile-nav__item--history"><a href="https://hoopshype.com/salaries/2000-2001/">History</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--twitter mobile-nav__item--parent sub-menu-minwidth140"><a title="NBA Media Twitters" href="/social/">Twitter</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--media"><a title="NBA Media Twitters" href="/social/">Media</a></li>
	<li class="mobile-nav__item mobile-nav__item--players"><a title="NBA Players on Twitter" href="/social/tweets/">Players</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--features mobile-nav__item--parent sub-menu-3columns sub-menu-columns-offset200"><a href="#">Features</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--agents"><a title="NBA Agents" href="/reps/">Agents</a></li>
	<li class="mobile-nav__item mobile-nav__item--awards"><a href="https://hoopshype.com/2019/08/08/nba-awards-all-the-winners-in-league-history/">Awards</a></li>
	<li class="mobile-nav__item mobile-nav__item--birthdays"><a href="https://hoopshype.com/2019/01/13/which-nba-player-was-born-the-same-day-as-you-find-out-here/">Birthdays</a></li>
	<li class="mobile-nav__item mobile-nav__item--birthplaces"><a title="Birthplaces" href="/2019/08/20/nba-players-birthplaces/">Birthplaces</a></li>
	<li class="mobile-nav__item mobile-nav__item--depth-charts"><a href="https://hoopshype.com/2019/07/10/nba-depth-charts/">Depth Charts</a></li>
	<li class="mobile-nav__item mobile-nav__item--draft"><a title="NBA Draft" href="/2018/01/09/nba-mock-draft-2018/">Draft</a></li>
	<li class="mobile-nav__item mobile-nav__item--free-agency-2019"><a title="NBA Free Agency 2019" href="/2018/08/09/nba-free-agency-2019-the-top-players">Free Agency 2019</a></li>
	<li class="mobile-nav__item mobile-nav__item--free-agency-2020"><a href="https://hoopshype.com/2019/07/18/nba-free-agency-2020-the-top-players/">Free Agency 2020</a></li>
	<li class="mobile-nav__item mobile-nav__item--hoopshype-explains"><a href="https://hoopshype.com/category/hoopshype-explains/">HoopsHype Explains</a></li>
	<li class="mobile-nav__item mobile-nav__item--hoopshype-podcasts"><a href="/category/podcast/">HoopsHype Podcasts</a></li>
	<li class="mobile-nav__item mobile-nav__item--instagram"><a title="NBA Players on Instagram" href="/social/gallery/">Instagram</a></li>
	<li class="mobile-nav__item mobile-nav__item--key-contract-dates"><a href="https://hoopshype.com/2019/06/17/nba-contracts-key-dates-deadlines-options-trade-eligibility/">Key Contract Dates</a></li>
	<li class="mobile-nav__item mobile-nav__item--longform"><a title="Longform" href="https://hoopshype.com/category/longform/">Longform</a></li>
	<li class="mobile-nav__item mobile-nav__item--nba-2k-ratings"><a href="https://hoopshype.com/nba2k/">NBA 2K Ratings</a></li>
	<li class="mobile-nav__item mobile-nav__item--nba-player-follows"><a href="https://hoopshype.com/2020/06/11/nba-player-twitter-follows/">NBA Player Follows</a></li>
	<li class="mobile-nav__item mobile-nav__item--nicknames"><a href="https://hoopshype.com/2019/02/24/all-the-nicknames-in-nba-history/">Nicknames</a></li>
	<li class="mobile-nav__item mobile-nav__item--players"><a title="NBA Players" href="/players/">Players</a></li>
	<li class="mobile-nav__item mobile-nav__item--re-drafts"><a href="https://hoopshype.com/tag/re-drafts/">Re-Drafts</a></li>
	<li class="mobile-nav__item mobile-nav__item--roster-details"><a href="https://hoopshype.com/2019/11/07/all-nba-rosters-in-one-page-with-some-extra-details/">Roster Details</a></li>
	<li class="mobile-nav__item mobile-nav__item--top-rumors"><a href="https://hoopshype.com/category/top-rumors/">Top Rumors</a></li>
	<li class="mobile-nav__item mobile-nav__item--transactions"><a title="NBA Transactions" href="/transactions.htm">Transactions</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--%f0%9f%91%89follows"><a href="https://hoopshype.com/2020/06/11/nba-player-twitter-follows/">👉Follows</a></li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-1179960" class="mobile-nav__item mobile-nav__item--terms-of-service"><a href="https://cm.usatoday.com/terms">Terms of Service</a></li>
<li id="menu-item-1304766" class="mobile-nav__item mobile-nav__item--privacy-policy"><a href="https://cm.usatoday.com/privacy">Privacy Policy</a></li>
<li id="menu-item-1179959" class="mobile-nav__item mobile-nav__item--your-california-privacy-rights-privacy-policy"><a href="https://cm.usatoday.com/privacy-policy">Your California Privacy Rights/Privacy Policy</a></li>
<li id="menu-item-1179961" class="mobile-nav__item mobile-nav__item--do-no-sell-my-info-cookie-policy"><a href="https://cm.usatoday.com/cookies">Do No Sell My Info/Cookie Policy</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=hoopshype.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</li>
			</ul>

	</div>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><script src='//0.gravatar.com/js/gprofiles.js?ver=202027y'></script>
<script>
var WPGroHo = {"my_hash":""};
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="85827622" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://hoopshype.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="HoopsHype" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="94aa26d0be" /><input type="hidden" name="_wp_http_referer" value="/2020/07/03/nba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade/" />		</form>

		<div class="arrow"></div>
	</div>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/_static/??-eJx9jkEOwjAMBD9EMFQqggPiLcG10rSJE8UOBV5POJQLgtvI61ktLNl4xlAHEpgEdPQ4X9P9A1sU2UD7wsRKrBCryaE6zwJoS6pCASbSbHE26+Gf5Iip+Bb8wC9XR4pt3M1nqGI1DfZhgl0KMRLENNTQ0icVx6TQ5JXfRZd43venrj/sumM3vQAf/Vk1?cssminify=yes' type='text/css' media='all' />
<script>
var comment_like_text = {"loading":"Loading..."};
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyVy00KgCAQQOELZUOQmIvoLtkQY/7BaHb8bFfLtu/xQU3CxJAxZLAMG55kMF295Q5eyxeRXNkpMJjofUvC0YH8GEcrcKWEf9AnNLj4eZBq1GqSUtsbk082wA=='></script>
<script src='https://native.sharethrough.com/assets/sfp.js?ver=1'></script>
<script>
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
</script>
<script>
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/s2.wp.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
</script>
<script>
var newsletter = {"i18n":{"cancel":"Cancel","close":"Close","want_more":"Want More?","try_again":"Please try again"},"force_modal":"","force_abovenav":"","is_mobile":"","modal_enabled":"","abovenav_enabled":"","cookie_expiry":"30","inline_position":"10","confirm_url":"","wiresites":{"enabled":false,"url":"https:\/\/hoopshype.com\/daily-email-newsletter"}};
</script>
<script>
var _LAWRENCE_ADS_EXPORTS = {"ad_refresh":{"seconds":"60","refresh_type":"all","distance":"2000","active":"1"}};
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJylk91OwzAMhV+ILqrQJrhAPIubeJ27JA6xs1Keng7BBoj1R9xF9qcT5xzH9KmyHBWjGj1gQDEnSqYIKDsYKg99xmjRBHbFj11wldhMScV0YhJkCFyibjq5M6MWReuLw49m91IwD6aQsZxxEyhOUz25FnWeSyykxHGeDBjLLcqRqDlhdJzPrcR+2JP3k7jjUGUEN0xSUNc3getsUJQth+RRf3gzlUbypaUo10IugfM34c3eU/qn0q/SjMNcZEG0GYXeoPELUJehbZehTVFdsgaOwHO71OTLyo8anpovZy3zkfCvi/RA9tjw6+WwJoAeBBo6y0TsZVwGxVx9/oSVwwZY/0Bw54Cfw1O9fdjudveP9a57B5oGh6k='></script>
<script type='text/javascript'>
( 'fetch' in window ) || document.write( '<script src="https://s0.wp.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?m=1573572739h&#038;ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://s1.wp.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?m=1540208548h&#038;ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://s0.wp.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?m=1585663916h&#038;ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://s2.wp.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?m=1585663916h&#038;ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://s1.wp.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?m=1550600082h&#038;ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://s2.wp.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?m=1540208548h&#038;ver=2.0.2"></scr' + 'ipt>' );
</script>
<script src='https://www.googletagservices.com/tag/js/gpt.js?ver=1.0'></script>
<script>
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
</script>
<script>
var wasabiFacebookReferral = "0";
</script>
<script>
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"1","headerHeight":"60","stickyAdSettings":"{\"66\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"90\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"250\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"}}"};
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJytkt1uwyAMhV9oLmqnqcvFtGdxwGqc8RNhSJc9/ZyqSirtimpXgDnnM9g21wlsioViMaHC5OuFo5gTzDyZUYwugBH9UtjKYZQX82AoAwW6aUwVLMnhshE8/izgEzqgbxU7cituix4Cx//E3VEcra9OIXpZVZXFpkytyYaUJhmWiVbMdniaEFLPnkA8O4KIcwvoioI9375T2Dd1YLdqTr5g4dRUhd0v+vAe83NmzDo6vql6uzng3849jCk67Szo01QohbLuIM2UM68zsMUaCSWj/VpL/Rk+jm/vXXc8vZ678RccvTJh'></script>
<script src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.4.2' async='async'></script>
<script>
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/hoopshype.com\/wp-admin\/admin-ajax.php","nonce":"6ed9ef389e","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/usathoopshype.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fhoopshype.com%2F2020%2F07%2F03%2Fnba-rumors-raymond-felton-ray-free-agent-agency-bubble-retirement-career-interview-podcast-knicks-bobcats-trade%2F","blog_id":"85827622","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=85827622&v=wpcom&tz=-4&user_id=0&subd=usathoopshype","is_public":"1","reblog_enabled":""};
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/mu-plugins/carousel/jetpack-carousel.js,/wp-includes/js/jquery/ui/tabs.min.js,/wp-content/themes/vip/usatoday-plugins/hoopshype/js/tabbed-widget.js?m=1592560282j'></script>
<script src='https://www.zergnet.com/zerg.js?id=67304&#038;ver=1.0'></script>
<script src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?61" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'85827622','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'85827622','v':'wpcom','tz':'-4','user_id':'0','post':'1362966','subd':'usathoopshype'}]);
function st_vt() {var x=document.createElement("img");x.src="https://pixel.wp.com/g.gif?blog=85827622&v=wpcomvt&tz=-4&user_id=0&post=1362966&subd=usathoopshype&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcvN1dHVE8tU1Y5Tk5xJUNPdGUvNWlURCVDWHdySjhHMEF6azhRa2xxSC5tLj1TNUl6JUpiRnJMdD1XPWRTWFg2VSYzemdFVTc3TktCY01XRD02TEMtK0RXdmliLFtVNFFJLjAtTS4lZS5mN3JjTkI9cGxmYVFiTStoJnM3UlpoXVpfJXp+K1ZTQ191RnolRWlicXRLLVBsL096VzNnbk5KWTAtVVNpVTNZaWE5bSZHNS93Wl9fTWItWi9hUnYtNHFqZ0RzbElLN19nRWksL05GWT0uWU55bnxsYl01aj16JTlSVmd+QnhqRkpNOENuamhFUm9WSTlY'}]);
_stq.push([ 'clickTrackerInit', '85827622', '1362966' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
		<script defer src="data:text/javascript,%21function%28%29%7B%22use%20strict%22%3Bvar%20e%3D%5B%5D%2Ct%3D%22wpcom.simple.ttfb.batcache.%22%3Btry%7Bfor%28var%20n%3Dperformance.getEntriesByType%28%22navigation%22%29%5B0%5D%7C%7C%7B%7D%2Co%3D0%2Cs%3Ddocument.body.childNodes%2Cc%3Ds.length-1%3Bc%3E%3D0%3Bc--%29s%5Bc%5D.nodeType%3D%3D%3DNode.COMMENT_NODE%26%26s%5Bc%5D.textContent.indexOf%28%22served%20from%20batcache%22%29%3E0%26%26%28o%3D1%29%3Bvar%20r%3DMath.round%28n.responseStart%7C%7C0%29%3Bif%28r%3E0%26%26%28o%3Fe.push%28t%2B%22hit%3A%22%2Br%2B%22%7Cms%22%29%3Ae.push%28t%2B%22miss%3A%22%2Br%2B%22%7Cms%22%29%29%2Ce.length%29document.createElement%28%22img%22%29.src%3D%22https%3A%2F%2Fpixel.wp.com%2Fboom.gif%3Fjson%3D%22%2BencodeURIComponent%28JSON.stringify%28%7Bbeacons%3Ae%7D%29%29%7Dcatch%28e%29%7B%7D%7D%28%29%3B"></script>
		<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
<!--
	generated 192 seconds ago
	generated in 0.380 seconds
	served from batcache in 0.003 seconds
	expires in 108 seconds
-->
